E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > MTX Subs + Amp to Stock Headunit



Reply
 
Thread Tools Search this Thread
      12-09-2011, 12:02 PM   #1
Moonesar
Bimmer Stance
 
Drives: Lexus IS300 & E90 325xi
Join Date: Jul 2011
Location: NJ

Posts: 54
iTrader: (0)

MTX Subs + Amp to Stock Headunit

I just purchased MTX Subs and amp and 4guage wires to hook up to my stock E90 325xi.

I was informed i need some type of aux adapter that has rca cables to hook up the amp to the stock head unit but not sure where to find them.

I search crutchfield but couldn't find anything bmw specific, anyone know where i can get this item or if i even need it? Maybe i need more?

I searched but got miminal help.

Thanks
Moonesar is offline   United_States
0
Reply With Quote
      12-10-2011, 11:01 AM   #2
Moonesar
Bimmer Stance
 
Drives: Lexus IS300 & E90 325xi
Join Date: Jul 2011
Location: NJ

Posts: 54
iTrader: (0)

No one knows? Really?
Moonesar is offline   United_States
0
Reply With Quote
      12-10-2011, 11:13 AM   #3
Technic
Lieutenant General
 
Technic's Avatar
 
Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

Posts: 11,099
iTrader: (17)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by Moonesar View Post
I just purchased MTX Subs and amp and 4guage wires to hook up to my stock E90 325xi.

I was informed i need some type of aux adapter that has rca cables to hook up the amp to the stock head unit but not sure where to find them.

I search crutchfield but couldn't find anything bmw specific, anyone know where i can get this item or if i even need it? Maybe i need more?

I searched but got miminal help.

Thanks
What is the OEM system in your car?
__________________
-2015 F30 320i, Imperial/Oyster, 8AT: August 2014 ED
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: Gone
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
Technic is offline   United_States
0
Reply With Quote
      12-10-2011, 11:19 AM   #4
Moonesar
Bimmer Stance
 
Drives: Lexus IS300 & E90 325xi
Join Date: Jul 2011
Location: NJ

Posts: 54
iTrader: (0)

Regular Professional .. no IDRIVE no LOGIC
Moonesar is offline   United_States
0
Reply With Quote
      12-10-2011, 11:40 AM   #5
Technic
Lieutenant General
 
Technic's Avatar
 
Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

Posts: 11,099
iTrader: (17)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by Moonesar View Post
Regular Professional .. no IDRIVE no LOGIC
Do you want to keep your OEM amp? I sell a harness to interface your sub/amp combo to the OEM amp without cutting or tapping the OEM wires. PM for details.
__________________
-2015 F30 320i, Imperial/Oyster, 8AT: August 2014 ED
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: Gone
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
Technic is offline   United_States
0
Reply With Quote
      12-18-2011, 08:43 PM   #6
Moonesar
Bimmer Stance
 
Drives: Lexus IS300 & E90 325xi
Join Date: Jul 2011
Location: NJ

Posts: 54
iTrader: (0)

Hooked it up to stock headunit through the amp in the back .. it bumped so much harder in my friends truck that has a aftermarket headunit. Even with the gain all the way up it doesnt hit nearly as hard as in my friends truck. Is this because he's running an aftermarket headunit? Right now im running a high/low converter. What you guys think?
Moonesar is offline   United_States
0
Reply With Quote
      12-18-2011, 08:56 PM   #7
ctuna
Brigadier General
 
Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

Posts: 4,221
iTrader: (0)

I might help to know what is in your car.

http://www.e90post.com/forums/attach...2&d=1260829447

http://www.e90post.com/forums/attach...2&d=1266451970

http://www.e90post.com/forums/attach...1&d=1209780865

its because the BMW amp is so wimpy.
Also the BMW has lots of sound insulation
ctuna is offline  
0
Reply With Quote
      12-18-2011, 09:32 PM   #8
Moonesar
Bimmer Stance
 
Drives: Lexus IS300 & E90 325xi
Join Date: Jul 2011
Location: NJ

Posts: 54
iTrader: (0)

The bmw stock amp would effect how hard the aftemarket sub and amp are hitting? Overall besides the cabin bass the subwoofers were pumping more bass on his car, i just want verification that this is probably because of him having an aftermarket headunit to adjust the bass more in detail?
Moonesar is offline   United_States
0
Reply With Quote
      12-19-2011, 06:27 AM   #9
kaigoss69
Brigadier General
 
kaigoss69's Avatar
 
Drives: '08 335i
Join Date: Jul 2008
Location: JAX

Posts: 3,029
iTrader: (5)

Quote:
Originally Posted by Moonesar View Post
The bmw stock amp would effect how hard the aftemarket sub and amp are hitting? Overall besides the cabin bass the subwoofers were pumping more bass on his car, i just want verification that this is probably because of him having an aftermarket headunit to adjust the bass more in detail?
Negative. If connected and setup correctly, there should not be any difference between aftermarket and OEM HU signals. Which output of the OEM amp did you tap for the signal?
__________________
Mobridge DA2 > JBL MS-8 > JL Audio HD600/4 > (3) Hybrid Audio L3SE & (2) Rainbow Cal25; JL Audio HD900/5 > (2) Morel HCW-10 & (1) IDMax 15
kaigoss69 is offline   United_States
0
Reply With Quote
      12-19-2011, 09:40 AM   #10
Moonesar
Bimmer Stance
 
Drives: Lexus IS300 & E90 325xi
Join Date: Jul 2011
Location: NJ

Posts: 54
iTrader: (0)

I took it to best buy and i had them set it up with a hi/low converter so im not sure which output on the stock amp they tapped into. Would this make a difference? I can check it out
Moonesar is offline   United_States
0
Reply With Quote
      12-19-2011, 10:00 AM   #11
kaigoss69
Brigadier General
 
kaigoss69's Avatar
 
Drives: '08 335i
Join Date: Jul 2008
Location: JAX

Posts: 3,029
iTrader: (5)

Quote:
Originally Posted by Moonesar View Post
I took it to best buy and i had them set it up with a hi/low converter so im not sure which output on the stock amp they tapped into. Would this make a difference? I can check it out
Oh boy. Search this forum for "wiring diagrams" and find the color code of the underseat woofer amp outputs for you audio system (sounds like you have HiFi). Make sure they used those outputs and that the polarity is correct. Also make sure they only tapped the outputs and did not completely disconnect them.
__________________
Mobridge DA2 > JBL MS-8 > JL Audio HD600/4 > (3) Hybrid Audio L3SE & (2) Rainbow Cal25; JL Audio HD900/5 > (2) Morel HCW-10 & (1) IDMax 15
kaigoss69 is offline   United_States
0
Reply With Quote
      12-19-2011, 10:12 AM   #12
Moonesar
Bimmer Stance
 
Drives: Lexus IS300 & E90 325xi
Join Date: Jul 2011
Location: NJ

Posts: 54
iTrader: (0)

I do not think i have the HIFI system, just the base stereo system (i have a 325xi) would this system still have the underseat woofer amp outputs>?
Moonesar is offline   United_States
0
Reply With Quote
      12-19-2011, 10:59 AM   #13
kaigoss69
Brigadier General
 
kaigoss69's Avatar
 
Drives: '08 335i
Join Date: Jul 2008
Location: JAX

Posts: 3,029
iTrader: (5)

Quote:
Originally Posted by Moonesar View Post
I do not think i have the HIFI system, just the base stereo system (i have a 325xi) would this system still have the underseat woofer amp outputs>?
If you have tweeters in the sail panels (mirror triangles) and a center channel then you have Logic 7. If you're missing the center, you have Hifi. If you're also missing the tweeters in the sail panels, you have the base system.

In any case you have woofers under the seats. But the way you connect the aftermarket amp is different in the base system.

First tell us which system you have. You may also want t search for best buy since you would not be the first BMW install they f'ed up.
__________________
Mobridge DA2 > JBL MS-8 > JL Audio HD600/4 > (3) Hybrid Audio L3SE & (2) Rainbow Cal25; JL Audio HD900/5 > (2) Morel HCW-10 & (1) IDMax 15
kaigoss69 is offline   United_States
0
Reply With Quote
      12-19-2011, 11:47 AM   #14
Moonesar
Bimmer Stance
 
Drives: Lexus IS300 & E90 325xi
Join Date: Jul 2011
Location: NJ

Posts: 54
iTrader: (0)

I have tweeters in the front and passenger window that i believe your talking about so i guess i do have the HiFi system. Had no idea, im in the process of contacting best buy as well.
Moonesar is offline   United_States
0
Reply With Quote
      12-19-2011, 12:11 PM   #15
kaigoss69
Brigadier General
 
kaigoss69's Avatar
 
Drives: '08 335i
Join Date: Jul 2008
Location: JAX

Posts: 3,029
iTrader: (5)

In the left rear corner of the trunk there us a grey panel. Pop it off. The hifi amp is underneath. You can probably shine a flashlight in there and see which wires were tapped. DO NOT trust them to have hooked it up correctly and DO NOT let them touch it again. Look for the wiring diagrams and check yourself. If they wired it incorrectly I would correct it myself. Best post some pics of the wiring and we'll help you figure it out.
__________________
Mobridge DA2 > JBL MS-8 > JL Audio HD600/4 > (3) Hybrid Audio L3SE & (2) Rainbow Cal25; JL Audio HD900/5 > (2) Morel HCW-10 & (1) IDMax 15
kaigoss69 is offline   United_States
0
Reply With Quote
      12-22-2011, 08:39 AM   #16
Moonesar
Bimmer Stance
 
Drives: Lexus IS300 & E90 325xi
Join Date: Jul 2011
Location: NJ

Posts: 54
iTrader: (0)

So i fixed the wires and now the subs hit the way they should ... however, after about 2 minutes they subs start fading in and out randomly. Figured a solution was to lower the gains which i lowered on the sub first and it didnt help much, eventually lowered the gains on the bass knob and lowered volume too with no luck. All wires are secure and it was working fine hitting really nice lows & highs.. but i dont know why the sub is going in and out randomly? Any ideas?
Moonesar is offline   United_States
0
Reply With Quote
      12-23-2011, 10:57 AM   #17
Moonesar
Bimmer Stance
 
Drives: Lexus IS300 & E90 325xi
Join Date: Jul 2011
Location: NJ

Posts: 54
iTrader: (0)

Rewired everything, i think the gains were too high as well as the settings on the headunit, everything was high. So the distortion usually comes when the gains are high, only way to remedy this of course is getting a stronger amp, but what do you guys think about a new headunit although i know its complicated with out cars. Think its best to get a new headunit to run RCA instead of these shitty stereo wires everything is hooked up with? Also, i do not have an official high lo convertor, should i consider buying a worthy high low? Any recommendations ?
Moonesar is offline   United_States
0
Reply With Quote
      12-23-2011, 11:45 AM   #18
kaigoss69
Brigadier General
 
kaigoss69's Avatar
 
Drives: '08 335i
Join Date: Jul 2008
Location: JAX

Posts: 3,029
iTrader: (5)

You need a good hi-low converter. If you keep running without one, you will end up blowing your amp and or subs, if you haven't already done so.
__________________
Mobridge DA2 > JBL MS-8 > JL Audio HD600/4 > (3) Hybrid Audio L3SE & (2) Rainbow Cal25; JL Audio HD900/5 > (2) Morel HCW-10 & (1) IDMax 15
kaigoss69 is offline   United_States
0
Reply With Quote
      12-29-2011, 08:32 AM   #19
Moonesar
Bimmer Stance
 
Drives: Lexus IS300 & E90 325xi
Join Date: Jul 2011
Location: NJ

Posts: 54
iTrader: (0)

Any recommendations on which 1 to buy and where from?
Moonesar is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:02 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST