E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > Australia > Alpine HiFi Upgrade



Reply
 
Thread Tools Search this Thread
      08-14-2011, 03:34 AM   #1
PerthBMW
Second Lieutenant
 
PerthBMW's Avatar
 
Drives: 2010 325i M Sports Innovation
Join Date: Jan 2011
Location: Perth Western Australia

Posts: 298
iTrader: (0)

Alpine HiFi Upgrade

Hey guys

Well I have my car booked in for Tuesday to get the Alpine HiFi upgrade done on the sound system. I purchased the HiFi kit and 2 x door surrounds from Schmiedmann in Denmark (had to return original shipment as tweeters were damaged - all good now new kit shipped back to me). I saved a lot of money purchasing the kit this way.

I am getting ripped off on the install at the Stealers but I have no choice if I want the warranty - it also has to be coded once installed. The down side of Perth only having one Stealer - you constantly get ripped off.

Will let you know how I go and if it is worth the $1,000.
Attached Images
     
PerthBMW is offline   Australia
0
Reply With Quote
      08-14-2011, 03:40 AM   #2
sbce90
Me Boosta
 
sbce90's Avatar
 
Drives: 320i / MB C63 / VW up!
Join Date: Jan 2010
Location: Sydney, Australia

Posts: 5,456
iTrader: (3)

Let me know.
sbce90 is offline   Australia
0
Reply With Quote
      08-14-2011, 03:52 AM   #3
OOOSQ
First Lieutenant
 
OOOSQ's Avatar
 
Drives: 2012 2.0d AW X3 M-Sport
Join Date: Mar 2009
Location: Brisbane, Australia

Posts: 348
iTrader: (0)

They look like Alpine DD Linears....... hmmm.
__________________
OOOSQ is offline   Australia
0
Reply With Quote
      08-14-2011, 03:42 PM   #4
bmwaddiction
Lieutenant
 
Drives: Titanium Silver 325i E90
Join Date: Feb 2010
Location: Darwin

Posts: 412
iTrader: (0)

mate, I've done exactly the same thing last year - the sound quality rocks compared to stock audio set up on a 325i
bmwaddiction is offline   Australia
0
Reply With Quote
      08-16-2011, 05:44 AM   #5
PerthBMW
Second Lieutenant
 
PerthBMW's Avatar
 
Drives: 2010 325i M Sports Innovation
Join Date: Jan 2011
Location: Perth Western Australia

Posts: 298
iTrader: (0)

Hi guys

Took the car to the Stealers today for the kit o be fitted. Got rung at 3:00 PM and told they needed to reprogram the car to recognise the amp and their system crashed so will need to keep the car overnight. Mentioned that they now need to completely reprogram the car so I guess one benefit is I get the latest of everything.

The additional work is at their cost so catching the train for one night won't kill me.

Let you know what it is like when I get it back tomrrow
PerthBMW is offline   Australia
0
Reply With Quote
      08-16-2011, 05:55 AM   #6
gaza01
Lieutenant Colonel
 
gaza01's Avatar
 
Drives: E92 335i
Join Date: Dec 2010
Location: London

Posts: 1,685
iTrader: (3)

Eh???...read loads of alpine upgrade threads. Never heard of the car needing recodig to recognise the amp! The supply to the amp is tapped off the speaker signal to the fronts after its left the head unit. Power is straight from the battery in the boot. The install is completely outside the intricacies of the bmw computer / coding requirements. Sounds like you're getting ripped off double time!!!
gaza01 is offline   United Kingdom
0
Reply With Quote
      08-16-2011, 06:01 AM   #7
Chris.G
Banned
 
Chris.G's Avatar
 
Drives: 2011 LCI MSPORT X5 30d
Join Date: Aug 2006
Location: Sydney, Australia

Posts: 3,122
iTrader: (0)

I can't wait for SBC's post...
Chris.G is offline   Australia
0
Reply With Quote
      08-16-2011, 06:20 AM   #8
PerthBMW
Second Lieutenant
 
PerthBMW's Avatar
 
Drives: 2010 325i M Sports Innovation
Join Date: Jan 2011
Location: Perth Western Australia

Posts: 298
iTrader: (0)

Nope I'm not...the installation instructions clearly state that the system needs to be coded to recognise the amp. Suggest you Google the instructions for the kit for models after March 2009.

Oh also, thanks for your positive and encouraging words - you are a real motivator arenít you.




Quote:
Originally Posted by gaza01 View Post
Eh???...read loads of alpine upgrade threads. Never heard of the car needing recodig to recognise the amp! The supply to the amp is tapped off the speaker signal to the fronts after its left the head unit. Power is straight from the battery in the boot. The install is completely outside the intricacies of the bmw computer / coding requirements. Sounds like you're getting ripped off double time!!!
PerthBMW is offline   Australia
0
Reply With Quote
      08-16-2011, 07:32 AM   #9
sbce90
Me Boosta
 
sbce90's Avatar
 
Drives: 320i / MB C63 / VW up!
Join Date: Jan 2010
Location: Sydney, Australia

Posts: 5,456
iTrader: (3)

Quote:
Originally Posted by Chris.G View Post
I can't wait for SBC's post...


OP don't worry about that fool. Car does need to be coded and being kept over night is no biggie. First time I put my car in to have Alpine done they kept it over night. The subsequent 9 months of appointments weren't so good.
sbce90 is offline   Australia
0
Reply With Quote
      08-16-2011, 06:09 PM   #10
gaza01
Lieutenant Colonel
 
gaza01's Avatar
 
Drives: E92 335i
Join Date: Dec 2010
Location: London

Posts: 1,685
iTrader: (3)

i stand corrected...didn't realise the newer models needed coding...currently doing the same on mine albeit an older model that doesn't need coding so I was wrong.

...and i wasn't trying to be discouraging...was actually trying to help
gaza01 is offline   United Kingdom
0
Reply With Quote
      08-16-2011, 06:52 PM   #11
pcockley
Banned
 
Drives: 335
Join Date: Apr 2011
Location: sydney

Posts: 1,732
iTrader: (1)

Quote:
Originally Posted by SBC View Post
The subsequent 9 months of appointments weren't so good.
9 Months
pcockley is offline  
0
Reply With Quote
      08-16-2011, 08:24 PM   #12
Dan320
Enlisted Member
 
Drives: 320d
Join Date: Mar 2010
Location: Sydney

Posts: 40
iTrader: (1)

Was it in labor after 9 months


Quote:
Originally Posted by SBC View Post


OP don't worry about that fool. Car does need to be coded and being kept over night is no biggie. First time I put my car in to have Alpine done they kept it over night. The subsequent 9 months of appointments weren't so good.
Dan320 is offline  
0
Reply With Quote
      08-17-2011, 05:59 PM   #13
PerthBMW
Second Lieutenant
 
PerthBMW's Avatar
 
Drives: 2010 325i M Sports Innovation
Join Date: Jan 2011
Location: Perth Western Australia

Posts: 298
iTrader: (0)

Hi everyone

Got the car back yesterday and man is the sound better - I really can't believe how it is now compared to the standard installation. As far as I am concerned it was well worth the money. Only thing is you need to drop the treble down due to the tweeters in the door surrounds.

I am going to install some Alpine SPS-410 speakers in the parcel shelf on the weekend and they are a 4" speaker/tweeter combo.

Well if you are thinking of upgrading I would recommend the Alpine HiFi kit - glad I did it.
PerthBMW is offline   Australia
0
Reply With Quote
      08-18-2011, 02:41 AM   #14
Ninjaoz
Captain
 
Ninjaoz's Avatar
 
Drives: BMW
Join Date: Feb 2008
Location: Melbourne

Posts: 915
iTrader: (0)

Garage List
2007 BMW X5 3.0d  [5.00]
2011 BMW 320d  [5.00]
niceeee! how much did you pay for the installation if you don't mine me asking?
Ninjaoz is offline   Australia
0
Reply With Quote
      08-18-2011, 09:11 AM   #15
sbce90
Me Boosta
 
sbce90's Avatar
 
Drives: 320i / MB C63 / VW up!
Join Date: Jan 2010
Location: Sydney, Australia

Posts: 5,456
iTrader: (3)

Good to hear yours worked perthbmw! It really is better than stock.
sbce90 is offline   Australia
0
Reply With Quote
      08-19-2011, 08:33 PM   #16
PerthBMW
Second Lieutenant
 
PerthBMW's Avatar
 
Drives: 2010 325i M Sports Innovation
Join Date: Jan 2011
Location: Perth Western Australia

Posts: 298
iTrader: (0)

Quote:
Originally Posted by Ninja333 View Post
niceeee! how much did you pay for the installation if you don't mine me asking?
$600 but you would no doubt get it cheaper on the East Coast due to Stealer competition - we only have one Stealer in Perth so you get screwed.
PerthBMW is offline   Australia
0
Reply With Quote
      09-20-2011, 08:35 PM   #17
gcbm
New Member
 
Drives: e82 135i
Join Date: Feb 2011
Location: Gold Coast, Australia

Posts: 13
iTrader: (0)

Who did you deal with at Schmiedmann? I ordered the same kit a few months back but the door covers turned up damaged (combination of them being bent to fit in the undersized box and the box being squashed in shipment). Despite some early promise I have no replacements and my emails are no longer being answered.
gcbm is offline   Australia
0
Reply With Quote
      01-03-2012, 05:35 PM   #18
Tichx
Private First Class
 
Drives: E92 335D Coupe
Join Date: Nov 2011
Location: London

Posts: 103
iTrader: (0)

Quote:
Originally Posted by PerthBMW View Post
Hi everyone

Got the car back yesterday and man is the sound better - I really can't believe how it is now compared to the standard installation. As far as I am concerned it was well worth the money. Only thing is you need to drop the treble down due to the tweeters in the door surrounds.

I am going to install some Alpine SPS-410 speakers in the parcel shelf on the weekend and they are a 4" speaker/tweeter combo.

Well if you are thinking of upgrading I would recommend the Alpine HiFi kit - glad I did it.
Quick question, I also have the Alpine kit, did you get the rear shelf speakers installed? how did you connect and power?

appreciated!
Tichx is offline  
0
Reply With Quote
      01-03-2012, 06:06 PM   #19
PerthBMW
Second Lieutenant
 
PerthBMW's Avatar
 
Drives: 2010 325i M Sports Innovation
Join Date: Jan 2011
Location: Perth Western Australia

Posts: 298
iTrader: (0)

Quote:
Originally Posted by Tichx View Post
Quick question, I also have the Alpine kit, did you get the rear shelf speakers installed? how did you connect and power?

appreciated!
Hi

No I did them myself - only took about 20 mins each. You just have to snap off one of the four mounting screw brackets (can only fit 3 in ******* and then connect the leads...all too easy and I think the sound is much better...

Hope that helps
PerthBMW is offline   Australia
0
Reply With Quote
      01-03-2012, 06:09 PM   #20
PerthBMW
Second Lieutenant
 
PerthBMW's Avatar
 
Drives: 2010 325i M Sports Innovation
Join Date: Jan 2011
Location: Perth Western Australia

Posts: 298
iTrader: (0)

Quote:
Originally Posted by gcbm View Post
Who did you deal with at Schmiedmann? I ordered the same kit a few months back but the door covers turned up damaged (combination of them being bent to fit in the undersized box and the box being squashed in shipment). Despite some early promise I have no replacements and my emails are no longer being answered.
The owner himself - Martin Andresen. Excuse the French but he is noting more than a wanker...I would NEVER deal with them again as they are crooks and won't replace damaged parts.
PerthBMW is offline   Australia
0
Reply With Quote
      01-03-2012, 06:12 PM   #21
Tichx
Private First Class
 
Drives: E92 335D Coupe
Join Date: Nov 2011
Location: London

Posts: 103
iTrader: (0)

Quote:
Originally Posted by PerthBMW View Post
Hi

No I did them myself - only took about 20 mins each. You just have to snap off one of the four mounting screw brackets (can only fit 3 in ******* and then connect the leads...all too easy and I think the sound is much better...

Hope that helps
sorry I think you miss read my question, I already have the Alpine Retrofit Kit installed...

How did you install the rear parcel shelf speakers and power? you mention Alpine SPS-410....

Thanks!
Tichx is offline  
0
Reply With Quote
      01-04-2012, 07:21 AM   #22
PerthBMW
Second Lieutenant
 
PerthBMW's Avatar
 
Drives: 2010 325i M Sports Innovation
Join Date: Jan 2011
Location: Perth Western Australia

Posts: 298
iTrader: (0)

Quote:
Originally Posted by Tichx View Post
sorry I think you miss read my question, I already have the Alpine Retrofit Kit installed...

How did you install the rear parcel shelf speakers and power? you mention Alpine SPS-410....

Thanks!
Yep that's what I was referring to - the rear deck speakers. Just removed the OEM ones, napped off one of the four mounting prongs and then wired them up using teh existing connections...

hope that helps...
PerthBMW is offline   Australia
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:18 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST