E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > iDrive crash and replacement questions



Reply
 
Thread Tools Search this Thread
      01-06-2012, 03:18 PM   #1
beer ad
New Member
 
Drives: E90 330i
Join Date: Aug 2008
Location: CLT

Posts: 27
iTrader: (3)

iDrive crash and replacement questions

First, I think it's bulls**t that a $2000 option fails on a <6yo car, is not covered under any CPO or extended warranty, and the dealer wants $1500 to fix/replace. So, I am forced to drive the car with no monitoring systems like Temps, TPMS etc., not to mention no Entertainment or Navigation until I get this fixed.. total bs.

I've been looking the options available and based on the price of the retrofit kits out there for CIC, and my plans to get into something else in the next few years, I can't justify the expense. So I'll be going the replacement and DIY route (which appears to have it's own obstacles!)

Hoping someone on here can help me with a few questions I have re: replacing the CCC before I tear into this..

Is there any way to bench test the unit once it's out of the car to see if the CCC is truly bad? I'm going by my dealer's diagnosis, and I always question their assessments, especially when they start talking 4 digit repair costs.

I ask because iDrive worked intermittently until I replaced the battery in the car. I had been getting a "Battery Low Charge" message that had become increasingly more frequent and thought it might have been related to my CCC failure (no warning at all, btw.. just driving along and iDrive went out). But after the car would sit, iDrive would boot, function for about 10min, then shut down again. Now that I have replaced the battery (dealer installed, along with his "no comm to CCC" diagnosis) there is nothing. Based on some research, replacing the battery was a potential fix to some CCC crashes, but I find it odd that it no longer boots at all. Of note, the HU still illuminates and the cooling fan on the backside of the unit functions. If anything, I just want to get power to the unit so I can eject the media before I send the unit in as a core. They tell me they can't guarantee I'll get the media back. I can't really do much without the Nav DVD, can I?

Lastly, when I install the new unit, what needs to happen? I suppose I'll need to return to the dealer for the new iDrive to be activated for my car (i call bs on that, too), but is there any plug-n-play functionality.. like maybe my Radio and/or Navigation? The install looks pretty straightforward, and it would be nice to have some of the functionality back before I have to take it back to the dealer and incur THAT expense!

Thanks for any info!
__________________
beer ad is offline   United_States
0
Reply With Quote
      01-06-2012, 03:38 PM   #2
GetSomeE92
Major
 
Drives: '09 Space Gray E92
Join Date: Mar 2011
Location: Miami, FL

Posts: 1,072
iTrader: (7)

Have you tried taking the car to an independent BMW shop to see what they say and what they would charge?
GetSomeE92 is offline   United_States
0
Reply With Quote
      01-06-2012, 03:58 PM   #3
beer ad
New Member
 
Drives: E90 330i
Join Date: Aug 2008
Location: CLT

Posts: 27
iTrader: (3)

Quote:
Originally Posted by GetSomeE92 View Post
Have you tried taking the car to an independent BMW shop to see what they say and what they would charge?
Actually no.. that's a good idea. Electronics can be tricky, and just thought the dealer techs would be best suited/trained to diagnose and repair. I'm fairly new the area, been under CPO/Maint Program, and haven't had a need to look for a reputable BMW indy in Charlotte. When I had my B5 S4, the indies I used here were mediocre at best so I did the work myself, inc. turbo swap.

I guess now's the time to find one!
__________________
beer ad is offline   United_States
0
Reply With Quote
      01-06-2012, 04:04 PM   #4
Technic
Lieutenant General
 
Technic's Avatar
 
Drives: 2012 E92 M3, 2014 528i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

Posts: 10,980
iTrader: (17)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by beer ad View Post
First, I think it's bulls**t that a $2000 option fails on a <6yo car, is not covered under any CPO or extended warranty, and the dealer wants $1500 to fix/replace. So, I am forced to drive the car with no monitoring systems like Temps, TPMS etc., not to mention no Entertainment or Navigation until I get this fixed.. total bs.

I've been looking the options available and based on the price of the retrofit kits out there for CIC, and my plans to get into something else in the next few years, I can't justify the expense. So I'll be going the replacement and DIY route (which appears to have it's own obstacles!)

Hoping someone on here can help me with a few questions I have re: replacing the CCC before I tear into this..

Is there any way to bench test the unit once it's out of the car to see if the CCC is truly bad? I'm going by my dealer's diagnosis, and I always question their assessments, especially when they start talking 4 digit repair costs.

I ask because iDrive worked intermittently until I replaced the battery in the car. I had been getting a "Battery Low Charge" message that had become increasingly more frequent and thought it might have been related to my CCC failure (no warning at all, btw.. just driving along and iDrive went out). But after the car would sit, iDrive would boot, function for about 10min, then shut down again. Now that I have replaced the battery (dealer installed, along with his "no comm to CCC" diagnosis) there is nothing. Based on some research, replacing the battery was a potential fix to some CCC crashes, but I find it odd that it no longer boots at all. Of note, the HU still illuminates and the cooling fan on the backside of the unit functions. If anything, I just want to get power to the unit so I can eject the media before I send the unit in as a core. They tell me they can't guarantee I'll get the media back. I can't really do much without the Nav DVD, can I?

Lastly, when I install the new unit, what needs to happen? I suppose I'll need to return to the dealer for the new iDrive to be activated for my car (i call bs on that, too), but is there any plug-n-play functionality.. like maybe my Radio and/or Navigation? The install looks pretty straightforward, and it would be nice to have some of the functionality back before I have to take it back to the dealer and incur THAT expense!

Thanks for any info!
http://www.ebay.com/itm/BMW-E90-E91-...item45fea2c868

Any local Autologic shop can code that unit to your car. Forum vendor BimmerTech can code it for your remotely -and most probably can even find you a cheaper CCC unit as well.
__________________
-2015 F30 320i, Imperial/Oyster, 8AT: August 2014 ED
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: September 2011 ED
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
Technic is offline   United_States
0
Reply With Quote
      01-06-2012, 04:18 PM   #5
timmahh
ghey
 
timmahh's Avatar
 
Drives: Viertürigen Fahrzeugs
Join Date: Oct 2010
Location: Southern California

Posts: 1,111
iTrader: (0)

So what exactly is wrong with it? Does it work fine for a few mins then shuts down? Do you get any visual on the screen?

The H.U. illumination probably doesn't mean much as that's controlled by the headlight switch in the car; different circuits etc.

The CCC has several components, including ram that could be bad.. Have you pulled the unit out a bit to see if touching any wires in the back yields any difference?

Have you tried the CCC hard reset [for when it's locked up]? Press the eject buttons on both the dvd-drive and the cd-drive, while holding press the volume/power/mute button. That should reset the system.

Try unpairing and unplugging all devices when it is working and see if that yields any difference, an old co worker had consistant lockups on the CCC when his blackberry was paired to the car. Unplug iPod etc.
__________________

The females confuse me.
timmahh is offline   United_States
0
Reply With Quote
      01-06-2012, 05:01 PM   #6
beer ad
New Member
 
Drives: E90 330i
Join Date: Aug 2008
Location: CLT

Posts: 27
iTrader: (3)

Quote:
Originally Posted by timmahh View Post
So what exactly is wrong with it? Does it work fine for a few mins then shuts down? Do you get any visual on the screen?

The H.U. illumination probably doesn't mean much as that's controlled by the headlight switch in the car; different circuits etc.

The CCC has several components, including ram that could be bad.. Have you pulled the unit out a bit to see if touching any wires in the back yields any difference?

Have you tried the CCC hard reset [for when it's locked up]? Press the eject buttons on both the dvd-drive and the cd-drive, while holding press the volume/power/mute button. That should reset the system.

Try unpairing and unplugging all devices when it is working and see if that yields any difference, an old co worker had consistant lockups on the CCC when his blackberry was paired to the car. Unplug iPod etc.
It does absolutely nothing now (exc. HU illum and fan)..I have a blank screen. Prior to battery replacement it worked for short periods of time for 3 days after it first went out. When it first went out, I was 15min in on my drive from ATL back to CLT (that was a fun 3h!). It didn't boot back up until the next morning (about 12h rest) , even after multiple attempts to stop/start the car when I got home. Sat overnight and ran for 10min, then shut down. That continued until I took the car in for battery replacement on the 4th day.

I guess fan would also be controlled by different circuit.. makes sense

Hard reset was the first thing I tried, and have done countless times since. I still need to check voltage on it to see if it's getting power..I don't think it is. If it's not, I need to figure out why. My SA suggested MOST boots in sequence, and I do have the iPod module that I installed a few years ago, but it hasn't given me any problems. I have thought about looking at that...
__________________

Last edited by beer ad; 01-06-2012 at 05:33 PM.
beer ad is offline   United_States
0
Reply With Quote
      01-06-2012, 05:05 PM   #7
beer ad
New Member
 
Drives: E90 330i
Join Date: Aug 2008
Location: CLT

Posts: 27
iTrader: (3)

Quote:
Originally Posted by Technic View Post
http://www.ebay.com/itm/BMW-E90-E91-...item45fea2c868

Any local Autologic shop can code that unit to your car. Forum vendor BimmerTech can code it for your remotely -and most probably can even find you a cheaper CCC unit as well.
Thanks, I might try BT.. was contemplating their GB last week, didn't think to ask about sourcing a CCC from them. Come to think of it, what about sourcing from a dismantler?

That ebay unit is not much less than the reman unit I get from Tischer, and they offer a 2yr warranty. If it were the right unit, and $100 less, I might bite. I'll keep looking there, too.
__________________
beer ad is offline   United_States
0
Reply With Quote
      01-06-2012, 05:23 PM   #8
timmahh
ghey
 
timmahh's Avatar
 
Drives: Viertürigen Fahrzeugs
Join Date: Oct 2010
Location: Southern California

Posts: 1,111
iTrader: (0)

Quote:
Originally Posted by beer ad View Post
It does absolutely nothing now (exc. HU illum and fan)..I have a blank screen. Prior to battery replacement it worked for short periods of time for 3 days after it first went out. When it first went out, I was 15min in on my drive from ATL back to CLT (that was a fun 3h!). It didn't boot back up until the next morning (about 12h rest) , even after multiple attempts to stop/start the car when I got home. Sat overnight and ran for 10min, then shut down. That continued until I took the car in for battery replacement on the 4th day.

I guess fan would also be controlled by different circuit.. makes sense

Hard reset was the first thing I tried, and have done countless times since. I still need to check voltage on it to see if it's getting power..I don't think it is. If it's not, I need to figure out why. My SA suggested MOST boots in sequence, and I do have the iPod module that I installed a few years ago, but it hasn't given me any problems. I have thought about looking at that...
I would definately check for loose wires in the back first; take it apart to the point where you can reach your hand behind and adjust the various harnesses etc.

The MOST network is for audio/communication; i.e. I think you can have the MOST loop broken or invalid and still get visual on the headunit. The important thing about MOST is that it's a closed loop fiber network, and the signal source and signal termination must be by the main communication device, i.e. the head unit.

There's generally a method of the MOST loop device sequencing, i.e. a specific order, but I don't believe it's really THAT important. I added a sirius unit to my car, and did so by just using the next available spot in the MOST block. Mine was a tad confusing because my configuration spans both blocks, but so long as they loop in to one other and terminate back into the head unit, no problem.

I suppose if there was a fatal error in the MOST loop it could cause bootup issues; but again I would think you would get video to the screen. Various errors, etc. but you should at least see the BMW logo. I believe there's also a MOST diagnostic port under the driver kick panel; make sure that didn't come loose or is missing the termination cap. You can also check the MOST blocks, which are behind the driver side rear passenger seat, on the outermost section of the seat [by the door]. If you have fold down rear seats it's a piece of cake, if you have single piece seats... loads of fun.

Do you have the HK/L7 system? Did the dealer give any insight into fault codes as to why the unit is bad? I have the extended warranty but opted to not pay additional for the radio/nav; assuming that if and when it goes bad i'll swap for the CIC.
__________________

The females confuse me.
timmahh is offline   United_States
0
Reply With Quote
      01-06-2012, 05:29 PM   #9
timmahh
ghey
 
timmahh's Avatar
 
Drives: Viertürigen Fahrzeugs
Join Date: Oct 2010
Location: Southern California

Posts: 1,111
iTrader: (0)

Also.. if it helps, you're not alone:
http://www.e90post.com/forums/showthread.php?t=630685
__________________

The females confuse me.
timmahh is offline   United_States
0
Reply With Quote
      01-09-2012, 05:32 PM   #10
beer ad
New Member
 
Drives: E90 330i
Join Date: Aug 2008
Location: CLT

Posts: 27
iTrader: (3)

Thanks Timmahh.. very helpful.

Is there an easy way to determine if I have the HK/L7 system? There are no markings on the faceplates or speakers, and I can't recall if there was anything in iDrive that told me I did.

I got nothing more than "No communication to CCC" from my SA, so I have no fault codes to research. I suppose I could have it hooked up again to see if there are/were any.
__________________
beer ad is offline   United_States
0
Reply With Quote
      01-31-2012, 12:14 PM   #11
beer ad
New Member
 
Drives: E90 330i
Join Date: Aug 2008
Location: CLT

Posts: 27
iTrader: (3)

I'm all fixed now and just wanted to update this thread with my findings and resolution. My hope is that it helps others with crashed CCCs not wanting to go the CIC retrofit route.. While I contemplated, I won't be in this car long enough to justify the expense. Saved me some money doing DIY..

I was able to confirm my CCC had crashed. It had a 03/05 manufacture date, so this appeared to be a very early unit. I removed with basic trim with torx bit tools and checked all connections. Both CD & DVD drives would still spin, cooling fan and illumination still worked, but no functioning buttons, so I could not eject the media (nav DVD and single CD).

With these findings, I decided to purchase a factory remanufactured unit from Tischer that has a 2yr warranty. However, there was a core charge for the old unit. I had to crack the cases to retrieve media before sending, because they could not guarantee I'd get it back. This was the most difficult and time consuming part of the entire job, and required some specialty tools (T6/8 torx), but I picked up a kit for $10 and Advance that had what I needed.

I did find units on eBay for considerably less, but opted to go the Dealer route because of the unknowns around purchasing salvaged parts. I also contacted Bimmerretrofit as suggested earlier for a CCC, but told they only source CIC units.

When unit arrived, it was a 15min job to plug in and button everything up, since the old unit was already out. I'm still not sure where the dealer quote of $1500 came from, since I only have a little over an hour into it at this point. Part was half that..unless they are quoting new, which is possible.

Glad to see that there was some plug-and-play functionality upon new CCC installation. My navigation worked and appeared that all of my car monitoring systems were functional. However, I had no audio.. My dings, dongs, and bongs did not work, and had no sound from radio, or any other input. Checked with local indy shop and they said that dealer had to program the new unit, so off it went yesterday. Programming took pretty much all day, and evidently did not work until they did a reset of the CCC and battery together (??). Flat fee of $250 charged (which I thought was a little high), but I'm now back in business!
__________________

Last edited by beer ad; 02-01-2012 at 08:05 PM.
beer ad is offline   United_States
0
Reply With Quote
      02-20-2012, 05:19 PM   #12
e2d
Private
 
e2d's Avatar
 
Drives: 2006 325xi
Join Date: Sep 2008
Location: Chicago, USA

Posts: 77
iTrader: (0)

beer ad - me and you are in the same boat.. my i-drive crashed because the place i got my sub and amp installed forgot to plug back in the cooling fan thus the CCC overheated and crashed..

I got absolutely nothing.. No nav, radio, zip and it sucks.. I came across a thread by Bimmer Tech that the newer CIC system will fit too. It's about 1900 and then another $500-$900 to get it activated. That's not to mention install, but I heard it's basically plug an play and will take about 30 minutes so I can't imagine it would be that costly..

If my CCC system never crashed, I wouldn't try to retro fit the CIC system cause I wouldn't want to dump that much $$ on something I dont need. However, if its gonna already cost me $2000 bucks to replace an old system, I'd save an additonal few hundred bucks for the newer CIC system with added and up to date goodies... You might be able to even DIY... Just a thought..

Check out the site and thread...

http://www.e90post.com/forums/showth...hlight=CIC+CCC

http://www.bimmer-tech.net/
e2d is offline   United_States
0
Reply With Quote
      04-19-2012, 02:16 PM   #13
sea335i
Private First Class
 
Drives: 2008 335i Coupe
Join Date: Jul 2011
Location: Seattle

Posts: 102
iTrader: (0)

Thanks for all the info guys and updates, my situation is exactly the same. My ccc unit is not getting any power so looks like it needs to be replaced. unless theres some kind of shortage of power to it.

on ebay these units go for about 500-600$ dollars, its basically plug and play, and then get it reprogrammed. Very curious where does dealer get 3K number from for this repair? this is literally 1 hr job.
sea335i is offline  
0
Reply With Quote
      04-23-2012, 03:33 AM   #14
RaPiDneSs
Private First Class
 
RaPiDneSs's Avatar
 
Drives: E90 328i
Join Date: Aug 2010
Location: Stockton, CA

Posts: 153
iTrader: (0)

Well guys, my idrive just crashed as well, except I can still hear radio, switch to auxilary etc.. i have an 07 e90, the screen is just black. I left my car outside on saturday it was really hot 90 degrees. I drove it the night before and it was fine, in the morning i turned on the car and the screen was blank.

You guys think it might just be a fuse? This is really irritating, as I lost my old job wich i was making good money in, now im at a shitty job, I shouldnt even own a bimmer! cant afford going into the dealer anymore.

How do I know wich fuse is for the monitor?
RaPiDneSs is offline   Mexico
0
Reply With Quote
      06-04-2012, 01:58 PM   #15
sea335i
Private First Class
 
Drives: 2008 335i Coupe
Join Date: Jul 2011
Location: Seattle

Posts: 102
iTrader: (0)

Quote:
Originally Posted by RaPiDneSs View Post

How do I know wich fuse is for the monitor?
Not sure about e90 but there was an fuse layout floating around.


Update on my situation:
I got a CCC unit from one of the members on this forum(thank you), and had no sound either, going to get reprogrammed this week, hopefully that will fix the audio issue.
sea335i is offline  
0
Reply With Quote
      06-06-2012, 03:53 PM   #16
uhaulball
Brigadier General
 
Drives: e90 330xi
Join Date: Dec 2005
Location: Long Island, NY

Posts: 4,164
iTrader: (11)

Send a message via AIM to uhaulball
we need to get everyone in a group install. My i-Drive just went to shit and I know exactly how everyone feels. You should replace it right away because mine was out for over 3 wks and i just dealt with it but then finally the fan continued spinning and I guess it drained my battery. I had to jumpstart. So now the dealer is quoting 15xx.xx to replace and program. the part is $845.05 I checked on realOEM and they quoted me a similar price when I called back, and they are saying it is a 3hr job, they will not budge. Just adding my $.02. It seems 1500 is the ballpark figure for this. Which is unreasonable it should be closer to 1200.

and imo the CIC is a much larger expense to replace. Involving a pricier unit and longer hours to retrofit. but replacing the CCC we should not be charged more than an hour labor. they're overcharging $350 in labor.
__________________
'06 bsm e90 330xi : 18" VMR CSL : KW V3 : GruppeM Rep Intake : UUC/Corsa Catback : Hartge Lip : ACS Roof Spoiler
OEM CF Trunk Spoiler : CF Emblems. Pillars. Mirror. Grille : LUXER12 led plate : V1 Hardwired : OG.longtran e90post sticker! circa 2005
uhaulball is offline  
0
Reply With Quote
      03-14-2013, 10:03 AM   #17
RussG
Registered
 
RussG's Avatar
 
Drives: 2006 330i
Join Date: Jun 2012
Location: Central Iowa

Posts: 4
iTrader: (0)

Do you know if it is possible to bypass the NAV system if you buy and install the fiber optic loop jumper? Hopefully all other accesories should work maybe..
RussG is offline  
0
Reply With Quote
      06-12-2013, 04:49 AM   #18
Kish2604
Enlisted Member
 
Kish2604's Avatar
 
Drives: E92 335i
Join Date: May 2013
Location: Durban South Africa

Posts: 41
iTrader: (1)

Thank you for the reset information above...
Kish2604 is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:39 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST