E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > **First Time Tuners** Start Here** Official Misfire Thread| Updated!



Reply
 
Thread Tools Search this Thread
      01-08-2012, 02:21 AM   #23
dicostal
First Lieutenant
dicostal's Avatar
Italy
5
Rep
395
Posts

 
Drives: 2007 335i
Join Date: Jun 2010
Location: Italian in CT - USA

iTrader: (0)

Quote:
Originally Posted by vasillalov View Post
So basically, what you are saying that after eliminating the obvious: spark plugs and coils, it could be a wide variety of things that can cause a misfire: anything from carbon build up, bad fuel injector, fuel pump , etc etc.

...not the moon phase?

What do you suggest for my situation:

* 25K miles on car
* Brand new spark plugs
* Swapping coils does not move the misfires to a different cylinder
* Injectors and HPFP replaced less than 5K miles during recall campaign
I would try fuel injection cleaner. I know many say it does nothing to Di engines, but i can swear it eliminated some of hesitation on hard acceleration. Cheap enough to try.
__________________
GIAC stage II|AA DP|DCI|HELIX FMIC
Appreciate 0
      01-08-2012, 09:28 AM   #24
vasillalov
Mad Linux Guru On The Loose
vasillalov's Avatar
Bulgaria
84
Rep
4,196
Posts

 
Drives: 2008 335i Sedan
Join Date: Aug 2009
Location: Chicago, IL

iTrader: (3)

Garage List
2008 335i E90  [4.00]
Quote:
Originally Posted by dicostal View Post
I would try fuel injection cleaner. I know many say it does nothing to Di engines, but i can swear it eliminated some of hesitation on hard acceleration. Cheap enough to try.
Well, I'll give it a shot. If it is contaminated injector, it might help.
__________________
Equal Opportunity Harasser!
6MT | COBB | AR | AE | Forge DV | HPF | P3 Gauge | Hybrid Intake | O.S.Giken TCD | All M3 bits | TCKLine | StopTech
Appreciate 0
      01-09-2012, 12:48 PM   #25
nitehawk
Lieutenant Colonel
nitehawk's Avatar
Canada
20
Rep
1,638
Posts

 
Drives: e92 335i 6MT
Join Date: May 2011
Location: Toronto

iTrader: (15)

Garage List
Has anyone here successfully coded injectors by themselves? I searched around but there doesn't seem to be any detail on how to do this...
Appreciate 0
      01-09-2012, 03:40 PM   #26
vasillalov
Mad Linux Guru On The Loose
vasillalov's Avatar
Bulgaria
84
Rep
4,196
Posts

 
Drives: 2008 335i Sedan
Join Date: Aug 2009
Location: Chicago, IL

iTrader: (3)

Garage List
2008 335i E90  [4.00]
Quote:
Originally Posted by nitehawk View Post
Has anyone here successfully coded injectors by themselves? I searched around but there doesn't seem to be any detail on how to do this...
I am working on this! As soon as I get my cable in the mail, I'll make a DIY.
__________________
Equal Opportunity Harasser!
6MT | COBB | AR | AE | Forge DV | HPF | P3 Gauge | Hybrid Intake | O.S.Giken TCD | All M3 bits | TCKLine | StopTech
Appreciate 0
      01-09-2012, 04:23 PM   #27
nitehawk
Lieutenant Colonel
nitehawk's Avatar
Canada
20
Rep
1,638
Posts

 
Drives: e92 335i 6MT
Join Date: May 2011
Location: Toronto

iTrader: (15)

Garage List
Quote:
Originally Posted by vasillalov View Post
I am working on this! As soon as I get my cable in the mail, I'll make a DIY.
Appreciate 0
      01-11-2012, 06:23 PM   #28
JamesM3M5
Some dude
United_States
24
Rep
1,760
Posts

 
Drives: E28 M5, E92 335i
Join Date: Sep 2011
Location: Northern VA

iTrader: (0)

Why is this not stickied?
__________________
RRT Racing
E92 335i/6MT Dinan Stage 3: intercooler, oil cooler, intake, flash, exhaust, LW dual-mass flywheel.
Vishnu PWM methanol custom trunk mount, Diffsonline 3-clutch Salisbury custom diff, Ohlins Road and Track coilovers, Vorshlag camber plates, much more...
E28 M5 w/ buncha stuff, R171 SLK350
Appreciate 0
      01-11-2012, 11:16 PM   #29
vasillalov
Mad Linux Guru On The Loose
vasillalov's Avatar
Bulgaria
84
Rep
4,196
Posts

 
Drives: 2008 335i Sedan
Join Date: Aug 2009
Location: Chicago, IL

iTrader: (3)

Garage List
2008 335i E90  [4.00]
I received a new fuel injector in the mail today along with some tools. If the weather is good this weekend, I'll swap it out. Still no INPA cable though, so no coding yet...
__________________
Equal Opportunity Harasser!
6MT | COBB | AR | AE | Forge DV | HPF | P3 Gauge | Hybrid Intake | O.S.Giken TCD | All M3 bits | TCKLine | StopTech
Appreciate 0
      01-12-2012, 12:25 PM   #30
Eracer76
Second Lieutenant
Eracer76's Avatar
United_States
6
Rep
239
Posts

 
Drives: 2008 E92 335xi
Join Date: Nov 2011
Location: IL

iTrader: (5)

I bought my 08' with 54k miles on it less then two months ago. Installed the JB4 and I instantly started getting misfire codes for cylinders 3, 4, and multiple cylinders that same day. I have since changed the plugs and moved the coils around with no luck. I'm still getting misfires on 3 and occasionally 4 and 1.
The problem happens almost ALL the time at part throttle (75% max) from 2k - 5k rpm and the car stutters/shakes and starts running rough until I re-start the car. It's gotten to the point that it even happens on map 0 now But the strange part is, that if I just hammer down the gas pedal, most of the time it will run like a raped ape to redline with no misfires! But anything in-between 2k and 5k rpm accelerating moderately (which is most of my daily spirited driving) it misfires bad

Anyway, I called the BMW dealer I bought the car from (the car was originally bought, serviced, and traded back in from this dealer) and set up an appointment to have them look at it. I gave them the VIN and supposedly the recalls were done already and the HPFP was replaced sometime in 2010 and the injectors in Jan 2011... And of course the OEM warranty was up when I bought the car, but I'm still under the dealers 60 day used car warranty. So I'm hoping they find some bad injectors or coils and fix it for me!

This just sucks... so now I'm pulling out the JB4 and putting the car back to stock tonight, and leaving the SES light on with the 3 misfire codes still showing.
__________________
Gone >2008 BMW 335xi E92: 11.988 @ 114.080 MPH
BMS JB4 G5, WW meth kit, OCC ~ Stett CAI ~ Helix FMIC ~ ER Charge Pipe w/Tial BOV ~AR Catless DP~ Aero Front Lip ~ BMS LED Angel Eyes ~ Black Kidney Grills ~ Painted Lower Grills
Painted Reflectors ~ Aluminum Pedals ~ 35% window tint ~ Painted Calipers/Rotors ~ KW V1 Coilovers ~ 19" Avant Garde M310's 235/35 & 275/30 G-Max AS-03 tires
Appreciate 0
      01-12-2012, 01:12 PM   #31
vase330
Colonel
vase330's Avatar
United_States
37
Rep
2,676
Posts

 
Drives: E92 335i ; 14 RangeRover SSC
Join Date: Jan 2007
Location: Arlington, Va

iTrader: (1)

Sounds like LPFP starting to go. Sometimes it wont even throw a code and will just fail completely one day then throw a code. Once they change that and fuel pressure regulator everything will be peachy and you will discover that's what was causing your misfires.
__________________
E92 335 | Space Gray | Saddle Brown Dakota | Dark Burl Trim | ZPP | ZSP | AT | Idrive | 6FL | FBO | Dinan CAI | Quaife LSD | STG3 PROCede.
Appreciate 0
      01-12-2012, 02:28 PM   #32
Jeff@TopGearSolutions
BimmerPost Supporting Vendor
Jeff@TopGearSolutions's Avatar
United_States
244
Rep
18,382
Posts


 
Drives: C6 Z06, GSXR-750, 09 335i
Join Date: Dec 2008
Location: TopGearSolutions.com

iTrader: (32)

Send a message via AIM to Jeff@TopGearSolutions
Quote:
Originally Posted by Eracer76 View Post
I bought my 08' with 54k miles on it less then two months ago. Installed the JB4 and I instantly started getting misfire codes for cylinders 3, 4, and multiple cylinders that same day. I have since changed the plugs and moved the coils around with no luck. I'm still getting misfires on 3 and occasionally 4 and 1.
The problem happens almost ALL the time at part throttle (75% max) from 2k - 5k rpm and the car stutters/shakes and starts running rough until I re-start the car. It's gotten to the point that it even happens on map 0 now But the strange part is, that if I just hammer down the gas pedal, most of the time it will run like a raped ape to redline with no misfires! But anything in-between 2k and 5k rpm accelerating moderately (which is most of my daily spirited driving) it misfires bad

Anyway, I called the BMW dealer I bought the car from (the car was originally bought, serviced, and traded back in from this dealer) and set up an appointment to have them look at it. I gave them the VIN and supposedly the recalls were done already and the HPFP was replaced sometime in 2010 and the injectors in Jan 2011... And of course the OEM warranty was up when I bought the car, but I'm still under the dealers 60 day used car warranty. So I'm hoping they find some bad injectors or coils and fix it for me!

This just sucks... so now I'm pulling out the JB4 and putting the car back to stock tonight, and leaving the SES light on with the 3 misfire codes still showing.
Any other codes ? fuel related?
Appreciate 0
      01-12-2012, 08:57 PM   #33
Eracer76
Second Lieutenant
Eracer76's Avatar
United_States
6
Rep
239
Posts

 
Drives: 2008 E92 335xi
Join Date: Nov 2011
Location: IL

iTrader: (5)

Quote:
Originally Posted by Jeff@topgearsolutions View Post
Any other codes ? fuel related?
Nope, I've cleared the codes about a dozen times now, and I've never gotten anything but misfire codes for the specific cylinders and the multiple cylinder misfire code, and thats it... no other codes.
Before the new plugs, it was only cylinders 3 and 4 every time (and I reset the codes 3 or 4 times)
Then I replaced all the plugs and I switched the #3 and #4 coils to the #1 and #2 spots.... and now I still get a misfire code from #3 every time, and occasionally #1 and #2, show up also... So, I'm wondering if I have a couple coils going bad, and one injector in the #3 spot.

Quote:
Originally Posted by vase330 View Post
Sounds like LPFP starting to go. Sometimes it wont even throw a code and will just fail completely one day then throw a code. Once they change that and fuel pressure regulator everything will be peachy and you will discover that's what was causing your misfires.
That would be nice if it were that easy, and simply replacing the pump, but that wouldnt be my luck!
I guess we'll find out what the dealer finds when I take it in, either tomorrow or Monday.
__________________
Gone >2008 BMW 335xi E92: 11.988 @ 114.080 MPH
BMS JB4 G5, WW meth kit, OCC ~ Stett CAI ~ Helix FMIC ~ ER Charge Pipe w/Tial BOV ~AR Catless DP~ Aero Front Lip ~ BMS LED Angel Eyes ~ Black Kidney Grills ~ Painted Lower Grills
Painted Reflectors ~ Aluminum Pedals ~ 35% window tint ~ Painted Calipers/Rotors ~ KW V1 Coilovers ~ 19" Avant Garde M310's 235/35 & 275/30 G-Max AS-03 tires
Appreciate 0
      01-12-2012, 08:59 PM   #34
Jeff@TopGearSolutions
BimmerPost Supporting Vendor
Jeff@TopGearSolutions's Avatar
United_States
244
Rep
18,382
Posts


 
Drives: C6 Z06, GSXR-750, 09 335i
Join Date: Dec 2008
Location: TopGearSolutions.com

iTrader: (32)

Send a message via AIM to Jeff@TopGearSolutions
Quote:
Originally Posted by Eracer76 View Post
I bought my 08' with 54k miles on it less then two months ago. Installed the JB4 and I instantly started getting misfire codes for cylinders 3, 4, and multiple cylinders that same day. I have since changed the plugs and moved the coils around with no luck. I'm still getting misfires on 3 and occasionally 4 and 1.
The problem happens almost ALL the time at part throttle (75% max) from 2k - 5k rpm and the car stutters/shakes and starts running rough until I re-start the car. It's gotten to the point that it even happens on map 0 now But the strange part is, that if I just hammer down the gas pedal, most of the time it will run like a raped ape to redline with no misfires! But anything in-between 2k and 5k rpm accelerating moderately (which is most of my daily spirited driving) it misfires bad

Anyway, I called the BMW dealer I bought the car from (the car was originally bought, serviced, and traded back in from this dealer) and set up an appointment to have them look at it. I gave them the VIN and supposedly the recalls were done already and the HPFP was replaced sometime in 2010 and the injectors in Jan 2011... And of course the OEM warranty was up when I bought the car, but I'm still under the dealers 60 day used car warranty. So I'm hoping they find some bad injectors or coils and fix it for me!

This just sucks... so now I'm pulling out the JB4 and putting the car back to stock tonight, and leaving the SES light on with the 3 misfire codes still showing.
Quote:
Originally Posted by Eracer76 View Post
Nope, I've cleared the codes about a dozen times now, and I've never gotten anything but misfire codes for the specific cylinders and the multiple cylinder misfire code, and thats it... no other codes.
Before the new plugs, it was only cylinders 3 and 4 every time (and I reset the codes 3 or 4 times)
Then I replaced all the plugs and I switched the #3 and #4 coils to the #1 and #2 spots.... and now I still get a misfire code from #3 every time, and occasionally #1 and #2, show up also... So, I'm wondering if I have a couple coils going bad, and one injector in the #3 spot.
I was actually thinking that exact thing. Perhaps you have some carbon build up too though.
Appreciate 0
      01-12-2012, 09:01 PM   #35
RaihaX
Major General
RaihaX's Avatar
Australia
65
Rep
5,029
Posts

 
Drives: 08' 135i
Join Date: Aug 2008
Location: Australia, Perth

iTrader: (2)

Quote:
Originally Posted by Eracer76 View Post
Nope, I've cleared the codes about a dozen times now, and I've never gotten anything but misfire codes for the specific cylinders and the multiple cylinder misfire code, and thats it... no other codes.
Before the new plugs, it was only cylinders 3 and 4 every time (and I reset the codes 3 or 4 times)
Then I replaced all the plugs and I switched the #3 and #4 coils to the #1 and #2 spots.... and now I still get a misfire code from #3 every time, and occasionally #1 and #2, show up also... So, I'm wondering if I have a couple coils going bad, and one injector in the #3 spot.
Does JB4 had a auto code clear function?

I had limp mode a couple of times and I was only getting limp mode code, then realise that the procede was clearing the other codes.

Turn off the auto code clear and I saw the code.
Appreciate 0
      01-13-2012, 10:49 PM   #36
Jeff@TopGearSolutions
BimmerPost Supporting Vendor
Jeff@TopGearSolutions's Avatar
United_States
244
Rep
18,382
Posts


 
Drives: C6 Z06, GSXR-750, 09 335i
Join Date: Dec 2008
Location: TopGearSolutions.com

iTrader: (32)

Send a message via AIM to Jeff@TopGearSolutions
Bump to avoid more threads
Appreciate 0
      01-13-2012, 10:51 PM   #37
Brey335i
Brigadier General
Brey335i's Avatar
52
Rep
4,737
Posts

 
Drives: e46 ///M3
Join Date: Oct 2009
Location: Austin, TX

iTrader: (11)

Quote:
Originally Posted by Jeff@topgearsolutions View Post
Bump to avoid more threads
This needs to be a sticky
Appreciate 0
      01-14-2012, 10:17 AM   #38
B_davis
Private
0
Rep
85
Posts

 
Drives: 335xi
Join Date: Jan 2011
Location: Wilmington, OH

iTrader: (0)

Quote:
Originally Posted by Jeff@topgearsolutions View Post
Bump to avoid more threads
Come on Jeff you know better .... It's my TUNE thats causing my misfires!!!
Appreciate 0
      01-14-2012, 02:46 PM   #39
Jeff@TopGearSolutions
BimmerPost Supporting Vendor
Jeff@TopGearSolutions's Avatar
United_States
244
Rep
18,382
Posts


 
Drives: C6 Z06, GSXR-750, 09 335i
Join Date: Dec 2008
Location: TopGearSolutions.com

iTrader: (32)

Send a message via AIM to Jeff@TopGearSolutions
Quote:
Originally Posted by B_davis View Post
Come on Jeff you know better .... It's my TUNE thats causing my misfires!!!


edit sarcasm? lol

Last edited by Jeff@TopGearSolutions; 01-14-2012 at 03:00 PM.
Appreciate 0
      01-14-2012, 07:44 PM   #40
nitehawk
Lieutenant Colonel
nitehawk's Avatar
Canada
20
Rep
1,638
Posts

 
Drives: e92 335i 6MT
Join Date: May 2011
Location: Toronto

iTrader: (15)

Garage List
Sticky icky icky icky
Appreciate 0
      01-14-2012, 08:56 PM   #41
themyst
Major General
themyst's Avatar
South Korea
86
Rep
6,602
Posts

 
Drives: E90 335i LCI
Join Date: Feb 2009
Location: NYC

iTrader: (8)

Send a message via AIM to themyst
Bout time!
__________________
E90 LCI N54 6AT
Appreciate 0
      01-15-2012, 11:21 AM   #42
keendog42
New Member
0
Rep
23
Posts

 
Drives: 335i
Join Date: Dec 2011
Location: NJ

iTrader: (1)

This forum is making me a bit nervous. I bought my 07' 335i with 15k on it two years ago, now at 27k I haven't really had any issues other than a footwell module & the HPFP recall. I had planned on keeping this car as it's my favorite of all time but all the issues posted here i.e. coils, plugs, injectors, carbon build-up, etc. have me second guessing that decision. It almost seems as if it's a matter of when not if something will fail prematurely.
Appreciate 0
      01-16-2012, 08:34 AM   #43
nitehawk
Lieutenant Colonel
nitehawk's Avatar
Canada
20
Rep
1,638
Posts

 
Drives: e92 335i 6MT
Join Date: May 2011
Location: Toronto

iTrader: (15)

Garage List
Quote:
Originally Posted by keendog42 View Post
This forum is making me a bit nervous. I bought my 07' 335i with 15k on it two years ago, now at 27k I haven't really had any issues other than a footwell module & the HPFP recall. I had planned on keeping this car as it's my favorite of all time but all the issues posted here i.e. coils, plugs, injectors, carbon build-up, etc. have me second guessing that decision. It almost seems as if it's a matter of when not if something will fail prematurely.
It mainly comes with the territory of running an aggressive map. Misfires may not even show up running stock or a basic stage 1 map on any tune. Fortunately, it is fairly straightforward to diagnose and replace the usual suspects - plugs and coils. It does not cost that much either; I would not let this deter you from keeping and enjoying your car
Appreciate 0
      01-16-2012, 12:57 PM   #44
Jeff@TopGearSolutions
BimmerPost Supporting Vendor
Jeff@TopGearSolutions's Avatar
United_States
244
Rep
18,382
Posts


 
Drives: C6 Z06, GSXR-750, 09 335i
Join Date: Dec 2008
Location: TopGearSolutions.com

iTrader: (32)

Send a message via AIM to Jeff@TopGearSolutions
Quote:
Originally Posted by keendog42 View Post
This forum is making me a bit nervous. I bought my 07' 335i with 15k on it two years ago, now at 27k I haven't really had any issues other than a footwell module & the HPFP recall. I had planned on keeping this car as it's my favorite of all time but all the issues posted here i.e. coils, plugs, injectors, carbon build-up, etc. have me second guessing that decision. It almost seems as if it's a matter of when not if something will fail prematurely.
Plugs and coils eventually fail on any car.

Carbon build up is inevitable on DI motors with any car.

Injectors are also common failure on DI motors.

All of this just comes with the territory. I always tell people to stay in warranty. I know I'm out of this car as soon as its done.

Car is great but too many quirks.

If you view any car forum all you see is the "Bad news". Since the information is here its not really a big deal. A few dollars here and there to make great power for a little money isnt a bad deal.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:21 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST