E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > DIY: Ultimate amplifier wiring guide



Reply
 
Thread Tools Search this Thread
      09-27-2010, 10:29 PM   #67
Jaya3666
New Member
 
Drives: E90
Join Date: Sep 2010
Location: Kuala Lumpur

Posts: 29
iTrader: (0)

harness

Hi, Thanks. Yes, I think so too. But I've no idea what or why I need an LOC and how to go about making the connection. I'm hoping the harness will solve my problem. I can't PM Technic yet until I have a sufficient number of posts. Technic has replied to another post of mine. So I'll follow up with him on that. I was hoping BSW would eventually come up with the amp upgrade, but from other posts, I think that may not happen soon. With my current set up, having only changed the door and rear speakers to the BSW, there's too much of a boomy mid bass. Don't know what to do. I wonder if anyone else has had this problem. Once I get Jason's spacers, I'll put in the SWS8s and see if there's a change.
Jaya3666 is offline   Malaysia
0
Reply With Quote
      02-19-2011, 04:50 AM   #68
nmf69
Private
 
Drives: F30 bmw 320i EDE
Join Date: Apr 2009
Location: The Netherlands

Posts: 66
iTrader: (0)

Kicker

Quote:
Originally Posted by nezoat View Post
I just use the wire guide info I found in this thread, and as you suspected, there is a mistake in the polarity. Both the front Left/Right have a Brown/Orange wire which is actually (+). Just reverse the polarity of the L/R front and you'll be fine. I discovered this after testing with a voltmeter using chasis ground as the reference point. The (+) wires carry about 70% of the balanced voltage and the (-) wires the other 30% (relative to chasis ground, mind you).

While it was wrong, my Kicker 2006 zx700.5 amp was confused all to hell and sounded OK but there was no stereo separation in the front channels until I corrected the polarity. Also, strangely, my fader and balance on my e90 HIFI didn't work quite right. I guess these balanced signals REALLY get weird when polarity isn't right.
Hi Neozat, I happen to use the same amplifier in my e90 2009 but, unfortunately, I am facing a problem with no solution so far: every time my car stops the engine at stoplight for instance (auto start-stop engaged) the amplifier keeps working but the moment the engine starts again the amplifier stops for a few seconds - pretty annoying, I guess it needs to much juice from the accu...is there a way to change this behavior?
nmf69 is offline   Netherlands
0
Reply With Quote
      01-25-2012, 03:50 PM   #69
hjvelez
Enlisted Member
 
Drives: 2012 E92 325i
Join Date: Jan 2012
Location: Cartagena, Colombia

Posts: 40
iTrader: (0)

Does anyone have wiring diagrams (with wire colors) for the base audio system (no amp, no tweeter)??
__________________
__________________________
2012 325i Coupe Mineral White
hjvelez is offline   Colombia
0
Reply With Quote
      02-08-2013, 01:29 AM   #70
1stBeemer
Registered
 
Drives: Black 328i w/black leather
Join Date: Oct 2011
Location: USA

Posts: 2
iTrader: (0)

Hi all, I need to contact JTSherri to get a pair of SWS-8 spacers, but I can't PM him since I'm new to this site and doesn't have enough posts. Could anyone please contact him and ask him to PM me? I appreciate your support.
1stBeemer is offline  
0
Reply With Quote
      02-08-2013, 01:44 AM   #71
ctuna
Brigadier General
 
Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

Posts: 4,211
iTrader: (0)

Done

Done
ctuna is offline  
0
Reply With Quote
      03-19-2013, 12:33 AM   #72
bacon33
New Member
 
Drives: 335i
Join Date: Mar 2013
Location: San Diego

Posts: 28
iTrader: (0)

Hoping to upgrade mine soon.
bacon33 is offline  
0
Reply With Quote
      03-27-2013, 02:13 PM   #73
jotremar
New Member
 
Drives: E90
Join Date: Mar 2013
Location: Spain

Posts: 12
iTrader: (0)

I have this amp (2005) and I have same questions about it:



What is the connector for optical fibre? I don't find it in ETK

There's 4 pin's beside to optical fibre. What I must to connect here?
jotremar is offline  
0
Reply With Quote
      03-30-2013, 05:40 AM   #74
jotremar
New Member
 
Drives: E90
Join Date: Mar 2013
Location: Spain

Posts: 12
iTrader: (0)

Nobody has installed this amp?
jotremar is offline  
0
Reply With Quote
      04-01-2013, 08:23 PM   #75
OveN
New Member
 
Drives: '09 E91 320d
Join Date: Dec 2012
Location: Norway

Posts: 11
iTrader: (0)

Quote:
Originally Posted by jotremar View Post
Nobody has installed this amp?
Are you installing a Logic 7 amplifier in a car that was not delivered with a Logic system?
That's the most difficult route you could possibly choose! Get a different amplifier that accepts the inputs you have available in your car.
OveN is offline   Norway
0
Reply With Quote
      04-02-2013, 09:01 AM   #76
jotremar
New Member
 
Drives: E90
Join Date: Mar 2013
Location: Spain

Posts: 12
iTrader: (0)

Quote:
Originally Posted by OveN View Post
Are you installing a Logic 7 amplifier in a car that was not delivered with a Logic system?
That's the most difficult route you could possibly choose! Get a different amplifier that accepts the inputs you have available in your car.
It isn't difficult if you had installed fibre optical, the problem is find a list of pieces for do it like OEM and recode it.
jotremar is offline  
0
Reply With Quote
      04-02-2013, 09:17 AM   #77
Dennyboy333
Registered
 
Drives: BMW 320d E90 2005
Join Date: Mar 2013
Location: Gibraltar

Posts: 1
iTrader: (0)

Hi I've bought a off market head unit and noticed my car has logic 7 with fiber optic cables so no sound is coming out of head unit does anyone know if they do a interface for e90 ????
Dennyboy333 is offline  
0
Reply With Quote
      04-02-2013, 04:37 PM   #78
deepsrd
Second Lieutenant
 
deepsrd's Avatar
 
Drives: 325i
Join Date: Mar 2012
Location: Dublin, IE

Posts: 201
iTrader: (0)

Quote:
Originally Posted by OveN View Post
Are you installing a Logic 7 amplifier in a car that was not delivered with a Logic system?
That's the most difficult route you could possibly choose! Get a different amplifier that accepts the inputs you have available in your car.
Quite the opposite.. Use the prewired CD changer optic and wire the speakers..
From a base audio,(non-hifi) it saves lot of work..
deepsrd is offline  
0
Reply With Quote
      04-05-2013, 09:54 AM   #79
OveN
New Member
 
Drives: '09 E91 320d
Join Date: Dec 2012
Location: Norway

Posts: 11
iTrader: (0)

Isn't that an option you had to choose when the car was built? "Preparation for CD changer? I'm not sure. It was like that on E46. If you didnt select that option there would be no cable ran for CD changer.
But yeah, if he already has fiber cable running from HU to the trunk then it makes more sense to do this.

I guess my comment in previous post was a bit harsh, I just find it strange to upgrade to a different type OEM amplifier when there are so many options for better stuff out there. Just my opinion
OveN is offline   Norway
0
Reply With Quote
      07-18-2013, 06:25 PM   #80
pinder91
Private
 
pinder91's Avatar
 
Drives: 07 E92 335i 6MT
Join Date: Apr 2013
Location: Farmington Hills, MI

Posts: 79
iTrader: (1)

Garage List
2007 BMW 335i  [4.00]
I hate to bump this, but I skimmed through here and didn't see it mentioned... These 2 "unknown" wires go to the gong/chime speaker in the cluster, correct? Since those sounds come from the L7 amp? If not, where does that speaker source its sounds?
Quote:
Originally Posted by wheelman2925 View Post
Pin 10 Red/Gray
Pin 20 Brown
__________________
2007 E92 335i BSM/Saddle 6MT
ZSP / ZPP / ZCW
LC818 / PSS
pinder91 is offline  
0
Reply With Quote
      07-20-2013, 10:57 PM   #81
Garticus
A & P guy
 
Garticus's Avatar
 
Drives: BMW 330i
Join Date: Apr 2013
Location: Florida

Posts: 64
iTrader: (1)

Garage List
06' BMW 330i  [0.00]
Quote:
Originally Posted by Lee Rambler View Post
this wire is switched (10.8volts though), however you should not use it - it has something to do with the air bag system, and has insufficient current to trigger amplifier(s). If you do use it, you need a standard bosch relay (ae5080) to handle the current. I still triggers a code to check the SRS system though, with a dash light lit up. I'd suggest tapping the 20amp radio fuse (can't remember the number, one of the 30's though I believe - just refer to the chart in the fuse box) as it is switched. Easy enough to run a wire back, but you should make sure to add a fuse for that line up at the fuse box too as you won't have the wire protected if you tap the hot side of the fuse (which should should so as to not tax the radio fuse). Make sure to use the 20amp radio fuse, it is the only switched one (the other 2 are constant). It does switch, though it stays on with the courtesy circuit for 5 minutes or so after the car is turned off, as do all of the switched circuits.

Is this for an e90/e92? If the radio can be turned on without the key fob being in the ignition......how can it be switched?

I have a JL 500/1 & I'm using the signal sensing turn on, but its rather annoying that the amp will shut down during:
-Low volume music
-Between songs with 5+ seconds gaps
-During the start of songs before the bass hits

I would like to run a wire to my amps' remote turn on (Logic7 system) and I was think of using something out of the fuse box.....maybe fan or wiper or something that should be switched.
__________________
A&P Avionics Mech.
Garticus is offline  
0
Reply With Quote
      07-21-2013, 12:51 AM   #82
ctuna
Brigadier General
 
Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

Posts: 4,211
iTrader: (0)

Some use the lighter for switched power.

Some use the lighter for switched power.(for aftermarket head units)
The wire picture above is for the Hi Fi System all the L7 has optical input from the head to the amp. Not sure how the L7 turns on but it must be switched to .
ctuna is offline  
0
Reply With Quote
      07-21-2013, 09:31 PM   #83
Garticus
A & P guy
 
Garticus's Avatar
 
Drives: BMW 330i
Join Date: Apr 2013
Location: Florida

Posts: 64
iTrader: (1)

Garage List
06' BMW 330i  [0.00]
The Logic 7 amp turn on must be something internal to the amp.....as the amps internal fan runs for a minute or two then shuts off.

Plus there's 10 pairs of wires in the L7 amp's wire harness (1 pair is power & ground and the other 9 pairs run the speakers....

(center 1 pair/front door 2 pair/rear door 2 pair/ back dash 2 pair/ under seat sub 2 pairs)
__________________
A&P Avionics Mech.
Garticus is offline  
0
Reply With Quote
      10-01-2013, 01:16 AM   #84
München
Private
 
Drives: Alpine White 335i
Join Date: Jul 2011
Location: Northern Virgnia

Posts: 55
iTrader: (0)

can someone tell me which side is the + / -
of this speaker. car is equipped with an L7
as seen the connectors can be easily installed
incorrectly due to the plug that goes or connects to the
speaker are the same with no indication
of + or -

thanks

http://
München is offline  
0
Reply With Quote
      10-01-2013, 01:30 AM   #85
München
Private
 
Drives: Alpine White 335i
Join Date: Jul 2011
Location: Northern Virgnia

Posts: 55
iTrader: (0)


Last edited by München; 10-01-2013 at 11:24 AM.
München is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:27 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST