E90Post
 


MINHS Auto Care Center
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > CEL/MIL at engine start



Reply
 
Thread Tools Search this Thread
      01-30-2012, 06:22 PM   #1
e90drvr
Private
 
Drives: Graphite/Terra 330i
Join Date: Sep 2008
Location: Los Angeles, CA

Posts: 61
iTrader: (0)

CEL/MIL at engine start

I just got done having my '06 330i SMOG tested in CA and it failed because of what the tech said was a problem with the "Service Engine Soon" light (MIL). He told me that it needs to come on for several seconds after the engine has started.
I went home and checked this out. The MIL comes on when I turn the ignition ON but remains off if I depress the clutch and START the engine from ignition OFF.
I also talked to an SA at the local dealer and he told me that if it stays on then there's a problem...ok, thanks.

I think the SMOG tech is wrong and I'd like to find out how to prove it so I'm hoping to get some help from the community. What's the normal operation of the MIL during engine start? Does yours come on for a few seconds when you start the car?

Thanks for the help.
e90drvr is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Tags
cel, service engine soon light, smog

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:44 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST