E90Post
 


N54Tuning.com
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > lost power steering??



Reply
 
Thread Tools Search this Thread
      02-13-2012, 10:08 AM   #1
poloace
Second Lieutenant
8
Rep
225
Posts

Drives: 09 335xi coupe
Join Date: Jan 2009
Location: upstate, ny

iTrader: (0)

lost power steering??

was driving home in the snow yesterday... thought I accumulated a little snow in the wheels (which melted overnight) - and this am... still no power steering.... car is still
under warranty- but, anyone ever have this happen? thanks all.
Appreciate 0
      02-13-2012, 10:32 AM   #2
enrita
Major General
enrita's Avatar
Sweden
99
Rep
7,382
Posts

Drives: 335i - Big turbos
Join Date: Sep 2008
Location: Italian in Sweden

iTrader: (0)

yeah could be the belt. check engine bay , battery will go down very fast as well if its the belt.
happened twice to me.
__________________
07 335i AT - MOTIV 750 - MHD E85 BMS flash - BMS PI - JB4G5 - Okada Coils - NGK 5992 Plugs - Helix IC - Snow Stg. 3 - Stett CP - Custom midpipes with 100 HJS Cats - Bastuck Quad - PSS10 - QUAIFE LSD - BMS OCC - Forge DVs - AR OC - ALCON BBK - M3 Chassi - Dinan CP - Velocity M rear Toe arms - Advan RZ-DF - LUX H8 - Level 10 AT upgrade
Appreciate 0
      02-13-2012, 11:56 AM   #3
poloace
Second Lieutenant
8
Rep
225
Posts

Drives: 09 335xi coupe
Join Date: Jan 2009
Location: upstate, ny

iTrader: (0)

wondering if it's the pump...? I don't even hear it making the normal sound it does.
Appreciate 0
      02-14-2012, 02:39 AM   #4
Railgun
Colonel
Railgun's Avatar
United Kingdom
258
Rep
2,182
Posts

Drives: FD, CBR600RR, F82
Join Date: Mar 2007
Location: Chicago --> SE London

iTrader: (2)

Garage List
2016 SMB M4  [0.00]
1993 Mazda RX-7  [0.00]
2007 Honda CBR600RR  [0.00]
Send a message via Skype™ to Railgun
If it was the belt, you'd have many bells and whistles going off. My belt shredded as I was about 200 ft from home and it definitely let me know.

You'll know if it's a belt. Its possible it could be pump related. Either way, call the dealer if it's under warranty.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 05:59 AM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST