E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > Australia > Alpine OEM Stereo Upgrade - cuts out in warm weather



Reply
 
Thread Tools Search this Thread
      02-13-2012, 07:31 AM   #1
bmwaddiction
Lieutenant
Australia
8
Rep
408
Posts

 
Drives: Titanium Silver 325i E90
Join Date: Feb 2010
Location: Darwin

iTrader: (0)

Alpine OEM Stereo Upgrade - cuts out in warm weather

Any stereo / ICE experts out there? The crux of my issue is that in warm weather my Alpine OEM upgrade system cuts out for 0.5 - 1 seconds and then comes back, this occurs every couple of minutes or so. It rarely happens in cold weather and if it does its normally after 30-40 minutes of driving. In warm weather it probably starts happening after 10 or so minutes.

I filmed the 'cut outs', there is one at the start and one at the end of the video



It happens both when playing the ipod/cd input as well as the radio input. So I assume that it may be an amplifier overheating issue?

Any solutions?

Last edited by bmwaddiction; 02-13-2012 at 07:40 AM.
Appreciate 0
      02-14-2012, 01:11 AM   #2
bmwaddiction
Lieutenant
Australia
8
Rep
408
Posts

 
Drives: Titanium Silver 325i E90
Join Date: Feb 2010
Location: Darwin

iTrader: (0)

anyone?
Appreciate 0
      02-14-2012, 03:42 AM   #3
DosVerde
New Member
0
Rep
25
Posts

 
Drives: 330i - stonechipped black
Join Date: Feb 2012
Location: Melbourne

iTrader: (0)

All I can say is, I have the same problem. Been looking at some higher powered / better quality 6 channel amps, but a bit confused about the wiring. Probably end up a winter project.

From what I've read they upgraded the amp to a fan cooled unit in 2008.

BTW, been umming and ahhing about your steering wheel. Seeing as this is my first post, could you PM me if still available (hold on, that could have been my 2nd post).

Cheers.
Appreciate 0
      02-14-2012, 04:21 AM   #4
bmwaddiction
Lieutenant
Australia
8
Rep
408
Posts

 
Drives: Titanium Silver 325i E90
Join Date: Feb 2010
Location: Darwin

iTrader: (0)

Thanks DosVerde, the kit was retrofitted by BMW in 2010 so I assume that a better / cooled amp was installed. Anyway it sounds like I might need to get someone with amp experience to check it out.

I'll PM you about the wheel.
Appreciate 0
      02-14-2012, 04:24 AM   #5
bmwaddiction
Lieutenant
Australia
8
Rep
408
Posts

 
Drives: Titanium Silver 325i E90
Join Date: Feb 2010
Location: Darwin

iTrader: (0)

Quote:
Originally Posted by DosVerde View Post
All I can say is, I have the same problem. Been looking at some higher powered / better quality 6 channel amps, but a bit confused about the wiring. Probably end up a winter project.

From what I've read they upgraded the amp to a fan cooled unit in 2008.

BTW, been umming and ahhing about your steering wheel. Seeing as this is my first post, could you PM me if still available (hold on, that could have been my 2nd post).

Cheers.
Can't PM you as you don't have 5 posts mate. The wheel is still available, you can SMS me on my temporary mobile if you need more info - 0458112385.
Appreciate 0
      08-17-2012, 03:20 AM   #6
nikkoman
New Member
1
Rep
17
Posts

 
Drives: BMW E90 335i xdrive LCI
Join Date: Apr 2012
Location: France

iTrader: (0)

hello

problem is fixed ?
Appreciate 0
      08-18-2012, 07:36 AM   #7
bmwaddiction
Lieutenant
Australia
8
Rep
408
Posts

 
Drives: Titanium Silver 325i E90
Join Date: Feb 2010
Location: Darwin

iTrader: (0)

yeah mate, i bought a replacement amp from Schmiedmann.com and did a straight swap in the boot (2 minute job) - the problem is now fixed

so it was a dodgy amp
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:34 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST