E90Post
 


N54Tuning.com
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > help!! misfiring. anyone know what's causing it ?



Reply
 
Thread Tools Search this Thread
      02-12-2012, 11:29 PM   #1
E92BA
FBO + e85 335i
United_States
2

 
Drives: E92 335i
Join Date: Dec 2011
Location: SoFlo


Posts: 78
iTrader: (0)

help!! misfiring. anyone know what's causing it ?

I've been misfiring. I was hoping someone might have had the same symptoms and might be able to tell me hat it is before I start buying coil packs and injectors and hope hey work.
-2007 335
-70k miles
-brand new hpfp
-most of the time only misfires when I put it on map 1 on jb4
-misfires on cylinders 4 &5

might be spark plugs ? anyone wanna give it a shot? thanks!!!!
Appreciate 0
      02-12-2012, 11:38 PM   #2
GmoBmw
Captain
18

 
GmoBmw's Avatar
 
Drives: 2007 335i
Join Date: Dec 2011
Location: California


Posts: 645
iTrader: (8)

haha mine did the same thing. Changed my plugs and it went away. If its not that might wanna check your coils. but most likely its plugs.
__________________
2007 BMW 335I- JB4 G5,DCI,VRSF DPs,NT555r Drag Radials Daily Driver
Appreciate 0
      02-12-2012, 11:38 PM   #3
reiss91
New Member
1

 
Drives: tacoma
Join Date: May 2011
Location: usa


Posts: 24
iTrader: (0)

Move the coils and plugs and see if the misfire moves. Assuming you have a scanner to read them.

This should identify if a coil or plug needs to be replaced. If that doesn't help you check the carbon build up on the intake valves. Cylinder 5 is usually always the dirtiest and 70k is about time to get it done.

Keep us posted
Appreciate 0
      02-12-2012, 11:39 PM   #4
skinrock
Agent Smith
84

 
skinrock's Avatar
 
Drives: 2013 Fusion AWD
Join Date: Jan 2011
Location: The Matrix


Posts: 2,860
iTrader: (9)

Garage List
2007 335i  [3.45]
http://www.e90post.com/forums/showthread.php?t=631829
Appreciate 0
      02-12-2012, 11:44 PM   #5
E92BA
FBO + e85 335i
United_States
2

 
Drives: E92 335i
Join Date: Dec 2011
Location: SoFlo


Posts: 78
iTrader: (0)

yea I'm gonna try the spark plugs. I'm pretty sure that's it. & I wanna do the carbon build up cleaning but it's a lotta $$$
Appreciate 0
      02-14-2012, 06:08 PM   #6
335iVA
Chyeah
4

 
335iVA's Avatar
 
Drives: 07 335i 6MT
Join Date: May 2011
Location: California


Posts: 31
iTrader: (0)

I had the same problem. I first noticed a misfire on Cyl. 4 when in Map 1. I moved to Map 5 and it was running for a month or so, then started misfiring on Cyl. 4 again. The only time it would not misfire was when I was running stock bypass. Changed the plugs, problem fixed. Car has been running smoothly ever since... So check the coils, change the plugs, you should be good to go. Hopefully its not your injectors, but if you are under warranty, shouldn't be a problem. Have you had the injectors replaced yet?
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:15 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST