E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > DIY Guides > DIY: Replacing DSC Hydro Unit E90, E92



Reply
 
Thread Tools Search this Thread
      10-19-2011, 10:51 PM   #1
3Coupe4Me
Private First Class
3Coupe4Me's Avatar
19
Rep
168
Posts

Drives: 2007 328i Coupe
Join Date: Aug 2010
Location: S.FL

iTrader: (1)

DIY: Replacing DSC Hydro Unit E90, E92

Sometime ago I got the dreaded ABS, Brake and DSC trifecta error while coming home from work but it went off after I restarted the car.



This intermittent fault continued on and off for some time afterwards until about a month ago it finally stayed permanently on. I decided to take the car to an indy mechanic and have the codes read. The fault cade came back as a "5DF0" code which is a faulty DSC Hydrolic Pump. The estimated cost of repair was $530 for the pump + 4 hours labor to fix it.

Having worked on all the cars I've ever owned I decided to tackle the pump replacement myself. I ordered the part from Tischer for about $100 less than the dealer and with a free weekend coming up I decided to do the job myself. The part that I was most worried about was bleeding the ABS pump which requires special software at the dealer to cycle the pump as part of the bleeding process. However I did some research and saw where you can cycle the pump using the old school method of stomping on the bakes on a slippery surface while driving at a slow speed. Well, I had such a surface on my nearly 100ft long gravel driveway which would affect nobody but myself if I somehow screwed up on bleeding the brakes correctly.

When the part arrived I was actually pleasantly surprised that it had installation instructions included from the manufacturer. Even though it should have been just a simple swap of the parts the instructions showed how to relieve the pressure from the brake lines and how to prevent the lines from loosing but a little fluid. Another surprise was that during the installation of the new pump I discovered that it was already bench bled from the factory and already had fluid in it.

In total it took only about 10 minutes to do the swap. The hardest part was bleeding the four wheels until the brakes were firm then activating the ABS using the method described above and then bleeding all four wheels again until the entire brake system was flushed with new fluid.

Here are some pics and a description of the steps

ABS PUMP LOCATED HERE


CLOSE-UP VIEW OF PUMP WITH THE INTAKE AN OUT BRAKE LINES REMOVED


PUMP REMOVED AND LINE CAPPED TO PREVENT FLUID LOSS


THE CAPS I USED


PUMP ASSEMBLY WITH CONTROL UNIT ATTACHED


OLD AND NEW UNIT SIDE BY SIDE



PREPARATION FOR PUMP SWAP.

I swapped just the pump and kept the control unit because it is already programmed for the car. If I had put in the new one i would have had to take it to the dealer for programming.






After all that work it was good to see this


I also tested the DSC, Start off Assist and Cruise Control and everything is now fully functional.

Here are the directions from the manufacturer.
Attached Images
  
Appreciate 1
      10-19-2011, 11:13 PM   #2
JAZA
Banned
Colombia
8
Rep
285
Posts

Drives: 2008 Ruby Black M3
Join Date: May 2011
Location: MIAMI

iTrader: (2)

Send a message via AIM to JAZA Send a message via Yahoo to JAZA
Awesome write up, thanks for the DYI
Appreciate 0
      10-22-2011, 04:05 PM   #3
fdriller9
Banned
United_States
139
Rep
7,090
Posts

Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

iTrader: (4)

Garage List
2006 330xi  [3.22]
Did you bleed the DSC unit after swapping out? Air can get trapped on the walls of the DSC unit and can cause a soft brake pedal.
Appreciate 0
      10-22-2011, 08:42 PM   #4
3Coupe4Me
Private First Class
3Coupe4Me's Avatar
19
Rep
168
Posts

Drives: 2007 328i Coupe
Join Date: Aug 2010
Location: S.FL

iTrader: (1)

Quote:
Originally Posted by ********* View Post
Did you bleed the DSC unit after swapping out? Air can get trapped on the walls of the DSC unit and can cause a soft brake pedal.
Yep, I bled it twice. Once just after installation and once after activation of the pump.
__________________
-------------------------------------------------------

-------------------------------------------------------
Appreciate 0
      10-23-2011, 09:17 PM   #5
TwinTuning
Captain
15
Rep
704
Posts

Drives: E90 335I
Join Date: Aug 2011
Location: HERE

iTrader: (7)

Great DIY.
Appreciate 0
      11-08-2011, 08:38 AM   #6
badsha
Private First Class
badsha's Avatar
9
Rep
106
Posts

Drives: BMW E90 318d 2006
Join Date: Nov 2010
Location: Norway

iTrader: (0)

witch part is the pump?? the silver or the black one?
Appreciate 0
      11-08-2011, 10:41 AM   #7
3Coupe4Me
Private First Class
3Coupe4Me's Avatar
19
Rep
168
Posts

Drives: 2007 328i Coupe
Join Date: Aug 2010
Location: S.FL

iTrader: (1)

Quote:
Originally Posted by badsha View Post
witch part is the pump?? the silver or the black one?
The Silver (aluminum) part is the pump assembly and the all black (plastic) part is the control module.
__________________
-------------------------------------------------------

-------------------------------------------------------
Appreciate 0
      02-15-2012, 01:00 AM   #8
ashleymarie0792
Banned
4
Rep
205
Posts

Drives: 335i e92
Join Date: Jan 2012
Location: florida

iTrader: (1)

question i repalced my dsc module and i still have the same codes.. i did not use the module or abs pump that was broken i replaced everything do i have to go to bmw to get it coded ?
Appreciate 0
      02-15-2012, 01:11 AM   #9
3Coupe4Me
Private First Class
3Coupe4Me's Avatar
19
Rep
168
Posts

Drives: 2007 328i Coupe
Join Date: Aug 2010
Location: S.FL

iTrader: (1)

Quote:
Originally Posted by ashleymarie0792 View Post
question i repalced my dsc module and i still have the same codes.. i did not use the module or abs pump that was broken i replaced everything do i have to go to bmw to get it coded ?
Yes, the new module has to be programmed. That's the reason I swapped mine with the old module so I did not have to get it reprogrammed.
__________________
-------------------------------------------------------

-------------------------------------------------------
Appreciate 0
      02-15-2012, 01:25 AM   #10
ashleymarie0792
Banned
4
Rep
205
Posts

Drives: 335i e92
Join Date: Jan 2012
Location: florida

iTrader: (1)

how much would that cost i already installed everything... just need it coded lol.
Appreciate 0
      02-15-2012, 01:31 AM   #11
3Coupe4Me
Private First Class
3Coupe4Me's Avatar
19
Rep
168
Posts

Drives: 2007 328i Coupe
Join Date: Aug 2010
Location: S.FL

iTrader: (1)

I did not research this however I remember someone saying it should cost about 1 hours worth of labor at the dealer. Give them a call in the morning and see what they say.
__________________
-------------------------------------------------------

-------------------------------------------------------
Appreciate 0
      05-03-2012, 11:14 AM   #12
90rr
First Lieutenant
90rr's Avatar
16
Rep
325
Posts

Drives: 2007 328i
Join Date: Aug 2011
Location: Delray Beach FL

iTrader: (0)

I got a same codes and they went away (twice) ... last time 10 days ago and never came back .
Now when I'm at a complete stop and car is on idle , feels like when you release a brake pedal just a little ,(car trying to push forward ) and then you slam on the brake ..everything in fraction of the second . kick are completely random , but only when i have my foot on the brake . sometimes i feel 3-4 quick jolts . Just wondering if you or anyone who replaced pump had a same problems before .
Thanks in advance !
__________________
http://i35.photobucket.com/albums/d159/novak223/jK.jpg
Appreciate 0
      07-14-2012, 02:28 PM   #13
3Coupe4Me
Private First Class
3Coupe4Me's Avatar
19
Rep
168
Posts

Drives: 2007 328i Coupe
Join Date: Aug 2010
Location: S.FL

iTrader: (1)

Here is the direct link for the part. http://parts.bmwofsouthatlanta.com/p...506777164.html

I have the electrical unit alone for sale if you need.
__________________
-------------------------------------------------------

-------------------------------------------------------
Appreciate 0
      08-08-2012, 06:13 AM   #14
signatureaudio
Registered
0
Rep
1
Posts

Drives: mk 2 golf gti
Join Date: Aug 2012
Location: shellharbour, nsw, australia

iTrader: (0)

DSC problems

Hey guys, I recently installed an audio system upgrade to BMW E90 and after taking the car for a short drive the DSC warning lights came on, there is also an icon at the very bottom of the LCD display, its a triangle with an exclamation mark in it with three zeros next to it.

Is the DSC related to the audio system in any way?
Appreciate 0
      08-08-2012, 03:16 PM   #15
david-m
New Member
0
Rep
6
Posts

Drives: e91 330d
Join Date: Apr 2012
Location: West Mids UK

iTrader: (0)

Nice writeup
Appreciate 0
      10-19-2012, 09:18 PM   #16
Hooy
Colonel
Hooy's Avatar
65
Rep
2,763
Posts

Drives: 2008 328i Coupe
Join Date: Sep 2009
Location: Houston, TX

iTrader: (12)

Garage List
2008 E92 328  [2.50]
Does anyone know if this is different for 2008's? I only see this part for 2007's.
__________________
Appreciate 0
      09-16-2013, 03:22 AM   #17
NYC2DEL
Registered
0
Rep
3
Posts

Drives: 325i
Join Date: Aug 2013
Location: India

iTrader: (0)

Hi all,

Hoping you can help. I started getting the ABS/DSC/ Flat Tire warnings and lights in January. I took it to the dealer and they said it was the DSC Hydro Pump which had failed. I purchased the same part from ebay (used but in great condition) and the seller gave me 90 return and had said the part was tested and in working condition.

I had the part installed by the dealers, they did the whole 9 yards of bleeding the breaks etc. and gave the car back. For a week the lights were out but came back on again. Now they are intermittent and come and go.

Any ideas on how to get rid of them?
Appreciate 0
      09-16-2013, 10:00 AM   #18
3Coupe4Me
Private First Class
3Coupe4Me's Avatar
19
Rep
168
Posts

Drives: 2007 328i Coupe
Join Date: Aug 2010
Location: S.FL

iTrader: (1)

I would get another scan and see what the codes are. Did you change both the pump and electronic module?
__________________
-------------------------------------------------------

-------------------------------------------------------
Appreciate 0
      10-12-2013, 08:01 PM   #19
fun2drive
BMWCCA 149159
fun2drive's Avatar
United_States
24
Rep
780
Posts

Drives: E93 335/ 14 JGC Diesel
Join Date: Jul 2006
Location: Florida Panhandle

iTrader: (1)

Got the same 3 lights and same codes. I ordered a new unit from BMW of Minn. Best price I have found to include Tischer. The write up and pictures are excellent. A couple of things to note. The ABS unit has 3 10 mm bolts that hold the unit in place. 2 are very visible and one is under the electrical harness which you need to remove to gain access. Don't drop them as they are hard to retrive. I used a magnet to remove and install them so I could not drop them. I also used the vacuum caps and found out that the lines are two different diameters so I lost a couple caps that feel into the area under the ABS area. The lines are all 11 mm so I used an 11 mm flare wrench to tighten and break the lines free but to get them loose and tightened some a regular open ended wrench worked just fine.
It is funny how the replacement unit plugs for the new unit were all over the place 10 mm, 11 mm and 12 mm but the existing lines mounted up just fine. When bleeding the brakes the rears use a 9 mm boxed end wrench and the fronts use a 12 mm.
Other than that the unit came out with little issue (once I removed the 3rd 10 mm nut) and reinstalling had to wiggle it in there and lined up.
Hope this helps someone else. After installing it I still had the lights until I cleared them with my CarSoft software...
Appreciate 0
      03-03-2014, 12:01 PM   #20
fun2drive
BMWCCA 149159
fun2drive's Avatar
United_States
24
Rep
780
Posts

Drives: E93 335/ 14 JGC Diesel
Join Date: Jul 2006
Location: Florida Panhandle

iTrader: (1)

As an update to anyone reading this I have discovered that the main problem with our units is the Bosch electric motor brushes fouling the brush holder causing the brushes to not be positioned correctly and causing a slower rpm which throws the code. It is still possible your electronic module is toast but this problem is the most likely case. I read a youtube DIY and did my own it for no cost but Modulemasters.com will repair the brushes and holder and never jam again. At the time of this writing they were quoting 100-150 bucks. Be sure to talk to a technician not the office staff as the office staff told me they don't do that work but the technician I talked to told me what they do to repair it.
Essentially this youtube video shows how the repair is done. Modulemasters actually does this in a much more professional manner with brushes and holders that will not get jammed with graphite material.
I am not associated with modulemasters in anyway but they can save you huge sums of money if you or your indy pull the unit which you can see is not that hard.
Hope this helps
Appreciate 0
      03-03-2014, 12:20 PM   #21
3Coupe4Me
Private First Class
3Coupe4Me's Avatar
19
Rep
168
Posts

Drives: 2007 328i Coupe
Join Date: Aug 2010
Location: S.FL

iTrader: (1)

Great update

Quote:
Originally Posted by fun2drive View Post
As an update to anyone reading this I have discovered that the main problem with our units is the Bosch electric motor brushes fouling the brush holder causing the brushes to not be positioned correctly and causing a slower rpm which throws the code. It is still possible your electronic module is toast but this problem is the most likely case. I read a youtube DIY and did my own it for no cost but Modulemasters.com will repair the brushes and holder and never jam again. At the time of this writing they were quoting 100-150 bucks. Be sure to talk to a technician not the office staff as the office staff told me they don't do that work but the technician I talked to told me what they do to repair it.
Essentially this youtube video shows how the repair is done. Modulemasters actually does this in a much more professional manner with brushes and holders that will not get jammed with graphite material.
I am not associated with modulemasters in anyway but they can save you huge sums of money if you or your indy pull the unit which you can see is not that hard.
Hope this helps
Appreciate 0
      03-05-2014, 04:36 AM   #22
betaruce
Enlisted Member
0
Rep
41
Posts

Drives: e90 335i
Join Date: Aug 2013
Location: hk

iTrader: (0)

thanks for your sharing fun2drive

want to clarify. Do you mean this is the likely reason why pre-LCI E9x DSC module/pump fail easily? and I heard this problem does not appear in newer E9x because BMW correct this problem?

so you DIY repair your own module with reference to a youtube video? do you mind share it here?

thanks a lot!

Quote:
Originally Posted by fun2drive View Post
As an update to anyone reading this I have discovered that the main problem with our units is the Bosch electric motor brushes fouling the brush holder causing the brushes to not be positioned correctly and causing a slower rpm which throws the code. It is still possible your electronic module is toast but this problem is the most likely case. I read a youtube DIY and did my own it for no cost but Modulemasters.com will repair the brushes and holder and never jam again. At the time of this writing they were quoting 100-150 bucks. Be sure to talk to a technician not the office staff as the office staff told me they don't do that work but the technician I talked to told me what they do to repair it.
Essentially this youtube video shows how the repair is done. Modulemasters actually does this in a much more professional manner with brushes and holders that will not get jammed with graphite material.
I am not associated with modulemasters in anyway but they can save you huge sums of money if you or your indy pull the unit which you can see is not that hard.
Hope this helps
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:34 AM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST