E90Post
 


Bimmertech
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > noise after st coils installed



Reply
 
Thread Tools Search this Thread
      12-19-2011, 10:29 PM   #1
sleepyyuan
Private
 
Drives: 08 AW/CR 335I MT
Join Date: Jun 2011
Location: Los Angeles, Ca

Posts: 68
iTrader: (1)

noise after st coils installed

i'm getting a clunking noise over bumps and turning after my ST v1 install. Any ideas anyone?
sleepyyuan is offline  
0
Reply With Quote
      12-19-2011, 11:43 PM   #2
Beas
Private First Class
 
Drives: e90
Join Date: Dec 2011
Location: NC

Posts: 147
iTrader: (0)

from what ive seen they just have a loose spring sitting on a threaded tube. common for most coilovers and the noise is common too. To illiminate that u need coilovers that allow you to keep the preload tight and the spring compressed and u actually twist the shock body to lower it. Buddy club, k sport, and several others are making coilovers this way now.
Beas is offline  
0
Reply With Quote
      02-17-2012, 01:30 PM   #3
Route 16
I got lei'd
 
Route 16's Avatar
 
Drives: '07 E90 328i
Join Date: Sep 2011
Location: BayArea

Posts: 4,150
iTrader: (24)

Quote:
Originally Posted by Beas View Post
from what ive seen they just have a loose spring sitting on a threaded tube. common for most coilovers and the noise is common too. To illiminate that u need coilovers that allow you to keep the preload tight and the spring compressed and u actually twist the shock body to lower it. Buddy club, k sport, and several others are making coilovers this way now.
Are st coils designed the same?
Route 16 is online now   Philippines
0
Reply With Quote
      02-18-2012, 06:58 AM   #4
engotski
oh haiii
 
engotski's Avatar
 
Drives: e92 328i
Join Date: May 2011
Location: VanCity

Posts: 1,102
iTrader: (4)

My kw v1 has been making nudging noises during the first several feet of vehicle movement after its been parked for atleast 15mins. No noise over bumps or anything besides that.

Annoying and I want to fix it but heard its a common issue with these coilovers?
engotski is offline   Philippines
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:16 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST