E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Logic7 SWS-8 Underseat Sub Upgrade FAQ



Reply
 
Thread Tools Search this Thread
      01-22-2012, 04:50 PM   #67
taibanl
Brigadier General
 
taibanl's Avatar
 
Drives: BMW
Join Date: Sep 2010
Location: NA

Posts: 3,561
iTrader: (4)

The OEM under seats are:
2 ohm for HiFi (Option 676)
4 Ohm for HK/L7 (Option 688)

Not sure if the L7 amp can push 2 ohm or not.
Attached Images
File Type: pdf bmw oem audio systems tis.pdf (191.5 KB, 135 views)
taibanl is offline  
0
Reply With Quote
      01-22-2012, 05:04 PM   #68
tomob63
Captain
 
tomob63's Avatar
 
Drives: 2009 335i
Join Date: Mar 2009
Location: Chicago

Posts: 624
iTrader: (13)

Send a message via AIM to tomob63
It's OK - I just sold the whole package (amp, spacers, subs and harnesses) to a forum member.
__________________
2009 335i
tomob63 is offline  
0
Reply With Quote
      02-23-2012, 01:27 AM   #69
gbpackersfan11
First Lieutenant
 
gbpackersfan11's Avatar
 
Drives: 2013 Porsche 958
Join Date: Feb 2012
Location: Camas, WA

Posts: 337
iTrader: (1)

Garage List
Quote:
Originally Posted by kmarei View Post
i was running them 120hz down, then switched to 90hz down
they sound much better, less boomy
i used to hear the bass coming from below the seat
now it feels like its coming from the door speakers
i like it much more
i am crossing over my door speakers at 60hz
and believe it or not they sound great
but i think the slight resonance i am hearing is the plastic cage of the actual speaker
not something else vibrating
i am using the logic 7 speakers
very happy with them otherwise, except at certain frequencies they resonate
can't think of a fix for that
i tried using weather sealant foam like you did on the 344is
improved, but not removed the resonance
any ideas?
for logic 7 sound system did to you add an extra amp or just use the stock one?
gbpackersfan11 is offline   United_States
0
Reply With Quote
      02-23-2012, 01:38 AM   #70
gbpackersfan11
First Lieutenant
 
gbpackersfan11's Avatar
 
Drives: 2013 Porsche 958
Join Date: Feb 2012
Location: Camas, WA

Posts: 337
iTrader: (1)

Garage List
Quote:
Originally Posted by taibanl View Post
The OEM under seats are:
2 ohm for HiFi (Option 676)
4 Ohm for HK/L7 (Option 688)

Not sure if the L7 amp can push 2 ohm or not.
The website for the earthquake says to use the 2 ohm speakers for the logic 7 system. Is that correct?
gbpackersfan11 is offline   United_States
0
Reply With Quote
      02-23-2012, 07:12 AM   #71
kaigoss69
Brigadier General
 
kaigoss69's Avatar
 
Drives: '08 335i
Join Date: Jul 2008
Location: JAX

Posts: 3,040
iTrader: (5)

Quote:
Originally Posted by gbpackersfan11
Quote:
Originally Posted by taibanl View Post
The OEM under seats are:
2 ohm for HiFi (Option 676)
4 Ohm for HK/L7 (Option 688)

Not sure if the L7 amp can push 2 ohm or not.
The website for the earthquake says to use the 2 ohm speakers for the logic 7 system. Is that correct?
No! The OEM amp cannot handle a 2 ohm load plus it does not have enough power to drive the Earthquakes at elevated volume levels.

Do not mess with the OEM amp, just don't.
__________________
Mobridge DA2 > JBL MS-8 > JL Audio HD600/4 > (3) Hybrid Audio L3SE & (2) Rainbow Cal25; JL Audio HD900/5 > (2) Morel HCW-10 & (1) IDMax 15
kaigoss69 is offline   United_States
0
Reply With Quote
      02-24-2012, 12:42 PM   #72
kmarei
Major General
 
kmarei's Avatar
 
Drives: 1988 E30 M3 Evo II
Join Date: Jul 2008
Location: Reston, VA

Posts: 6,481
iTrader: (33)

Garage List
Quote:
Originally Posted by gbpackersfan11 View Post
for logic 7 sound system did to you add an extra amp or just use the stock one?
i never had the logic 7 system
i had the logic 7 speakers only
__________________
This user has been banned from the 4 series forum because he doesn't sing its merits like the admins want us all to

kmarei is offline   Egypt
0
Reply With Quote
      02-24-2012, 07:45 PM   #73
gbpackersfan11
First Lieutenant
 
gbpackersfan11's Avatar
 
Drives: 2013 Porsche 958
Join Date: Feb 2012
Location: Camas, WA

Posts: 337
iTrader: (1)

Garage List
Quote:
Originally Posted by kaigoss69 View Post
No! The OEM amp cannot handle a 2 ohm load plus it does not have enough power to drive the Earthquakes at elevated volume levels.

Do not mess with the OEM amp, just don't.
Thank you. Personally I like the logic 7 sound system. its still better then what most cars have in them.
gbpackersfan11 is offline   United_States
0
Reply With Quote
      02-24-2012, 08:17 PM   #74
VP Electricity
Brigadier General
 
VP Electricity's Avatar
 
Drives: E91 XDrive
Join Date: Jan 2008
Location: portland oregon

Posts: 3,177
iTrader: (3)

Quote:
Originally Posted by gbpackersfan11 View Post
Thank you. Personally I like the logic 7 sound system. its still better then what most cars have in them.
"Being better than what most cars have" doesn't mean it doesn't need lots of improvement...

The Earthquake folks really, honestly, don't know what they are doing with the BMWs. You should see their "tech tip" for installing the SWS-8.
VP Electricity is offline   United_States
0
Reply With Quote
      02-25-2012, 02:16 AM   #75
Lotus99
Lieutenant Colonel
 
Lotus99's Avatar
 
Drives: 335i
Join Date: Jul 2007
Location: Canada

Posts: 1,629
iTrader: (1)

Quote:
Originally Posted by VP Electricity View Post
"Being better than what most cars have" doesn't mean it doesn't need lots of improvement...

The Earthquake folks really, honestly, don't know what they are doing with the BMWs. You should see their "tech tip" for installing the SWS-8.
I'm hoping to install mine soon, and was going to start gathering info on it. Do you have a link to this install guide (though it sounds like I should avoid it! LOL!). Any info I figure is better than none, and then I'll make up my own mind as to what's the best technique.

And if you can tell me what this pitfall is that I should avoid, even better!
Lotus99 is offline   Canada
0
Reply With Quote
      02-25-2012, 08:08 AM   #76
Technic
Lieutenant General
 
Technic's Avatar
 
Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

Posts: 11,109
iTrader: (17)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by Lotus99 View Post
I'm hoping to install mine soon, and was going to start gathering info on it. Do you have a link to this install guide (though it sounds like I should avoid it! LOL!). Any info I figure is better than none, and then I'll make up my own mind as to what's the best technique.

And if you can tell me what this pitfall is that I should avoid, even better!
Read the first post in the thread.
__________________
-2015 F30 320i, Imperial/Oyster, 8AT: August 2014 ED
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: Gone
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
Technic is offline   United_States
0
Reply With Quote
      02-25-2012, 12:26 PM   #77
VP Electricity
Brigadier General
 
VP Electricity's Avatar
 
Drives: E91 XDrive
Join Date: Jan 2008
Location: portland oregon

Posts: 3,177
iTrader: (3)

The SWS do not "bolt in" - they have the right bolt pattern but are too deep, and the notch in the enclosure for the connector is left open.

EQ tells people to use hugely thick foam tape as a spacer, and never mentions the notch at all.

We supply metal rings and gasket tape, and starting last year we also include HiFi/Top HiFi wiring adapters preinstalled on the woofers and the rings.
VP Electricity is offline   United_States
0
Reply With Quote
      02-29-2012, 05:25 PM   #78
gIzzE
Major General
 
gIzzE's Avatar
 
Drives: E350 cdi Estate.
Join Date: Apr 2006
Location: Norfolk, UK.

Posts: 5,131
iTrader: (2)

I took my subs out today and the driver was glued in.
I am sure on my 2006 E91 and the 2008 E91 the driver was bolted into the enclosure and it was just a case of unbolting it?

This was from a 2010 X1, so not sure if it is a year thing or an X1 specific thing? Anyone got any info?
gIzzE is offline  
0
Reply With Quote
      03-01-2012, 11:55 AM   #79
Technic
Lieutenant General
 
Technic's Avatar
 
Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

Posts: 11,109
iTrader: (17)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by gIzzE View Post
I took my subs out today and the driver was glued in.
I am sure on my 2006 E91 and the 2008 E91 the driver was bolted into the enclosure and it was just a case of unbolting it?

This was from a 2010 X1, so not sure if it is a year thing or an X1 specific thing? Anyone got any info?
Glued in = 160mm woofer = Stereo system
Bolted in = 200 mm woofer = HiFi and Top HiFi systems
__________________
-2015 F30 320i, Imperial/Oyster, 8AT: August 2014 ED
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: Gone
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
Technic is offline   United_States
0
Reply With Quote
      03-01-2012, 01:42 PM   #80
gIzzE
Major General
 
gIzzE's Avatar
 
Drives: E350 cdi Estate.
Join Date: Apr 2006
Location: Norfolk, UK.

Posts: 5,131
iTrader: (2)

But my early 335i was the 160mm woofer and that wasn't glued, nor was the woofer on my wifes 320d E91.
That was a 2006 and 2007 car.

So is there a trick to getting them out???
gIzzE is offline  
0
Reply With Quote
      03-01-2012, 04:55 PM   #81
taibanl
Brigadier General
 
taibanl's Avatar
 
Drives: BMW
Join Date: Sep 2010
Location: NA

Posts: 3,561
iTrader: (4)

VP once gave me perfect advice for this task:

"pry like it's not your car"
taibanl is offline  
0
Reply With Quote
      03-01-2012, 06:31 PM   #82
Technic
Lieutenant General
 
Technic's Avatar
 
Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

Posts: 11,109
iTrader: (17)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by gIzzE View Post
But my early 335i was the 160mm woofer and that wasn't glued, nor was the woofer on my wifes 320d E91.
That was a 2006 and 2007 car.

So is there a trick to getting them out???
The changes were done from 2010-on.
__________________
-2015 F30 320i, Imperial/Oyster, 8AT: August 2014 ED
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: Gone
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
Technic is offline   United_States
0
Reply With Quote
      05-30-2012, 10:17 PM   #83
supraken
Private
 
Drives: car
Join Date: Apr 2012
Location: NY

Posts: 85
iTrader: (3)

So if I have hifi system with stock amp, should I be using the 2 ohm or the 4 ohm version??
supraken is offline  
0
Reply With Quote
      05-30-2012, 10:22 PM   #84
kaigoss69
Brigadier General
 
kaigoss69's Avatar
 
Drives: '08 335i
Join Date: Jul 2008
Location: JAX

Posts: 3,040
iTrader: (5)

If you're planning on using the stock amp, the answer is neither. Keep the OEM woofers as they are more efficient than anything aftermarket.
__________________
Mobridge DA2 > JBL MS-8 > JL Audio HD600/4 > (3) Hybrid Audio L3SE & (2) Rainbow Cal25; JL Audio HD900/5 > (2) Morel HCW-10 & (1) IDMax 15
kaigoss69 is offline   United_States
0
Reply With Quote
      05-30-2012, 11:39 PM   #85
VP Electricity
Brigadier General
 
VP Electricity's Avatar
 
Drives: E91 XDrive
Join Date: Jan 2008
Location: portland oregon

Posts: 3,177
iTrader: (3)

And since none of the stock systems use 2-ohm woofers, not certain what then2-ohms are good for. With HiFi, you really should upgrade the amp and the speakers...
VP Electricity is offline   United_States
0
Reply With Quote
      06-01-2012, 10:25 AM   #86
taibanl
Brigadier General
 
taibanl's Avatar
 
Drives: BMW
Join Date: Sep 2010
Location: NA

Posts: 3,561
iTrader: (4)

According to the BMW pdf, the HiFi are 2 ohm woofers
taibanl is offline  
0
Reply With Quote
      06-01-2012, 12:03 PM   #87
VP Electricity
Brigadier General
 
VP Electricity's Avatar
 
Drives: E91 XDrive
Join Date: Jan 2008
Location: portland oregon

Posts: 3,177
iTrader: (3)

Apologies. Last time this came up I actually metered my old HiFi woofers and they were indeed 2 ohms. I have some kind of mental block on this topic.

I guess I'm still trying to wrap my brain around a 2-ohm SWS on a HiFI amp
VP Electricity is offline   United_States
0
Reply With Quote
      06-01-2012, 01:07 PM   #88
taibanl
Brigadier General
 
taibanl's Avatar
 
Drives: BMW
Join Date: Sep 2010
Location: NA

Posts: 3,561
iTrader: (4)

Quote:
Originally Posted by VP Electricity
Apologies. Last time this came up I actually metered my old HiFi woofers and they were indeed 2 ohms. I have some kind of mental block on this topic.

I guess I'm still trying to wrap my brain around a 2-ohm SWS on a HiFI amp
Because you sell, and most of us on this forum buy...much better solutions
taibanl is offline  
0
Reply With Quote
Reply

Bookmarks

Tags
logic 7, subs, sws-8

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:14 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST