E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > Not happy (iDrive)



Reply
 
Thread Tools Search this Thread
      02-25-2012, 02:18 PM   #1
Ted Rascal
Enlisted Member
England
2
Rep
48
Posts

 
Drives: 325d M-sport Coupe
Join Date: Jan 2012
Location: North West England

iTrader: (0)

Not happy (iDrive)

So I have owned the car for about a week and today I start it up and the idrive screen goes bright red then total black out.

Music still plays and everything works but no screen. Tried again and the same. Red screen then nothing.

Although it is under warranty I am pissed off. Did not expect this from BMW considering the money I have spent on the car.

Total inconvenience however long it takes to fix.

Also noticed a small chip on my CF spoiler. Minor but annoying for me. How the fuck has that happened.
Appreciate 0
      02-25-2012, 02:20 PM   #2
dxb335d
The Tarmac Terrorist
dxb335d's Avatar
England
381
Rep
29,288
Posts

 
Drives: E46 M3 CS
Join Date: Mar 2007
Location: ''Fandango Towers''

iTrader: (3)

Garage List
That's unfortunate mate, new cars do sometimes go wrong. My I-drive never played up in my 335d.
__________________
M3 gone .... But I now have a M3 CS
Appreciate 0
      02-25-2012, 02:27 PM   #3
Dr Dave
Zummerzet Zyder Drinker!
Dr Dave's Avatar
United Kingdom
63
Rep
5,541
Posts

 
Drives: '06 330D Le Mans Blue
Join Date: May 2009
Location: Somerset

iTrader: (3)

Garage List
How old is the car??
Appreciate 0
      02-25-2012, 02:40 PM   #4
Ted Rascal
Enlisted Member
England
2
Rep
48
Posts

 
Drives: 325d M-sport Coupe
Join Date: Jan 2012
Location: North West England

iTrader: (0)

It is about 18 months old
Appreciate 0
      02-26-2012, 07:45 AM   #5
MEGA
Dieseasal
MEGA's Avatar
United Kingdom
108
Rep
6,849
Posts

 
Drives: LCI E92 335d M-Sport
Join Date: Jan 2009
Location: Harrow, London

iTrader: (2)

Send a message via MSN to MEGA
Shit happens - it's not as if the dealer could have anticipated the screen dying within a week.

At least the iDrive unit itself is fine. It'll either be a kink in the optical wiring, or the screen itself being lost: Very unlikely to be a full CIC unit replacement so shouldn't take them too long.

Hard luck though..
__________________
Previously: 2003 Peugeot 206 1.6 8v | 2006 E90 320d M-Sport, 19" BBS CH, Full Ice-cold JL audio install, August 2010 Total BMW 6 page feature car. | 2003 Nissan 350Z GT Coupe 286BHP
Now:2010 E92 LCI 335d M-Sport
Appreciate 0
      02-26-2012, 01:17 PM   #6
Ted Rascal
Enlisted Member
England
2
Rep
48
Posts

 
Drives: 325d M-sport Coupe
Join Date: Jan 2012
Location: North West England

iTrader: (0)

Strange, it is back working as normal today, no issues at all...

Hmmm
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:52 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST