E90Post
 


MINHS Auto Care Center
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > Recoding for Alpine Retrofit into my '10 E90?



Reply
 
Thread Tools Search this Thread
      03-02-2012, 01:48 PM   #45
ordobane
New Member
United_States
0
Rep
20
Posts

 
Drives: 2011 335is
Join Date: Nov 2011
Location: Dallas

iTrader: (0)

Quote:
Originally Posted by Exwoodchuck View Post
You'll get coded to 676 then -- and your gongs/BT/PDC/nav volumes will go quiet. And then you'll have the same problem I've got!
I am a bit apprehensive about the dealer trying to fix it.

Would you say the BT/NAV volumes become unusable or just quieter than they should be?
Appreciate 0
      03-02-2012, 02:31 PM   #46
Exwoodchuck
Private
United_States
2
Rep
83
Posts

 
Drives: Yes
Join Date: Aug 2011
Location: Hometown, US

iTrader: (0)

Nav doesn't seem as bad as the BT volume. BT, even cranked up to max while on an active call, is usable up to about 60mph. Past that, I'm better off not answering or making a call -- it's unusable.
Appreciate 0
      03-02-2012, 05:33 PM   #47
ordobane
New Member
United_States
0
Rep
20
Posts

 
Drives: 2011 335is
Join Date: Nov 2011
Location: Dallas

iTrader: (0)

It is hard to believe that a company with the engineering resources of BMW can't make this work properly with a kit they sell.
Appreciate 0
      03-03-2012, 11:07 AM   #48
Exwoodchuck
Private
United_States
2
Rep
83
Posts

 
Drives: Yes
Join Date: Aug 2011
Location: Hometown, US

iTrader: (0)

Its inexcusable in my opinion. If I could return the kit at this point, I'd be half-tempted to remove it all and get my $ back. Its a shame, because if it's coded, it sounds great! Too bad it breaks 3 other things...!

That Cadillac ATS is looking more and more tempting all the time!
Appreciate 0
      03-05-2012, 09:12 AM   #49
taibanl
Brigadier General
taibanl's Avatar
65
Rep
3,643
Posts

 
Drives: BMW
Join Date: Sep 2010
Location: NA

iTrader: (4)

Exwood, you could always return it, get a technic harness and an xd 600/6 and new fronts and it will sound great!

I still recommend you adjust the PDF level though,
Appreciate 0
      03-05-2012, 12:18 PM   #50
Exwoodchuck
Private
United_States
2
Rep
83
Posts

 
Drives: Yes
Join Date: Aug 2011
Location: Hometown, US

iTrader: (0)

Quote:
Originally Posted by taibanl View Post
Exwood, you could always return it, get a technic harness and an xd 600/6 and new fronts and it will sound great!

I still recommend you adjust the PDF level though,
In BMW's opinion, this is an 'electronic', and thus isn't returnable.

I'm confident that we can come up with a workable solution. I'm also confident that BMW won't come up with a fix, because they believe there is not a problem.
Appreciate 0
      03-05-2012, 12:29 PM   #51
Imperator
Major
Imperator's Avatar
United_States
18
Rep
1,128
Posts

 
Drives: 2010 E92 335i
Join Date: Mar 2010
Location: Plano, Texas

iTrader: (7)

Chuck, do you have a coding cable and software to experiment with the volume/system changes in CIC?

In that note, what is the VO code used to "re-activate" STEREO on Chuck's car, since being coded to HI-FI?
Appreciate 0
      03-05-2012, 12:39 PM   #52
taibanl
Brigadier General
taibanl's Avatar
65
Rep
3,643
Posts

 
Drives: BMW
Join Date: Sep 2010
Location: NA

iTrader: (4)

Quote:
Originally Posted by Exwoodchuck View Post
In BMW's opinion, this is an 'electronic', and thus isn't returnable.

I'm confident that we can come up with a workable solution. I'm also confident that BMW won't come up with a fix, because they believe there is not a problem.
The problem for you and BMW is that this retrofit is neither Stereo NOR HiFi, it's a little of both. ISTA/P can toggle the output between either but not adjust individual variables such as those you discovered (well it could be programmed to do so).

I speculate that immediately post 03/09 BMW decided recoding was a better idea, as this is the best solution for SQ. Then later discovered it was detrimental to PDC output, and thus withdrew the instructions to code the vehicle, returning to the pre 03/09 solution.

It is possible that the 8 jumpers in some magical combination can flatten the EQ curve but without someone like montr and his test equipment, we won't know what the effect of each is.

I think the best solution right here and right now is to leave it coded to HiFi, and adjust the PDC level back to e90_stereo. Try that and that alone, and report back?
Appreciate 0
      03-06-2012, 06:07 PM   #53
ordobane
New Member
United_States
0
Rep
20
Posts

 
Drives: 2011 335is
Join Date: Nov 2011
Location: Dallas

iTrader: (0)

Well, it looks like they fixed mine. I am waiting to hear back from the SA with the details. My phone interface looks different so they updated some software. My paperwork says "Software retrofit for Alpine HIFI" and " Imported VO using ISSS".

The sound is now "normal" I have the treb set to +1 and base +2 - but I haven't spent much time in the car yet. The sound is a massive improvement over the base system. The overly bright and harsh tone is gone.

My BT phone sounds fine. The gongs are still kinda loud (turned all the way down). I haven't tried navigation yet. I don't have PDC.
Appreciate 0
      03-07-2012, 10:45 AM   #54
ordobane
New Member
United_States
0
Rep
20
Posts

 
Drives: 2011 335is
Join Date: Nov 2011
Location: Dallas

iTrader: (0)

It looks like they have no details other than a software update was applied and a VO update for the Alpine retrofit.
Appreciate 0
      03-08-2012, 11:10 AM   #55
taibanl
Brigadier General
taibanl's Avatar
65
Rep
3,643
Posts

 
Drives: BMW
Join Date: Sep 2010
Location: NA

iTrader: (4)

I never thought to suggest it before but you could always get louder/better rear speakers for about $60
Appreciate 0
      03-11-2012, 12:44 PM   #56
spektor75
Private
4
Rep
76
Posts

 
Drives: 2011 AW 328i xdrive
Join Date: Aug 2011
Location: Thornhill

iTrader: (1)

Woodchuck it really sounds like the wires connecting the tweeters to the mids are not hoooked up properly
Appreciate 0
      03-11-2012, 02:29 PM   #57
taibanl
Brigadier General
taibanl's Avatar
65
Rep
3,643
Posts

 
Drives: BMW
Join Date: Sep 2010
Location: NA

iTrader: (4)

I dont see why you would draw that conclusion. Pdc does not run through his frontstage and his fr on the frontstage hasnt sounded like crap
Appreciate 0
      03-12-2012, 08:37 AM   #58
spektor75
Private
4
Rep
76
Posts

 
Drives: 2011 AW 328i xdrive
Join Date: Aug 2011
Location: Thornhill

iTrader: (1)

Im not too sure about the pdc, so i should not say, but just judging from what others like ordobane have reported and what other have posted in other threads regarding this matter, it seems they are having success after recoding. Also another member on another post claimed to have the same issues as woodchuck, minus the pdc as his car did not have it, and changing the way the wires were connected to the tweeter is what fixed it for him. I dont think that will change the pdc coming from the rear speakers though
I could be very wrong but you never know
Appreciate 0
      03-12-2012, 04:34 PM   #59
Exwoodchuck
Private
United_States
2
Rep
83
Posts

 
Drives: Yes
Join Date: Aug 2011
Location: Hometown, US

iTrader: (0)

Interesting twist to all of this -- my voice command (the Sneezing Man button on the steering wheel) plays at a normal volume levels. The Nav instructions (when they cut into the music being played) are at a much lower level, as is BT calls.

This isn't an issue of the crossovers to the tweeters being wired wrong. Taibnal hit it on the head- the Alpine retrofit kit is neither Stereo or Hifi (in coding-speak)-- it's a mix. Coding just the PDC or BT or Nav volume codes all of the values that way, i.e., e90_hifi in Nav to e90_stereo will change all volume levels to e90_stereo.

I've pretty much resigned myself to the fact that--
1) BMW *knew* of this problem,
2) they should have never sold the Kit in the first place,
3) The 'fix' for it is to never install it in the first place, and to go with another solution
4) There is no coding fix that produces ALL of the items working at the same time via NCSExpert or INPA/P-- although there might be something else that might work...

Signed-
Grumpy in South Texas.
Appreciate 0
      03-12-2012, 04:35 PM   #60
Exwoodchuck
Private
United_States
2
Rep
83
Posts

 
Drives: Yes
Join Date: Aug 2011
Location: Hometown, US

iTrader: (0)

Quote:
Originally Posted by ordobane View Post
It looks like they have no details other than a software update was applied and a VO update for the Alpine retrofit.
Yeah- they uncoded your car and restored your VO. If you pull your VO, you'd find 676 now gone.

They want to do it to my car to 'fix' it, but that ain't happening.
Appreciate 0
      03-12-2012, 05:56 PM   #61
spektor75
Private
4
Rep
76
Posts

 
Drives: 2011 AW 328i xdrive
Join Date: Aug 2011
Location: Thornhill

iTrader: (1)

Quote:
Originally Posted by Exwoodchuck View Post
Yeah- they uncoded your car and restored your VO. If you pull your VO, you'd find 676 now gone.

They want to do it to my car to 'fix' it, but that ain't happening.
The first time ordobane went to the dealer they just installed the kit with no coding, now that coding has been done he claimed that it sounded much better and the bluetooth worked normally

ordobane is this correct? car was coded and everythings running smoothly?
I only have bluetooth, no pdc or nav still dont know whether to code or not
Appreciate 0
      03-12-2012, 09:29 PM   #62
ordobane
New Member
United_States
0
Rep
20
Posts

 
Drives: 2011 335is
Join Date: Nov 2011
Location: Dallas

iTrader: (0)

Quote:
Originally Posted by spektor75 View Post
The first time ordobane went to the dealer they just installed the kit with no coding, now that coding has been done he claimed that it sounded much better and the bluetooth worked normally

ordobane is this correct? car was coded and everythings running smoothly?
I only have bluetooth, no pdc or nav still dont know whether to code or not
This is correct. The first time I went they did not do any coding as they determined none was necessary. I found the sound to be overly bright and unbalanced.

After they "discovered" some software updates, I went back and had them do the coding. This fixed the sound and my BT and Nav work fine. The volume adjustments for each seem to be in a normal range.

I could not pin them down on what they did and they really didn't seem to know. I think they did a software update and adjusted my VO.

So, it working correctly for me after coding, but I do not have PDC.
Appreciate 0
      03-13-2012, 09:19 AM   #63
spektor75
Private
4
Rep
76
Posts

 
Drives: 2011 AW 328i xdrive
Join Date: Aug 2011
Location: Thornhill

iTrader: (1)

perfect thanks for clearing that up
im in the same boat as you, no pdc so i guess im gonna go through with the coding
cant wait for this to finally work as it should
Appreciate 0
      03-13-2012, 09:35 AM   #64
Catalyst Group
Private
1
Rep
57
Posts

 
Drives: 2011
Join Date: Jan 2012
Location: Croatia

iTrader: (0)

Still trying to find the solution... argh...
Appreciate 0
      03-13-2012, 11:45 AM   #65
spektor75
Private
4
Rep
76
Posts

 
Drives: 2011 AW 328i xdrive
Join Date: Aug 2011
Location: Thornhill

iTrader: (1)

catalyst do you have pdc?
Appreciate 0
      03-13-2012, 05:19 PM   #66
taibanl
Brigadier General
taibanl's Avatar
65
Rep
3,643
Posts

 
Drives: BMW
Join Date: Sep 2010
Location: NA

iTrader: (4)

Catalyst has PDC, I think he was the OP with the problem
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:28 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST