E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > HPFP failure FAQ!



Reply
 
Thread Tools Search this Thread
      08-26-2015, 08:10 AM   #1233
robkellz
Registered
0
Rep
2
Posts

Drives: 2008 335i Coupe
Join Date: Aug 2015
Location: Gulf Breeze, FL

iTrader: (0)

Hey guys!

My problem seems to have some of the symptoms explained in the HPFP problem, but other warnings lead me to believe it is something else. While driving to work last week my 335i jerked for a second while on the freeway and the "service engine soon" light came on for a second. The car ran fine until I got ready to leave work and a bunch of messages came on the idrive, the half engine showed up on the dash, and the car went into limp mode. These are the messages that I got:

Engine malfunction - reduced power
Malfunction in transmission
DSC malfunction
Start-off assistance malfunction
DBC malfunction

I'm taking the car to the dealership to get a diagnostics test this morning. Any suggestions on whether this is HPFP related or something else? Maybe the battery or alternator (Battery is about 1.5 years old).

I had the alternator/battery tested at O'reilly's and since they couldnt hook directly to the battery in the trunk, they had to use the connection under the hood. The said the battery tested out fine, but the alternator voltage regulator failed... I'm just not sure how accurate this test is since it was performed in the engine bay.

One last thing. The service history shows that the HPFP was changed back in 2010.
Appreciate 0
      10-04-2015, 11:07 AM   #1234
supahman04
New Member
0
Rep
11
Posts

Drives: 08 335i
Join Date: Oct 2014
Location: Palm Beach, Fl

iTrader: (0)

So Ive been getting an awful lot of 2cf7-Throttle Body Potentiometer codes as well as a bunch of 29F1-Fuel Pressure Plausibility codes. As well as some Cylinder misfiring codes. I can clear all but the 2cf7 codes. Last night it caused the car to shut down completely and not even idle. I need my car. I'm on trauma call at a hospital quite often and need this taken care of.

I have done quite a lot of reading on here and have replaced the spark plugs. I have bought a new throttle body. I've replaced the battery. Im almost out of options. Is there any way this is the HPFP?! It's driving me insane!! Also, I bought the car at a used car dealer. I'm not the first owner. So I'm assuming the dealership wont do anything for me with extending any kind of warranty. Correct? Its an 08 335i.

Thanks for any help in advance!
Appreciate 0
      10-07-2015, 08:36 PM   #1235
JStang
N54 ADDICT
JStang's Avatar
150
Rep
3,415
Posts

Drives: FBO E92 335i
Join Date: Dec 2010
Location: St. Petersburg, FL

iTrader: (8)

I'm happy to say that up until this point, I am one of the lucky ones who hasn't had to visit this thread. I recently started getting really rough starts with Code 29F2 and half engine symbol on cold starts. This would usually happen if the car sat for 36+ hours at a time.

I have replaced injectors with index 12 so injectors are not the issue. I had to clear the code when uninstalling my Cobb tune and the dealer won't replace the HPFP without the code even though it has started rough for them the last couple of mornings. Symptoms are there, but no code. The tech stated that there was smoke from the exhaust and brought up the injectors. Would the fuel pump leak overnight causing these rough cold start misfires?

When I turn off the car and clear the code the car runs perfectly.
Appreciate 0
      10-12-2015, 08:06 PM   #1236
GreaseMonkey
Second Lieutenant
GreaseMonkey's Avatar
12
Rep
237
Posts

Drives: '09 335i xDrive
Join Date: Feb 2013
Location: CT

iTrader: (4)

My pump just went at 62,000 miles, almost out of the clear blue in fact. Before realizing the pump had a problem, I had a fairly significant amount of smoke from the exhaust that would dissipate quickly. Now that it has been replaced, I have zero smoke from the exhaust, even in 40 degree weather.

I could usually force a HPFP code by lugging the engine a bit, say 3rd gear at 20-25 mph and then floor it. Car would stutter and jerk for a few seconds at most before throwing the half engine light.

Good luck, I hope you can get it resolved quickly.
__________________
'09 335 xdrive: JB4 G5 ISO - BMS Pump Flash - E30 / BMS DCI / VRSF DP / VRSF FMIC / BMS CP / BMS CDV / BMS Clutch Stop / ZHP Knob
'07 Mustang GT/CS vert: Intake / Tune / Straight Pipes / Strut Brace
'67 Jacobsen Tractor: Yardwork Toy
Appreciate 0
      10-13-2015, 10:25 PM   #1237
akbarrajabi
Registered
0
Rep
2
Posts

Drives: e90 335i msport
Join Date: Oct 2015
Location: East Bay, CA

iTrader: (0)

Nice write up! thankfully havent come across hpfp failure yet!
Appreciate 0
      11-10-2015, 12:01 PM   #1238
dannyjones
Second Lieutenant
22
Rep
293
Posts

Drives: 2011 BMW 335i M-Sport
Join Date: Jan 2014
Location: Florida, USA

iTrader: (0)

Can anyone confirm the best replacement part to get? 13-51-7-616-170 or 13-51-7-616-446?

The one ending 446 is much cheaper, but I won't get it if its another problematic one.
Appreciate 0
      02-09-2016, 02:40 AM   #1239
Guam135i
First Lieutenant
Guam135i's Avatar
Guam
13
Rep
340
Posts

Drives: 08 BMW 135i, 08 128 Cab
Join Date: Oct 2011
Location: Guam

iTrader: (0)

Quote:
Originally Posted by quattr0 View Post
[b]

All owners/lessees in the United States are Class members. This is a Nationwide Class.

Wigington Rumley Dunn, L.L.P.
Attorneys at Law
601 Howard
San Antonio, Texas 78212
(210) 487-7500

Y'all feel free to chime in/update/corrections, etc.
My car has been with the dealer since Sept 14, 2015 for the recalls. I'm joining this. I wrote the attorney hopefully they respond back
__________________

1970 Morris Cooper S * 1973 Mini 1275GT
2008 BMW 135i Coupe * 2008 BMW 128i Convertible
1995 BMW M3* 2016 Mazda MX5
Appreciate 0
      02-10-2016, 03:52 PM   #1240
Zilla37
New Member
1
Rep
7
Posts

Drives: BMW 328xi
Join Date: Aug 2011
Location: Vancouver

iTrader: (0)

Driving home yesterday my loose gas cap light came on.
I removed and tighten the cap back on drove 10 minutes to work but a empty yellow engine light remains on. Started my car 2 hours later and light still appears. No other codes appear just the yellow light. I did a google search and have herd from get it checked right away to drive for a few days and it will go away.
Not sure what to do can any of you offer any help.

BMW
328 XI
2008
Appreciate 0
      02-25-2016, 07:39 PM   #1241
Guam135i
First Lieutenant
Guam135i's Avatar
Guam
13
Rep
340
Posts

Drives: 08 BMW 135i, 08 128 Cab
Join Date: Oct 2011
Location: Guam

iTrader: (0)

I just got my car back since September and replaced all the injectors and HPFP and now the car is back to its old self a blast to drive
__________________

1970 Morris Cooper S * 1973 Mini 1275GT
2008 BMW 135i Coupe * 2008 BMW 128i Convertible
1995 BMW M3* 2016 Mazda MX5
Appreciate 0
      02-26-2016, 10:39 PM   #1242
bman5150
Second Lieutenant
17
Rep
231
Posts

Drives: 2011 335i XDrive
Join Date: Apr 2007
Location: Cowtown

iTrader: (0)

My n55 powered 2011 is currently at the dealer getting its HPFP replaced. Only symptom was increasingly frequent long cranks on cold starts
__________________
2011 BMW 335i XDrive Msport (auto)
Appreciate 1
      03-16-2016, 08:13 PM   #1243
AndreyT
Major
AndreyT's Avatar
United_States
26
Rep
1,037
Posts

Drives: 2011 335i Sedan, Sport
Join Date: Feb 2011
Location: Northern California

iTrader: (0)

My HPFP just failed at 57K miles in 2011 335i with N55 engine. The symptoms began much earlier than that, still under the original warranty but without fault codes (so the dealer "could not reproduce" anything). But eventually it started throwing 2BEE and finally this Sunday I got a SES after a rough start, with a barrage of various additional fault codes on top of 2BEE.

I went to the dealer to have it fixed. I thought that at 57k I'd have to pay for it out of my pocket. However, to my (pleasant) surprise, HPFP turned out to be covered under California Emissions Warranty (7 years/70k miles). So, I got mine replaced free of charge.
Appreciate 0
      05-25-2016, 06:20 PM   #1244
89mustaine
Stuff and Things
89mustaine's Avatar
United_States
26
Rep
155
Posts

Drives: E60 535i Sport W/SAT MHD
Join Date: Apr 2016
Location: Chico CA

iTrader: (0)

So my pump has been acting up for a while but never threw any codes. I get 30ff if I WOT 3rd hear from 2k-5ish but only with MHD installed so the dealer could never make it happen. Extended crank and miss firing if I let it idle on a cold start and didn't drive right away. The dealer in my town is useless so I gave up trying to get them to replace it.

Anyway long story short I went 2 hours out of my way to find a Service writer I could work with and on the first visit I had recently changed the plugs so they did a carbon cleaning. After doing this they said no evidence of fuel pump issues were present So I picked it up (2 hour drive) and went about my business, immediately started noticing extended crank and rough idle again. So I took video footage of the symptoms and took it back. This time they agreed to do the fuel pump which is awesome because I'm sure it never threw the typical codes, and the car has 111k on it so it's just in time. I also agreed to let them change the engine and trans oil pan gaskets and put new VANOS solenoids in since cleaning them really helped the rough idle (3rd party warranty covered a lot of this). So they have my car for 10 days and Monday I picked it up, seemed good since it started nicely, with the stock tune I wouldn't be able to get limp mode so I couldn't really test the pump. Tuesday it turns over 20 times before start, about the worst it ever does So I call the guy and after a long awkward conversation he realizes that they forgot to do the solenoids AND the fuel pump. Purely because of miscommunication and his best tech calling in sick the day he was supposed to do it (also the day my writer has off). So some other guy did all the gaskets and stamped a big DONE on the whole job. My guy comes in the next day and calls me "hey it's done!" and I leave work early, drive two hours, excitedly pick up my car (hand over about $700) and head home to find out its got to go back...

Honestly I think some people would be furious at this whole situation, but I'm still glad I found a service writer who will work with a modded car and grey area warranty stuff. That's my honest telling of the story you can react to it however you like but if you're tired of stealerships killing your dreams and you'd like to convenience of working with a dealership again (loaner cars and free coffee) Shoot me a PM and I'll gladly refer you to the one I've been ranting about. It would help if you're in the NorCal area.
Appreciate 0
      07-03-2016, 07:59 PM   #1245
nicolassf
Registered
0
Rep
1
Posts

Drives: 335i 07 silver
Join Date: Jul 2016
Location: California

iTrader: (0)

So I just got my 5th HPFP installed a few days ago on my 07 335i.
Interestingly the symptoms were quite different this time around: no long crank, just very rough idle on cold start (like misfires) that would go away with a restart of the engine. I thought I had leaky injectors but the dealership replaced the HPFP and the problem seems to be gone.

It was done under warranty as it's less than 10 years old.
For reference here are the part numbers I've been through... Hopefully this one will last a bit longer...

2000 miles 320
4900 miles 320
39k miles 881
45k miles 933
72k miles 170
Appreciate 0
      07-06-2016, 05:09 PM   #1246
specialist
Second Lieutenant
6
Rep
279
Posts

Drives: 335i
Join Date: Apr 2013
Location: toronto

iTrader: (0)

Hello
I think my HPFP is going. I just replaced my LPFP and i still get the same error code cc id 29. Sometime i have problems it stuggles to start but it starts. Today I did a hard pull and the 1/2 engine light went on. The car didn't go in to limp mode it allow me to still boost. waht do you think it could be. It idles fine. plese help
Appreciate 0
      07-19-2016, 11:19 AM   #1247
rsyed07
Private First Class
rsyed07's Avatar
United_States
7
Rep
115
Posts

Drives: E46 330i, E92 335is
Join Date: Jun 2016
Location: Central FL

iTrader: (0)

Why aren't later models included in the HPFP recall? Is it because they put the updated better HPFP on them already? I'm wondering because I have a '11 335is and i'm not looking forward to this if it happens.
Appreciate 0
      07-21-2016, 08:29 PM   #1248
Llbcde
New Member
0
Rep
5
Posts

Drives: 08 335i 108xxx
Join Date: Jul 2016
Location: High desert

iTrader: (0)

Jsuti

Bmw
Appreciate 0
      08-22-2016, 03:19 PM   #1249
Um3r
New Member
Um3r's Avatar
0
Rep
25
Posts

Drives: 2011 335i xDrive
Join Date: Nov 2014
Location: Pittsburgh, PA

iTrader: (0)

Garage List
Mine just failed at ~65k miles on N55 11' 335 x-drive. Luckily its still under CPO so its going to be replaced under warranty.

Last Thursday the car just died when I stopped at a stop sign and did it three times in a row. No fault codes or anything, would start right up again without any unusual cranks or anything. Then on Friday I got the limp mode notification for sometime and then it went away and the car was fine again. Dealer checked and said it was the fuel pump.
Although last year I had the car die out similarly once or twice a few weeks apart and when I took it to the dealership they couldn't find any issues so they just updated some software and sent me on my way.
Appreciate 0
      09-05-2016, 11:11 AM   #1250
wshgrntd
First Lieutenant
wshgrntd's Avatar
6
Rep
354
Posts

Drives: E90 335i
Join Date: Sep 2013
Location: Baltimore

iTrader: (0)

I replaced my pump 2 months ago however it is starting to through a hpfp shadow code. Also a little bit of a rough idle if I start it and let it sit. I didnt change the fuel line could that be an issue?
Appreciate 0
      09-09-2016, 12:46 PM   #1251
e46mike
Private
0
Rep
90
Posts

Drives: a board with 4 wheels
Join Date: Oct 2010
Location: on the road

iTrader: (0)

Quote:
Originally Posted by rsyed07 View Post
Why aren't later models included in the HPFP recall? Is it because they put the updated better HPFP on them already? I'm wondering because I have a '11 335is and i'm not looking forward to this if it happens.
have a '11 335is as well with 75k miles and hpfp is starting to go out and bmw won't cover it.
Appreciate 0
      09-09-2016, 07:57 PM   #1252
techwhiz
Colonel
techwhiz's Avatar
United_States
139
Rep
2,523
Posts

Drives: e90 335i Sedan - Arctic
Join Date: Feb 2012
Location: Bay Area, Ca

iTrader: (4)

Quote:
Originally Posted by e46mike View Post
have a '11 335is as well with 75k miles and hpfp is starting to go out and bmw won't cover it.
https://www.scribd.com/doc/153404704...-Extension-TSB

I would scream.
Even after they swapped my pump (3 times) , it still failed.
This was long after 2011.
Find another dealer and have them contact BMWUSA
__________________
Arctic Metallic\CF Splitters\CF Spoiler\Blacklines\LSD\Tinted\Coded\Apex EC7-19"\LED Angel Eyes\Gloss Black Grill\Integrated V1 & Galaxy Tab\M-Performance Brakes\Cobb Tuned and -> is your friend.
Appreciate 0
      09-13-2016, 10:36 AM   #1253
rsyed07
Private First Class
rsyed07's Avatar
United_States
7
Rep
115
Posts

Drives: E46 330i, E92 335is
Join Date: Jun 2016
Location: Central FL

iTrader: (0)

SMH cuts off right at 2010. Well it's going to be a gamble but let's see how long it lasts.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 01:34 AM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST