E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > DIY Guides > DIY - Replacing Camshaft VANOS Solenoid



Reply
 
Thread Tools Search this Thread
      11-16-2011, 02:48 PM   #45
spdnman
New Member
0
Rep
24
Posts

Drives: 335xi
Join Date: Aug 2011
Location: NY

iTrader: (0)

Quote:
Originally Posted by BAL278 View Post
Thanks for this DIY.. Came in handy
What is a ballpark cost of just purchasing the Vanos Solenoid? Thanks
Appreciate 0
      11-16-2011, 04:44 PM   #46
firechicken99
Major
14
Rep
1,035
Posts

Drives: Black '07 335i
Join Date: Mar 2011
Location: United States

iTrader: (0)

Quote:
Originally Posted by spdnman View Post
What is a ballpark cost of just purchasing the Vanos Solenoid? Thanks
Just over $100 a piece from tischer (getbmwparts.com)
Appreciate 0
      12-17-2011, 11:53 PM   #47
Mseg
New Member
United_States
0
Rep
17
Posts

Drives: e90
Join Date: May 2011
Location: Duarte, California

iTrader: (0)

This DIY was great. Helped me out after I spotted the 2A99 code. All I did was use my air compressor to clean my exhaust solenoid, put it back, and the code hasn't come back yet
Appreciate 0
      12-18-2011, 10:52 AM   #48
ENINTY
Banned
75
Rep
3,415
Posts

Drives: 2006 325i Sport
Join Date: Jun 2006
Location: Virginia

iTrader: (0)

Okay, it's now been 19,000 miles since I did the clean and swap. No reappearence of the codes.
Appreciate 0
      01-05-2012, 11:19 AM   #49
blipszyc
Registered
0
Rep
1
Posts

Drives: Mystic Blue 530xi
Join Date: Dec 2009
Location: Ohio

iTrader: (0)

For those that just cleaned with "air" would canned air be enough or would I need something stronger?
Appreciate 0
      01-07-2012, 04:14 PM   #50
MARIO11
Registered
2
Rep
4
Posts

Drives: E90 325iA
Join Date: Jan 2012
Location: PL.

iTrader: (0)

I just read whole topic. I will try this !
Thanks again for Vmax222 becouse he wrote me about this topic.
After reading I have good humor I will check this in my car. Hope it helps.
and thank you orionredwing for this DIY !!
greetings


edit: blipszyc - I will use comp. air and maybe try carb cleaner
Appreciate 0
      01-14-2012, 12:29 PM   #51
chrismanchr
Second Lieutenant
8
Rep
222
Posts

Drives: 1986 mr2 mk1
Join Date: Mar 2011
Location: manchester england

iTrader: (0)

ive just changed my inlet solenoid as per this article and it fixed my poor running and constant yellow light and fault codes thanks very much for posting it
Appreciate 0
      01-18-2012, 09:58 PM   #52
AlanAZ
Captain
AlanAZ's Avatar
15
Rep
810
Posts

Drives: E90 325i sport manual
Join Date: Aug 2009
Location: Scottsdale, AZ

iTrader: (4)

What's the exact process for cleaning the solenoids? Haven't found anything online. How many psi on the shop air? Thanks! Alan.
Appreciate 0
      01-19-2012, 09:05 PM   #53
Ethan
Registered
0
Rep
1
Posts

Drives: Silver
Join Date: Jan 2012
Location: Minnesota

iTrader: (0)

I have a 2006 325. For about a month now, the engine has been shaking intermittently while in park or when the car is fully stopped. Diagnosed a 2A87 code. Service guy told me selonoid needs to be cleaned. I just cleaned it and it did help a little. While in park it does not shake anymore. While in drive, but fully stopped it still shakes. Thinking about replacing both selonid. Any suggestions??

If replacing selonoids, do you have to reprogram the car after replacing the solenoids?
Appreciate 0
      01-19-2012, 11:38 PM   #54
ska///235i
***** noob
ska///235i's Avatar
United_States
463
Rep
10,280
Posts

Drives: 325xi>M235i>428GCx Mspor
Join Date: Sep 2005
Location: Boston

iTrader: (34)

Garage List
2006 325xi  [0.00]
after you take out the solenoids...theres an O ring sitting inside the hole. Per bentley manual, you should replace them but they looked fine so i just left them inside. Make sure when you reinstall the vanos that the O rings are still there and it didnt fall off

i clean them with carburator cleaners, used the tiny straw and spray right inside the hole from the top of the solenoid ( becareful the spray might bounce back, wear glasses...etc). Shit started to come out of the hole. I swap the two and clear the P1553 generic code.

(edit) CEL havent come back after a month...so everything is good



added some more info

.
Attached Images
    
__________________
2006 325xi (Sold)
2014 M235I (Current)
2015 428xi Gran Coupe (STB)

Last edited by ska///235i; 04-12-2012 at 03:56 PM.
Appreciate 0
      01-19-2012, 11:39 PM   #55
ska///235i
***** noob
ska///235i's Avatar
United_States
463
Rep
10,280
Posts

Drives: 325xi>M235i>428GCx Mspor
Join Date: Sep 2005
Location: Boston

iTrader: (34)

Garage List
2006 325xi  [0.00]
.
Attached Images
    
__________________
2006 325xi (Sold)
2014 M235I (Current)
2015 428xi Gran Coupe (STB)
Appreciate 0
      01-22-2012, 02:20 AM   #56
335R
Private First Class
335R's Avatar
United_States
6
Rep
152
Posts

Drives: E93 335i
Join Date: May 2009
Location: Tampa, FL

iTrader: (4)

I also had the same issue, under boost 2A87/3100 and limp mode, I took them out and clean them with break cleaner and compressed air and put them back in, same code and hesitation came back on after few WOTs. Then I took them out, cleaned again and swapped the top one with the bottom one. Issue is fixed. Make sure you swap them around before replacement.
Appreciate 0
      01-30-2012, 05:01 PM   #57
spool twice
Rainbow Racer
spool twice's Avatar
United_States
36
Rep
1,304
Posts

Drives: S65B40
Join Date: Sep 2010
Location: Sarasota, FL

iTrader: (7)

same issue, limp mode upon hard acceleration (happened to me twice within three weeks of owning my car).

I'm glad I found this DIY, helped me. I was able to just remove the two front engine cover hex screws and lift the engine cover slightly and bent it to the left (the engine cover was flexible enough and i didn't have to remove the charcoal filter doing it this way, but I do not recommend doing it that way as you can permanently bend it or snap the engine cover if not careful). I did not remove the snorkel as my hands fit fine in the gap (I have the oil cooler as well). Removed the intake, then exhaust. I had limp modes for the exhaust so I cleaned that one out with brake cleaner and let it dry for a minute swinging it back-n-forth in the air. Re-installed it in reverse order making sure I swap the intake/exhaust solenoids. It only took me 10minutes to do this and it was my first time.

Instantly I noticed my part-throttle acceleration is stronger and more responsive, no difference @ WOT though, and the stumble/misfire @ idle is reduced. It's only been 4 days since I've done this, but no reports of limp modes or ghost codes yet.
__________________
'15 IS350 F-sport Ultra White/Rioja Red
'09 E90 M3 7-DCT Interlagos Blue/Novillo Silver
[MS Pullies|K&N drop-in|Test Pipes |Evolve Stage II tune|Evolve Servotronic Map|Evolve M3 GTS-DCT file]
Now gone
Appreciate 0
      01-31-2012, 01:19 PM   #58
AlanAZ
Captain
AlanAZ's Avatar
15
Rep
810
Posts

Drives: E90 325i sport manual
Join Date: Aug 2009
Location: Scottsdale, AZ

iTrader: (4)

I cleaned my solenoids a week ago @ 80K miles, purely for maintenance reasons. Thanks to ENINTY for his advice how to do this.

Took both bolts out, then removed both solenoids, marking the top one with a cable tie so I knew which was which, and after cleaning, installed both solenoids before the bolts.

I cleaned with MAF cleaner, it cleans oil and dirt, and is plastic safe. The way I cleaned them, the cleaner poured over the plastic connector -- I didn't want to break what wasn't broken.

I set them in empty oil qt containers to drain the remaining oil, they have a hole in the inside end (I did all this while doing other work on the car), blew them out with 50 psi of shop air using an old 1 gal water container with the top cut off to control the spray, held them connector end down, and sprayed MAF cleaner thru the hole in the end with the spray extension, held them that way for 30-60 sec to dissolve the oil in the mechanism, tipped it over to drain the cleaner and hit it with air.

I did this another couple of times, the first time, the cleaner run brown when tipped over, the other two, clear. Let them dry thoroughly and reinstalled in opposite positions.
Appreciate 0
      02-08-2012, 01:10 AM   #59
markdevis2011
Registered
0
Rep
1
Posts

Drives: Nice car
Join Date: Feb 2012
Location: London

iTrader: (0)

Thanks for this DIY is the problem my car yesterday only has 40 k miles and idling very rough took to dealer and they were instead.
__________________
Appreciate 0
      02-23-2012, 12:35 AM   #60
pracklam
Enlisted Member
0
Rep
34
Posts

Drives: 2006 e90 325i
Join Date: Jan 2009
Location: Fairway, KS

iTrader: (0)

Had the solenoids cleaned by dealer under warranty about a year ago after I took it in for intermittent "service engine soon" light. At that time they cleaned them and changed oil.

Took the car back in two weeks ago (car not under warranty) with rough idle and intermittent light. Main source of rough idle was a bad ignition coil which I replaced myself for $60 (dealer wanted $300). They wanted to replace both solenoids for $600 since they had already tried to clean once. I took it home, removed the solenoids, blew out with compressor air and applied a lot of WD40. I put them back on, changed the oil & filter and have not had a light since.
Appreciate 0
      02-23-2012, 03:15 PM   #61
ska///235i
***** noob
ska///235i's Avatar
United_States
463
Rep
10,280
Posts

Drives: 325xi>M235i>428GCx Mspor
Join Date: Sep 2005
Location: Boston

iTrader: (34)

Garage List
2006 325xi  [0.00]
WD40????
__________________
2006 325xi (Sold)
2014 M235I (Current)
2015 428xi Gran Coupe (STB)
Appreciate 0
      02-24-2012, 07:33 PM   #62
ENINTY
Banned
75
Rep
3,415
Posts

Drives: 2006 325i Sport
Join Date: Jun 2006
Location: Virginia

iTrader: (0)

Quote:
Originally Posted by AlanAZ View Post
I cleaned my solenoids a week ago @ 80K miles, purely for maintenance reasons. Thanks to ENINTY for his advice how to do this.

Took both bolts out, then removed both solenoids, marking the top one with a cable tie so I knew which was which, and after cleaning, installed both solenoids before the bolts.

I cleaned with MAF cleaner, it cleans oil and dirt, and is plastic safe. The way I cleaned them, the cleaner poured over the plastic connector -- I didn't want to break what wasn't broken.

I set them in empty oil qt containers to drain the remaining oil, they have a hole in the inside end (I did all this while doing other work on the car), blew them out with 50 psi of shop air using an old 1 gal water container with the top cut off to control the spray, held them connector end down, and sprayed MAF cleaner thru the hole in the end with the spray extension, held them that way for 30-60 sec to dissolve the oil in the mechanism, tipped it over to drain the cleaner and hit it with air.

I did this another couple of times, the first time, the cleaner run brown when tipped over, the other two, clear. Let them dry thoroughly and reinstalled in opposite positions.
Hey, the real thanks goes to Orionredwing, he initiated the DIY, I just took it a step further after reading the Bentley manual and putting two & two together. The only reason I figured out my problem last year was remembering this DIY by Orionredwing. I take no credit.

This proceedure should be standard maintenance for N52/N54s.
Appreciate 0
      03-19-2012, 05:12 PM   #63
GoRomeo
Colonel
GoRomeo's Avatar
42
Rep
2,593
Posts

Drives: 330i
Join Date: Feb 2006
Location: San Diego CA

iTrader: (0)

Garage List
2006 330i  [2.83]
Quote:
Originally Posted by ENINTY View Post
Hey, the real thanks goes to Orionredwing, he initiated the DIY, I just took it a step further after reading the Bentley manual and putting two & two together. The only reason I figured out my problem last year was remembering this DIY by Orionredwing. I take no credit.

This proceedure should be standard maintenance for N52/N54s.

Hi there,

Recently did the charcoal delete and had MAF sensor cleaned as well. Noticed a little faster throttle response. No big sound difference either. Now, I really would like to clean my Vanos Solenoid only as maintenance procedure, I have no error codes or anything, my car is running smooth no issues here. Have anyone experienced a real difference after cleaning the these Solenoids? If so, I would like to know cuz i am about to do it after I clean my engine bay soon. My engine is N54 330i with 87k miles. Thanks in advance.
Appreciate 0
      03-20-2012, 12:03 AM   #64
DaanBMW
Lieutenant
DaanBMW's Avatar
United_States
8
Rep
466
Posts

Drives: 2007 328i coupe
Join Date: Jun 2011
Location: Portland, OR

iTrader: (1)

Yeah, I'd also like to know WHY this should be done as a matter of maintenance and not just if any codes are triggered. What does it fix or improve ? How can you tell you might need it, short of any codes ? Rough idling is one symptom mentioned, anything else ?
__________________
328i Sports Pkg, Michelin PSS on Staggered 18" OZ Ultraleggeras
. BMS Powerbox. Cyba scoops + charcoal delete. Wavetrac LSD
. M3: subframe bushings + sways + control arms. Meyle rear toe arms. M3 diff fr bushings
. BMW Perf: springs + v1 dampers
. Short Shifter + ZHP M weighted shift knob. CDV delete.
Appreciate 0
      03-20-2012, 12:49 PM   #65
AlanAZ
Captain
AlanAZ's Avatar
15
Rep
810
Posts

Drives: E90 325i sport manual
Join Date: Aug 2009
Location: Scottsdale, AZ

iTrader: (4)

I did it as preventive maintenance, wanting the solenoids to last as long as possible, 150K mls? I do have 80K mls, and they are mechanical, so cleaning them now seemed to be a good idea.

Plus I changed to a 0 cold weight oil (M1 0w40), changing twice as frequently as the original owner, and that will help keep them clean going forward. Does seem a bit stronger mid-high rpm. All it cost was some time and MAF cleaner, and with this DIY it's dead easy to do.
Appreciate 0
      03-20-2012, 02:04 PM   #66
ska///235i
***** noob
ska///235i's Avatar
United_States
463
Rep
10,280
Posts

Drives: 325xi>M235i>428GCx Mspor
Join Date: Sep 2005
Location: Boston

iTrader: (34)

Garage List
2006 325xi  [0.00]
dawm read the thread...there are plenty of info why ppl are doing it
__________________
2006 325xi (Sold)
2014 M235I (Current)
2015 428xi Gran Coupe (STB)
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 07:35 AM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST