E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > DIY Guides > My $0.02 Steering Angle Sensor Fix



Reply
 
Thread Tools Search this Thread
      09-12-2011, 11:11 AM   #23
crazy car
Registered
crazy car's Avatar
United_States
0
Rep
2
Posts

Drives: 328i
Join Date: Aug 2011
Location: US

iTrader: (0)

Thank you for posting a detailed step-by-step instruction. I drive a 2007 328i Coupe. I have been getting the dreaded error codes since January of 2011. I took it to the dealership. They quoted $1096 to replace and program the SZL cluster. I was not willing to pay that kinda money. I took it to two independent bmw shops, and they both said that they could replace it but but I will need to go back to the stealership to program the new module. Then I came across this wonderful post. I pretty much followed the instructions and it worked like a charm. However, I did not have to solder or reline the PCB. It looked brand new (even under a magnifying glass). I decided not to touch it, but went ahead and cleaned the optical disk using alcohol and put everything back. It has been over a month since I did this, and I have not seen those dreaded symbols on my dashboard. I can't thank enough the original poster. I really appreciate your kindness in sharing this fix.

Last edited by crazy car; 09-13-2011 at 11:59 AM.
Appreciate 0
      09-20-2011, 02:27 AM   #24
northerncalguy
Throw your hands in the air, if you's a true playa.
northerncalguy's Avatar
United_States
84
Rep
435
Posts

Drives: 2006 325i, 2014 435i
Join Date: Sep 2005
Location: NorCal

iTrader: (0)

Garage List
2006 325i  [0.00]
I've been gone from this forum for quite sometime, but thought I'd poke my head back in to say thanks to the OP of this tutorial. Like a few others, I took the SZL apart and cleaned the optical disk with a bit of alcohol and a few cotton swabs. The lights went away after a short drive and although it's only been a few hours, I've got confidence this was likely the source of the fault codes. If this cleaning truly resolved the faults, it would literally save me about $1200 that the stealer wanted. Crossing my fingers! Go E90post!
__________________
Appreciate 0
      09-22-2011, 01:29 PM   #25
Tat08
Enlisted Member
5
Rep
32
Posts

Drives: E90 325i 2006
Join Date: May 2011
Location: Paraguay

iTrader: (0)

amazing! i did this and is true, in my case the DSC light was on and the turn signal lights didn't work properly, all i did was a nice cleaning of the IR LED and the cover, till now, all is working fine again, thanks a lot!
Appreciate 0
      09-28-2011, 09:56 PM   #26
prelude2perfect
Lieutenant
17
Rep
528
Posts

Drives: 2007 335i Sedan
Join Date: Apr 2010
Location: Tacoma

iTrader: (8)

Tried this last week. I cleaned the optical disc, sensor, and led cover. Didn't work for me. I need to take it apart again and this time try taking off the led cover and actually cleaning the led too. I didin't have a torx small enough to take the cover off. Hopefully that will fix it.
__________________


'07 E90 MT Sports Package l RB Turbos l JB4 G5 with Race Backend Flashl AA CP, BOV, and IC l Modified Injen DCI l Raceland 2.5" DP's l M2 Dual 2.75" Exhaust l
Appreciate 0
      09-30-2011, 01:56 PM   #27
Tat08
Enlisted Member
5
Rep
32
Posts

Drives: E90 325i 2006
Join Date: May 2011
Location: Paraguay

iTrader: (0)

Quote:
Originally Posted by prelude2perfect View Post
Tried this last week. I cleaned the optical disc, sensor, and led cover. Didn't work for me. I need to take it apart again and this time try taking off the led cover and actually cleaning the led too. I didin't have a torx small enough to take the cover off. Hopefully that will fix it.
definitely you'll need the small torx, clean it although it does not seem dirty
Appreciate 0
      10-01-2011, 12:58 AM   #28
aakrusen
To Punish and Enslave
aakrusen's Avatar
9
Rep
207
Posts

Drives: with both hands on the wheel
Join Date: Jul 2008
Location: Under the hood

iTrader: (2)

Garage List
2012 X5  [4.50]
I'd like to ad that I had this problem and tried Yikes method in this thread. It's been two weeks and I have not had any problems since. Thank you!!
Appreciate 0
      10-03-2011, 01:22 PM   #29
Richwm
Captain
Richwm's Avatar
United_States
18
Rep
876
Posts

Drives: 06 E90 330i 6MT, 01 E46 330i
Join Date: May 2006
Location: Canyon Country, CA.

iTrader: (0)

Garage List
I tried cleaning it and now its faulted all of the time. I have CC-ID faults 24,50,354, and 35. I tried using my BT to Calibrate the steering angle sensor and clear the faults but they keep coming back. It doesn't seem like the steering angle Cal is working. I wonder if the dealer tool will work better.
__________________
Mar 05 Build date,2006 E90 330i, Sport Package, Premium Package, TR MT-1's . V-1 Hard-wired power with custom V-1 Concealment Display . Rear fogs, Rear power outlet's, M short shifter knob, BlackLines, BMW Strut tower bar, CDV Delete, M3 wishbones + tension struts, BMW Performance shocks and springs, BMW Performance Brake kit F&R, OEM short shift kit.
198K miles.
Appreciate 0
      10-11-2011, 11:33 PM   #30
prelude2perfect
Lieutenant
17
Rep
528
Posts

Drives: 2007 335i Sedan
Join Date: Apr 2010
Location: Tacoma

iTrader: (8)

Took it apart again and this time removed the led cover with my new mini torx set. Cleaned everything again with alcohol and even polished the optical disc with meguirers plastix. Still not working. I studied both sides of the board as well and didn't notice any bad connections on the board.

Maybe this isn't my problem? Or maybe I'm just unlucky and have to buy a new one?

I don't have a navigation screen so I don't know what faults I'm getting but, my abs light and red brake light are on and my traction control is off. My cruise control, abs, headlight tracking, and start off assist don't work.
__________________


'07 E90 MT Sports Package l RB Turbos l JB4 G5 with Race Backend Flashl AA CP, BOV, and IC l Modified Injen DCI l Raceland 2.5" DP's l M2 Dual 2.75" Exhaust l
Appreciate 0
      10-11-2011, 11:38 PM   #31
aakrusen
To Punish and Enslave
aakrusen's Avatar
9
Rep
207
Posts

Drives: with both hands on the wheel
Join Date: Jul 2008
Location: Under the hood

iTrader: (2)

Garage List
2012 X5  [4.50]
Based on your symptoms, it sounds like you're in the right area. I had the same symptoms as you but after cleaning the disc everything was fine for me. I think you're right in that you're probably just unlucky enough so you'll have to buy a new unit.
Appreciate 0
      10-12-2011, 08:07 AM   #32
Richwm
Captain
Richwm's Avatar
United_States
18
Rep
876
Posts

Drives: 06 E90 330i 6MT, 01 E46 330i
Join Date: May 2006
Location: Canyon Country, CA.

iTrader: (0)

Garage List
Quote:
Originally Posted by Richwm View Post
I tried cleaning it and now its faulted all of the time. I have CC-ID faults 24,50,354, and 35. I tried using my BT to Calibrate the steering angle sensor and clear the faults but they keep coming back. It doesn't seem like the steering angle Cal is working. I wonder if the dealer tool will work better.

So after taking my car to the dealer and having them do the SAS Cal and clearing the faults my car is now fixed. It wasn't a $.02 fix for me but $120 is a lot better than $1300 to replace it. Oh and the BT tool can not do the Cal or clear steering angle plosibility faults I tried many times and it would not work and the dealership had no issues.

__________________
Mar 05 Build date,2006 E90 330i, Sport Package, Premium Package, TR MT-1's . V-1 Hard-wired power with custom V-1 Concealment Display . Rear fogs, Rear power outlet's, M short shifter knob, BlackLines, BMW Strut tower bar, CDV Delete, M3 wishbones + tension struts, BMW Performance shocks and springs, BMW Performance Brake kit F&R, OEM short shift kit.
198K miles.
Appreciate 0
      10-12-2011, 08:43 AM   #33
aakrusen
To Punish and Enslave
aakrusen's Avatar
9
Rep
207
Posts

Drives: with both hands on the wheel
Join Date: Jul 2008
Location: Under the hood

iTrader: (2)

Garage List
2012 X5  [4.50]
Quote:
Originally Posted by Richwm View Post
Oh and the BT tool can not do the Cal or clear steering angle plosibility faults I tried many times and it would not work and the dealership had no issues.

Wow, that's good to know. Hopefully there's a thread somewhere where we can "sticky" that because I almost bought the BT just in case I had to clear any codes related to my SAS.
Appreciate 0
      10-13-2011, 04:18 PM   #34
prelude2perfect
Lieutenant
17
Rep
528
Posts

Drives: 2007 335i Sedan
Join Date: Apr 2010
Location: Tacoma

iTrader: (8)

Quote:
Originally Posted by Richwm View Post
So after taking my car to the dealer and having them do the SAS Cal and clearing the faults my car is now fixed. It wasn't a $.02 fix for me but $120 is a lot better than $1300 to replace it. Oh and the BT tool can not do the Cal or clear steering angle plosibility faults I tried many times and it would not work and the dealership had no issues.

Maybe that would work for me?
__________________


'07 E90 MT Sports Package l RB Turbos l JB4 G5 with Race Backend Flashl AA CP, BOV, and IC l Modified Injen DCI l Raceland 2.5" DP's l M2 Dual 2.75" Exhaust l
Appreciate 0
      10-13-2011, 05:35 PM   #35
Richwm
Captain
Richwm's Avatar
United_States
18
Rep
876
Posts

Drives: 06 E90 330i 6MT, 01 E46 330i
Join Date: May 2006
Location: Canyon Country, CA.

iTrader: (0)

Garage List
Quote:
Originally Posted by prelude2perfect View Post
Maybe that would work for me?
I think it would be worth a try $120 is a lot better than having to buy a new SAS.
__________________
Mar 05 Build date,2006 E90 330i, Sport Package, Premium Package, TR MT-1's . V-1 Hard-wired power with custom V-1 Concealment Display . Rear fogs, Rear power outlet's, M short shifter knob, BlackLines, BMW Strut tower bar, CDV Delete, M3 wishbones + tension struts, BMW Performance shocks and springs, BMW Performance Brake kit F&R, OEM short shift kit.
198K miles.
Appreciate 0
      12-12-2011, 10:32 PM   #36
NiVeDh
Major General
NiVeDh's Avatar
United_States
189
Rep
8,017
Posts

Drives: '08 E90 335i, '99 E36 M3
Join Date: Apr 2009
Location: Houston, TX & Atlanta, GA

iTrader: (132)

Garage List
Good info here.
Appreciate 0
      12-28-2011, 12:24 PM   #37
OfficialBOLO
Captain
OfficialBOLO's Avatar
Russian Federation
17
Rep
735
Posts

Drives: 2013 F30 335i X-Drive MSport
Join Date: Sep 2010
Location: Brooklyn

iTrader: (3)

Garage List
I had to change my steering column module recently and all 3 of these lights popped up. This is a great DIY, however based on the info that others provided it seems that I would need a BMW tech to code the new module to the car.

Anyone know if that is the case for all new modules?
__________________
2013 F30 335i X-Drive / AW / CR / MSPORT / PREMIUM / TECH / HK / Heated Seats / Sport Auto / PDC / M Performance Grills and Spoiler / 20% tint
Appreciate 0
      01-02-2012, 01:14 PM   #38
yikes98
New Member
United_States
13
Rep
26
Posts

Drives: 11' E70 & E90,07' E92,96' E36
Join Date: Jan 2008
Location: SoCal

iTrader: (0)

Quote:
Originally Posted by BkNy3 View Post
I had to change my steering column module recently and all 3 of these lights popped up. This is a great DIY, however based on the info that others provided it seems that I would need a BMW tech to code the new module to the car.

Anyone know if that is the case for all new modules?
Yes, if the module is not the original one from the vehicle.

"Signal Flow
The acquired and calculated data of the steering column switch cluster are mainly transferred via the F-CAN to the corresponding control units.
The information for diagnosis is therefore also transferred via the F-CAN to the DSC. The DSC establishes the communication interface with the BMW diagnosis system.
The steering column switch cluster cannot be addressed directly via the BMW diagnosis system.
The DSC must be encoded after replacing the steering column switch cluster. The DSC transfers the coding to the steering column switch cluster."
Appreciate 0
      03-16-2012, 12:05 AM   #39
derick1981
Registered
0
Rep
3
Posts

Drives: 2008 328i Coupe Sport Premium
Join Date: Mar 2012
Location: Los Angeles, CA

iTrader: (0)

First off What a great post! I was looking at the cost of this repair and was blown away. I thought I would go ahead and give this a shot. Although your tutorial is done very well, I am not sure how you did the soldering. Also what part needs to be cleaned? The sensor? The Led? What do you use to clean them? Would you be so kind to help us out with some pics or video. Again, ingenious post. I really hope this helps me out. Thanks again,

Last edited by derick1981; 03-16-2012 at 12:25 AM. Reason: adding text
Appreciate 0
      03-24-2012, 03:51 PM   #40
stbradle
Enlisted Member
stbradle's Avatar
2
Rep
40
Posts

Drives: 2007 328xi Coupe
Join Date: Jun 2011
Location: Boston Area

iTrader: (0)

Quote:
Originally Posted by derick1981 View Post
First off What a great post! I was looking at the cost of this repair and was blown away. I thought I would go ahead and give this a shot. Although your tutorial is done very well, I am not sure how you did the soldering. Also what part needs to be cleaned? The sensor? The Led? What do you use to clean them? Would you be so kind to help us out with some pics or video. Again, ingenious post. I really hope this helps me out. Thanks again,
Try reading the full post again, all your questions are answered within.

I actually have had this problem for about 7 months and am now planning on taking this project on. I will update when I get to it...
__________________
"For whoever calls upon the name of the Lord shall be saved.'' Roman 10:13
Appreciate 0
      03-25-2012, 11:07 PM   #41
prelude2perfect
Lieutenant
17
Rep
528
Posts

Drives: 2007 335i Sedan
Join Date: Apr 2010
Location: Tacoma

iTrader: (8)

Cleanded mine twice and it didn't fix my problems. I had brake light. traction control, and SES lights. My tracking headlights wouldn't track, cruise control wouldn't work, traction control was disabled, and start off assist wouldnt work.

When I driving the car once I hit about 20 mph the computer would reset everything and then it would come right back. It also reclears the codes randomly when driving and they always came right back.

Took it into bmw and they found it was a dirty speed sensor. All they did was cleaned it off and everything works great now. Been about 1000 miles with no issues. They didn't even charge me for the cleaning.

So if this great writeup doesn't work for your problem I would consider cleaning the speed sensors
__________________


'07 E90 MT Sports Package l RB Turbos l JB4 G5 with Race Backend Flashl AA CP, BOV, and IC l Modified Injen DCI l Raceland 2.5" DP's l M2 Dual 2.75" Exhaust l
Appreciate 0
      03-25-2012, 11:18 PM   #42
derick1981
Registered
0
Rep
3
Posts

Drives: 2008 328i Coupe Sport Premium
Join Date: Mar 2012
Location: Los Angeles, CA

iTrader: (0)

I followed this and did the cleaning to the sensor and reassembled the steering wheel. This did not help with my car. I took it apart again and this time I took a heat gun to the circuit board just like a PS3 Yellow light of death. It worked! Has been a week now with no DSC, DTC, or start off assistance light. Wooo hoooo. Thank you for this write up.
Appreciate 0
      03-29-2012, 10:32 PM   #43
Maconperformance
New Member
2
Rep
26
Posts

Drives: 2006 325i
Join Date: Mar 2012
Location: Macon, GA

iTrader: (0)

OK - I have this and got up the nerve to tackle it and could not get the air bag released... I tried different size allen wrenches, could not find a spring release for it anywhere. Maybe i'm mechanically challenged? Is anyone located in GA that might could help me or direct me to someone close... I would love to have my cruise control working again along with the dash free of lights... Thank you in advance!
Appreciate 0
      03-29-2012, 10:50 PM   #44
derick1981
Registered
0
Rep
3
Posts

Drives: 2008 328i Coupe Sport Premium
Join Date: Mar 2012
Location: Los Angeles, CA

iTrader: (0)

Quote:
Originally Posted by Maconperformance View Post
OK - I have this and got up the nerve to tackle it and could not get the air bag released... I tried different size allen wrenches, could not find a spring release for it anywhere. Maybe i'm mechanically challenged? Is anyone located in GA that might could help me or direct me to someone close... I would love to have my cruise control working again along with the dash free of lights... Thank you in advance!
Hey man, you have to poke through the leather on the back I'd the steering wheel. You have to feel around to find the hole, and then ouch! Poke your baby. Once you are in get a decent sized screwdriver and push right toward the BMW logo on the wheel keeping the handle close the the wheel itself. Meaning there is no angle from the front of the car to the rear. Straight up. Hope that helps you.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 05:40 AM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST