E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Rough Idle, stumbling rpms



Reply
 
Thread Tools Search this Thread
      03-23-2012, 12:47 PM   #155
PR3CI5N
need4speed
 
PR3CI5N's Avatar
 
Drives: 2010 E90 M 335i
Join Date: Jun 2010
Location: West Coast

Posts: 1,216
iTrader: (15)

What about the oxygen sensors? When my 07' used to act funny at idle and driving, it was usually due to bad oxygen sensors. Had the same problem twice.
__________________
N54
PR3CI5N is offline   United_States
0
Reply With Quote
      03-24-2012, 04:49 AM   #156
Norcal_335i
First Lieutenant
 
Drives: 2008 E92 335i
Join Date: Aug 2010
Location: Roseville, CA

Posts: 321
iTrader: (4)

Clean TMAP/ MAP sensors with mass flow cleaner. Fixed my problem!!
Norcal_335i is offline   United_States
0
Reply With Quote
      03-24-2012, 11:09 AM   #157
robc1976
DIYER
 
robc1976's Avatar
 
Drives: E90 335i
Join Date: Mar 2012
Location: Illinois

Posts: 4,502
iTrader: (11)

Quote:
Originally Posted by Norcal_335i View Post
Clean TMAP/ MAP sensors with mass flow cleaner. Fixed my problem!!
Man, I feel like a a idiot now...I had my map sensor off of my charge pipe the other day lol! Makes sense though great idea!!!

Last edited by robc1976; 03-24-2012 at 11:10 AM. Reason: Spelling
robc1976 is online now  
0
Reply With Quote
      03-24-2012, 10:42 PM   #158
Norcal_335i
First Lieutenant
 
Drives: 2008 E92 335i
Join Date: Aug 2010
Location: Roseville, CA

Posts: 321
iTrader: (4)

Quote:
Originally Posted by robc1976 View Post
Man, I feel like a a idiot now...I had my map sensor off of my charge pipe the other day lol! Makes sense though great idea!!!
I know its a pain in the ass to take eveything off to get to it again.
Norcal_335i is offline   United_States
0
Reply With Quote
      03-25-2012, 12:40 AM   #159
robc1976
DIYER
 
robc1976's Avatar
 
Drives: E90 335i
Join Date: Mar 2012
Location: Illinois

Posts: 4,502
iTrader: (11)

Quote:
Originally Posted by Norcal_335i View Post
I know its a pain in the ass to take eveything off to get to it again.
Mine is actually easy, I have no intake box or diverter valve hoses...I have DCI and a CPE BOV kit so it is right there. My car is hitting 15 PSI so I do not think My MAF sensor is messed up but I am going to clean it anyway though. Next on the list is the intake valve cleaning LOL!! I think I have a slight exaust leak (Running JB4 map 2 and has a bit of gas/exaust smell) but I am installing AR Dps in 2 weeks or so so I will see! I know when running map 2 you should hae a FMIC and DPS I am getting a ER FMIC & AR DPS, map 2 is so much better than map 5 LOL!!
robc1976 is online now  
0
Reply With Quote
      04-07-2012, 11:09 PM   #160
Frosty
Lieutenant Colonel
 
Frosty's Avatar
 
Drives: Ordered my E92 (7/10/06)
Join Date: May 2006
Location: Northern NJ

Posts: 1,908
iTrader: (0)

...for the record i have the same rough idle situation, changed my plugs a week ago ~
__________________
.................................................. ....................
335i Coupe (6MT) (2007: 9/06 build, pre ordered, only owner): Space Grey / Black Leatherette / Grey Poplar trim / ZCW / ZSP / BMW assist w/ bluetooth / power rear shade / navi with iDrive / comfort access keyless entry /+homelink mirror/ 154,885+miles (Nov-12-2013)
.................................................. ......................
Frosty is offline  
0
Reply With Quote
      04-07-2012, 11:24 PM   #161
robc1976
DIYER
 
robc1976's Avatar
 
Drives: E90 335i
Join Date: Mar 2012
Location: Illinois

Posts: 4,502
iTrader: (11)

Quote:
Originally Posted by Frosty View Post
...for the record i have the same rough idle situation, changed my plugs a week ago ~
I have to , I went to change the plugs and one of the cylinders had gasoline on the plug, all other cylinders where dry and perfect. I have a leaking fuel injector and I hope this is the problem with the idle. I have to say though that I installed the catless ar Dps and the stumble has seemed to go away.

Here is pics of the plugs, notice the odd ball lol! I am sure it is not firing.

http://img37.imageshack.us/img37/4311/1333858970066.jpg
robc1976 is online now  
0
Reply With Quote
      04-08-2012, 11:58 AM   #162
Schnitzel
Private First Class
 
Drives: E92 335i MT
Join Date: Mar 2009
Location: Bavaria

Posts: 147
iTrader: (0)

Quote:
Originally Posted by Frosty View Post
...for the record i have the same rough idle situation, changed my plugs a week ago ~
Me too. Replaced my plugs two weeks ago and since then my idle speed is approx. 200rpm higher (800 instead of 600) as soon as the engine/oil is warm.
__________________
Schnitzel is offline   Germany
0
Reply With Quote
      04-08-2012, 08:46 PM   #163
Frosty
Lieutenant Colonel
 
Frosty's Avatar
 
Drives: Ordered my E92 (7/10/06)
Join Date: May 2006
Location: Northern NJ

Posts: 1,908
iTrader: (0)

Quote:
Originally Posted by robc1976 View Post
I have to , I went to change the plugs and one of the cylinders had gasoline on the plug, all other cylinders where dry and perfect. I have a leaking fuel injector and I hope this is the problem with the idle. I have to say though that I installed the catless ar Dps and the stumble has seemed to go away.

Here is pics of the plugs, notice the odd ball lol! I am sure it is not firing.

http://img37.imageshack.us/img37/4311/1333858970066.jpg
I had one that was black as well.... rest a light grey... do you feel the blackened appearance on the plug is due to a leaky FI?

~Frost
__________________
.................................................. ....................
335i Coupe (6MT) (2007: 9/06 build, pre ordered, only owner): Space Grey / Black Leatherette / Grey Poplar trim / ZCW / ZSP / BMW assist w/ bluetooth / power rear shade / navi with iDrive / comfort access keyless entry /+homelink mirror/ 154,885+miles (Nov-12-2013)
.................................................. ......................
Frosty is offline  
0
Reply With Quote
      04-08-2012, 11:58 PM   #164
robc1976
DIYER
 
robc1976's Avatar
 
Drives: E90 335i
Join Date: Mar 2012
Location: Illinois

Posts: 4,502
iTrader: (11)

Quote:
Originally Posted by Frosty View Post
I had one that was black as well.... rest a light grey... do you feel the blackened appearance on the plug is due to a leaky FI?

~Frost
I am pretty sure it is, if you leave the car sit over night is that back plug wet wih gas? Mine was wet with gas when it sat overnight witch points at a leaking fuel injector. I even switched the coil that was on The plug with the wet plug & it did not transfer witch shows it was not the coil, also switched out the plug and it still got wet with gas. I have a appointment Tuesday with my dealer to get the fuel injector fixed and will update this thread.
robc1976 is online now  
0
Reply With Quote
      04-09-2012, 10:58 AM   #165
Frosty
Lieutenant Colonel
 
Frosty's Avatar
 
Drives: Ordered my E92 (7/10/06)
Join Date: May 2006
Location: Northern NJ

Posts: 1,908
iTrader: (0)

Quote:
Originally Posted by robc1976 View Post
I am pretty sure it is, if you leave the car sit over night is that back plug wet wih gas? Mine was wet with gas when it sat overnight witch points at a leaking fuel injector. I even switched the coil that was on The plug with the wet plug & it did not transfer witch shows it was not the coil, also switched out the plug and it still got wet with gas. I have a appointment Tuesday with my dealer to get the fuel injector fixed and will update this thread.
thanks for the update, would love to hear the results ~Frost
__________________
.................................................. ....................
335i Coupe (6MT) (2007: 9/06 build, pre ordered, only owner): Space Grey / Black Leatherette / Grey Poplar trim / ZCW / ZSP / BMW assist w/ bluetooth / power rear shade / navi with iDrive / comfort access keyless entry /+homelink mirror/ 154,885+miles (Nov-12-2013)
.................................................. ......................
Frosty is offline  
0
Reply With Quote
      04-09-2012, 04:41 PM   #166
robc1976
DIYER
 
robc1976's Avatar
 
Drives: E90 335i
Join Date: Mar 2012
Location: Illinois

Posts: 4,502
iTrader: (11)

Quote:
Originally Posted by Frosty View Post
thanks for the update, would love to hear the results ~Frost
If for some reason the injector does not cure the problem, I am also cleaning my intake valves after so we will find out what it is. I am not having the dealer do it because I want to know what is causing this idle issue and if you have 2 things done at the same ime you may cure the problem but you will not know what caused it and that does not help anyone.

Will update he thread at about noon tomorrow....also installing a ER FMIC tommorow, can't wait!
robc1976 is online now  
0
Reply With Quote
      04-10-2012, 02:03 PM   #167
Frosty
Lieutenant Colonel
 
Frosty's Avatar
 
Drives: Ordered my E92 (7/10/06)
Join Date: May 2006
Location: Northern NJ

Posts: 1,908
iTrader: (0)

Quote:
Originally Posted by robc1976 View Post
If for some reason the injector does not cure the problem, I am also cleaning my intake valves after so we will find out what it is. I am not having the dealer do it because I want to know what is causing this idle issue and if you have 2 things done at the same ime you may cure the problem but you will not know what caused it and that does not help anyone.

Will update he thread at about noon tomorrow....also installing a ER FMIC tommorow, can't wait!
.. interesting it's not the FI... I have seen some who replaced their throttle body, and others that cleaned the TMAP sensor to cure their roumble / rough idle... fwiw

~Frost
__________________
.................................................. ....................
335i Coupe (6MT) (2007: 9/06 build, pre ordered, only owner): Space Grey / Black Leatherette / Grey Poplar trim / ZCW / ZSP / BMW assist w/ bluetooth / power rear shade / navi with iDrive / comfort access keyless entry /+homelink mirror/ 154,885+miles (Nov-12-2013)
.................................................. ......................
Frosty is offline  
0
Reply With Quote
      04-10-2012, 02:42 PM   #168
robc1976
DIYER
 
robc1976's Avatar
 
Drives: E90 335i
Join Date: Mar 2012
Location: Illinois

Posts: 4,502
iTrader: (11)

Quote:
Originally Posted by Frosty View Post
.. interesting it's not the FI... I have seen some who replaced their throttle body, and others that cleaned the TMAP sensor to cure their roumble / rough idle... fwiw

~Frost
My car is getting fixed Thursday instead ' I have a new map and throttle body lol! I hope it I'd the injector!!
__________________
JB4 G5, WEDGE flash, 455 LPFP, HFS-4 meth kit, BMS OCC, Motiv 750 ST, RB valve, BMS DCI, 3" AR Dps, Custom OC W/ SS lines, ER FMIC, ER CP W/HKS BOV, M3 control arms, M3 guide rods, M3 upper links, M3 front & rear sway-bars, HPA rear toe arms, Wavetrac LSD, HPF Gen 2 exhaust DEFIV kit, KW clubsport, Power-Flex subframe bushings, stoptech rotors, Rogue Tranny Mounts, 1M bumper, M3 CF hood, MORR VS8.2 rims 245/295
robc1976 is online now  
0
Reply With Quote
      04-12-2012, 11:54 PM   #169
robc1976
DIYER
 
robc1976's Avatar
 
Drives: E90 335i
Join Date: Mar 2012
Location: Illinois

Posts: 4,502
iTrader: (11)

Quote:
Originally Posted by Frosty View Post
thanks for the update, would love to hear the results ~Frost
Idle is perfect!! I had a stuck open injector and they replaced it and it purrs like a kitten....well......growl like a tiger gas smell is gone, stumble/jolt in idle is gone, stumbling/ long start with sputtering is gone, slight rattle after starting is gone (thought it was the waste gates). Horse power is crazy now instead of falling on its face.

Hope ths helps!! It didn't help the 5.0 mustang I schooled lol!!
__________________
JB4 G5, WEDGE flash, 455 LPFP, HFS-4 meth kit, BMS OCC, Motiv 750 ST, RB valve, BMS DCI, 3" AR Dps, Custom OC W/ SS lines, ER FMIC, ER CP W/HKS BOV, M3 control arms, M3 guide rods, M3 upper links, M3 front & rear sway-bars, HPA rear toe arms, Wavetrac LSD, HPF Gen 2 exhaust DEFIV kit, KW clubsport, Power-Flex subframe bushings, stoptech rotors, Rogue Tranny Mounts, 1M bumper, M3 CF hood, MORR VS8.2 rims 245/295
robc1976 is online now  
0
Reply With Quote
      04-12-2012, 11:58 PM   #170
robc1976
DIYER
 
robc1976's Avatar
 
Drives: E90 335i
Join Date: Mar 2012
Location: Illinois

Posts: 4,502
iTrader: (11)

Quote:
Originally Posted by Frosty View Post
.. interesting it's not the FI... I have seen some who replaced their throttle body, and others that cleaned the TMAP sensor to cure their roumble / rough idle... fwiw

~Frost
I would let your car sit overnight and Check your plugs, if you see any that are Black wet snap a pic to show the dealer....worked for me.....my after-market warranty covered it. One replaced injector is $549.00 to replace. Pretty pricey!!!
__________________
JB4 G5, WEDGE flash, 455 LPFP, HFS-4 meth kit, BMS OCC, Motiv 750 ST, RB valve, BMS DCI, 3" AR Dps, Custom OC W/ SS lines, ER FMIC, ER CP W/HKS BOV, M3 control arms, M3 guide rods, M3 upper links, M3 front & rear sway-bars, HPA rear toe arms, Wavetrac LSD, HPF Gen 2 exhaust DEFIV kit, KW clubsport, Power-Flex subframe bushings, stoptech rotors, Rogue Tranny Mounts, 1M bumper, M3 CF hood, MORR VS8.2 rims 245/295
robc1976 is online now  
0
Reply With Quote
      04-13-2012, 12:10 PM   #171
AWD Addict
Chief Executive
 
AWD Addict's Avatar
 
Drives: 2008 335xi 6spd Coupe
Join Date: Dec 2007
Location: Boston

Posts: 2,483
iTrader: (1)

Garage List
2008 335xi  [0.00]
My warranty is about up, so I had an independent shop do a full rubber glove treatment on the car to find any lingering warranty issues that I may want resolved prior to expiration.

I did mention the stumble issue, and he said he'd brainstorm a bit during the rest of the inspection on that.

Long story short, he smoke tested my engine, and found leaks at the intake tract at the boot and air valve. He reccomended replacing the boot, tract and valves.

BMW is working on it today. I could understand why a vacuum leak would cause irregular idling, so I'm keeping my fingers crossed!
AWD Addict is offline  
0
Reply With Quote
      04-14-2012, 02:10 PM   #172
Frosty
Lieutenant Colonel
 
Frosty's Avatar
 
Drives: Ordered my E92 (7/10/06)
Join Date: May 2006
Location: Northern NJ

Posts: 1,908
iTrader: (0)

Quote:
Originally Posted by robc1976 View Post
I would let your car sit overnight and Check your plugs, if you see any that are Black wet snap a pic to show the dealer....worked for me.....my after-market warranty covered it. One replaced injector is $549.00 to replace. Pretty pricey!!!
..I'm over warranty sadly... I did the plugs myself and when I took them out after leaving the car sit overnight the tips were dry, but cylinder 1 was black compared to an expected ashen grey...

~Frost
__________________
.................................................. ....................
335i Coupe (6MT) (2007: 9/06 build, pre ordered, only owner): Space Grey / Black Leatherette / Grey Poplar trim / ZCW / ZSP / BMW assist w/ bluetooth / power rear shade / navi with iDrive / comfort access keyless entry /+homelink mirror/ 154,885+miles (Nov-12-2013)
.................................................. ......................
Frosty is offline  
0
Reply With Quote
      04-14-2012, 02:12 PM   #173
Frosty
Lieutenant Colonel
 
Frosty's Avatar
 
Drives: Ordered my E92 (7/10/06)
Join Date: May 2006
Location: Northern NJ

Posts: 1,908
iTrader: (0)

Quote:
Originally Posted by robc1976 View Post
Idle is perfect!! I had a stuck open injector and they replaced it and it purrs like a kitten....well......growl like a tiger gas smell is gone, stumble/jolt in idle is gone, stumbling/ long start with sputtering is gone, slight rattle after starting is gone (thought it was the waste gates). Horse power is crazy now instead of falling on its face.

Hope ths helps!! It didn't help the 5.0 mustang I schooled lol!!
Fanfreaking tastic!! Happy to hear ROb! My car seems to be adapting if thats possible... going to pull codes, it still is rocky but a bit less so...(at idle)

~Frost
__________________
.................................................. ....................
335i Coupe (6MT) (2007: 9/06 build, pre ordered, only owner): Space Grey / Black Leatherette / Grey Poplar trim / ZCW / ZSP / BMW assist w/ bluetooth / power rear shade / navi with iDrive / comfort access keyless entry /+homelink mirror/ 154,885+miles (Nov-12-2013)
.................................................. ......................
Frosty is offline  
0
Reply With Quote
      04-14-2012, 02:13 PM   #174
robc1976
DIYER
 
robc1976's Avatar
 
Drives: E90 335i
Join Date: Mar 2012
Location: Illinois

Posts: 4,502
iTrader: (11)

Quote:
Originally Posted by Frosty View Post
..I'm over warranty sadly... I did the plugs myself and when I took them out after leaving the car sit overnight the tips were dry, but cylinder 1 was black compared to an expected ashen grey...

~Frost
I have a aftermarket warranty from Nissan and it was covered, that sounds like a injector to me! What year is your cars build date there was a injector recall! It us worth the $500.00 if not, really is!
__________________
JB4 G5, WEDGE flash, 455 LPFP, HFS-4 meth kit, BMS OCC, Motiv 750 ST, RB valve, BMS DCI, 3" AR Dps, Custom OC W/ SS lines, ER FMIC, ER CP W/HKS BOV, M3 control arms, M3 guide rods, M3 upper links, M3 front & rear sway-bars, HPA rear toe arms, Wavetrac LSD, HPF Gen 2 exhaust DEFIV kit, KW clubsport, Power-Flex subframe bushings, stoptech rotors, Rogue Tranny Mounts, 1M bumper, M3 CF hood, MORR VS8.2 rims 245/295
robc1976 is online now  
0
Reply With Quote
      04-14-2012, 02:17 PM   #175
robc1976
DIYER
 
robc1976's Avatar
 
Drives: E90 335i
Join Date: Mar 2012
Location: Illinois

Posts: 4,502
iTrader: (11)

Quote:
Originally Posted by Frosty View Post
Fanfreaking tastic!! Happy to hear ROb! My car seems to be adapting if thats possible... going to pull codes, it still is rocky but a bit less so...(at idle)

~Frost
I am going to clean the valves tonight and want to see what #2 port looks like. Unplugg your battery for 1-2 hrs and it will reset the adaptions.....I also do the throttle reset to, it does work.
__________________
JB4 G5, WEDGE flash, 455 LPFP, HFS-4 meth kit, BMS OCC, Motiv 750 ST, RB valve, BMS DCI, 3" AR Dps, Custom OC W/ SS lines, ER FMIC, ER CP W/HKS BOV, M3 control arms, M3 guide rods, M3 upper links, M3 front & rear sway-bars, HPA rear toe arms, Wavetrac LSD, HPF Gen 2 exhaust DEFIV kit, KW clubsport, Power-Flex subframe bushings, stoptech rotors, Rogue Tranny Mounts, 1M bumper, M3 CF hood, MORR VS8.2 rims 245/295
robc1976 is online now  
0
Reply With Quote
      04-14-2012, 02:39 PM   #176
Frosty
Lieutenant Colonel
 
Frosty's Avatar
 
Drives: Ordered my E92 (7/10/06)
Join Date: May 2006
Location: Northern NJ

Posts: 1,908
iTrader: (0)

Quote:
Originally Posted by robc1976 View Post
I have a aftermarket warranty from Nissan and it was covered, that sounds like a injector to me! What year is your cars build date there was a injector recall! It us worth the $500.00 if not, really is!
...blackened plug... that's indicative of a bad-acting FI?

My car (in sig) is at 128,000+ miles (all driven by me ha ha)

no warranty wants to touch me now

~Frost
__________________
.................................................. ....................
335i Coupe (6MT) (2007: 9/06 build, pre ordered, only owner): Space Grey / Black Leatherette / Grey Poplar trim / ZCW / ZSP / BMW assist w/ bluetooth / power rear shade / navi with iDrive / comfort access keyless entry /+homelink mirror/ 154,885+miles (Nov-12-2013)
.................................................. ......................
Frosty is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:06 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST