E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > Issues w/ brakes and car ecu?



Reply
 
Thread Tools Search this Thread
      04-13-2012, 06:42 PM   #1
DR_E92
Lieutenant
 
Drives: 07 E92 Coupe
Join Date: Jan 2009
Location: North Jersey

Posts: 506
iTrader: (1)

Issues w/ brakes and car ecu?

Took my car into service for some regular stuff and my brake light goes on that morning. They service it, said its fine, the brake sensors were replaces because the brakes were measured and are still good.
3 days later... the brake light comes back on. Take it to another dealer and they say that the brakes and sensors are fine, the car's computer is reading that the brakes have over 200k miles on them and they need to reprogram it which is an hour and a half of labor.

Any idea of how I can resolve this before letting them charge me $150 for this? I tried resetting it with the BT tool but couldn't find anything there to help me out. Any advice is appreciated.

Rob
__________________
and go nuts
DR_E92 is offline   Dominican Republic
0
Reply With Quote
      04-13-2012, 07:33 PM   #2
Bavarian Tech
Captain
 
Drives: 335i
Join Date: Jan 2007
Location: Pittsburgh/Harrisburg

Posts: 653
iTrader: (10)

Garage List
2006 330i  [5.00]
Skip the BT scan tool, and do it the old fashion way

__________________
335i Sport Sedan: 6Speed: Sport :Prem : CIC Swap : M3 Cluster
Bavarian Tech is offline  
0
Reply With Quote
      04-14-2012, 03:58 AM   #3
crypticc
Captain
 
Drives: e92 M3 DCT + Comp
Join Date: Dec 2011
Location: London, UK

Posts: 609
iTrader: (0)

Quote:
Originally Posted by DR_E92
Took my car into service for some regular stuff and my brake light goes on that morning. They service it, said its fine, the brake sensors were replaces because the brakes were measured and are still good.
3 days later... the brake light comes back on. Take it to another dealer and they say that the brakes and sensors are fine, the car's computer is reading that the brakes have over 200k miles on them and they need to reprogram it which is an hour and a half of labor.

Any idea of how I can resolve this before letting them charge me $150 for this? I tried resetting it with the BT tool but couldn't find anything there to help me out. Any advice is appreciated.

Rob
I wonder if there's a known issue..when I first for my car new, 2007, after one month it said minus 9000 miles and I've been getting them to reset it every year or so since. I still have over ten k miles left.
crypticc is offline   United Kingdom
0
Reply With Quote
      04-14-2012, 01:41 PM   #4
DR_E92
Lieutenant
 
Drives: 07 E92 Coupe
Join Date: Jan 2009
Location: North Jersey

Posts: 506
iTrader: (1)

Im out of warranty now so dealer wont reset it for me
__________________
and go nuts
DR_E92 is offline   Dominican Republic
0
Reply With Quote
      04-14-2012, 10:25 PM   #5
chisss
Private
 
Drives: 2007 335i
Join Date: Oct 2011
Location: CT

Posts: 65
iTrader: (2)

I'm having the same issue but I changed my brakes and sensors about 3K miles ago, Reset the service through the Dash and it was fine until 2 days ago where it's telling me I have to replace all 4 wheels again.

Now mind you last time I got the change brakes it was all 4 wheels again and when I went to replace them the brakes were completely fine but I changed it anyway. Any clues? does anyone know if this is covered under the CPO warranty?
chisss is offline  
0
Reply With Quote
      04-15-2012, 11:06 AM   #6
DR_E92
Lieutenant
 
Drives: 07 E92 Coupe
Join Date: Jan 2009
Location: North Jersey

Posts: 506
iTrader: (1)

Yea those are your brake sensors. CPO covers it
__________________
and go nuts
DR_E92 is offline   Dominican Republic
0
Reply With Quote
      04-15-2012, 11:07 AM   #7
DR_E92
Lieutenant
 
Drives: 07 E92 Coupe
Join Date: Jan 2009
Location: North Jersey

Posts: 506
iTrader: (1)

Msbc721

I tried the youtube video and it worked. Thanks a lot!
__________________
and go nuts
DR_E92 is offline   Dominican Republic
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:58 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST