E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > LCI Taillight retrofit coding issue



Reply
 
Thread Tools Search this Thread
      04-01-2012, 01:07 PM   #1
Bunkei
Anti-Fanboy
 
Drives: 2008 BMW M3
Join Date: Apr 2008
Location: Burien, WA

Posts: 486
iTrader: (0)

Send a message via AIM to Bunkei Send a message via MSN to Bunkei Send a message via Skype™ to Bunkei
LCI Taillight retrofit coding issue

Hi there,

There's a E92 335 owner and myself that have ran into a weird error. I've searched all over the board (and others too) and haven't found any leads. The story is this: I got my car retrofitted yesterday with the LCI Taillight retrofit that I bought from EAS (the lights are great by the way).

I had a coder follow the instructions located in the other thread to disable the bulb checks. Now, when the car starts up, there are no errors. However, as soon as I put the car in gear, there's a "rear right taillamp malfunction" error that comes on, and does not go away.

Has anyone heard of this issue, and if so, know the solution or perhaps point us to someone who may be able to help?

Thanks!

~Ben
Bunkei is offline  
0
Reply With Quote
      04-01-2012, 04:47 PM   #2
Dziqsek_
Banned
 
Drives: e91 320d
Join Date: Feb 2012
Location: Jelenia Gora ( Lower Silesia )

Posts: 413
iTrader: (0)

I assume you do only Cold Check, not Warmcheck thats why your error pops up
Dziqsek_ is offline   Poland
0
Reply With Quote
      04-01-2012, 07:19 PM   #3
Bunkei
Anti-Fanboy
 
Drives: 2008 BMW M3
Join Date: Apr 2008
Location: Burien, WA

Posts: 486
iTrader: (0)

Send a message via AIM to Bunkei Send a message via MSN to Bunkei Send a message via Skype™ to Bunkei
Quote:
Originally Posted by *******_ View Post
I assume you do only Cold Check, not Warmcheck thats why your error pops up
We thought of that too since the error occurs only when the car is put into gear. I will doublecheck this coming weekend when my coder comes to visit. Can you take a look at the other thread and see if there are any warm checks that might be missing from the list?
Bunkei is offline  
0
Reply With Quote
      04-01-2012, 07:45 PM   #4
Dziqsek_
Banned
 
Drives: e91 320d
Join Date: Feb 2012
Location: Jelenia Gora ( Lower Silesia )

Posts: 413
iTrader: (0)

This is all functions you need to change to get rid of bulb errors :


Warm test Brake
WARMUEBERWACHUNG_BL_MI -> nicht_aktiv

Cold Test Brake
KALTUEBERWACHUNG_BL_MI -> nicht_aktiv

Warm test turn
WARMUEBERWACHUNG_BLK_HI -> nicht_aktiv

Cold test turn
KALTUEBERWACHUNG_BLK_HI -> nicht_aktiv

cold rear turn signal...
KALTUEBERWACHUNG_BLK_H -> nicht_aktiv

cold brake light.....
KALTUEBERWACHUNG_BL -> nicht_aktiv

warm rear turn signal...
WARMUEBERWACHUNG_BLK_H -> nicht_aktiv

warm brake light..
WARMUEBERWACHUNG_BL -> nicht_aktiv

Brake force display
CC_MELD_BFD_BL -> nicht_aktiv
FEHLERMELDUNG_CC_BFD_L -> nicht_aktiv
FEHLERMELDUNG_CC_BFD_R -> nicht_aktiv


[[Cold Test Brake Light]]
KALTUEBERWACHUNG_BL -> nicht_aktiv

[[Warm Test Blinker Rear]]
WARMUEBERWACHUNG_BLK_H -> nicht_aktiv

[[Warm Test Brake Light]]
WARMUEBERWACHUNG_BL -> nicht_aktiv

[[Cold Test Brake Force Display]]
KALTUEBERWACHUNG_BFD <--Cold BFD test

[[Warm Test Brake Force Display]]
WARMUEBERWACHUNG_BFD <--Warm BFD test

WARMUEBERWACHUNG_BLK_H


You may not have all features , they are from my nfrm but most of them should present in your module.

Greets from Poland
Dziqsek_ is offline   Poland
0
Reply With Quote
      04-01-2012, 08:26 PM   #5
Bunkei
Anti-Fanboy
 
Drives: 2008 BMW M3
Join Date: Apr 2008
Location: Burien, WA

Posts: 486
iTrader: (0)

Send a message via AIM to Bunkei Send a message via MSN to Bunkei Send a message via Skype™ to Bunkei
Quote:
Originally Posted by *******_ View Post
This is all functions you need to change to get rid of bulb errors :


Warm test Brake
WARMUEBERWACHUNG_BL_MI -> nicht_aktiv

Cold Test Brake
KALTUEBERWACHUNG_BL_MI -> nicht_aktiv

Warm test turn
WARMUEBERWACHUNG_BLK_HI -> nicht_aktiv

Cold test turn
KALTUEBERWACHUNG_BLK_HI -> nicht_aktiv

cold rear turn signal...
KALTUEBERWACHUNG_BLK_H -> nicht_aktiv

cold brake light.....
KALTUEBERWACHUNG_BL -> nicht_aktiv

warm rear turn signal...
WARMUEBERWACHUNG_BLK_H -> nicht_aktiv

warm brake light..
WARMUEBERWACHUNG_BL -> nicht_aktiv

Brake force display
CC_MELD_BFD_BL -> nicht_aktiv
FEHLERMELDUNG_CC_BFD_L -> nicht_aktiv
FEHLERMELDUNG_CC_BFD_R -> nicht_aktiv


[[Cold Test Brake Light]]
KALTUEBERWACHUNG_BL -> nicht_aktiv

[[Warm Test Blinker Rear]]
WARMUEBERWACHUNG_BLK_H -> nicht_aktiv

[[Warm Test Brake Light]]
WARMUEBERWACHUNG_BL -> nicht_aktiv

[[Cold Test Brake Force Display]]
KALTUEBERWACHUNG_BFD <--Cold BFD test

[[Warm Test Brake Force Display]]
WARMUEBERWACHUNG_BFD <--Warm BFD test

WARMUEBERWACHUNG_BLK_H


You may not have all features , they are from my nfrm but most of them should present in your module.

Greets from Poland
Thank you sooo much. We'll go through each one this coming weekend to make sure we didn't miss anything. Greets from Seattle!!

~Ben
Bunkei is offline  
0
Reply With Quote
      05-05-2012, 06:22 PM   #6
makkan00
Major General
 
makkan00's Avatar
 
Drives: E91 330D
Join Date: Dec 2011
Location: Essex

Posts: 6,787
iTrader: (47)

I have tried and entered most of these codes, but still signal indicator flashes very quickly.
Any suggestions?
__________________
makkan00 is offline   United Kingdom
0
Reply With Quote
      05-05-2012, 07:58 PM   #7
Dziqsek_
Banned
 
Drives: e91 320d
Join Date: Feb 2012
Location: Jelenia Gora ( Lower Silesia )

Posts: 413
iTrader: (0)

Quote:
Originally Posted by makkan00 View Post
I have tried and entered most of these codes, but still signal indicator flashes very quickly.
Any suggestions?

There is a command with led_blinker_hinte or something like that, change it to aktiv
Dziqsek_ is offline   Poland
0
Reply With Quote
      05-05-2012, 08:01 PM   #8
rafiq335i
Private First Class
 
Drives: 2008 BMW 335i Coupe
Join Date: Jan 2012
Location: San Diego, CA

Posts: 118
iTrader: (0)

Garage List
Try a warm check
__________________
'08 335i Coupe Stock Soon: Remus Quad Exhaust, CF Diffuser, CF Spoiler, LCI Tails
rafiq335i is offline  
0
Reply With Quote
      05-06-2012, 05:02 AM   #9
makkan00
Major General
 
makkan00's Avatar
 
Drives: E91 330D
Join Date: Dec 2011
Location: Essex

Posts: 6,787
iTrader: (47)

Quote:
Originally Posted by *******_ View Post
There is a command with led_blinker_hinte or something like that, change it to aktiv
It cannot be in English.
Can you kindly confirm what actually it is?

I changed all these values, and after finishing with programming, all values are reverting back to old values.

Coding works and I have done all other codings except this one.

Any suggestions?
__________________
makkan00 is offline   United Kingdom
0
Reply With Quote
      05-06-2012, 05:02 AM   #10
makkan00
Major General
 
makkan00's Avatar
 
Drives: E91 330D
Join Date: Dec 2011
Location: Essex

Posts: 6,787
iTrader: (47)

Quote:
Originally Posted by rafiq335i View Post
Try a warm check
Thanks mate, can you kindly explain what is it?

I have deactivated all cold and warm check but it still blinks fast.
__________________
makkan00 is offline   United Kingdom
0
Reply With Quote
      05-06-2012, 05:26 AM   #11
Dziqsek_
Banned
 
Drives: e91 320d
Join Date: Feb 2012
Location: Jelenia Gora ( Lower Silesia )

Posts: 413
iTrader: (0)

Quote:
Originally Posted by makkan00 View Post
It cannot be in English.
Can you kindly confirm what actually it is?

I changed all these values, and after finishing with programming, all values are reverting back to old values.

Coding works and I have done all other codings except this one.

Any suggestions?
Just checked in my frm2 and like i wrote before:

LED_BLINKER_HINTEN aktiv
Dziqsek_ is offline   Poland
0
Reply With Quote
      05-06-2012, 06:48 PM   #12
makkan00
Major General
 
makkan00's Avatar
 
Drives: E91 330D
Join Date: Dec 2011
Location: Essex

Posts: 6,787
iTrader: (47)

Quote:
Originally Posted by *******_ View Post
Just checked in my frm2 and like i wrote before:

LED_BLINKER_HINTEN aktiv
Thanks mate.

Can I confirm couple of things with you.
A) How do you know that you have FRM or FRMA (Frm2)? Is it on production date or can you find out from inpa or NCS expert?
B) considering you used NCS expert, you do followings
Load profile to expert mode
Press F1 and F3 --> select E89.
Now a windows pop up and gives you CAS, FRM, and FRMA options. I go for CAS option (well tried FRM and FRMA too but no success).
Then you select back.
then you click on ECU tab and select FRM.
Now you click on read ECU (frm in this case).
A windows pops out with many digits.
Now you head to 'Shortcut to my work' and go for FSW_PSW and save it as FSW_PSW.MAN and edit all those things which you mentioned above.

Once done you go back to NCS expert and click on basic functions.
Select 'CoapiReadSgGetFswPsw' and ok.
A small window pops out saying 'basic function perfect ended'.
Press OK.
now change job type to 'SG_CODIEREN and press ok.
Execute job and once coding finished, I check the indicator and it is still flashing fast.


Sorry to put all this here, but just wants to know if I am doing anything wrong.

Despite of trying 20-30 times, no luck.

Any suggestions?
__________________
makkan00 is offline   United Kingdom
0
Reply With Quote
      05-06-2012, 07:43 PM   #13
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: 917-939-4980
Join Date: Jun 2007
Location: New York

Posts: 18,266
iTrader: (5)

Send a message via Yahoo to cn555ic
Quote:
Originally Posted by makkan00 View Post
Thanks mate.

Can I confirm couple of things with you.
A) How do you know that you have FRM or FRMA (Frm2)? Is it on production date or can you find out from inpa or NCS expert?
B) considering you used NCS expert, you do followings
Load profile to expert mode
Press F1 and F3 --> select E89.
Now a windows pop up and gives you CAS, FRM, and FRMA options. I go for CAS option (well tried FRM and FRMA too but no success).
Then you select back.
then you click on ECU tab and select FRM.
Now you click on read ECU (frm in this case).
A windows pops out with many digits.
Now you head to 'Shortcut to my work' and go for FSW_PSW and save it as FSW_PSW.MAN and edit all those things which you mentioned above.

Once done you go back to NCS expert and click on basic functions.
Select 'CoapiReadSgGetFswPsw' and ok.
A small window pops out saying 'basic function perfect ended'.
Press OK.
now change job type to 'SG_CODIEREN and press ok.
Execute job and once coding finished, I check the indicator and it is still flashing fast.


Sorry to put all this here, but just wants to know if I am doing anything wrong.

Despite of trying 20-30 times, no luck.

Any suggestions?
The steps you are taking are correct to the tee, but your using the wrong profile in Expertmode...YOu are basically writing the default parameters back to factory settings...Did you follow the directions and make a writable profile in which you can edit and save the FSW_PSW.man file??

Did you do this from steps 21 to step 34 from this PDF???

http://www.e90post.com/forums/attach...6&d=1330630236
__________________

Coding E and F New York 917-939-4980

Last edited by cn555ic; 05-06-2012 at 08:09 PM.
cn555ic is offline   United_States
0
Reply With Quote
      05-06-2012, 09:43 PM   #14
Dziqsek_
Banned
 
Drives: e91 320d
Join Date: Feb 2012
Location: Jelenia Gora ( Lower Silesia )

Posts: 413
iTrader: (0)

So wrong... Cn555ic wrote correct. I will pm you in couple pf hours its 4am here now and its the best time to gp to sleep
Dziqsek_ is offline   Poland
0
Reply With Quote
      05-07-2012, 02:23 AM   #15
makkan00
Major General
 
makkan00's Avatar
 
Drives: E91 330D
Join Date: Dec 2011
Location: Essex

Posts: 6,787
iTrader: (47)

Quote:
Originally Posted by cn555ic View Post
The steps you are taking are correct to the tee, but your using the wrong profile in Expertmode...YOu are basically writing the default parameters back to factory settings...Did you follow the directions and make a writable profile in which you can edit and save the FSW_PSW.man file??

Did you do this from steps 21 to step 34 from this PDF???

http://www.e90post.com/forums/attach...6&d=1330630236

Thanks cn555ic.
Since day 1, I could never do step 25, as I never get that screen.

My coding history started couple of months ago, where I could not do step 25. Asked many people, and nobody could reply and I was told to skip step 35.
The files I had, already had FSW_PSW.man file. I have successfully entered locking / unlocking beeps, 'v' on cluster and some other features.

However I am stuck at LCI retrofitting coding.
Can you kindly explain how to do step 25?

Thanks.
__________________
makkan00 is offline   United Kingdom
0
Reply With Quote
      05-07-2012, 02:48 AM   #16
makkan00
Major General
 
makkan00's Avatar
 
Drives: E91 330D
Join Date: Dec 2011
Location: Essex

Posts: 6,787
iTrader: (47)

Quote:
Originally Posted by cn555ic View Post
The steps you are taking are correct to the tee, but your using the wrong profile in Expertmode...YOu are basically writing the default parameters back to factory settings...Did you follow the directions and make a writable profile in which you can edit and save the FSW_PSW.man file??

Did you do this from steps 21 to step 34 from this PDF???

http://www.e90post.com/forums/attach...6&d=1330630236
Thanks Cn555ic and Dzik.
You guys are champs. I was not loading the correct profile.
My mistake. Sorted and it worked like a charm.
__________________

Last edited by makkan00; 05-07-2012 at 07:22 AM.
makkan00 is offline   United Kingdom
0
Reply With Quote
      05-07-2012, 06:02 AM   #17
Dziqsek_
Banned
 
Drives: e91 320d
Join Date: Feb 2012
Location: Jelenia Gora ( Lower Silesia )

Posts: 413
iTrader: (0)

Your welcome- thats why we are here
Dziqsek_ is offline   Poland
0
Reply With Quote
      11-28-2012, 02:08 PM   #18
pepsih
Captain
 
pepsih's Avatar
 
Drives: E90 335i
Join Date: Oct 2011
Location: Currently NY

Posts: 690
iTrader: (2)

Bump for a very helpful thread

dzieki wielkie ******* hehe
pepsih is offline   France
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:45 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST