E90Post
 


GT Haus
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > yellow battery light



Reply
 
Thread Tools Search this Thread
      05-09-2012, 08:12 PM   #1
mrogo44
Enlisted Member
United_States
2
Rep
35
Posts

 
Drives: 335i 6MT
Join Date: Jan 2012
Location: Florida

iTrader: (0)

yellow battery light

The other day when I stopped driving, I turned off my engine and left the keys in with the music on for about 1-2 minutes. After 2 minutes, the service light with the yellow battery showed up. I took the keys out, and attempted to start the car and it did not lag or sound any different than usual. This happens pretty much every time I do anything in the car with the keys still in. This week I took the car to a nearby shop to get the battery tested, and it showed it was charging, and recharging fine. What could be the issue here?

Thank you!
Appreciate 0
      05-09-2012, 08:14 PM   #2
onebadmofo
Banned
Russian Federation
54
Rep
2,394
Posts

 
Drives: 2007 E92 335i
Join Date: Aug 2010
Location: Central NJ

iTrader: (14)

What year is the car?
Appreciate 0
      05-09-2012, 08:20 PM   #3
mrogo44
Enlisted Member
United_States
2
Rep
35
Posts

 
Drives: 335i 6MT
Join Date: Jan 2012
Location: Florida

iTrader: (0)

Quote:
Originally Posted by onebadmofo View Post
What year is the car?
Sorry, its an '08 e92
Appreciate 0
      05-09-2012, 08:23 PM   #4
Tom K.
Major General
Tom K.'s Avatar
United_States
54
Rep
5,411
Posts

 
Drives: '07 328iT, '13 Boxster
Join Date: Mar 2008
Location: Maryland

iTrader: (0)

Quote:
Originally Posted by mrogo44 View Post
The other day when I stopped driving, I turned off my engine and left the keys in with the music on for about 1-2 minutes. After 2 minutes, the service light with the yellow battery showed up. I took the keys out, and attempted to start the car and it did not lag or sound any different than usual. This happens pretty much every time I do anything in the car with the keys still in. This week I took the car to a nearby shop to get the battery tested, and it showed it was charging, and recharging fine. What could be the issue here?

Thank you!
The first time that happened to my '07 E91, the alternator and IBS unit were replaced. When the problem resurfaced 6 months later, it turned out to be a bad wire shorting to ground.

As I understand it, there is a service bulletin on the shorting problem so you might want to take it to a dealer.

Tom
Appreciate 0
      05-09-2012, 08:32 PM   #5
mrogo44
Enlisted Member
United_States
2
Rep
35
Posts

 
Drives: 335i 6MT
Join Date: Jan 2012
Location: Florida

iTrader: (0)

Quote:
Originally Posted by Tom K. View Post
The first time that happened to my '07 E91, the alternator and IBS unit were replaced. When the problem resurfaced 6 months later, it turned out to be a bad wire shorting to ground.

As I understand it, there is a service bulletin on the shorting problem so you might want to take it to a dealer.

Tom
After all the repairs, does it still happen now?
Appreciate 0
      05-09-2012, 09:28 PM   #6
BKV122
Major
BKV122's Avatar
United_States
14
Rep
1,096
Posts

 
Drives: E90
Join Date: Feb 2009
Location: NY

iTrader: (1)

Garage List
2006 330xi  [4.75]
You had the car off and a load on the battery, the warning was just letting you know the battery was being used with out being recharged. Once you started it up it was able to recharge and what not, obviously if you sat there for longer with your radio on and keys in the ignition your battery would have died.
You should be fine, if you want you can check the battery voltage with a multimeter with the car off it should be at like 12.5V and with the car running should be at like 13-14V
__________________

Monaco Blue 330xi - Terra Interior/6-MT/Sport/Premium/Cold/CSL's/M3 Spoiler Lip/Black Kidney's
Appreciate 1
      05-09-2012, 09:43 PM   #7
Tom K.
Major General
Tom K.'s Avatar
United_States
54
Rep
5,411
Posts

 
Drives: '07 328iT, '13 Boxster
Join Date: Mar 2008
Location: Maryland

iTrader: (0)

Quote:
Originally Posted by mrogo44 View Post
After all the repairs, does it still happen now?

While I just got it back a few days ago, it seems to be fine. The Comfort Access always works (it was intermittent before) and I listened to the radio with the motor off for 5 minutes with no problems. Before, the yellow "Low Battery" warning would appear after 60 seconds. And as far as I know, the car is still on the original battery after 5 years.

Tom
Appreciate 0
      12-02-2013, 02:55 PM   #8
insane79
Major
insane79's Avatar
No_Country
17
Rep
1,084
Posts

 
Drives: E90 lci
Join Date: Apr 2012
Location: Earth

iTrader: (0)

to the OP, you got your battery replaced? i got a similar warning in my car today, was fiddling with the idrive when the car was switched off..

Thanks.
Appreciate 0
      12-02-2013, 03:02 PM   #9
shadow191
Major
10
Rep
1,045
Posts

 
Drives: '07 E92 335i / '07 Infiniti FX
Join Date: Dec 2012
Location: GA

iTrader: (3)

When that started happening to me, it started getting more and more frequent until the battery went. ie, the first time it happened, the car had been on for 20 minutes or so and I was cycling through the cooling system so that was causing a drain. Then a month later, it came back when I was messing with the stereo and it took maybe 10 minutes. Then a little while later, it would come on after 5 minutes. Then 2 months after that, the car went from cranking fine to almost not starting within about a day. I was expecting this since it's an '07 on it's original battery.

If it's happening in 2 minutes, I would keep an eye on the battery.
Appreciate 0
      12-10-2013, 10:22 PM   #10
pauloxxi
Private
United_States
0
Rep
52
Posts

 
Drives: 2009 -328i / 2014 -320 XDrive
Join Date: May 2010
Location: Ohio

iTrader: (0)

So... should we replace the battery at the BMW dealer or can we do that at another service shop. The dealer told me the battery cost is close to US$300.00. What do you guys think?
Appreciate 0
      12-12-2013, 03:03 AM   #11
1QuikWS6
No 55mph
1QuikWS6's Avatar
United_States
67
Rep
4,810
Posts

 
Drives: 09 E92 328iX N51 3-Stage ->M6
Join Date: Jul 2009
Location: Blitzburgh, PA

iTrader: (83)

Garage List
You can buy batteries of same specs as many different BMW batteries (including AGM style) at Advanced Auto right now with additional $40 off using Promo Code TRT41 @ checkout...

Do the install yourself - but make sure you register the battery (or have someone that has BT Cable do it for you)


Just replaced my battery in my 09' - kept getting a code '2DEB' which has to do with Power Management. Battery was charging fine, but car was sluggish starting in cold weather...

When dealer checked the battery it came up as being OK - but needed charged. However, it was also showing 638CCA when it should have been 900.

Dealer wanted $585 to install new battery - I told them that was insane & showed them the printout from Advanced Auto for their pricing. I told them I would just get my own battery & install - I have cable to do my own registration.

Ended up they did the battery for me for only labor cost $212 (battery test + battery install/registration + putting car on scope for error code) - gave me the battery for FREE under 'goodwill' Yes, that's $60 more than what I could have done it for myself - but it was worth the xtra $60 to not have to change out a battery in the driveway with temps around 20 deg

My car is an 09' - but it only has 32k on it. 5yrs on battery, but I only drive 26mi/day, half of which is in dark with a lot of accessories ON, so battery doesn't ever have a chance to fully charge - apparently they don't like that
__________________
2009 328ix E92//SGM//ACS Roof Spoiler//MTech Aero Lip+Trunk Spoiler//M3 Side Skirts//CF Roundels+Grilles//M3 Novillo Interior//Perf Shift Lever+Boot//MPerf DCT Wheel//M3 GT3 eBrake Handle+Boot//ACS Pedals//M3 Mirrors//LCI Tails w/LUX Rev//DTEC V7 AE+MTec 6000K D1S+HPB HID 6000K Fogs//HPB LED Interior//RPI Scoops//CF Euro Airbox+Underhood Hsgs//K&N//BMW PE//MTech Rear Bumper-iS Sport Diffuser//CF Strut Brace//Vishnu OFT//BMW 193M's+Kumho 4X
Appreciate 0
Reply

Bookmarks

Tags
battery, problem, service, yellow

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:25 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST