E90Post
 


jb4store
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > 330i Transmission problem on switching back to 1st gear



Reply
 
Thread Tools Search this Thread
      05-14-2012, 01:53 AM   #1
testdriver
Private
3

 
Drives: E92 M3
Join Date: Jan 2012
Location: HK


Posts: 58
iTrader: (0)

330i Transmission problem on switching back to 1st gear

The transmission on my 330i is having some strange problem every time when I come to a stop.....

When I'm about to stop the car (on D drive), I can feel a "push/ jumping" from the tranny when its downshift back to 1st and the whole car is "jumping" forward.


I did the following test and determine the problem is on 2nd to 1st gear:

>> when I drive on M mode, the car can stop smoothly and the gear will stay on M2 at complete stop.... once I switch from M2 to M1 manually (with brake apply) car "jump forward"

>> car stop at M2.... switching from M2 back to D.... "jump" occur

Does anyone know what happen to it and what is the solution to fix this..... is it a hardware or software problem ?

Right now I try to avoid the Jumping by push to N right before stop or keep driving on M2 so the tranny wont go back to 1st on its own.


Thank you and please offer advise...


car info: 2007 330i / 43000km / change tranny oil 4 month ago but without changing the Pan/filter
Appreciate 0
      05-14-2012, 09:35 AM   #2
NBK
Second Lieutenant
5

 
Drives: bazinga
Join Date: Mar 2012
Location: bazinga


Posts: 287
iTrader: (1)

and thats why i dont change tranny fluid.
Appreciate 0
      05-14-2012, 11:27 AM   #3
Johnny D
Major
45

 
Johnny D's Avatar
 
Drives: 2006 BMW 325i
Join Date: Apr 2011
Location: Hot Springs, AR


Posts: 1,124
iTrader: (4)

Garage List
2006 BMW 325i  [4.58]
Sometimes I can feel my torque converter unlock when Im slowing down, but Ive never had the car "jump". I cant help you on this one, my only suggestion would be take it in and get it checked out.
Appreciate 0
      05-14-2012, 02:26 PM   #4
FrankE90xi
Private First Class
United_States
10

 
FrankE90xi's Avatar
 
Drives: Black 2007 BMW 328xi
Join Date: May 2011
Location: Orland park


Posts: 185
iTrader: (1)

Garage List
2007 BMW 328 xi  [4.20]
My car does this too 07 328 xi idk what it is one time the code came up for a shift solenoid but I've never seen it since
__________________
18" alzor style 703, 20mm rear spacers, 10mm front spacers, 235/40/18 Nitto Neogen, Afe Stage 2 pro5r CAI, Eurocharged tune, Meistershaft catback exhaust, 35% Window Tints, Taillight and Side Marker Tint, Debadge, Blackout Grille, CF Interior kit, Cyba Scoops
Appreciate 0
      05-14-2012, 08:31 PM   #5
testdriver
Private
3

 
Drives: E92 M3
Join Date: Jan 2012
Location: HK


Posts: 58
iTrader: (0)

Quote:
Originally Posted by NBK View Post
and thats why i dont change tranny fluid.
I hope that is not related.... I changed my tranny fluid like 4 months ago, everything is running fine until 3 weeks ago.
Appreciate 0
      05-14-2012, 08:34 PM   #6
testdriver
Private
3

 
Drives: E92 M3
Join Date: Jan 2012
Location: HK


Posts: 58
iTrader: (0)

Quote:
Originally Posted by jntar View Post
Sometimes I can feel my torque converter unlock when Im slowing down, but Ive never had the car "jump". I cant help you on this one, my only suggestion would be take it in and get it checked out.
Some shop tell me to change the fluid + oil pan filter but I'm not too sure will that work. Also no code has ever appear so they may not found anything.
Appreciate 0
      05-14-2012, 08:35 PM   #7
NBK
Second Lieutenant
5

 
Drives: bazinga
Join Date: Mar 2012
Location: bazinga


Posts: 287
iTrader: (1)

Quote:
Originally Posted by testdriver View Post
I hope that is not related.... I changed my tranny fluid like 4 months ago, everything is running fine until 3 weeks ago.
all it takes is for one small particle to come free when changing fluid- and resting in a place it shouldn't be.

thats my take on AT transmissions at least.....
Appreciate 0
      05-14-2012, 08:35 PM   #8
testdriver
Private
3

 
Drives: E92 M3
Join Date: Jan 2012
Location: HK


Posts: 58
iTrader: (0)

Quote:
Originally Posted by FrankE90xi View Post
My car does this too 07 328 xi idk what it is one time the code came up for a shift solenoid but I've never seen it since
No code on my case...
Appreciate 0
      05-14-2012, 09:45 PM   #9
Cisco661
Cisco661
United_States
27

 
Cisco661's Avatar
 
Drives: 2006 Monaco Blue 330I
Join Date: Jul 2011
Location: California


Posts: 921
iTrader: (17)

Garage List
2006 BMW 330i  [0.00]
how many miles did you have on car when you changed tranny fluid?
__________________
2006 330i/ Monaco Blue/ ZSP/ ZPP/ I Drive/ Burl Walnut Trim/ Steptronic/ Xenon Adaptives/ Logic7/ CF Mirror Caps/ Matte Black Grills
Appreciate 0
      05-14-2012, 10:32 PM   #10
testdriver
Private
3

 
Drives: E92 M3
Join Date: Jan 2012
Location: HK


Posts: 58
iTrader: (0)

Quote:
Originally Posted by Cisco661 View Post
how many miles did you have on car when you changed tranny fluid?
around 39500 KM (4 months ago), right now is ~43000KM.
Appreciate 0
      05-15-2012, 02:50 PM   #11
mike-y
just another bmw douche bag
United_States
41

 
Drives: 1.9L of fury
Join Date: Nov 2008
Location: Los Angeles, CA


Posts: 3,398
iTrader: (4)

why would you change the trans fluid on the automatic at 39km? The auto trans is supposed to go around 100k miles (160,000km) without needing service. Some people do it around 80k miles, but 39,000km is way too early.
Appreciate 0
      05-15-2012, 07:49 PM   #12
Bavarian Tech
Captain
36

 
Bavarian Tech's Avatar
 
Drives: 335i
Join Date: Jan 2007
Location: Pittsburgh/Harrisburg


Posts: 706
iTrader: (10)

Garage List
2006 330i  [5.00]
Quote:
Originally Posted by mike-y View Post
why would you change the trans fluid on the automatic at 39km? The auto trans is supposed to go around 100k miles (160,000km) without needing service. Some people do it around 80k miles, but 39,000km is way too early.
Not necessarily, ask any old timer..they'll say around 30k...or earlier..Yes BMW quotes the tranny fluid is good till 100k too but that's also when any of their warranties expire also.(No it wont blow up @ 100,001) but A few hundred dollars over the life time of the car is still alot cheaper than a $5,000 transmission.. IMO

OP, Do you have access to a Scan tool ?
__________________
335i Sport Sedan: 6Speed: Sport : Prem : Cold Weather : CIC Swap/Combox : M3 Cluster
Appreciate 0
      05-15-2012, 08:03 PM   #13
tc328
Private First Class
6

 
Drives: 328
Join Date: Apr 2007
Location: bstny


Posts: 120
iTrader: (3)

Garage List
2007 3  [0.00]
you cant mix old ATF with new, unless you flush within days

you need to flush your ATF again asap, and change your pan/filter

REMEMBER TO USE OEM ATF...No redline, motual, r purple if you want to save your tranny

Last edited by tc328; 05-15-2012 at 08:13 PM.
Appreciate 0
      05-16-2012, 08:23 PM   #14
testdriver
Private
3

 
Drives: E92 M3
Join Date: Jan 2012
Location: HK


Posts: 58
iTrader: (0)

Quote:
Originally Posted by Bavarian Tech View Post
Not necessarily, ask any old timer..they'll say around 30k...or earlier..Yes BMW quotes the tranny fluid is good till 100k too but that's also when any of their warranties expire also.(No it wont blow up @ 100,001) but A few hundred dollars over the life time of the car is still alot cheaper than a $5,000 transmission.. IMO

OP, Do you have access to a Scan tool ?
I can find a shop which has it but no code ever appear so I'm not sure will that help...... but I will try.
Appreciate 0
      05-16-2012, 08:29 PM   #15
testdriver
Private
3

 
Drives: E92 M3
Join Date: Jan 2012
Location: HK


Posts: 58
iTrader: (0)

Quote:
Originally Posted by tc328 View Post
you cant mix old ATF with new, unless you flush within days

you need to flush your ATF again asap, and change your pan/filter

REMEMBER TO USE OEM ATF...No redline, motual, r purple if you want to save your tranny

Not too sure did the shop drain out all the fluid 100% completely but even if there's old ATF there it should be not be a lot left...... may I ask why can't mix old ATF with new?? what is the reason behind it? thanks

btw.... I did use OEM ATF but did not change my AT pan/filter last time.
Appreciate 0
      05-16-2012, 08:44 PM   #16
Bavarian Tech
Captain
36

 
Bavarian Tech's Avatar
 
Drives: 335i
Join Date: Jan 2007
Location: Pittsburgh/Harrisburg


Posts: 706
iTrader: (10)

Garage List
2006 330i  [5.00]
Quote:
Originally Posted by testdriver View Post
I can find a shop which has it but no code ever appear so I'm not sure will that help...... but I will try.
Look around on the forum, maybe theirs someone in your area to help ya out..Might help by just doing adaptation reset.


Quote:
Originally Posted by testdriver View Post
Not too sure did the shop drain out all the fluid 100% completely but even if there's old ATF there it should be not be a lot left...... may I ask why can't mix old ATF with new?? what is the reason behind it? thanks

btw.... I did use OEM ATF but did not change my AT pan/filter last time.
You really cant drain all the fluid out an automatic trans..(Torque converter, valve body,pump...all hold fluid) Mixing old n new fluid is going to happen regardless..Same thing as an oil change..you never get it all out..
__________________
335i Sport Sedan: 6Speed: Sport : Prem : Cold Weather : CIC Swap/Combox : M3 Cluster

Last edited by Bavarian Tech; 05-16-2012 at 08:51 PM.
Appreciate 0
      05-16-2012, 09:33 PM   #17
ska///235i
***** noob
United_States
480

 
ska///235i's Avatar
 
Drives: M235i
Join Date: Sep 2005
Location: Boston


Posts: 9,165
iTrader: (32)

Garage List
2006 325xi  [0.00]
you never get it all out but flushing it then a pan/filter change can at least get you 85% new fluid. the torque converter and other listed can hold up to 3-4 qts. if you dont flush it then dont touch it at all
Appreciate 0
      05-16-2012, 09:34 PM   #18
testdriver
Private
3

 
Drives: E92 M3
Join Date: Jan 2012
Location: HK


Posts: 58
iTrader: (0)

Quote:
Originally Posted by Bavarian Tech View Post
Look around on the forum, maybe theirs someone in your area to help ya out..Might help by just doing adaptation reset.
I actually has a "feeling" this could be a software problem regarding than hardware.... may I ask what is " adaptation reset" ?

I try to figure out is it possible for me to reset my tranny ecu and make it learn how to drive again....


I agree with you that unless it is a brand new tranny... there's no way one can drain out all the ATF.... anyway, a shop did tell me to change the ATF with oil pan/ filter to see if it can fix the problem. I'm not too sure will that work.

Thanks again...
Appreciate 0
      05-16-2012, 09:39 PM   #19
testdriver
Private
3

 
Drives: E92 M3
Join Date: Jan 2012
Location: HK


Posts: 58
iTrader: (0)

Quote:
Originally Posted by ska325xi View Post
you never get it all out but flushing it then a pan/filter change can at least get you 85% new fluid. the torque converter and other listed can hold up to 3-4 qts. if you dont flush it then dont touch it at all
I understand what you meant... and more than one person has said do not mix old ATF with new. My question is if this is a big no no..... then why would my tranny doing fine after the ATF changed and the problem occur 5 months later (3000km) ?

thanks....
Appreciate 0
      05-16-2012, 09:48 PM   #20
ska///235i
***** noob
United_States
480

 
ska///235i's Avatar
 
Drives: M235i
Join Date: Sep 2005
Location: Boston


Posts: 9,165
iTrader: (32)

Garage List
2006 325xi  [0.00]
things doesnt break down right away, 1 tiny particle can cause your tranny to slip, its a chain rection....heat will start to generate more and more over time

stop wasting time, i also recommend a pan filter change but it might be too late
Appreciate 0
      03-19-2013, 02:47 PM   #21
kosherthunder
New Member
0

 
Drives: 2013 BMW 328i Sport Line
Join Date: Nov 2012
Location: Los Angeles


Posts: 8
iTrader: (0)

Re:Transmission Issue

Hi Testdriver,

I've been searching every website to see if anyone else had this problem. My 328i sport does the same exact thing ! It kicks/jumps right as i slow down to the 10mph mark. Every time, I took it to the dealer and drove with a mechanic. It stopped doing it right then and there. As soon as I left the lot it returned and has gotten really bad, sometimes the whole car shakes.

Have you figured out what it is yet? It's driving me crazy.
Appreciate 0
      03-21-2013, 09:19 AM   #22
evssss1
New Member
2

 
Drives: E90 325i TiAg Pre-LCI
Join Date: Sep 2012
Location: HK


Posts: 23
iTrader: (0)

Same symptom in my 05 325i. Try resetting the adaptation in INPA which will help. But it is just a matter of time this weird jump is coming back and then another reset will help for a period.

Let me know if changing ATF will oil pan helps.....
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:25 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST