E90Post
 


E92 Lighting
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Help! Low coolant and engine overheating.



Reply
 
Thread Tools Search this Thread
      02-07-2012, 02:08 AM   #1
ace008
Second Lieutenant
 
Drives: 2013 F10 535i
Join Date: May 2005
Location: San Francisco, CA

Posts: 221
iTrader: (0)

Garage List
2007 335i  [0.00]
Help! Low coolant and engine overheating.

While driving on the highway, I noticed the low coolant yellow light came on. I saw the temperature rising over 250 all the way to 280 and the engine overheating light came on. I was about 2 blocks from my house, so pulled over, let the car cool down, and made it back to my house. Also, I noticed that when trying to use the heater to let the car cool down some, it was just blowing cold air... How do I check to see if the coolant is low? I bought some prestone 50/50 for now. Can I use that to top it off? Is bleeding required, or can I just top it off and pour it in the coolant tank? What do you guys think the problem can be? Should I bring it into the dealer instead? Thanks for the help in advance!
ace008 is offline  
0
Reply With Quote
      02-07-2012, 03:02 AM   #2
ace008
Second Lieutenant
 
Drives: 2013 F10 535i
Join Date: May 2005
Location: San Francisco, CA

Posts: 221
iTrader: (0)

Garage List
2007 335i  [0.00]
Well I checked the coolant tank and it looks almost completely empty... I bought some prestone 50/50 for now. Also, some people recommended that I just distilled water for now, until I can get a coolant change. What do you guys recommend? Also, after filling it up, should I take it to the dealer for them to take a look at it?
ace008 is offline  
0
Reply With Quote
      02-07-2012, 03:06 AM   #3
soulja620
Cpl D
 
soulja620's Avatar
 
Drives: 07 335i
Join Date: May 2010
Location: Phoenix, AZ

Posts: 564
iTrader: (8)

non bmw coolant = fail
__________________
07 AW e90 335 :jb4/dci/ic/meth= 12.2 @116 :jb4/dci/ic/meth/RaceGas/Slicks/gutted = Broken ET BOARD!
88- Mitsubishi Starion Turbo- Built~My feedback~ http://www.starquestclub.com/forum/i...0&fromsearch=1
soulja620 is offline  
0
Reply With Quote
      02-07-2012, 01:53 PM   #4
ace008
Second Lieutenant
 
Drives: 2013 F10 535i
Join Date: May 2005
Location: San Francisco, CA

Posts: 221
iTrader: (0)

Garage List
2007 335i  [0.00]
Its at the dealer now. Hopefully extended warranty covers it. Car has 86k miles btw.
ace008 is offline  
0
Reply With Quote
      02-07-2012, 03:54 PM   #5
apme123
First Lieutenant
 
apme123's Avatar
 
Drives: 2002 Honda S2000
Join Date: May 2005
Location: Los Angeles, CA, USA

Posts: 321
iTrader: (0)

if you dont see and you are loosing coolant, check the head gasket, otherwise look for leaks or a faulty water pump and thermostat
__________________
apme123 is offline  
0
Reply With Quote
      02-08-2012, 08:42 PM   #6
ace008
Second Lieutenant
 
Drives: 2013 F10 535i
Join Date: May 2005
Location: San Francisco, CA

Posts: 221
iTrader: (0)

Garage List
2007 335i  [0.00]
Dealer called back, and they still don't know what the issue is... They said the radiator cap was off or blew out, which caused the loss of coolant, but now, the engine is also misfiring and white smoke came out of the tailpipes. I had to authorize an engine teardown ($2000) while they take the engine apart and see what's going on. I have extended warranty through GE, thank god, and hopefully this will all be covered, but they need to find out what the issue is before they can start the warranty claim process.
ace008 is offline  
0
Reply With Quote
      02-09-2012, 12:25 AM   #7
rader1
Banned
 
Drives: Cobb Stage 2+ 135i
Join Date: Apr 2011
Location: Roanoke, VA

Posts: 2,197
iTrader: (0)

sounds like a headgasket.
rader1 is offline  
0
Reply With Quote
      02-09-2012, 12:52 AM   #8
Kris 335i
...
 
Kris 335i's Avatar
 
Drives: 335
Join Date: Dec 2009
Location: USA

Posts: 92
iTrader: (0)

Quote:
Originally Posted by ace008 View Post
Dealer called back, and they still don't know what the issue is... They said the radiator cap was off or blew out, which caused the loss of coolant, but now, the engine is also misfiring and white smoke came out of the tailpipes. I had to authorize an engine teardown ($2000) while they take the engine apart and see what's going on. I have extended warranty through GE, thank god, and hopefully this will all be covered, but they need to find out what the issue is before they can start the warranty claim process.
Yeah you can't make it far without coolant before something (usually the head gasket) goes.
Kris 335i is offline  
0
Reply With Quote
      02-14-2012, 01:54 AM   #9
ace008
Second Lieutenant
 
Drives: 2013 F10 535i
Join Date: May 2005
Location: San Francisco, CA

Posts: 221
iTrader: (0)

Garage List
2007 335i  [0.00]
Got the car back today. Turns out the water pump went bad, and also they had to replace the radiator. No engine damage. Car seems to drive fine now.
ace008 is offline  
0
Reply With Quote
      02-14-2012, 02:08 AM   #10
JunkStory
Major
 
Drives: naked.
Join Date: May 2008
Location: 98230

Posts: 1,185
iTrader: (3)

yep, water pump failure is becoming more common these days as the car ages.
JunkStory is offline  
0
Reply With Quote
      02-16-2012, 08:47 AM   #11
correll24
Correll24
 
Drives: 2006 BMW 325i
Join Date: Feb 2012
Location: Sweetwater, TN

Posts: 4
iTrader: (0)

If you cannot get to the BMW dealer, Try O'Rielly's AutoParts. They carry Pentosin products which are made in Germany and good in just about all German cars.
PF-NF-1.5L Pentafrost
correll24 is offline   United_States
0
Reply With Quote
      05-28-2012, 02:49 AM   #12
villanueva3c
Registered
 
Drives: 2007 335i
Join Date: Apr 2012
Location: Fresno, Ca

Posts: 2
iTrader: (0)

I need some advice, today my 2007bmw 335i's overheating light came on. My cap was loose and lost some coolant. Went to fill it and the light came back on. Used peak coolant BTW. My water pump is pumping. Thermostat, don't know. It's got 140000 miles on it. Any feedback on what the problem is would be really helpful
villanueva3c is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:05 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST