E90Post
 


 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > I'm getting desperate



Reply
 
Thread Tools Search this Thread
      05-28-2012, 10:42 PM   #1
kavadarci
Lieutenant
 
Drives: 335xi
Join Date: Apr 2012
Location: canada

Posts: 556
iTrader: (0)

I'm getting desperate

Ok,

I have a problem with the master power window switch and i'm getting desperate as i don't know where to start.

the switch sometimes works sometimes doesn't, not sure what triggers the action.

i have checked all the connection, switch, cables, door main connector, all looks good no rust.
dealer wants 200 bucks for the master switch and i can't return if it's not the switch.

some suggested that it might be the actuator, regulator or even power window mirror.

how many parts can be causing this issue and where do i start?
Thank you.
kavadarci is offline  
0
Reply With Quote
      05-28-2012, 11:18 PM   #2
superjay
Resident Car Audio Guru
 
superjay's Avatar
 
Drives: 2007 E93 335i
Join Date: May 2012
Location: Rancho Cucamonga, CA

Posts: 596
iTrader: (0)

if you have the expertise to take the switch apart look at the contacts. They may be corroded. This can be cleaned with a pink pencil eraser. If the contacts ARE corroded, and you dont' want to clean them, spend the $200 for a new switch.
__________________
It's not about how much power you have, it's about how well you use it.
superjay is offline   United_States
0
Reply With Quote
      05-29-2012, 07:16 AM   #3
kavadarci
Lieutenant
 
Drives: 335xi
Join Date: Apr 2012
Location: canada

Posts: 556
iTrader: (0)

i will open it, no issues but so far i have seen zero signs of corrosion anywhere on the connections. but i guess it is something i can try.
kavadarci is offline  
0
Reply With Quote
      05-29-2012, 09:37 AM   #4
superjay
Resident Car Audio Guru
 
superjay's Avatar
 
Drives: 2007 E93 335i
Join Date: May 2012
Location: Rancho Cucamonga, CA

Posts: 596
iTrader: (0)

the switches are far more likely to become corroded than the plug, since the plug stays out of the weather, and anything spilled on the switch will magically find its way directly to the contacts.
__________________
It's not about how much power you have, it's about how well you use it.
superjay is offline   United_States
0
Reply With Quote
      05-29-2012, 09:42 AM   #5
smallseafishie
Lieutenant Colonel
 
Drives: AW 07 e92 335i + AW 11 X5 35d
Join Date: Jun 2007
Location: Atlanta GA

Posts: 1,681
iTrader: (12)

Garage List
2007 E92 335i  [0.00]
When it fails, does it not go up or not go down?

If it doesn't go down, if you hold your unlock button on the key fob, does it go down?

If it doesn't go up... then code your car to enable the roll up window by holding lock button down feature!
smallseafishie is offline  
0
Reply With Quote
      05-29-2012, 09:48 AM   #6
smallseafishie
Lieutenant Colonel
 
Drives: AW 07 e92 335i + AW 11 X5 35d
Join Date: Jun 2007
Location: Atlanta GA

Posts: 1,681
iTrader: (12)

Garage List
2007 E92 335i  [0.00]
As far as possibilities of issues...

Could be the switch panel (can be ruled out if the remote fob doesn't work).

Could be the window regulator motor itself (dirty motor brushes). -assuming only one window doesn't work...

And then there's the umbrella issue of having a flaky connection in a wiring harness or solder joint in related circuits.

Do you not know anyone else with a similar car? It's easy enough to pop the switch panel off and try. Or ebay a used one.

http://www.ebay.com/itm/06-07-08-BMW...ht_2925wt_1144
smallseafishie is offline  
0
Reply With Quote
      05-29-2012, 10:47 AM   #7
kavadarci
Lieutenant
 
Drives: 335xi
Join Date: Apr 2012
Location: canada

Posts: 556
iTrader: (0)

Quote:
Originally Posted by smallseafishie View Post
As far as possibilities of issues...

Could be the switch panel (can be ruled out if the remote fob doesn't work).
Remote fob works.
Could be the window regulator motor itself (dirty motor brushes). -assuming only one window doesn't work...
None of the windows work from the master switch, also the mirrors don't work and the windows lock switch doesn't work. All other windows work from their own door switches.
And then there's the umbrella issue of having a flaky connection in a wiring harness or solder joint in related circuits.
Not sure what to do here.
Do you not know anyone else with a similar car? It's easy enough to pop the switch panel off and try. Or ebay a used one.
I guess it's a good start. It's says 06/07/08. I have 09, is it the same switch?

http://www.ebay.com/itm/06-07-08-BMW...ht_2925wt_1144

Thank you.
kavadarci is offline  
0
Reply With Quote
      05-29-2012, 03:46 PM   #8
kavadarci
Lieutenant
 
Drives: 335xi
Join Date: Apr 2012
Location: canada

Posts: 556
iTrader: (0)

Update:

all taken out, switch looks like new inside out, connectors everything is like new, not a single sign of rust.
kavadarci is offline  
0
Reply With Quote
      05-29-2012, 03:55 PM   #9
superjay
Resident Car Audio Guru
 
superjay's Avatar
 
Drives: 2007 E93 335i
Join Date: May 2012
Location: Rancho Cucamonga, CA

Posts: 596
iTrader: (0)

did you check the window module? That would be my next step. The control module may have corrosion, or just may be on its way out. Do they use salt on the roads where you live?
__________________
It's not about how much power you have, it's about how well you use it.
superjay is offline   United_States
0
Reply With Quote
      05-29-2012, 03:56 PM   #10
kavadarci
Lieutenant
 
Drives: 335xi
Join Date: Apr 2012
Location: canada

Posts: 556
iTrader: (0)

yes, salt is used.
Where is the control module located?

Thank you.
kavadarci is offline  
0
Reply With Quote
      05-29-2012, 04:36 PM   #11
superjay
Resident Car Audio Guru
 
superjay's Avatar
 
Drives: 2007 E93 335i
Join Date: May 2012
Location: Rancho Cucamonga, CA

Posts: 596
iTrader: (0)

I believe it is in the door. I have not had to troubleshoot one of them, so I may be mistaken, but in the 04 7 series it is in the door.
__________________
It's not about how much power you have, it's about how well you use it.
superjay is offline   United_States
0
Reply With Quote
      05-29-2012, 11:54 PM   #12
tmo24
Captain
 
tmo24's Avatar
 
Drives: 2010 335i e90 Msport
Join Date: Aug 2010
Location: Las Vegas

Posts: 869
iTrader: (3)

Do you have a friend with the same car? If so, you can swap switches to ind out before spending $200.
__________________
2010 335i AW e90 Msport
tmo24 is offline   United_States
0
Reply With Quote
      07-11-2012, 02:43 PM   #13
RimasRS
Colonel
 
RimasRS's Avatar
 
Drives: 135i MT 2009 AW
Join Date: Sep 2010
Location: Europe

Posts: 2,378
iTrader: (0)

I have something same. It's just when car stays on the sun and heats up main switch does not operate not just windows but also mirrors. When I drive car few minutes it cools down and starts to operate.

What can be wrong? OP did you find it out?
RimasRS is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:31 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST