E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > All-Wheel-Drive (Xi / xDrive) Talk > 335xi Stumbling under acceleration



Reply
 
Thread Tools Search this Thread
      05-06-2012, 08:14 PM   #1
cyndi335icoupe
Registered
1
Rep
2
Posts

 
Drives: 335xicoupe
Join Date: May 2012
Location: n.h.

iTrader: (0)

Question 335xi Stumbling under acceleration

Just purchased with 44k on it, I love it.

First time on highway most noticable accelerating from 60 to 90 it stumbles. It feels like the all wheel drive Astro van I once had. I always felt like the all wheel drive system on the van was fighting it self. Seems to be only in automatic mode, not when using paddles.

Going to the dealer next week just checking to see if anyone has had a similiar issue.
Appreciate 0
      05-09-2012, 12:11 PM   #2
Fun w/N54
Lieutenant
United_States
6
Rep
425
Posts

 
Drives: '11 E92 335is AW/CR/DCT
Join Date: Apr 2011
Location: WI

iTrader: (0)

Mine stumbles as well between 2300 and 3000 rpm during moderate pedal action. So if on highway would be about right speed. I have 6AT and if I get on it it kick's down then no issues.

Have you done your plugs yet...any codes stored?
Appreciate 0
      05-15-2012, 01:30 PM   #3
RVS 8
SDG
RVS 8's Avatar
United_States
24
Rep
2,082
Posts

 
Drives: 335I
Join Date: Nov 2008
Location: New York

iTrader: (10)

It could be your tires, just a thought
__________________
OEM Performance Parts | AirPlay | WAZE
Appreciate 0
      05-15-2012, 02:50 PM   #4
AWD Addict
Chief Executive
AWD Addict's Avatar
35
Rep
2,483
Posts

 
Drives: 2008 335xi 6spd Coupe
Join Date: Dec 2007
Location: Boston

iTrader: (1)

Garage List
2008 335xi  [0.00]
What year xi, and are you on original plugs and injectors?
Appreciate 0
      05-16-2012, 12:30 AM   #5
giaolong
Second Lieutenant
giaolong's Avatar
2
Rep
271
Posts

 
Drives: E92 335xi, Genesis, IS300
Join Date: Jan 2012
Location: Virginia Beach, VA

iTrader: (2)

Bump for this, i did this tonight on the interstate and massive vibration at the same speed. It feels like the car fighting itself....
Appreciate 0
      05-16-2012, 09:29 AM   #6
Patrick719
Lieutenant
Patrick719's Avatar
United_States
4
Rep
421
Posts

 
Drives: Really Fast
Join Date: Jan 2011
Location: Castle Rock, CO

iTrader: (2)

Garage List
Send a message via MSN to Patrick719
+1 for AWD Addict's recommendation. Get your injectors and plugs checked. Misfires at that speed will definitely feel like the car stumbling and fighting itself. Might also want to check the fluid in your diff.
__________________
2010 RRSS Autobiography - #7 resonator delete
2008 335xi Coupe - sold

Appreciate 0
      05-16-2012, 09:31 AM   #7
Timmayy
Private
United_States
0
Rep
50
Posts

 
Drives: 09 E92 335i Blk/Blk xDrive 6MT
Join Date: Mar 2012
Location: Seattle

iTrader: (0)

The way the OP describes it the issue is most likely a misfire, especially given the fact that the plugs and coils are known to be problematic on the N54.
Appreciate 0
      05-16-2012, 11:36 AM   #8
Chrisred
Captain
Chrisred's Avatar
Canada
12
Rep
738
Posts

 
Drives: BMW 335xi coupe
Join Date: Jan 2010
Location: Montreal, Canada

iTrader: (0)

Have same issue as soon as I installed tune. Got weird shaking when tried to press on throttle more then 60%. Car sounded like a Subaru with exhaust with less power. Codes are misfires on 4 5 and 6 cyl. Also on multiple cylinders. Btw i changer sparks like 8 months ago and cyl 2 & 3 injectors and coils
__________________
JB4 cp-e IC AMS exhaust BMS DCI AR DP's METH
19" VMR VB3 Stoptech BBK TC KLINE VORSHLAG
Appreciate 0
      05-16-2012, 05:51 PM   #9
AWD Addict
Chief Executive
AWD Addict's Avatar
35
Rep
2,483
Posts

 
Drives: 2008 335xi 6spd Coupe
Join Date: Dec 2007
Location: Boston

iTrader: (1)

Garage List
2008 335xi  [0.00]
This is well documented on these forums. You need new plugs, and if that doesn't fix it, your injectors are likely toast. Depending on the year of your car, there is a TSB for replacing the old injectors out with a newer version at the dealer's cost under warranty.
Appreciate 0
      05-16-2012, 09:35 PM   #10
giaolong
Second Lieutenant
giaolong's Avatar
2
Rep
271
Posts

 
Drives: E92 335xi, Genesis, IS300
Join Date: Jan 2012
Location: Virginia Beach, VA

iTrader: (2)

I will buy new plugs since my car has 51k miles on it.
What about Coils?

Putting the car back to stock tune for now and see if it happens since i think if it doesnt.....i cant get it fix under warranty if it only happens on JB4 Tune.
Appreciate 0
      05-17-2012, 11:33 AM   #11
Chrisred
Captain
Chrisred's Avatar
Canada
12
Rep
738
Posts

 
Drives: BMW 335xi coupe
Join Date: Jan 2010
Location: Montreal, Canada

iTrader: (0)

If u have tune on the misfires are more apparent. I had slight symptoms and then put tune in and all codes started.
__________________
JB4 cp-e IC AMS exhaust BMS DCI AR DP's METH
19" VMR VB3 Stoptech BBK TC KLINE VORSHLAG
Appreciate 0
      05-17-2012, 02:08 PM   #12
itsmeek
Lieutenant
itsmeek's Avatar
5
Rep
412
Posts

 
Drives: 2009 E90 335xi
Join Date: Mar 2012
Location: DC Metro

iTrader: (3)

Sparkplugs, injectors, fuel pump, valve cleaning in that order.
__________________
1997 Supra TT (900ish hp)
2010 Range Rover Sport
1965 Mustang 302 5 speed!
2010 Prius
Appreciate 0
      05-17-2012, 02:31 PM   #13
Sam335ix
Major
Sam335ix's Avatar
22
Rep
1,275
Posts

 
Drives: 335 ix performance edition
Join Date: Sep 2011
Location: Redskin Country

iTrader: (0)

I had the same problem with 3rd and 4th gear when I had procede installed... but I only had 4000 miles on the car so your issues are different than mine. gl.
__________________
2011 e90 KW V1, JB4, BMS Dp, BMS Intake, CP, Alpina Flash, ISO, E85

Coming soon to the garage: 2014 M3 Maybe M5
Appreciate 0
      06-01-2012, 09:11 AM   #14
krazyking
Lieutenant
4
Rep
478
Posts

 
Drives: '08 E92 BMW 335Xi
Join Date: Jan 2012
Location: Boston, MA

iTrader: (3)

Will the dealer replace injectors under CPO warranty? Not that I think I need to replace mine, but for future reference. Although I've also been experiencing similar symptoms to those of the OP. Will be changing my plugs soon..
__________________
'08 E92 335Xi - Premium, Cold and Sports Packages
JB4 // AFE DCI // Matte Black Grills // MTEC Angel Eyes // CF Mirror Covers // Forgestar F14's
Appreciate 0
      06-04-2012, 02:48 PM   #15
cyndi335icoupe
Registered
1
Rep
2
Posts

 
Drives: 335xicoupe
Join Date: May 2012
Location: n.h.

iTrader: (0)

Thanks for the response

Thanks to all that reponded. The dealer cleaned the valves in cylinders 4-6 and changed the plugs and the problem went away. I guess they pull the intake manifold and clean from there. Said it was a common problem if the car was driven to easy, (low rpm high load).
Appreciate 0
      06-05-2012, 07:31 AM   #16
Timmayy
Private
United_States
0
Rep
50
Posts

 
Drives: 09 E92 335i Blk/Blk xDrive 6MT
Join Date: Mar 2012
Location: Seattle

iTrader: (0)

Glad to hear that they took care of it.
Appreciate 0
      06-07-2012, 05:17 PM   #17
BMW_Belgier
Lieutenant Colonel
BMW_Belgier's Avatar
Switzerland
19
Rep
1,522
Posts

 
Drives: E92 335xi n55
Join Date: May 2012
Location: Switzerland

iTrader: (0)

Quote:
Originally Posted by cyndi335icoupe View Post
Thanks to all that reponded. The dealer cleaned the valves in cylinders 4-6 and changed the plugs and the problem went away. I guess they pull the intake manifold and clean from there. Said it was a common problem if the car was driven to easy, (low rpm high load).
What do they mean with "low rpm high load"? Under 1000, 1200, 1400,...
Appreciate 0
      06-08-2012, 10:22 AM   #18
rongomer
boom
rongomer's Avatar
6
Rep
598
Posts

 
Drives: 335xi
Join Date: Apr 2011
Location: Varies

iTrader: (6)

Quote:
Originally Posted by BMW_Belgier View Post
What do they mean with "low rpm high load"? Under 1000, 1200, 1400,...
It means you drive around in D all the time or short shift the 6MT, these cars need regular high RPM runs and sustained RPMs to burn off the crap on the valves.

I'm at 55k miles and my valves do not need cleaning, I've run meth for ~10k miles but I drive in DS even on the freeway and my car gets a workout to and from work
Appreciate 0
      06-09-2012, 12:47 AM   #19
giaolong
Second Lieutenant
giaolong's Avatar
2
Rep
271
Posts

 
Drives: E92 335xi, Genesis, IS300
Join Date: Jan 2012
Location: Virginia Beach, VA

iTrader: (2)

Quote:
Originally Posted by mykal335xi View Post
It means you drive around in D all the time or short shift the 6MT, these cars need regular high RPM runs and sustained RPMs to burn off the crap on the valves.

I'm at 55k miles and my valves do not need cleaning, I've run meth for ~10k miles but I drive in DS even on the freeway and my car gets a workout to and from work
Lol, same here....the moment the car warmed up to the Temp....work-out start



Also, i had the same stumble problem (Misfire Cylinder #5) and i changed out to new Spark plugs and the problem went away since then.
Appreciate 0
      06-09-2012, 12:48 AM   #20
michaelalex17
Colonel
michaelalex17's Avatar
53
Rep
2,228
Posts

 
Drives: 335xi E92
Join Date: Aug 2010
Location: NY

iTrader: (3)

injectors
Appreciate 0
      06-09-2012, 10:34 AM   #21
antrot
Private First Class
Canada
2
Rep
182
Posts

 
Drives: 11 335i sedan
Join Date: Mar 2009
Location: Toronto/Vaughan

iTrader: (0)

I am also experiencing this...
AT 2011 335i xdrive
I picked up my car brand new and after 200 kms the spark plugs were done
Car wouldnt start.. Apparently they were soaked in fuel

So they changed all of my plugs but now im getting this stumble around 1500-2000 rpm, the shifts seem jerky and its AT with 4400 kms
But I do drive it pretty soft

What should I do before bringing to dealer
Also how can I figure out which spark plug i should fix if they are all brand new
Any help??
Appreciate 0
      06-14-2012, 11:24 AM   #22
Slow89irocz
New Member
0
Rep
22
Posts

 
Drives: 2011 335i xDrive M-Sport
Join Date: May 2012
Location: Chicago, Illinois

iTrader: (0)

I am experienceing this as well. I have a stumble when the car is cold if I accelerate mildly at about 2300rpms. Also I have been noticing a bit of surging if I dont let the car warm up after startup and try to drive off. Any ideas?
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:12 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST