E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Help: Audio system has no sound



Reply
 
Thread Tools Search this Thread
      06-05-2012, 06:35 PM   #1
bogeyorpar
Registered
1
Rep
4
Posts

 
Drives: BMW 2006 330i
Join Date: Jun 2012
Location: WA

iTrader: (0)

Question Help: Audio system has no sound

Hi, I'm new to the forum, so apologize in advance if this question has been answered before.

My car is a BMW 2006 330i 4 door sedan. Recently suddenly the audio system stopped working. I can still turn on radio, CD, Satellite, Aux, and the screen works, but no sound comes out of it. It seems like something muted it. However, I can't find any button or menu item to mute/unmute. Any guidance on how to diagnose and fix the issue?

Another maybe unrelated issue: the muting happens right after I took the car to Costco tire center for a tire rotation. Is it possible during tire rotation they accidentally cut some wire?
Appreciate 0
      06-05-2012, 06:46 PM   #2
mob17
Brigadier General
mob17's Avatar
United Kingdom
79
Rep
3,811
Posts

 
Drives: E92 335D
Join Date: Mar 2012
Location: East Midlands, UK

iTrader: (4)

this might not be the solution and may sound really obvious but try pushing the volume knob in. this mutes and unmutes
__________________
2008 E92 335D SE - Ohlins
2010 E90 320D SE
1994 E36 318I SE
1996 E36 316I SE
Appreciate 0
      06-05-2012, 07:06 PM   #3
just4kickz
boku no namae ha...
United_States
134
Rep
11,038
Posts

 
Drives: 2006 BS 330i
Join Date: Feb 2006
Location: S. Bay Area, CA + Newark, NJ + ChiCity + True Blue

iTrader: (11)

Garage List
2006 E90 330i  [0.00]
Quote:
Originally Posted by mob17 View Post
this might not be the solution and may sound really obvious but try pushing the volume knob in. this mutes and unmutes
hehe.
__________________
looking for a PreLCI Black Sapphire e90 front bumper without license plate holes

"Akimbo shotguns. Broken wrists anyone? And don't give me that 'it's just a game' bull****. Where the **** are my akimbo interventions then?! One scope on each eye mother****er!!"
Appreciate 0
      06-05-2012, 07:43 PM   #4
bogeyorpar
Registered
1
Rep
4
Posts

 
Drives: BMW 2006 330i
Join Date: Jun 2012
Location: WA

iTrader: (0)

Pushing the button will turn audio on/off, but won't mute/unmute when it's on. Any other ideas?
Appreciate 0
      06-05-2012, 08:13 PM   #5
bmw325i
Brigadier General
58
Rep
4,482
Posts

 
Drives: 2006 BMW 325i
Join Date: Oct 2010
Location: United States

iTrader: (6)

I have a logic 7 amp for sale if that ends up being the problem. Not sure how you can be sure that's the problem though.
Appreciate 0
      06-06-2012, 03:05 PM   #6
just4kickz
boku no namae ha...
United_States
134
Rep
11,038
Posts

 
Drives: 2006 BS 330i
Join Date: Feb 2006
Location: S. Bay Area, CA + Newark, NJ + ChiCity + True Blue

iTrader: (11)

Garage List
2006 E90 330i  [0.00]
Quote:
Originally Posted by bogeyorpar View Post
Pushing the button will turn audio on/off, but won't mute/unmute when it's on. Any other ideas?
no idrive? check fuse on amp. if its not the fuse, might be the wiring. if its not the wiring, might need reprogramming. if reprogramming doesn't work, replace the part.
__________________
looking for a PreLCI Black Sapphire e90 front bumper without license plate holes

"Akimbo shotguns. Broken wrists anyone? And don't give me that 'it's just a game' bull****. Where the **** are my akimbo interventions then?! One scope on each eye mother****er!!"
Appreciate 0
      06-06-2012, 03:14 PM   #7
bogeyorpar
Registered
1
Rep
4
Posts

 
Drives: BMW 2006 330i
Join Date: Jun 2012
Location: WA

iTrader: (0)

Yeah, I have no iDrive.

How do I check fuse on amp? Which fuse is it? I looked at the fuse chart but could not understand all the symbols.
Appreciate 0
      06-06-2012, 06:50 PM   #8
dmatre
First Lieutenant
United_States
3
Rep
316
Posts

 
Drives: 2011 328i Sedan
Join Date: Apr 2011
Location: Charlotte, NC

iTrader: (0)

Open the trunk, look down to the left, there is a plastic cover.

Pry the plastic cover off (not hard to do using only your fingers, no tools required).

You are now looking at your amp.

Have someone turn on/off the stereo while you watch/listen for the amp to start.

(I don't have logic7 so I don't know if there's an LED on this amp or not).

It does seem relatively common for logic7 amps to fail.

Best bet would be to check ebay or classifieds here for someone selling one. Replacement path with L7 is more cumbersome than with HiFi.

Good Luck.
Appreciate 0
      06-06-2012, 06:51 PM   #9
bmw325i
Brigadier General
58
Rep
4,482
Posts

 
Drives: 2006 BMW 325i
Join Date: Oct 2010
Location: United States

iTrader: (6)

Is the fan on the amp on?
Appreciate 0
      06-07-2012, 10:58 AM   #10
bogeyorpar
Registered
1
Rep
4
Posts

 
Drives: BMW 2006 330i
Join Date: Jun 2012
Location: WA

iTrader: (0)

I checked the amp. When the radio is turned on, the amp is very quiet, doesn't seem like any fan is on. There is a faint yellow light on the side towards the rear bumper, but I'm not sure if that's from the amp or from some other lighting.

Is there a fuse on the amp? If so, where is it?
Appreciate 0
      06-07-2012, 11:48 AM   #11
ctuna
Brigadier General
45
Rep
4,322
Posts

 
Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

FYI

Repair resources
http://www.e90post.com/forums/showthread.php?t=635672
http://www.bmwgm5.com/Logic7_6941681.htm
http://cgi.ebay.com/ebaymotors/BMW-C...ioQ5fVideo#ht_
http://www.diyparadise.net/bmw_cd73_repair.html
http://www.bmwradiorepair.com/?gclid...FccbQgodIEn0Cg
Appreciate 0
Reply

Bookmarks

Tags
audio system, diagnose, e90, fix, no sound

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:49 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST