E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > CIC System Flickering



Reply
 
Thread Tools Search this Thread
      05-13-2012, 07:46 PM   #1
tcw
Captain
13
Rep
722
Posts

 
Drives: 2008 335i
Join Date: Jan 2012
Location: Atlanta, GA

iTrader: (2)

CIC System Flickering

I retrofitted the CIC into my '08 E92 a while ago. Over the past month the CIC would randomly flicker off and on. It might be off for 1/2 second. The sound of music stops at the same time and a light by the sunroof control flickers as well (SOS light maybe?) Any idea what could cause this? Maybe a loose connection? Or is there any precedence for this happening in other CIC's, I couldn't find any searching. Although it doesn't happen when I hit bumps, it seems completely random. Also it doesn't reboot after the flicker it just resumes where it was, so I don't think its a power issue, but maybe signal.

Any ideas?
__________________
2008 335I E92, AW, VFF700, 18" Forgestar F14, M3 front/side, M-tech rear, AMS IC, H&R Touring Cup Kit suspension, HID AE, ER Charge Pipe & Synapse BOV, CIC Retrofit, Quafie, DSS, Defiv Lockdown, SPEC 2+/Steel SMFW, Walbro 450
Appreciate 0
      05-15-2012, 11:18 AM   #2
Johndong888
John
Johndong888's Avatar
United_States
9
Rep
792
Posts

 
Drives: '12 AW/FR M3 & '14 F15 X5
Join Date: Feb 2008
Location: Cherry Hill, NJ

iTrader: (8)

Send a message via Skype™ to Johndong888
Did you break any of the pins in the CID screen>
__________________

Current - 2012 AW/FR E92 M3 - DCT w EDC, ZPP w Tech, Apps, Enhanced Sound, SAT.
Mods - BPMTune Stg1 + Servo, Piano Black, Euro Visors, OEM Performance CF Spoiler + Grills + Pedals, IND Gloss Blk Pkg, Umnitza V4, ModeCarbon GTS V1 Lip, 19" HRE P40
Sold - 2008 BSM/Black E92 335i - Step, Premium, Sports, Logic7, Comfort, Navi, SAT, Alum.
Appreciate 0
      05-15-2012, 01:45 PM   #3
tcw
Captain
13
Rep
722
Posts

 
Drives: 2008 335i
Join Date: Jan 2012
Location: Atlanta, GA

iTrader: (2)

No. Even if I did that shouldn't stop the radio the same time the screen flickers.
__________________
2008 335I E92, AW, VFF700, 18" Forgestar F14, M3 front/side, M-tech rear, AMS IC, H&R Touring Cup Kit suspension, HID AE, ER Charge Pipe & Synapse BOV, CIC Retrofit, Quafie, DSS, Defiv Lockdown, SPEC 2+/Steel SMFW, Walbro 450
Appreciate 0
      05-15-2012, 03:38 PM   #4
Johndong888
John
Johndong888's Avatar
United_States
9
Rep
792
Posts

 
Drives: '12 AW/FR M3 & '14 F15 X5
Join Date: Feb 2008
Location: Cherry Hill, NJ

iTrader: (8)

Send a message via Skype™ to Johndong888
Quote:
Originally Posted by tcw View Post
No. Even if I did that shouldn't stop the radio the same time the screen flickers.
That's what I thought at first but apparently one of the pins actually carries a sound signal.

Do you have one of those PnP activation modules or is it built into the CIC? I am assuming you double check the connections already.
__________________

Current - 2012 AW/FR E92 M3 - DCT w EDC, ZPP w Tech, Apps, Enhanced Sound, SAT.
Mods - BPMTune Stg1 + Servo, Piano Black, Euro Visors, OEM Performance CF Spoiler + Grills + Pedals, IND Gloss Blk Pkg, Umnitza V4, ModeCarbon GTS V1 Lip, 19" HRE P40
Sold - 2008 BSM/Black E92 335i - Step, Premium, Sports, Logic7, Comfort, Navi, SAT, Alum.
Appreciate 0
      06-11-2012, 01:23 PM   #5
tcw
Captain
13
Rep
722
Posts

 
Drives: 2008 335i
Join Date: Jan 2012
Location: Atlanta, GA

iTrader: (2)

Just came across this:
Some customers reported, that CICEMU sometimes restart itself (CIC LCD screen blinking). This is car power supply noices effect (HID lamps, bad akku etc.). To solve this blinking add 2 additional 10-47uf electrolyt capasitors like in picture:


http://www.codecard.lt/dash/bmw-cic-.../prod_432.html


So I guess I will try this to fix it... as this is the emulator I have.
__________________
2008 335I E92, AW, VFF700, 18" Forgestar F14, M3 front/side, M-tech rear, AMS IC, H&R Touring Cup Kit suspension, HID AE, ER Charge Pipe & Synapse BOV, CIC Retrofit, Quafie, DSS, Defiv Lockdown, SPEC 2+/Steel SMFW, Walbro 450
Appreciate 0
      06-16-2012, 12:54 PM   #6
tcw
Captain
13
Rep
722
Posts

 
Drives: 2008 335i
Join Date: Jan 2012
Location: Atlanta, GA

iTrader: (2)

Soldered the capacitors in today. I will update in a week or so as to if it fixed the flickering.
__________________
2008 335I E92, AW, VFF700, 18" Forgestar F14, M3 front/side, M-tech rear, AMS IC, H&R Touring Cup Kit suspension, HID AE, ER Charge Pipe & Synapse BOV, CIC Retrofit, Quafie, DSS, Defiv Lockdown, SPEC 2+/Steel SMFW, Walbro 450
Appreciate 0
      06-19-2012, 11:48 AM   #7
Johndong888
John
Johndong888's Avatar
United_States
9
Rep
792
Posts

 
Drives: '12 AW/FR M3 & '14 F15 X5
Join Date: Feb 2008
Location: Cherry Hill, NJ

iTrader: (8)

Send a message via Skype™ to Johndong888
Did that fix it for you?
__________________

Current - 2012 AW/FR E92 M3 - DCT w EDC, ZPP w Tech, Apps, Enhanced Sound, SAT.
Mods - BPMTune Stg1 + Servo, Piano Black, Euro Visors, OEM Performance CF Spoiler + Grills + Pedals, IND Gloss Blk Pkg, Umnitza V4, ModeCarbon GTS V1 Lip, 19" HRE P40
Sold - 2008 BSM/Black E92 335i - Step, Premium, Sports, Logic7, Comfort, Navi, SAT, Alum.
Appreciate 0
      06-19-2012, 01:53 PM   #8
bmwretrofit
BimmerPost Supporting Vendor
bmwretrofit's Avatar
Canada
40
Rep
626
Posts


 
Drives: BMW
Join Date: Nov 2010
Location: Canada

iTrader: (0)

Quote:
Originally Posted by tcw View Post
I retrofitted the CIC into my '08 E92 a while ago. Over the past month the CIC would randomly flicker off and on. It might be off for 1/2 second. The sound of music stops at the same time and a light by the sunroof control flickers as well (SOS light maybe?) Any idea what could cause this? Maybe a loose connection? Or is there any precedence for this happening in other CIC's, I couldn't find any searching. Although it doesn't happen when I hit bumps, it seems completely random. Also it doesn't reboot after the flicker it just resumes where it was, so I don't think its a power issue, but maybe signal.

Any ideas?
You use a bad quality CAN Filter Activation module.
Flickering of the screen on the CIC is well known problem for some cheap CAN filters.
Contact with manufacturer and ask for the replacement.
It is not right when the manufacturer is asking you to solder the electronic components on board of their product to get the problem fixed.
Appreciate 0
      06-19-2012, 02:06 PM   #9
tcw
Captain
13
Rep
722
Posts

 
Drives: 2008 335i
Join Date: Jan 2012
Location: Atlanta, GA

iTrader: (2)

Quote:
Originally Posted by bmwretrofit View Post
You use a bad quality CAN Filter Activation module.
Flickering of the screen on the CIC is well known problem for some cheap CAN filters.
Contact with manufacturer and ask for the replacement.
It is not right when the manufacturer is asking you to solder the electronic components on board of their product to get the problem fixed.
Well I bought my CIC from ebay from a guy who was putting his car back to stock to sell (CCC) and it came with this emulator. Also judging from their website I doubt they will stand behind their product and I don't have a purchase receipt for it (outside of ebay.)

As for whether or not the capacitors work... it has flickered once since then which is a big improvement, but I am going to just keep an eye on it for the time being. If need be I guess I could solder on 2 more capacitors in parallel, but we will see.
__________________
2008 335I E92, AW, VFF700, 18" Forgestar F14, M3 front/side, M-tech rear, AMS IC, H&R Touring Cup Kit suspension, HID AE, ER Charge Pipe & Synapse BOV, CIC Retrofit, Quafie, DSS, Defiv Lockdown, SPEC 2+/Steel SMFW, Walbro 450
Appreciate 0
      06-20-2012, 02:13 PM   #10
Patrys@BimmerTech
BimmerPost Supporting Vendor
Patrys@BimmerTech's Avatar
Poland
83
Rep
1,607
Posts


 
Drives: 2007 E92 335i
Join Date: Feb 2009
Location: Warsaw/Poland

iTrader: (7)

Quote:
Originally Posted by tcw View Post
Well I bought my CIC from ebay from a guy who was putting his car back to stock to sell (CCC) and it came with this emulator. Also judging from their website I doubt they will stand behind their product and I don't have a purchase receipt for it (outside of ebay.)

As for whether or not the capacitors work... it has flickered once since then which is a big improvement, but I am going to just keep an eye on it for the time being. If need be I guess I could solder on 2 more capacitors in parallel, but we will see.
The screen flickering can be caused by the CAN module you installed and looking at the picture you posted that seems to be the case.
However in general there might be other reasons why one could have this issue, so if this does not stop even after changing the module you might need some professional help to get this sorted out.

I hope these two capacitors will do the trick for you... good luck!
__________________
BimmerTech
Phone (USA): (646) 439-7920 (7:00am - 3:00pm ET) :: info@bimmer-tech.net :: www.bimmer-tech.net
Installation facilities worldwide.

Appreciate 0
      12-14-2014, 07:35 AM   #11
papajetta
New Member
0
Rep
5
Posts

 
Drives: e46xit e34///M5
Join Date: Nov 2014
Location: nyc

iTrader: (0)

can somebody confirm polarity direction of the caps? i can only see the top one
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:35 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST