E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > e93 instrument cluster not working /headlights and roof



Reply
 
Thread Tools Search this Thread
      07-05-2012, 03:42 PM   #1
willroy69
mark
 
Drives: e93 330d m sport
Join Date: Mar 2011
Location: united kingdom

Posts: 2
iTrader: (0)

e93 instrument cluster not working /headlights and roof

Hi new to all this so here goes.

removed my instrument cluster other dayto replace the plastic screen which was damaged when i bought it .. replaced the screen . ,But only fitted the cluster back after afew days so car was with out instruments (never used vehicle).. when i came to refit and turned on ignition nothing illuminates on dash , basically dead alsothe headlights no longer work and the convertible roof has stopped working ,. Any help appreciated..
willroy69 is offline   United Kingdom
0
Reply With Quote
      07-05-2012, 04:03 PM   #2
N54_Fan
Lieutenant
 
Drives: BMW
Join Date: May 2008
Location: Parts unknown

Posts: 502
iTrader: (0)

Quote:
Originally Posted by willroy69 View Post
Hi new to all this so here goes.

removed my instrument cluster other dayto replace the plastic screen which was damaged when i bought it .. replaced the screen . ,But only fitted the cluster back after afew days so car was with out instruments (never used vehicle).. when i came to refit and turned on ignition nothing illuminates on dash , basically dead alsothe headlights no longer work and the convertible roof has stopped working ,. Any help appreciated..
Obvious thing is to back track and make sure all connections are snug and that any wires are not frayed but i assume you did that. Next check the fuse. If you look at the white card that comes on the back of the glove box it will tell you the fuse number. It sounds like a fuse problem given the high number of things all related to the instrument cluster and lights that are not working. I would check fuses for ignition, lights, instrument panel and roof. That is where I would start.
N54_Fan is offline  
0
Reply With Quote
      07-05-2012, 04:31 PM   #3
willroy69
mark
 
Drives: e93 330d m sport
Join Date: Mar 2011
Location: united kingdom

Posts: 2
iTrader: (0)

Checked fuses for instrument cluster 5amp and roof 20amp all seemed ok will get my meter across them to double check . just seems weird why aload of things would stop worlking .I thought with the cluster being out for a few days it may need coding ,but i dont know ..
willroy69 is offline   United Kingdom
0
Reply With Quote
      07-05-2012, 09:05 PM   #4
N54_Fan
Lieutenant
 
Drives: BMW
Join Date: May 2008
Location: Parts unknown

Posts: 502
iTrader: (0)

Quote:
Originally Posted by willroy69 View Post
Checked fuses for instrument cluster 5amp and roof 20amp all seemed ok will get my meter across them to double check . just seems weird why aload of things would stop worlking .I thought with the cluster being out for a few days it may need coding ,but i dont know ..
I doubt seriously it needs recoding. Sounds like a connection or wire. I would go through it again and check all the ignition fuses too. I suspect there could also be a CAN related bus wire that is loose or connected incorrectly. I was under my dash and accidently disonnected a wire that seemed to lead to a terminal end,..."the wire to no where" and my radio stopped working at the same exact moment. I reconnected it and it worked again. The wire just seems to just end at this terminal but it was critical fo rthe radio.

If you cant figure it out today, sleep on it. Usually that brings clarity for me.

I hope this helps.
N54_Fan is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:08 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST