E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Ipod not working?



Reply
 
Thread Tools Search this Thread
      07-24-2012, 02:57 PM   #1
bb103
Private First Class
2

 
Drives: 08 BMW 328i
Join Date: Apr 2012
Location: Toronto


Posts: 126
iTrader: (0)

Ipod not working?

Hi I have a 08 328i e90 and it has aux and USB. when i try to use the USB with my IPOD and select ipod from the radio it keeps telling me to insert. anyone know about this issue?
Appreciate 0
      07-24-2012, 03:00 PM   #2
bb103
Private First Class
2

 
Drives: 08 BMW 328i
Join Date: Apr 2012
Location: Toronto


Posts: 126
iTrader: (0)

also to add do i need any special cable? or does the regular IPOD cable work?
Appreciate 0
      07-24-2012, 05:49 PM   #3
abgs87
Private
United Kingdom
1

 
Drives: 318d M sport
Join Date: Apr 2012
Location: Reading, UK.


Posts: 58
iTrader: (0)

I just use the aux and select it through controls on my steering wheel and it works just fine
Appreciate 0
      07-24-2012, 05:50 PM   #4
bb103
Private First Class
2

 
Drives: 08 BMW 328i
Join Date: Apr 2012
Location: Toronto


Posts: 126
iTrader: (0)

I just tried and I can't control it though the stearing wheel
Appreciate 0
      07-24-2012, 06:07 PM   #5
BMW_Belgier
Lieutenant Colonel
Switzerland
19

 
BMW_Belgier's Avatar
 
Drives: E92 335xi n55
Join Date: May 2012
Location: Switzerland


Posts: 1,522
iTrader: (0)

Quote:
Originally Posted by bb103 View Post
I just tried and I can't control it though the stearing wheel
You can't control it through the steering wheel when you connect through AUX!

Witch generation of IPod are we talking about?
Appreciate 0
      07-24-2012, 10:47 PM   #6
bb103
Private First Class
2

 
Drives: 08 BMW 328i
Join Date: Apr 2012
Location: Toronto


Posts: 126
iTrader: (0)

Quote:
Originally Posted by BMW_Belgier View Post
You can't control it through the steering wheel when you connect through AUX!

Witch generation of IPod are we talking about?
i believe its 4th gen... well its the newest one. just bought it about 5 months ago.
Appreciate 0
      07-25-2012, 02:29 AM   #7
BMW_Belgier
Lieutenant Colonel
Switzerland
19

 
BMW_Belgier's Avatar
 
Drives: E92 335xi n55
Join Date: May 2012
Location: Switzerland


Posts: 1,522
iTrader: (0)

There are 2 USB contacts (2012 model). 1 in armrest and 1 in the glovebox.

I used my regular IPhone cable and plugged it in in the armrest USB port. It works fine...

Were did you put it in?
Appreciate 0
      07-25-2012, 04:22 AM   #8
J02 335i
Lieutenant Colonel
Canada
17

 
J02 335i's Avatar
 
Drives: E90 335i
Join Date: Aug 2010
Location: Ontario


Posts: 1,538
iTrader: (0)

Quote:
Originally Posted by BMW_Belgier View Post
There are 2 USB contacts (2012 model). 1 in armrest and 1 in the glovebox.

I used my regular IPhone cable and plugged it in in the armrest USB port. It works fine...

Were did you put it in?
I'm assuming the op's car being an 08 just has the AUX (1/8 inch) cable input in the centre storage section.
__________________

Sport pack, JB3, Dci, factory oil cooler, 18" M3 reps, Michelin PSS, painted trim, black grills, smoked side markers, LED plate lights, H&R coils, Borla catback
Appreciate 0
      07-25-2012, 09:34 AM   #9
THE TECH
Lieutenant General
United_States
156

 
THE TECH's Avatar
 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas


Posts: 13,116
iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Gotta use the armrest one.
__________________
Appreciate 0
      07-25-2012, 10:06 AM   #10
JimVR4
Second Lieutenant
United_States
6

 
JimVR4's Avatar
 
Drives: 09 328i M-Sport 6MT
Join Date: Nov 2011
Location: San Jose, CA


Posts: 289
iTrader: (0)

Quote:
Originally Posted by THE TECH View Post
Gotta use the armrest one.
+1. And you need the black BMW branded Y cable, not the apple white cable in your 2008.
__________________
2009 E90 328i ///M-Sport / Blue Water Metallic / Oyster/Black Dakota / PP / 6MT / 194M / Comfort / iPod+USB w/ProClip charging dash mount / $494 /
1995 3000GT Spyder VR4
Appreciate 0
      07-25-2012, 10:23 AM   #11
bb103
Private First Class
2

 
Drives: 08 BMW 328i
Join Date: Apr 2012
Location: Toronto


Posts: 126
iTrader: (0)

Quote:
Originally Posted by JimVR4 View Post
+1. And you need the black BMW branded Y cable, not the apple white cable in your 2008.
ahhh ok i was using the cable that came with the ipod.... and yes I am using the one in the arm rest. any idea where i should get the cable or should i just go to the dealer.... I just checked ebay and saw a few but they were saying that its for systems with I-Drive
Appreciate 0
      07-25-2012, 12:53 PM   #12
JimVR4
Second Lieutenant
United_States
6

 
JimVR4's Avatar
 
Drives: 09 328i M-Sport 6MT
Join Date: Nov 2011
Location: San Jose, CA


Posts: 289
iTrader: (0)

Quote:
Originally Posted by bb103 View Post
ahhh ok i was using the cable that came with the ipod.... and yes I am using the one in the arm rest. any idea where i should get the cable or should i just go to the dealer.... I just checked ebay and saw a few but they were saying that its for systems with I-Drive
The Y cable is independent from I-Drive. The key is to get an authentic one. Some of the knockoffs have not worked for people. Pretty sure I found mine on ebay but I couldn't tell you what seller. I hate that your purchase history disappears after 60 days
__________________
2009 E90 328i ///M-Sport / Blue Water Metallic / Oyster/Black Dakota / PP / 6MT / 194M / Comfort / iPod+USB w/ProClip charging dash mount / $494 /
1995 3000GT Spyder VR4
Appreciate 0
      07-25-2012, 01:48 PM   #13
bb103
Private First Class
2

 
Drives: 08 BMW 328i
Join Date: Apr 2012
Location: Toronto


Posts: 126
iTrader: (0)

I just called BMW $77+Tax for the cable =/
Appreciate 0
      07-25-2012, 04:01 PM   #14
Sweattdogg
Second Lieutenant
2

 
Drives: '09 335d RIP '08 e90 M3
Join Date: Feb 2012
Location: Columbus, OH


Posts: 232
iTrader: (2)

Quote:
Originally Posted by JimVR4 View Post
The Y cable is independent from I-Drive. The key is to get an authentic one. Some of the knockoffs have not worked for people. Pretty sure I found mine on ebay but I couldn't tell you what seller. I hate that your purchase history disappears after 60 days
I cheaped out and bought one from Amazon. Charging is hit or miss so I agree with your statement to buy the original. Buy cheap, buy twice applied to me here.
Appreciate 0
      07-25-2012, 09:34 PM   #15
electro-house
Lieutenant
9

 
electro-house's Avatar
 
Drives: 2008 335i coupe
Join Date: Sep 2010
Location: Phoenix


Posts: 512
iTrader: (0)

It can work without the real cable, but it is better with it because it can load playlists onto the i-drive. Otherwise, you have to control the songs from the ipod which is too much of a hassle.

The cable is $70 at BMW, but $25 I believe on Amazon.
Appreciate 0
      07-25-2012, 09:48 PM   #16
MrCairo
Enlisted Member
0

 
Drives: 2009 BMW 335i
Join Date: Jun 2012
Location: Phoenix, AZ


Posts: 36
iTrader: (0)

Garage List
Quote:
Originally Posted by bb103 View Post
Hi I have a 08 328i e90 and it has aux and USB. when i try to use the USB with my IPOD and select ipod from the radio it keeps telling me to insert. anyone know about this issue?
This may sound simple but have you tried to unplug the USB connector from the Armrest and then plug it back in while the radio was on? I have issues with the iPod being recognized sometimes and this is what I have to do. It actually works best for me to connect the iPod *before* turning on the radio. Other times I have to resort to the unplug and replug the USB process to get it work.

Also make sure that the connector is fully inserted into the iPod itself. Some cases prevent the dock connector from fully making contact.

Beyond that, it could simply be a defective cable.
__________________
2009 335i Sedan / Space Gray Metallic / ZPP / Xenon Adaptive Lights / Steptronic with paddles / Logic7 / AT
2003 Z4 3.0i / Titanium Silver Metallic / Dream Red Leather / Xenon Headlights / 6MT / Super Fun
Appreciate 0
      07-26-2012, 08:58 AM   #17
bb103
Private First Class
2

 
Drives: 08 BMW 328i
Join Date: Apr 2012
Location: Toronto


Posts: 126
iTrader: (0)

Quote:
Originally Posted by MrCairo View Post
This may sound simple but have you tried to unplug the USB connector from the Armrest and then plug it back in while the radio was on? I have issues with the iPod being recognized sometimes and this is what I have to do. It actually works best for me to connect the iPod *before* turning on the radio. Other times I have to resort to the unplug and replug the USB process to get it work.

Also make sure that the connector is fully inserted into the iPod itself. Some cases prevent the dock connector from fully making contact.

Beyond that, it could simply be a defective cable.

I tried all of that with no success... I'm going to prob. just pick it up from bmw. I think this is the most I've paid for some rubber tubes with copper lol
Appreciate 0
      07-26-2012, 10:56 AM   #18
BMW_Belgier
Lieutenant Colonel
Switzerland
19

 
BMW_Belgier's Avatar
 
Drives: E92 335xi n55
Join Date: May 2012
Location: Switzerland


Posts: 1,522
iTrader: (0)

Quote:
Originally Posted by bb103 View Post
I tried all of that with no success... I'm going to prob. just pick it up from bmw. I think this is the most I've paid for some rubber tubes with copper lol
Oh you did! You buyed a BMW
Appreciate 0
      07-26-2012, 12:02 PM   #19
JimVR4
Second Lieutenant
United_States
6

 
JimVR4's Avatar
 
Drives: 09 328i M-Sport 6MT
Join Date: Nov 2011
Location: San Jose, CA


Posts: 289
iTrader: (0)

Quote:
Originally Posted by Aaron Sweat View Post
I cheaped out and bought one from Amazon. Charging is hit or miss so I agree with your statement to buy the original. Buy cheap, buy twice applied to me here.
Hit and miss charging can occur even with the authentic cable due to compatibility issues between BMW variations and the many flavors of ipods and iphones. I believe charging capability is negotiated between the device and the car when you first plug in and it depends on the voltage sensed at the device as to whether charging is enabled. The CableJive solution I have makes sure that charging voltage is sufficient.

Quote:
Originally Posted by MrCairo View Post
This may sound simple but have you tried to unplug the USB connector from the Armrest and then plug it back in while the radio was on? I have issues with the iPod being recognized sometimes and this is what I have to do. It actually works best for me to connect the iPod *before* turning on the radio. Other times I have to resort to the unplug and replug the USB process to get it work.

Also make sure that the connector is fully inserted into the iPod itself. Some cases prevent the dock connector from fully making contact.

Beyond that, it could simply be a defective cable.
I too had issues with USB recognition and had to unplug/plug the USB connection. It was resolved by replacing the USB/Aux socket which was flakey.

Quote:
Originally Posted by bb103 View Post
I tried all of that with no success... I'm going to prob. just pick it up from bmw. I think this is the most I've paid for some rubber tubes with copper lol
I would still consider Amazon. Check reviews and purchase from Amazon direct, not a third party. Then if it doesn't work you can return it for a new one or your money back.
__________________
2009 E90 328i ///M-Sport / Blue Water Metallic / Oyster/Black Dakota / PP / 6MT / 194M / Comfort / iPod+USB w/ProClip charging dash mount / $494 /
1995 3000GT Spyder VR4
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:17 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST