E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > All-Wheel-Drive (Xi / xDrive) Talk > body work done, now have driving issues



Reply
 
Thread Tools Search this Thread
      08-15-2012, 03:04 PM   #1
FrankE90xi
Private First Class
 
FrankE90xi's Avatar
 
Drives: Black 2007 BMW 328xi
Join Date: May 2011
Location: Orland park

Posts: 185
iTrader: (1)

Garage List
2007 BMW 328 xi  [4.20]
body work done, now have driving issues

i took my car in a few weeks ago to get my front bumper hood and grilles replaced and when i got my car back i have a 4x4 light , abs light, and a red brake light, and my sunroof needed to be reset just to open again.My car is a328xi and im now rear wheel drive too. HOWEVER!!!, my battery is also now bad and not holding a charge so im assuming since its 7 years old it is probably bad and just needs to be replaced. does anyone have any idea whats going on. is the car just in limp mode? is the battery the main cause? or do i have a bad servo motor like ive been reading about on the forums
__________________
18" alzor style 703, 20mm rear spacers, 10mm front spacers, 235/40/18 Nitto Neogen, Afe Stage 2 pro5r CAI, Eurocharged tune, Meistershaft catback exhaust, 35% Window Tints, Taillight and Side Marker Tint, Debadge, Blackout Grille, CF Interior kit, Cyba Scoops
FrankE90xi is offline   United_States
0
Reply With Quote
      08-15-2012, 06:13 PM   #2
JaysBlueE92
Mr. Monaco
 
JaysBlueE92's Avatar
 
Drives: Slow..
Join Date: Sep 2008
Location: New Jersey

Posts: 3,804
iTrader: (8)

Garage List
2007 E92  [2.50]
battery could be the problem..did you get it registered?
__________________
JaysBlueE92 is offline   United_States
0
Reply With Quote
      08-15-2012, 06:55 PM   #3
BMW_Belgier
Lieutenant Colonel
 
BMW_Belgier's Avatar
 
Drives: E92 335xi n55
Join Date: May 2012
Location: Switzerland

Posts: 1,519
iTrader: (0)

Quote:
Originally Posted by FrankE90xi View Post
i took my car in a few weeks ago to get my front bumper hood and grilles replaced and when i got my car back i have a 4x4 light , abs light, and a red brake light, and my sunroof needed to be reset just to open again.My car is a328xi and im now rear wheel drive too. HOWEVER!!!, my battery is also now bad and not holding a charge so im assuming since its 7 years old it is probably bad and just needs to be replaced. does anyone have any idea whats going on. is the car just in limp mode? is the battery the main cause? or do i have a bad servo motor like ive been reading about on the forums
You got your car back like that...?

I would have killed somebody...
(just a matter of speaking)
__________________
BEFORE: 130i N52 (2006-2011)
NOW: 335xi N55 (2011- )
BMW_Belgier is offline   Switzerland
0
Reply With Quote
      08-15-2012, 07:02 PM   #4
Amini77
Brigadier General
 
Amini77's Avatar
 
Drives: SGM E90 330xi
Join Date: Nov 2011
Location: Tarzana, CA

Posts: 4,467
iTrader: (1)

Garage List
2006 330XI  [3.75]
Could be a fuse burnt out. I took one of mine out for few minutes to have fun with RWD lol but those signs usually come up when the fuse is out.. so you might want to check that out.
__________________

instagram: amini77
| KW V1 | LCI rear | 359m Style | Michelin PSS | AA Stage 2 | Gruppe M | Remus | Mtech Rear | M3 Front |
Amini77 is offline   United_States
0
Reply With Quote
      08-16-2012, 12:11 AM   #5
FrankE90xi
Private First Class
 
FrankE90xi's Avatar
 
Drives: Black 2007 BMW 328xi
Join Date: May 2011
Location: Orland park

Posts: 185
iTrader: (1)

Garage List
2007 BMW 328 xi  [4.20]
did not register it and i was also thinking fuses im gonna check those in the morning do u remember what fuse it was?
__________________
18" alzor style 703, 20mm rear spacers, 10mm front spacers, 235/40/18 Nitto Neogen, Afe Stage 2 pro5r CAI, Eurocharged tune, Meistershaft catback exhaust, 35% Window Tints, Taillight and Side Marker Tint, Debadge, Blackout Grille, CF Interior kit, Cyba Scoops
FrankE90xi is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:54 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST