E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Coolant leakage! :(



Reply
 
Thread Tools Search this Thread
      08-28-2012, 12:35 AM   #1
VANOS
NFS
 
VANOS's Avatar
 
Drives: 2013 F30 328i Sedan
Join Date: May 2008
Location: N/A

Posts: 118
iTrader: (0)

Alright this is how it happened...

I'm driving on the freeway and my light for the coolant showed it was low. Then the light turned red and the car stopped in the middle of the freeway ( no leak, nothing! The coolant was just low. So I filled her up with some coolant and it seemed to be ok. Later, next day driving it, I noticed how my car seemed a tad slow, didn't pick up as quick as it usually does. And next thing you know, that low coolant light came on, turned red, and this time white smoke came out of the hood and it leaked all over the street! I mean a lot!! And it was brown colored! (

What's going on with my coolant!? Is it a blown head gasket? What is the cause of the problem? Anyone know?

Thanks!
__________________
Guten Tag
VANOS is offline   United_States
0
Reply With Quote
      08-28-2012, 12:37 AM   #2
VANOS
NFS
 
VANOS's Avatar
 
Drives: 2013 F30 328i Sedan
Join Date: May 2008
Location: N/A

Posts: 118
iTrader: (0)

By the way, my entire engine bay was cover all over with coolant! That as well looked brown! :/ It was as if the car went exorcist on me!
__________________
Guten Tag
VANOS is offline   United_States
0
Reply With Quote
      08-28-2012, 12:55 AM   #3
e90328i
Banned
 
Drives: 07 E90 335i
Join Date: May 2011
Location: socal

Posts: 387
iTrader: (4)

Quote:
Originally Posted by VANOS View Post
By the way, my entire engine bay was cover all over with coolant! That as well looked brown! :/ It was as if the car went exorcist on me!
was it dense milky type brown? = blown head gasket
e90328i is offline  
0
Reply With Quote
      08-28-2012, 01:00 AM   #4
VANOS
NFS
 
VANOS's Avatar
 
Drives: 2013 F30 328i Sedan
Join Date: May 2008
Location: N/A

Posts: 118
iTrader: (0)

Yes it was! it looked milky! Aww crap! How much would it cost to repair it?
__________________
Guten Tag
VANOS is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:54 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST