E90Post
 


VIBE Motorsports
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > E90 OverHeating



Reply
 
Thread Tools Search this Thread
      08-14-2012, 12:06 PM   #1
M_POWERED_BMW
New Member
0
Rep
16
Posts

 
Drives: 2006 BMW 325I
Join Date: Jan 2012
Location: Orland Park

iTrader: (0)

E90 OverHeating

Today my sister was taking the e90 to work, it came up (30 minutes into her commute) with the temperature symbol in yellow then turned red. Im planning my approach to this one already (she isnt back from work yet) and Im already assuming water pump but maybe its something else.

Its a 2006 325i with 66K

I have a peake tool that I use for my Z3 however I think Ill need the obd II adapter for it since I dont think the diagnositc port is under the hood as it is on my Z.

Is this the best diagnostic tool? Anyway to check the water pump? Any way to get codes for pump or anything without the peake?

Any Help or tips for things to check would be great! Thanks!
Appreciate 0
      08-14-2012, 12:09 PM   #2
BMW_Belgier
Lieutenant Colonel
BMW_Belgier's Avatar
Switzerland
19
Rep
1,522
Posts

 
Drives: E92 335xi n55
Join Date: May 2012
Location: Switzerland

iTrader: (0)

Quote:
Originally Posted by M_POWERED_BMW View Post
Today my sister was taking the e90 to work, it came up (30 minutes into her commute) with the temperature symbol in yellow then turned red. Im planning my approach to this one already (she isnt back from work yet) and Im already assuming water pump but maybe its something else.

Its a 2006 325i with 66K

I have a peake tool that I use for my Z3 however I think Ill need the obd II adapter for it since I dont think the diagnositc port is under the hood as it is on my Z.

Is this the best diagnostic tool? Anyway to check the water pump? Any way to get codes for pump or anything without the peake?

Any Help or tips for things to check would be great! Thanks!
Could be not just the water pump...

Did you check coolant liquid? Is it dropping fluid? The fan is working? Radiator not leaking?
__________________
BEFORE: 130i N52 (2006-2011)
NOW: 335xi N55 (2011- )
Appreciate 0
      08-14-2012, 12:16 PM   #3
M_POWERED_BMW
New Member
0
Rep
16
Posts

 
Drives: 2006 BMW 325I
Join Date: Jan 2012
Location: Orland Park

iTrader: (0)

T stat also a possibility Im afraid too but Im trying to gather a list for when I am able to look at the car I have a checklist of experience to guide me.

I do have to say, after so long....BMW still has the balls to give us crappy cooling systems.....
Appreciate 0
      08-14-2012, 12:20 PM   #4
BMW_Belgier
Lieutenant Colonel
BMW_Belgier's Avatar
Switzerland
19
Rep
1,522
Posts

 
Drives: E92 335xi n55
Join Date: May 2012
Location: Switzerland

iTrader: (0)

Quote:
Originally Posted by M_POWERED_BMW View Post
T stat also a possibility Im afraid too but Im trying to gather a list for when I am able to look at the car I have a checklist of experience to guide me.

I do have to say, after so long....BMW still has the balls to give us crappy cooling systems.....
Even the newly build ones suffer from old problems...

Red lights are never good! Wouldn't drive it anymore...
__________________
BEFORE: 130i N52 (2006-2011)
NOW: 335xi N55 (2011- )
Appreciate 0
      08-14-2012, 01:26 PM   #5
M_POWERED_BMW
New Member
0
Rep
16
Posts

 
Drives: 2006 BMW 325I
Join Date: Jan 2012
Location: Orland Park

iTrader: (0)

Yeah shes just trying to get home and she says it went off so I told her that as soon as yellow hits, she should be on the side of the road.....Idc if it takes 2 hours to get home....bring it back without a melted block. (Commute is only 15 minutes away so well see in 3-4 hours how it goes.
Appreciate 0
      08-14-2012, 05:12 PM   #6
Whit
Private
Whit's Avatar
United_States
0
Rep
83
Posts

 
Drives: 06' 325i, 09' X5 30i, 67' 912
Join Date: Jul 2012
Location: Nor Cal

iTrader: (1)

Garage List
2006 BMW 325i  [0.00]
Test the water pump by running it through the venting procedure. It will be obvious by the sound and amount of water you can hear it pushing whether it is working.
__________________
Whit
Northern Nor Cal

Last edited by Whit; 08-14-2012 at 07:17 PM.
Appreciate 0
      08-14-2012, 07:01 PM   #7
TheTal0n
Lieutenant
TheTal0n's Avatar
9
Rep
535
Posts

 
Drives: 2006 330i
Join Date: Sep 2011
Location: Utah

iTrader: (0)

Should go into limp mode, and if it does she better pull over or suffer the consequences.
Appreciate 0
      08-15-2012, 12:57 AM   #8
mike3000fl
Colonel
mike3000fl's Avatar
United_States
49
Rep
2,435
Posts

 
Drives: 06 330i
Join Date: Feb 2010
Location: Tampa

iTrader: (0)

Quote:
Originally Posted by Whit View Post
Test the water pump by running it through the venting procedure. It will be obvious by the sound and amount of water you can hear it pushing whether it is working.


__________________
2006 330i - Jet Black - 19" E46 M3 wheels - HR Sport - 206,000 Miles...

Appreciate 0
      08-15-2012, 10:23 AM   #9
M_POWERED_BMW
New Member
0
Rep
16
Posts

 
Drives: 2006 BMW 325I
Join Date: Jan 2012
Location: Orland Park

iTrader: (0)

WHats the venting procedure? Too many results for "water pump test"
Appreciate 0
      08-15-2012, 11:18 AM   #10
gatoracer
Private First Class
gatoracer's Avatar
United_States
1
Rep
106
Posts

 
Drives: '07 335i MT
Join Date: Apr 2012
Location: Jax, FL

iTrader: (1)

Here is procedure. Starts at step 17.
http://www.e90post.com/forums/showthread.php?t=248187
__________________
Appreciate 0
      08-15-2012, 03:38 PM   #11
HVYWGHT
Private First Class
HVYWGHT's Avatar
United_States
3
Rep
111
Posts

 
Drives: 2012 E91 328i
Join Date: Jul 2007
Location: Brookline, MA

iTrader: (0)

Most likely the water pump and thermostat. Went on my E90 at 74k miles on Christmas Eve in the middle of nowhere NH. Very common.
__________________
-'15 BMW 335i xDrive (F30): Black Saphire, Oyster, DHP, ZPP, ZSL, 6 MT; En route!
-'12 BMW 328i (E91): Tasman Green, Oyster, Premium, Sport, Auto; 6/26/2012-
-'06 BMW 325i (E90): Arctic, Grey, Premium, Auto; 7/2009-5/2012
-'04 MINI Cooper (R50): Indi Blue w/White Top, Black, Cold Weather, Manual; 1/2/2004-
Appreciate 0
      08-15-2012, 11:23 PM   #12
JDM2BMW
Registered
0
Rep
2
Posts

 
Drives: 2006 325i
Join Date: Aug 2012
Location: East Coast

iTrader: (0)

I have a 2006 325i. This problem happened to me last week (yellow thermostat light changing to red), and fan making all kinds of noises with engine on or off. Waterpump failed, thermostat changed at same time. Do not drive the car. Get it towed to service. Common issue.
Appreciate 0
      08-15-2012, 11:28 PM   #13
2ndname
Autobot
2ndname's Avatar
4
Rep
454
Posts

 
Drives: E90 325i Auto~NO~Go
Join Date: Apr 2012
Location: East Bay

iTrader: (1)

Garage List
2006 BMW 325i  [5.00]
Same thing happened to me, limp mode and everything. It's your water pump and thermostat.
__________________
Appreciate 0
      08-16-2012, 12:01 AM   #14
forever_speed
First Lieutenant
forever_speed's Avatar
United_States
4
Rep
390
Posts

 
Drives: 06 325i Jet Black
Join Date: Oct 2011
Location: Reston, VA

iTrader: (2)

Garage List
2006 BMW 325i  [0.00]
I just had this happen to me while on 95 from nothern VA to Brooklyn -4 hour trip. My car lost power to around 50% i was going 80 and slowedd dow to a max speed of 35. My anti freeze was not mixed properly and was low. I had to bleed the system and do 50/50 water and fluid

Edit: my car is a 2006 e90 325i with 73 miles
__________________
LC 818|35% tints|Coding|Blackline|LS3 AA- Full Blackout |HID fogs| AA tune stage 2|Muffler Delete

Last edited by forever_speed; 08-16-2012 at 12:02 AM. Reason: Incorrect
Appreciate 0
      08-16-2012, 12:22 AM   #15
thecoupe335
Private First Class
thecoupe335's Avatar
United_States
4
Rep
137
Posts

 
Drives: 2007 335i coupe
Join Date: Aug 2011
Location: Sarasota, Florida

iTrader: (1)

Quote:
Originally Posted by 2ndname View Post
Same thing happened to me, limp mode and everything. It's your water pump and thermostat.
+2^^^

my girls 06 325i is at the shop getting new water pump and thermostat right now bc of the same issue. her car has 63k miles on it
Appreciate 0
      09-20-2012, 03:01 PM   #16
JRINNS
Private First Class
JRINNS's Avatar
United Kingdom
1
Rep
128
Posts

 
Drives: Audi A5 Cab and Jag XJ
Join Date: Jan 2008
Location: UK

iTrader: (0)

Garage List
Well my trusty steed 325i e90 with 145k on the clock has just broken down, no doubt wear and tear to the wp and tstat. Not bad though 144k 2006 and all thats gone wrong is this and a spark plug/coil pack.
__________________
BMW E90 325i MSport 146000 and counting - Gone and will be missed.
Range Rover Evoque White Dynamic - Gone
Audi A5 Cab
+ 1 more undecided.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:11 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST