E90Post
 


GTB Performance
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Car overheating???



Reply
 
Thread Tools Search this Thread
      09-06-2012, 05:22 PM   #1
Blk33zeroxi
Private First Class
 
Drives: 335xi coupe
Join Date: Mar 2011
Location: NJ

Posts: 136
iTrader: (0)

Car overheating???

So my car is acting very odd. out of no where the engine overheating warning is coming on the fans kick in, it sounds like a jet engine and my car goes limp. the actual temp gauge in my car is reading 160-200 and the engine doesnt feel hot at all what can the issue be right now I'm stuck at work and I don't know what to do because it won't drive.... Is it a faulty sensor can I get reset it do I can drive home?? Please help
Blk33zeroxi is offline  
0
Reply With Quote
      09-06-2012, 05:26 PM   #2
GoRomeo
Colonel
 
GoRomeo's Avatar
 
Drives: 330i
Join Date: Feb 2006
Location: San Diego CA

Posts: 2,230
iTrader: (0)

Garage List
2006 330i  [2.83]
If its overheating dont drive it. Have it towed to a shop asap. Most likely is the water pump/thermostat. hopefully im wrong. Good luck and keep us posted.
GoRomeo is offline  
0
Reply With Quote
      09-06-2012, 07:05 PM   #3
husks002
Second Lieutenant
 
husks002's Avatar
 
Drives: E92 M3
Join Date: Nov 2011
Location: Los Angeles

Posts: 258
iTrader: (1)

99.99% positive it is the water pump. get it towed to the dealer and they will tell you.
husks002 is offline   United_States
0
Reply With Quote
      09-06-2012, 07:13 PM   #4
Verbatim
Colonel
 
Verbatim's Avatar
 
Drives: 2008 335i
Join Date: Sep 2010
Location: at the repair shop

Posts: 2,555
iTrader: (0)

Garage List
2008 BMW 335i  [5.00]
the temperatures that you are seeing (160-200) are the oil temps, not the water temps.
how many miles on the car? water pumps are pretty much maintenance items on the 3 series
__________________

2008 BMW 335i Sedan | Sparkling Graphite | Sport | Premium | Navigation | Comfort Access | Logic7
Golf Tee | M3 Spoiler | LED Angel Eyes | 5000k Fogs | Resonator Delete | Black Kidney Grills | Black Finisher Rods | 35%/18% Tint |12mm/20mm (F/R) Spacers | Black Lines


Verbatim is offline   United_States
0
Reply With Quote
      09-06-2012, 07:33 PM   #5
BMW_Belgier
Lieutenant Colonel
 
BMW_Belgier's Avatar
 
Drives: E92 335xi n55
Join Date: May 2012
Location: Switzerland

Posts: 1,522
iTrader: (0)

Quote:
Originally Posted by husks002 View Post
99.99% positive it is the water pump. get it towed to the dealer and they will tell you.
It sounds like it...
__________________
BEFORE: 130i N52 (2006-2011)
NOW: 335xi N55 (2011- )
BMW_Belgier is offline   Switzerland
0
Reply With Quote
      09-06-2012, 07:39 PM   #6
O HELLA BMW
I <3 My E93
 
O HELLA BMW's Avatar
 
Drives: 08 335i vert
Join Date: Nov 2010
Location: PA

Posts: 3,138
iTrader: (21)

im 100% sure its your water pump...how many miles you have? im at 67,xxx miles and my water pump went bad and i had the engine overheating warning lights come on and yes my car sounded like a jet engine bc the fan noise was super loud...

if your not under warranty thats a $1,200 fix....GOOD LUCK
__________________
08 BMW 335i E93
**Stance will make B!tches Dance**
CCW LM5T
O HELLA BMW is offline   United_States
0
Reply With Quote
      09-06-2012, 09:21 PM   #7
2ndname
Autobot
 
2ndname's Avatar
 
Drives: E90 325i Auto~NO~Go
Join Date: Apr 2012
Location: East Bay

Posts: 454
iTrader: (1)

Garage List
2006 BMW 325i  [5.00]
Yes, 100% sure that it's your water pump. Same exact symptoms that I experienced.
__________________
2ndname is offline  
0
Reply With Quote
      09-06-2012, 10:32 PM   #8
Vegetable
Lieutenant
 
Vegetable's Avatar
 
Drives: 435i M-Sport MT
Join Date: Jun 2012
Location: Nor Cal

Posts: 437
iTrader: (0)

Quote:
Originally Posted by Blk33zeroxi View Post
So my car is acting very odd. out of no where the engine overheating warning is coming on the fans kick in, it sounds like a jet engine and my car goes limp. the actual temp gauge in my car is reading 160-200 and the engine doesn't feel hot at all what can the issue be right now I'm stuck at work and I don't know what to do because it won't drive.... Is it a faulty sensor can I get reset it do I can drive home?? Please help

. your oil temp gauge is reading only 160-200? That is super low. Mine runs 230 all day long.
Vegetable is offline   United_States
0
Reply With Quote
      09-06-2012, 10:45 PM   #9
Blk33zeroxi
Private First Class
 
Drives: 335xi coupe
Join Date: Mar 2011
Location: NJ

Posts: 136
iTrader: (0)

just got it towed to the shop seems like just in parts a new water pump is around $600 this is not going tot be fun i have 57k miles so nope my car is no longer covered
Blk33zeroxi is offline  
0
Reply With Quote
      09-06-2012, 10:58 PM   #10
2ndname
Autobot
 
2ndname's Avatar
 
Drives: E90 325i Auto~NO~Go
Join Date: Apr 2012
Location: East Bay

Posts: 454
iTrader: (1)

Garage List
2006 BMW 325i  [5.00]
Find an independent shop if possible and shop around now that you know that it is indeed the WP.
__________________
2ndname is offline  
0
Reply With Quote
      09-07-2012, 10:49 PM   #11
335beeeemer
Private First Class
 
335beeeemer's Avatar
 
Drives: 2008 335 i convertible
Join Date: Oct 2010
Location: nj

Posts: 100
iTrader: (0)

Mine just did the same thing 80,000 miles. Water pump. $1200! I need the loaner so whatever I would save on Indy shop I would spend on rental.
335beeeemer is offline  
0
Reply With Quote
      09-08-2012, 02:59 AM   #12
2ndname
Autobot
 
2ndname's Avatar
 
Drives: E90 325i Auto~NO~Go
Join Date: Apr 2012
Location: East Bay

Posts: 454
iTrader: (1)

Garage List
2006 BMW 325i  [5.00]
The good thing is that all e90 will experience this at around the 80K miles, might as well chalk it up as part of preventative maintenance. I know there are the lucky few who managed to clock 150K+ miles on the original water pump but I'm not one of them, haha.
__________________
2ndname is offline  
0
Reply With Quote
      09-13-2012, 07:28 PM   #13
princessvee_888
Private
 
princessvee_888's Avatar
 
Drives: 2008 335xi
Join Date: Feb 2011
Location: kirkland, wa

Posts: 55
iTrader: (0)

this happened to me yesterday.
did you figure out what happened? cause my cars in the shop right now and they can't figure out what's going on.
princessvee_888 is offline   United_States
0
Reply With Quote
      09-22-2012, 04:36 PM   #14
Blk33zeroxi
Private First Class
 
Drives: 335xi coupe
Join Date: Mar 2011
Location: NJ

Posts: 136
iTrader: (0)

yet it was the water pump $858
Blk33zeroxi is offline  
0
Reply With Quote
      09-22-2012, 05:16 PM   #15
tsensational
New Member
 
Drives: 328i Coupe
Join Date: Sep 2012
Location: United States

Posts: 9
iTrader: (0)

80k is around the time alot of accessories break down for many cars, ie water pump, power steering etc. If you can source your own parts (pump, gasket, O-rings, coolant etc) and have decent mechanical skills, you can do it yourself and save a bit on labor.
tsensational is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:23 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST