E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > 29D1 misfire/SES, only code thrown



Reply
 
Thread Tools Search this Thread
      09-23-2012, 09:33 AM   #1
stratplaya06
Captain
stratplaya06's Avatar
United_States
11
Rep
886
Posts

 
Drives: 2008 E92 335xi
Join Date: May 2008
Location: Maryland

iTrader: (7)

29D1 misfire/SES, only code thrown

Hey guys,

I have been fighting with a misfire issue on my car for about two weeks now, and I am really fed up with it.

Here's what's going on:
-Accelerating to 4500 rpm with gas floored, the car will have small shudders in power but will not throw lights.
-Above 4500rpm, the car will shudder harder and at about 5k it'll throw an SES and shut the cylinder down.
-Now: the only code that shows up is 29d1: misfire cylinder 5
In the past two weeks I have done:
-Carbon buildup cleaning
-Spark plug change
-Move coils between cylinders (Still 29d1, didn't move with the coil movement)
-Move injectors between cylinders (Again, cylinder 5)
-Remove procede, problem still exists

I was able to do one pull last night after taking the tune off, and at that point the car had just passed 160*F oil temp. The pull was very smooth and I thought I had the issue fixed until I tried again and then the problem reared its ugly head just as it did before. That is what has me convinced that there is no internal engine damage.

I have searched for days on forums for this, and most posts have other codes associated, or problems that followed coils. Those threads also mentioned bad ECU components (lots of other codes thrown in that case), and O2 sensor failure (again, other codes thrown). The only thread to mention ONLY 29D1 codes ended up being fixed by the carbon cleaning, but obviously I have already done this.

Any other ideas? How would I diagnose a bad injector/coil driver in the DME? I was thinking that I might send it to vishnu for them to do the flexfuel flash, provided they can confirm that the DME is working perfectly (mechanically speaking) before changing the programming, but I would rather just probe the DME components myself.
__________________

| PROcede Rev3 | Vishnu Meth | DCI | BMW Perf. Exhaust | AR Coated/Catless | CP-E FMIC | Quaife |
Appreciate 0
      09-23-2012, 10:00 AM   #2
cn555ic
BimmerPost Supporting Vendor
cn555ic's Avatar
United_States
246
Rep
18,287
Posts


 
Drives: Bimmerscoding.com
Join Date: Jun 2007
Location: New York

iTrader: (5)

Send a message via Yahoo to cn555ic
Dzenno went Through similar issues and found out it was this: hope this is not your case but look at the other forums to find his post on it


Camshaft rectangrings and cam bearing ledges were broken/worn.


It can possibly be another issue as you stated it did this also in stock. Dzenno issue happens at high rpm which boost is greater than 13psi.
__________________
917-939-4980 CODING E and F Series New York Area


Last edited by cn555ic; 09-23-2012 at 10:13 AM.
Appreciate 0
      09-28-2012, 01:30 PM   #3
stratplaya06
Captain
stratplaya06's Avatar
United_States
11
Rep
886
Posts

 
Drives: 2008 E92 335xi
Join Date: May 2008
Location: Maryland

iTrader: (7)

Thanks for the reply. I have been examining the car some more today and here are my findings:

The ECU components probe out similarly, with no real outliers.
I cleaned the vanos solenoids and reinstalled
I drove the car and found that the problem only exists in 3rd gear, and that I am able to accelerate to redline on 1st and 2nd with no trouble.

Anyone have similar experiences?
__________________

| PROcede Rev3 | Vishnu Meth | DCI | BMW Perf. Exhaust | AR Coated/Catless | CP-E FMIC | Quaife |
Appreciate 0
      09-28-2012, 02:55 PM   #4
JamesM3M5
Some dude
United_States
24
Rep
1,760
Posts

 
Drives: E28 M5, E92 335i
Join Date: Sep 2011
Location: Northern VA

iTrader: (0)

If you have an oscilloscope, you can view the coil firing and injector firing waveforms. That will help determine whether it's a bad driver in the ECU or maybe just flaky wiring.

There are several threads on cylinder 5 misfires. Seems to be a common problem. Just had another 335i w/ PPK tune only throwing misfires on 2 and 5 on cold start. That one might be a simple injector issue, will find out next week when it comes back.

So - the problem might be crankcase vent (PCV) related. Themyst has commented on valve cover gasket issues, and Rob Beck has developed an upgraded PCV valve for $45. Might want to uprade to the Rob Beck PCV valve (which just happens to sit right on top of cylinder 5 in the valve cover) and replace the valve cover gasket. Also use a high quality sealant on the gasket around the ports from the PCV in the VC to the cylinder head. It is plausible that a leak can suck lots of excess oil into the ports, especially cylinder 5 due to the location of the PCV valve and the channel that runs into each individual intake port.

My ports were quite wet with oil, and there were black tar balls on the #5 valve stems - this is after only 15k miles since I last cleaned them a year ago! Looks like PCV could easily be to blame for the oil, and possibly the cause of weird misfires that seem to be most common on cylinder 5.
__________________
RRT Racing
E92 335i/6MT Dinan Stage 3: intercooler, oil cooler, intake, flash, exhaust, LW dual-mass flywheel.
Vishnu PWM methanol custom trunk mount, Diffsonline 3-clutch Salisbury custom diff, Ohlins Road and Track coilovers, Vorshlag camber plates, much more...
E28 M5 w/ buncha stuff, R171 SLK350
Appreciate 0
      09-28-2012, 04:01 PM   #5
Renus
Lieutenant
Renus's Avatar
5
Rep
524
Posts

 
Drives: E92 335i
Join Date: Oct 2009
Location: Hong Kong

iTrader: (1)

Quote:
Originally Posted by stratplaya06 View Post
Hey guys,

I have been fighting with a misfire issue on my car for about two weeks now, and I am really fed up with it.

Here's what's going on:
-Accelerating to 4500 rpm with gas floored, the car will have small shudders in power but will not throw lights.
-Above 4500rpm, the car will shudder harder and at about 5k it'll throw an SES and shut the cylinder down.
-Now: the only code that shows up is 29d1: misfire cylinder 5
In the past two weeks I have done:
-Carbon buildup cleaning
-Spark plug change
-Move coils between cylinders (Still 29d1, didn't move with the coil movement)
-Move injectors between cylinders (Again, cylinder 5)
-Remove procede, problem still exists

I was able to do one pull last night after taking the tune off, and at that point the car had just passed 160*F oil temp. The pull was very smooth and I thought I had the issue fixed until I tried again and then the problem reared its ugly head just as it did before. That is what has me convinced that there is no internal engine damage.

I have searched for days on forums for this, and most posts have other codes associated, or problems that followed coils. Those threads also mentioned bad ECU components (lots of other codes thrown in that case), and O2 sensor failure (again, other codes thrown). The only thread to mention ONLY 29D1 codes ended up being fixed by the carbon cleaning, but obviously I have already done this.

Any other ideas? How would I diagnose a bad injector/coil driver in the DME? I was thinking that I might send it to vishnu for them to do the flexfuel flash, provided they can confirm that the DME is working perfectly (mechanically speaking) before changing the programming, but I would rather just probe the DME components myself.


Maybe you need new coils, after you moved coil to each other, the misfire remain on cylinder 5 or changed?
Appreciate 0
      09-28-2012, 05:16 PM   #6
stratplaya06
Captain
stratplaya06's Avatar
United_States
11
Rep
886
Posts

 
Drives: 2008 E92 335xi
Join Date: May 2008
Location: Maryland

iTrader: (7)

The misfire remained on cylinder 5 despite moving coils and injectors.

Interesting thought about the PCV. When I did the carbon buildup I expected terrible amounts (did it at about 80k), but it wasn't as bad as some of those that I have seen on the forum. I was running a catch can for a while but took it off when the reports of restriction came out. I have inspected the valve cover for oil seepage and can't find anything, what else would be a sign of a bad gasket? I am definitely up for trying rob beck's PCV valve, can someone PM me a link to where he sells them? Can't seem to find it myself.

Thanks for the help guys. I really like the oscilloscope idea, and my mechanic friend has an old one that I am going to ask him if we can try.
__________________

| PROcede Rev3 | Vishnu Meth | DCI | BMW Perf. Exhaust | AR Coated/Catless | CP-E FMIC | Quaife |
Appreciate 0
      10-10-2012, 05:10 PM   #7
BostonBeemah
The Stig
BostonBeemah's Avatar
Armenia
4
Rep
391
Posts

 
Drives: AW 135i 6spd
Join Date: Sep 2011
Location: Belmont, Ma

iTrader: (2)

any updates? im having similar issues...
__________________

RIP 2008 AW/BL 135illMods: JB4 G5 ISO, 2Step, Raceland DPs,Turbo Back Straight Pipes, BMS DCI, ER CP, HKS BOV, CM10 + CM14 METH, P3 Vent Gauge
Dragstrip: 1.81 60ft 12.2@113 NO METHDynoDayhttp://www.n54tech.com/forums/showthread.php?t=15337
Appreciate 0
      11-02-2012, 12:29 PM   #8
Prazision
Private
1
Rep
79
Posts

 
Drives: 2007 335i Auto
Join Date: Mar 2011
Location: Boston

iTrader: (0)

bump this up, I too have been having similar issues, replaced under CPO warranty the following : injector 5, injector 5 coil, both vanos solenoids.
Still nothing for me.
Appreciate 0
      01-14-2013, 07:35 PM   #9
saxon
First Lieutenant
5
Rep
323
Posts

 
Drives: 07 335i
Join Date: Oct 2011
Location: pa

iTrader: (2)

it is absolutely crazy how many cylinder 5 misfires are out there, whoever figures this out will surely get a paypal contribution from me!
Appreciate 0
      01-15-2013, 09:38 AM   #10
TexE90
Banned
2
Rep
135
Posts

 
Drives: 2007 335i E90
Join Date: Nov 2012
Location: United States

iTrader: (1)

Are you all driving '07 335is around the same build period?
Appreciate 0
      01-15-2013, 12:58 PM   #11
NTXE92
Enlisted Member
0
Rep
36
Posts

 
Drives: 2009 335i
Join Date: Jan 2013
Location: Plano

iTrader: (0)

Did you let the DME know you swapped injectors?
Appreciate 0
      01-15-2013, 01:58 PM   #12
David1
Colonel
David1's Avatar
United_States
28
Rep
2,664
Posts

 
Drives: 09 E92 09 X5
Join Date: Mar 2007
Location: City With No Room For Ludicris Speed!

iTrader: (0)

Quote:
Originally Posted by NTXE92 View Post
Did you let the DME know you swapped injectors?
Yup, you cant just move the injector and I hope he put a new seals and couplers on them.
__________________
09 335i Coupe LBM - Black Dakota/Glacier aluminum-6spd|Nav|M-Sport|Premium|Logic7|Heated Seats|CA|BMW Performance Suspension & M3 Control Arms|M3 lip spoiler|Avant Garde M510 Wheels
07 335 coupe - Sold
Appreciate 0
      01-15-2013, 07:29 PM   #13
saxon
First Lieutenant
5
Rep
323
Posts

 
Drives: 07 335i
Join Date: Oct 2011
Location: pa

iTrader: (2)

Quote:
Originally Posted by TexE90 View Post
Are you all driving '07 335is around the same build period?
10/06 build here
Appreciate 0
      07-26-2013, 08:31 AM   #14
j_syk
New Member
United_States
0
Rep
10
Posts

 
Drives: 08 335xi e92
Join Date: May 2013
Location: Lake Geneva, WI

iTrader: (0)

Garage List
I know this is a bit old, but I'm having very similar problems with an '08. Did you find any resolution? Did you buy that PCV valve?
Appreciate 0
      07-26-2013, 08:39 AM   #15
Timore
Private
Timore's Avatar
United_States
0
Rep
65
Posts

 
Drives: 2012 335is
Join Date: Mar 2007
Location: Bergen County, NJ

iTrader: (0)

Garage List
2012 BMW 335is  [5.00]
I get an occasional cylinder 5 misfire on cold start. Otherwise the car runs great. No idea what could be causing this.
__________________
2012 335is Sapphire Black/Red Dakota
COBB Protune | AFE DCI | AWE BOVs | BMS Downpipes | ETS FMIC

If you dont know... !
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:21 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST