E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > Error code P0440 ?



Reply
 
Thread Tools Search this Thread
      09-23-2012, 03:14 PM   #1
kiwi29
Team iTouge
kiwi29's Avatar
United_States
35
Rep
2,074
Posts

 
Drives: 09 M-Tech 328i
Join Date: Jul 2011
Location: Long Beach, CA

iTrader: (9)

Error code P0440 ?

Just the other day I had an error code that sent a CEL on active, I scanned the code with an OBD2 reset/scan tool and it said code P0440. When I looked it up in the manual, it said malfunction with the evaporate emissions system. My question is what could that be? Is it major or could it have been a gas cap malfunction? I was able to reset the code and erase it and it never reappeared. (Its been about 1 week) I just wanted to make sure that nothing was wrong with it. Any help will be greatly appreciated!
__________________
Quote:
Originally Posted by The HACK View Post
I'm going to use a very simple analogy, I hope you'll understand.
Driving is like having sex.
It really is. You can read up all you want about how to please a woman, you can look at all the diagrams in the world, but just like the clitoris, you won't know what the hell an apex is before you actually find it.
Appreciate 0
      09-23-2012, 04:39 PM   #2
josephbet01
Private First Class
2
Rep
111
Posts

 
Drives: E93 328i
Join Date: Oct 2010
Location: York, PA

iTrader: (0)

There's an electric pump that pressure tests the system for leaks whenever the car "wakes up". You may hear it cycle quickly when you open the door first thing in the morning.

I believe I posted a pic of this pump at one point. It's located inside the passenger side rear wheel well under the plastic shield. Its called a DTML Pump. Worth about $100 and takes about an hour start to finish. Easy job.

http://www.e90post.com/forums/showthread.php?t=260065


If its not a loose gas cap this would be my bet.
Appreciate 0
      09-23-2012, 06:39 PM   #3
kiwi29
Team iTouge
kiwi29's Avatar
United_States
35
Rep
2,074
Posts

 
Drives: 09 M-Tech 328i
Join Date: Jul 2011
Location: Long Beach, CA

iTrader: (9)

Quote:
Originally Posted by josephbet01 View Post
There's an electric pump that pressure tests the system for leaks whenever the car "wakes up". You may hear it cycle quickly when you open the door first thing in the morning.

I believe I posted a pic of this pump at one point. It's located inside the passenger side rear wheel well under the plastic shield. Its called a DTML Pump. Worth about $100 and takes about an hour start to finish. Easy job.

http://www.e90post.com/forums/showthread.php?t=260065


If its not a loose gas cap this would be my bet.
Thank you, but do you think that this would send an emissions code?
__________________
Quote:
Originally Posted by The HACK View Post
I'm going to use a very simple analogy, I hope you'll understand.
Driving is like having sex.
It really is. You can read up all you want about how to please a woman, you can look at all the diagrams in the world, but just like the clitoris, you won't know what the hell an apex is before you actually find it.
Appreciate 0
      09-23-2012, 07:14 PM   #4
josephbet01
Private First Class
2
Rep
111
Posts

 
Drives: E93 328i
Join Date: Oct 2010
Location: York, PA

iTrader: (0)

If it fails? Of course. There are a few threads here where people have seen them fail. It throws a check engine light.
Appreciate 0
      09-24-2012, 04:00 AM   #5
1QuikWS6
No 55mph
1QuikWS6's Avatar
United_States
67
Rep
4,801
Posts

 
Drives: 09 E92 328iX N51 3-Stage ->M6
Join Date: Jul 2009
Location: Blitzburgh, PA

iTrader: (83)

Garage List
Sometimes that code is thrown for the simple fact that the gas cap has not been put back on correctly as you surmised.

Take off cap, put back on and give it a couple 'clicks' see if the problem goes away. It could also be that the cap is bad & needs replaced.

I always start with the least expensive/involved items on the diagnostic tree before moving on to the more $$

Last edited by 1QuikWS6; 09-24-2012 at 04:10 AM.
Appreciate 0
      09-24-2012, 06:45 PM   #6
kiwi29
Team iTouge
kiwi29's Avatar
United_States
35
Rep
2,074
Posts

 
Drives: 09 M-Tech 328i
Join Date: Jul 2011
Location: Long Beach, CA

iTrader: (9)

Quote:
Originally Posted by josephbet01 View Post
If it fails? Of course. There are a few threads here where people have seen them fail. It throws a check engine light.
That's actually pretty weird though? But thanks, ill look into it this weekend

Quote:
Originally Posted by 1QuikWS6 View Post
Sometimes that code is thrown for the simple fact that the gas cap has not been put back on correctly as you surmised.

Take off cap, put back on and give it a couple 'clicks' see if the problem goes away. It could also be that the cap is bad & needs replaced.

I always start with the least expensive/involved items on the diagnostic tree before moving on to the more $$
I think it was the gas cap? But the thing is, I filled up the tank about 5 days prior to the problem and haven't touched it since? any clue why it'd go off? Do our gas caps untighted themselves ?! O.o
__________________
Quote:
Originally Posted by The HACK View Post
I'm going to use a very simple analogy, I hope you'll understand.
Driving is like having sex.
It really is. You can read up all you want about how to please a woman, you can look at all the diagrams in the world, but just like the clitoris, you won't know what the hell an apex is before you actually find it.
Appreciate 0
      10-03-2012, 11:58 PM   #7
pinoye90
Private First Class
United_States
4
Rep
154
Posts

 
Drives: 07 328I e90 MT
Join Date: Dec 2011
Location: PHX

iTrader: (0)

I had the same problem and ppl kept saying its the gas cap but when I replaced it the light when back on after 10min of driving. Then after researching more I found out it was the vapor sensor which is common to going out on bmw's. I did a DIY on this forum on how to replace it. Cost can be about 200+ at the dealer to diagnose. I'm pretty sure that's what's throwing the code.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:25 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST