E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N55 Turbo Engine Tuning and Exhaust Modifications - 335i Tuning > Malfunction Message - Please Help :(



Reply
 
Thread Tools Search this Thread
      09-19-2012, 08:26 AM   #1
hiter202
Captain
 
Drives: BMW
Join Date: Jul 2011
Location: CT

Posts: 713
iTrader: (4)

Malfunction Message - Please Help :(

Hey guys, I have a bit of a problem.

I have a JB4 but I mostly drive with it off due to the fact that I hate the Intake sound of my Injen, but anyways..

I was driving today to work, after about an hour drive, I almost get to work, 5 mins away and all of a sudden I get a message that comes on the screen

Engine malfunction! Reduced Power
Engine malfunction
Engine operating at reduced output. Possible to continue. Drive with caution. Have the system checked by the nearest BMW center.


Now as I stated before. the JB4 was off. I turned it off this morning after driving 5 mins from my house, so it was off for about an hour drive give or take, and then this comes on. I do not believe that I've gotten this message before, so I am quite worried what this can be.

When I got to work and parked, I turned on the JB4 and it cleared the message, but what I am worried about is why it came on in the first place. Usually I just get SRS light that comes on my dash after driving for 50 miles or so, so I turn on the JB4 and turn it right back off and it clears that, but this message is a first for me.

Can someone please shed some light on this.
Attached Images
 
hiter202 is offline   United_States
0
Reply With Quote
      09-19-2012, 09:17 AM   #2
hiter202
Captain
 
Drives: BMW
Join Date: Jul 2011
Location: CT

Posts: 713
iTrader: (4)

bump .... anyone
hiter202 is offline   United_States
0
Reply With Quote
      09-19-2012, 11:38 AM   #3
F335i
Private First Class
 
Drives: 2012 335i Coupe 6AT
Join Date: Jun 2012
Location: Miami, Florida

Posts: 101
iTrader: (0)

Turn off autoclear on the JB4 and let it happen again. By turning on the jb4 it deleted the codes that you were suppose to read or next time don't turn on the jb4 at all and just read the codes when you get this malfunction.
__________________
JB4 S2 ISO Map7, BMS Intake, BMS Chargepipe, BMS Downpipe, BMS OCC, Flex fuel wires.
F335i is offline   United_States
0
Reply With Quote
      09-19-2012, 11:52 AM   #4
hiter202
Captain
 
Drives: BMW
Join Date: Jul 2011
Location: CT

Posts: 713
iTrader: (4)

alright, i just wnt to the car on my lunch break, i made sure the jb4 was off before turning the car off this morning, i just got into the car, started it, and it automatically came back.....

these are the codes:

2C71
2E4C
2C83
2C58
hiter202 is offline   United_States
0
Reply With Quote
      09-19-2012, 03:31 PM   #5
trk411
Private
 
Drives: 2011 335i xdrive 6MT
Join Date: Oct 2011
Location: Southwestern PA

Posts: 68
iTrader: (0)

2C71 = boost pressure too high
2E4C = exhaust flapper disconnected
2C83 = pressure before throttle valve too high
2C58 = boost pressure built up locked
trk411 is offline   United_States
0
Reply With Quote
      09-19-2012, 03:41 PM   #6
hiter202
Captain
 
Drives: BMW
Join Date: Jul 2011
Location: CT

Posts: 713
iTrader: (4)

So are these normal tuner codes for people with JB4, Catless DP, Intake, and all other crap? And if so, then why the heck am I getting the Engine Malfunction message?
hiter202 is offline   United_States
0
Reply With Quote
      09-19-2012, 04:30 PM   #7
madmanhiker
Lieutenant Colonel
 
madmanhiker's Avatar
 
Drives: '11 E92 335i
Join Date: Jul 2008
Location: Jacksonville, Fl

Posts: 1,546
iTrader: (3)

Garage List
reseat all of your JB4 connectors. I have found moisture (from car wash) in one of them (TMAP) and it caused LIMP mode (different error related to fuel rail sensor) BUT... it's something.

Reseat your connectors and try again.
__________________
-madmanhiker jax,fl
madmanhiker is offline   United_States
0
Reply With Quote
      09-20-2012, 10:40 AM   #8
Andrewe92
enthusiast
 
Andrewe92's Avatar
 
Drives: 2011 e92 lci 335xi
Join Date: Feb 2012
Location: NJ

Posts: 744
iTrader: (0)

Garage List
Quote:
Originally Posted by trk411 View Post
2C71 = boost pressure too high
2E4C = exhaust flapper disconnected
2C83 = pressure before throttle valve too high
2C58 = boost pressure built up locked
hahah seem like normal codes to get with a jb4
Andrewe92 is offline   United_States
0
Reply With Quote
      09-20-2012, 10:57 AM   #9
Mike@N54Tuning.com
BimmerPost Supporting Vendor

 
Drives: 07335i
Join Date: Dec 2008
Location: Earth

Posts: 14,319
iTrader: (86)

Quote:
Originally Posted by trk411 View Post
2C71 = boost pressure too high
2E4C = exhaust flapper disconnected
2C83 = pressure before throttle valve too high
2C58 = boost pressure built up locked
Nope, those are not normal tuner codes, except for your unplugged exhaust flapper.

They mean boost was too high and that the DME shut down boost / gave a limp mode. As to why boost is too high I can't help you there. Maybe a defective wastegate or diverter valve? You could log it and send the log in to BMS to see if they can spot anything.

Mike
Mike@N54Tuning.com is online now   Canada
0
Reply With Quote
      09-20-2012, 09:01 PM   #10
elinstylez
Private First Class
 
Drives: N55 335xi e92 M-Sport 6MT
Join Date: Feb 2012
Location: SoCal

Posts: 149
iTrader: (2)

I had the same problem when I initially installed the jb4. I went over all the connections and prayed and the error codes went away.
elinstylez is offline   United_States
0
Reply With Quote
      09-26-2012, 06:22 AM   #11
Mike@N54Tuning.com
BimmerPost Supporting Vendor

 
Drives: 07335i
Join Date: Dec 2008
Location: Earth

Posts: 14,319
iTrader: (86)

Step 1 should always be to email the code details in for professional advice. Unless you just enjoy chasing your tail around. In which case then make a post on the forums and pray someone gives you the right advice.

Mike
Mike@N54Tuning.com is online now   Canada
0
Reply With Quote
      09-26-2012, 05:27 PM   #12
hiter202
Captain
 
Drives: BMW
Join Date: Jul 2011
Location: CT

Posts: 713
iTrader: (4)

Hey Mike,

Thanks for the info, i already sent it off to Terry and he pretty much didnt say anything about them being out of the ordinary. The exhaust flapper, that i know, I disconnected the plug a while back, way before the jb4, never bothered reconnecting it, as for the other 3, i've had those since day one that i installed the jb4, since then i've got an intake and catless dp
hiter202 is offline   United_States
0
Reply With Quote
      09-26-2012, 07:00 PM   #13
F335i
Private First Class
 
Drives: 2012 335i Coupe 6AT
Join Date: Jun 2012
Location: Miami, Florida

Posts: 101
iTrader: (0)

I say uninstall and reinstall again, start from scratch by disconnecting the battery and all that good stuff, lock the doors and put the keys away from the car and wait 10 minutes for the ECU to fall asleep.
__________________
JB4 S2 ISO Map7, BMS Intake, BMS Chargepipe, BMS Downpipe, BMS OCC, Flex fuel wires.
F335i is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:57 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST