E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Wash, Wax, Detailing and Cosmetic protection/repairs > Rust runoff on wheels?



Reply
 
Thread Tools Search this Thread
      09-26-2012, 10:44 PM   #1
Fun w/N54
Lieutenant
 
Drives: '11 E92 335is AW/CR/DCT
Join Date: Apr 2011
Location: WI

Posts: 405
iTrader: (0)

Rust runoff on wheels?

This started on the right front wheel and now doing on left front as well. Seems to apprear right after cleaning car/wheels. It's easily removed just very annoying. Only use cleaners safe for All Wheels...thought?
Attached Images
 
Fun w/N54 is offline   United_States
0
Reply With Quote
      09-27-2012, 06:32 AM   #2
Speedwagon
First Lieutenant
 
Speedwagon's Avatar
 
Drives: Sportwagon
Join Date: Sep 2012
Location: Colorado

Posts: 366
iTrader: (0)

Quote:
Originally Posted by Fun w/N54 View Post
This started on the right front wheel and now doing on left front as well. Seems to apprear right after cleaning car/wheels. It's easily removed just very annoying. Only use cleaners safe for All Wheels...thought?
My 2012 E91 has a lot of rust on the center hubs on the fronts and the hubs on the rears are not as bad but are rusting also. The car is brand new built Jan 2012, delivered Feb 2012! I received it from the factory here in Germany their wasn't and ocean trip with the salty air! It sits in the garage most of the time. What's up? I'm getting ready to put my winter wheels on. I need to get some repairs items, my OCD won't let me just put the wheels on and not do the repairs!
Speedwagon is offline   United_States
0
Reply With Quote
      09-27-2012, 09:07 AM   #3
dmatre
Second Lieutenant
 
Drives: 2011 328i Sedan
Join Date: Apr 2011
Location: Charlotte, NC

Posts: 296
iTrader: (0)

Used Wolf's Decon or similar product to remove the iron. Follow the directions on the package: Spray on, let sit 10-15 minutes, agitate with a brush/mitt, then spray off.

http://www.detailersdomain.com/Wolfs...Gel_p_533.html
dmatre is offline   United_States
0
Reply With Quote
      09-27-2012, 12:15 PM   #4
Fun w/N54
Lieutenant
 
Drives: '11 E92 335is AW/CR/DCT
Join Date: Apr 2011
Location: WI

Posts: 405
iTrader: (0)

Cleaning the wheels isn't the problem, if I understand you correctly. Appears that the coating of the hub or one of the brake components must have worn off? Need brakes soon under maint warranty will let dealer sort it out I guess.

Thanks
Fun w/N54 is offline   United_States
0
Reply With Quote
      09-27-2012, 01:12 PM   #5
dmatre
Second Lieutenant
 
Drives: 2011 328i Sedan
Join Date: Apr 2011
Location: Charlotte, NC

Posts: 296
iTrader: (0)

To be honest, that doesn't look like rust.

Please check your brake fluid ASAP!

It appears only on the trailing edge of the spoke - means it's spraying/being ejected from the inside of the wheel. The distance from the hub is about equivalent to the inner edge of the caliper. It could be a bad brake line or seal....

Is the material thick (highly viscous)? or thin? If thick, it could also be a bad wheel bearing seal. If thin, it's more likely brake fluid.
dmatre is offline   United_States
0
Reply With Quote
      09-27-2012, 01:19 PM   #6
GoRomeo
Colonel
 
GoRomeo's Avatar
 
Drives: 330i
Join Date: Feb 2006
Location: San Diego CA

Posts: 2,231
iTrader: (0)

Garage List
2006 330i  [2.83]
Also smell it, if it stinks could be dog pee....
GoRomeo is offline  
0
Reply With Quote
      09-27-2012, 02:05 PM   #7
Speedwagon
First Lieutenant
 
Speedwagon's Avatar
 
Drives: Sportwagon
Join Date: Sep 2012
Location: Colorado

Posts: 366
iTrader: (0)

Quote:
Originally Posted by GoRomeo View Post
Also smell it, if it stinks could be dog pee....
Quit, you guys are killing me!
Speedwagon is offline   United_States
0
Reply With Quote
      09-27-2012, 03:31 PM   #8
dmatre
Second Lieutenant
 
Drives: 2011 328i Sedan
Join Date: Apr 2011
Location: Charlotte, NC

Posts: 296
iTrader: (0)

Quote:
Originally Posted by GoRomeo View Post
Also smell it, if it stinks could be dog pee....
Dog pee would be one, or at most two, spokes (ask me how I know)
dmatre is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:18 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST