E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Photo/Video/Media Gallery > CPS Front lip install



Reply
 
Thread Tools Search this Thread
      09-29-2012, 08:57 PM   #1
eccarlino
Private
United_States
1
Rep
56
Posts

 
Drives: 2009 335i M-Sport
Join Date: Jul 2012
Location: North, New Jersey

iTrader: (0)

CPS Front lip install

there should be pics here but something went wrong...

installed my lip, drove it and at 85-100mph, part detached and scratched, i fixs it with some epoxy, luckily it was just the bottom and it's not noticeable unless you look underneath...

anyone ever install one these? it sounds simply but something but be wrong... anyone use any screws in particular? adhesive anywhere? help please.thanks
Appreciate 0
      09-29-2012, 10:57 PM   #2
bimmerwar51
Lieutenant
bimmerwar51's Avatar
7
Rep
408
Posts

 
Drives: e92 335i sold, e92 335is
Join Date: Jun 2009
Location: SoCal 562

iTrader: (6)

Got mine installed at ltmw. They used 3m tape and screws.
__________________
2011 335is/AFE DCI/ER Charge Pipe/AR Catless DP's/VRSF Intercooler /COBB V3/KW V2 Suspension/RPI Scoops/Motorsport Hardware Race extended nuts/Full LED kit/Arkym Lip Spoiler/LTMW CF Side Skirt Splitters/Duke Dynamics CF Quad Performance Diffuser /Cyba Black Chrome Quad tips/BLK/white Roundels/Black Painted roof/BMW Performance Trunk Spoiler/RSV Forged Sl1 RS10/Toyo Proxes 4
Appreciate 0
      09-29-2012, 10:59 PM   #3
khaye1
Colonel
khaye1's Avatar
Philippines
37
Rep
2,690
Posts

 
Drives: '12 MW 335i
Join Date: Feb 2009
Location: San Diego

iTrader: (7)

If you're talking about the Arkym rep...then yes, kinda... I have the real Arkym, but I would assume it installs the same way.

I hope you didn't use the OEM bolts, they're too short to keep both the lip and the bumper in place. I also used double sided tape for the front.

I bought the screws from Home Depot. They're #8 1 inch screws and I paired them with 1 inch washers also bought from Home Depot.
__________________

Last edited by khaye1; 09-30-2012 at 12:07 AM.
Appreciate 0
      09-30-2012, 02:59 PM   #4
TurboAL47
Captain
TurboAL47's Avatar
Philippines
15
Rep
931
Posts

 
Drives: 335xi coupe
Join Date: Jun 2008
Location: Queens, NYC

iTrader: (20)

Garage List
Send a message via AIM to TurboAL47
Quote:
Originally Posted by khaye1 View Post
If you're talking about the Arkym rep...then yes, kinda... I have the real Arkym, but I would assume it installs the same way.

I hope you didn't use the OEM bolts, they're too short to keep both the lip and the bumper in place. I also used double sided tape for the front.

I bought the screws from Home Depot. They're #8 1 inch screws and I paired them with 1 inch washers also bought from Home Depot.
+1. i bought 8 x #8, 1" screws. tried to get hex head but couldn't find them. also used 1" washers as well plus 3m tape in the front. brought these plus the lip to a shop to have this installed and now it's flush. hope this helps and best of luck.

Last edited by TurboAL47; 09-30-2012 at 10:13 PM.
Appreciate 0
      09-30-2012, 03:52 PM   #5
eccarlino
Private
United_States
1
Rep
56
Posts

 
Drives: 2009 335i M-Sport
Join Date: Jul 2012
Location: North, New Jersey

iTrader: (0)

thanks guys, just cant get the front to stick with the adhesive, using 3m outdoor mounting adhesive, great adhesive ive used for spoilers and all but it just wont sit
Appreciate 0
      09-30-2012, 06:34 PM   #6
chap_2j_70
Padawan Learner
Canada
0
Rep
37
Posts

 
Drives: E92 335
Join Date: Jun 2011
Location: 905

iTrader: (0)

Make sure to clean the surface well (IPA) and use painter's tape to hold it in place.
Appreciate 0
      09-30-2012, 10:14 PM   #7
TurboAL47
Captain
TurboAL47's Avatar
Philippines
15
Rep
931
Posts

 
Drives: 335xi coupe
Join Date: Jun 2008
Location: Queens, NYC

iTrader: (20)

Garage List
Send a message via AIM to TurboAL47
Quote:
Originally Posted by eccarlino View Post
thanks guys, just cant get the front to stick with the adhesive, using 3m outdoor mounting adhesive, great adhesive ive used for spoilers and all but it just wont sit
that's the tape we used as well.
__________________

'14 SG F15 - MSport / '08 AW E92 | Mods and Photoshoot | FOR SALE
Appreciate 0
      09-30-2012, 10:22 PM   #8
khaye1
Colonel
khaye1's Avatar
Philippines
37
Rep
2,690
Posts

 
Drives: '12 MW 335i
Join Date: Feb 2009
Location: San Diego

iTrader: (7)

Quote:
Originally Posted by eccarlino View Post
thanks guys, just cant get the front to stick with the adhesive, using 3m outdoor mounting adhesive, great adhesive ive used for spoilers and all but it just wont sit
Clay the bumper and clean both bumper and lip with IPA then heat it up. Let it sit for awhile with painters tape for support and do not drive or wash it.
__________________
Appreciate 0
      10-06-2012, 07:42 PM   #9
eccarlino
Private
United_States
1
Rep
56
Posts

 
Drives: 2009 335i M-Sport
Join Date: Jul 2012
Location: North, New Jersey

iTrader: (0)

thanks guys
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:47 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST