E90Post
 


TireRack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Check engine light - scanned with INPA and got...



Reply
 
Thread Tools Search this Thread
      10-01-2012, 01:52 AM   #1
JordanE93
Private First Class
JordanE93's Avatar
United Kingdom
4
Rep
102
Posts

 
Drives: BMW E93
Join Date: Aug 2011
Location: Essex

iTrader: (0)

Check engine light - scanned with INPA and got...

Check Engine Light - INPA error codes

--------------------------------------------------------------------------------
Hi Guys,

For the last 2 weeks I have been getting the empty check engine light appear every 5 days or so only to disappear after restarting the car 4 times.

The car seems to run fine and everything appears normal, it doesn't even appear sluggish or anything just the light randomly just turns on when driving normally.

I scanned the car with INPA and got the following error codes..

2AF2 - nitric oxide sensor, Lambda linear
2AF4 - NOXsensor, electrical
2AF6 - nitric oxide sensor, lambda binary


Can you advise whats wrong and whats needed to fix this? i have a 320i n43 2007 69k miles.

Many thanks
Appreciate 0
      10-04-2012, 06:04 AM   #2
JordanE93
Private First Class
JordanE93's Avatar
United Kingdom
4
Rep
102
Posts

 
Drives: BMW E93
Join Date: Aug 2011
Location: Essex

iTrader: (0)

anyone???
Appreciate 0
      10-04-2012, 08:25 AM   #3
WilliamS
GoofBall
United_States
13
Rep
913
Posts

 
Drives: 2008 E92 N54 Xdrive
Join Date: Jun 2012
Location: Tampa, FL

iTrader: (2)

Could be a sensor is kicking the bucket on you 02 that is, or you have a cat failing. Becuase its all 3 codes I would assume 02 sensor.
Appreciate 0
      10-04-2012, 09:45 AM   #4
Meeni
Gateropode
Meeni's Avatar
22
Rep
1,862
Posts

 
Drives: BMW 330i 06
Join Date: Apr 2012
Location: TN

iTrader: (0)

Seems to be CAT
Appreciate 0
      10-04-2012, 04:00 PM   #5
JordanE93
Private First Class
JordanE93's Avatar
United Kingdom
4
Rep
102
Posts

 
Drives: BMW E93
Join Date: Aug 2011
Location: Essex

iTrader: (0)

What makes you think its the CAT as a whole? I was thinking possibly the NOx sensor?
Appreciate 0
      10-04-2012, 04:04 PM   #6
WilliamS
GoofBall
United_States
13
Rep
913
Posts

 
Drives: 2008 E92 N54 Xdrive
Join Date: Jun 2012
Location: Tampa, FL

iTrader: (2)

Im thinking its the sensor becuase of the second code.
Appreciate 0
      10-05-2012, 10:44 AM   #7
JordanE93
Private First Class
JordanE93's Avatar
United Kingdom
4
Rep
102
Posts

 
Drives: BMW E93
Join Date: Aug 2011
Location: Essex

iTrader: (0)

I've attached a screen from a engine diagnostic page in INPA. As you can see the lambda after bank 2 is not reporting anything? does this make sense to anyone or is that how it is on a 320i?
Attached Images
 
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:33 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST