E90Post
 


GTB Performance
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > USA - Florida > FS: Escort Radar 8500 X50 (red display) with box, manual, etc...MINT



Reply
 
Thread Tools Search this Thread
      09-28-2012, 11:58 AM   #1
pimp4cheddar
El Capitán
 
pimp4cheddar's Avatar
 
Drives: Mojave E92
Join Date: Jul 2011
Location: Central Florida

Posts: 1,778
iTrader: (11)

FS: Escort Radar 8500 X50 (red display) with box, manual, etc...MINT

SOLD

Last edited by pimp4cheddar; 10-05-2012 at 02:39 PM.
pimp4cheddar is offline   United_States
0
Reply With Quote
      10-01-2012, 03:58 PM   #2
pimp4cheddar
El Capitán
 
pimp4cheddar's Avatar
 
Drives: Mojave E92
Join Date: Jul 2011
Location: Central Florida

Posts: 1,778
iTrader: (11)

TTT
pimp4cheddar is offline   United_States
0
Reply With Quote
      10-02-2012, 03:52 PM   #3
pimp4cheddar
El Capitán
 
pimp4cheddar's Avatar
 
Drives: Mojave E92
Join Date: Jul 2011
Location: Central Florida

Posts: 1,778
iTrader: (11)

SOLD

Last edited by pimp4cheddar; 10-05-2012 at 02:39 PM.
pimp4cheddar is offline   United_States
0
Reply With Quote
      10-02-2012, 04:10 PM   #4
GeorgiaTech335coupe
Lieutenant Colonel
 
Drives: Black BMW 335i coupe
Join Date: Mar 2007
Location: USA

Posts: 1,884
iTrader: (0)

Question: where did you get it serviced? My 9500 might have died, but haven't been able to determine if its the power connection or actual unit. Thanks.
__________________
Legal Disclaimer: Anything I or anyone else says about my vehicle on this website(e90post.com or any affiliated or nonaffiliated sites), pertaining to modifications, is only to gain acceptance from my/our peers, and does not actually represent anything actually existing on my car, and thus, cannot be held against me in any issues, i.e. warranty claims, that may arise.
GeorgiaTech335coupe is offline  
0
Reply With Quote
      10-02-2012, 04:25 PM   #5
pimp4cheddar
El Capitán
 
pimp4cheddar's Avatar
 
Drives: Mojave E92
Join Date: Jul 2011
Location: Central Florida

Posts: 1,778
iTrader: (11)

Quote:
Originally Posted by GeorgiaTech335coupe View Post
Question: where did you get it serviced? My 9500 might have died, but haven't been able to determine if its the power connection or actual unit. Thanks.
Sent it to Escort.

I know this cable is shot...so it might be the cable. Only way to tell is to have someone else plug up your radar in their car and see if it turns on.
pimp4cheddar is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:42 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST