E90Post
 


N54Tuning.com
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > Australia > 2006 e92 325i - 2 issues



Reply
 
Thread Tools Search this Thread
      09-30-2012, 02:50 AM   #1
aznbob
New Member
0
Rep
24
Posts

 
Drives: 325i e92
Join Date: Sep 2012
Location: sydney

iTrader: (0)

2006 e92 325i - 2 issues

hi there, just wondering if anyone has experienced these issues with their cars:

1. seatbelt/airbag passenger light always on - seems like a faulty sensor

from my brief research, bmw usa had a recall on a 'faulty mat sensor' that fixes this i think? anyone in aus get this done from bmw for free?

2. bluetooth/radio/audio/music not working

all of a sudden my audio stopped working. if i leave the radio on, very rarely i will get a dosage of sound but it will cut out. is this a common prob? is there a fix or work around?

3. i'm also interested in putting in a bmw oem ssk. Anyone live around newington with the bmw ssk installed? mind if i test drive it? ill pay u 20 bucks

thanks guys!
Appreciate 0
      10-01-2012, 07:21 PM   #2
Stuart@BMRAutowerkes
BimmerPost Supporting Vendor
Stuart@BMRAutowerkes's Avatar
96
Rep
4,873
Posts


 
Drives: a black car
Join Date: Sep 2010
Location: Sydney

iTrader: (3)

1. Yep sounds like a faulty sensor, could be as simple as resetting it with a BT tool or autologic, or could be more involved...
2. Likely to be an amp/power issue. Not real experienced with it though.
3. SSK is great. Do it and don't look back
Appreciate 0
      10-02-2012, 03:59 AM   #3
bmwaddiction
Lieutenant
Australia
8
Rep
408
Posts

 
Drives: Titanium Silver 325i E90
Join Date: Feb 2010
Location: Darwin

iTrader: (0)

your audio issue is most likely faulty amplifier...I had a similar issue but was able to easily fix it by ordering and replacing the amp

look up the correct part number for your car's VIN on www.realoem.com, then order it from schmiedmann.com or bmminiparts.com

the installation is simple 2 minute job - plug and play replacement in the boot of your car
Appreciate 0
      10-04-2012, 06:25 AM   #4
aznbob
New Member
0
Rep
24
Posts

 
Drives: 325i e92
Join Date: Sep 2012
Location: sydney

iTrader: (0)

hah, believe it or not - under the passenger seat a black connector was not plugged in. plugged it in, got a reset - all good now

1 issue down

and bmrox - when are you getting those ssk's in?
Appreciate 0
      10-07-2012, 12:33 AM   #5
Jin-ActiveMotorwerke
Private First Class
1
Rep
126
Posts

 
Drives: BMW E46 330i
Join Date: Apr 2012
Location: Melbourne

iTrader: (0)

Most likely AMP issue? If you understand how the MOST system works, you will know anything connected to that system can cause similar issue.
Amp normally fail when water is leaking through the left hand tail light.

And with these cars, the most common fault is from the ULF - bluetooth module. If you are in Melbourne, I can check this out for you in our workshop. Or you can borrow a ULF from someone to test it out. It's pretty easy to swap.
Appreciate 0
      10-07-2012, 07:57 AM   #6
aznbob
New Member
0
Rep
24
Posts

 
Drives: 325i e92
Join Date: Sep 2012
Location: sydney

iTrader: (0)

I think you are on to something.

The bluetooth started playing up first. Then music/radio/aux started cutting out. Now bluetooth completely not working and music/radio/aux 99% not working.

I also cannot even select TV anymore for some reason. Its like 'greyed' out.

Where can I get some more info on this stuff? I'm from Sydney.
Appreciate 0
      10-08-2012, 07:00 PM   #7
Jin-ActiveMotorwerke
Private First Class
1
Rep
126
Posts

 
Drives: BMW E46 330i
Join Date: Apr 2012
Location: Melbourne

iTrader: (0)

I don't know any good mechanic for BMW in sydney. Might have to try the dealer.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:05 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST