E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > N52 Owners: Elec Water Pump Check-In



View Poll Results: How many miles have you logged, and have you replaced your water pump yet?
Not yet, I have 60-75,000 miles 95 33.57%
Not yet, I have 75-90,000 miles 59 20.85%
Not yet, I have 90-105,000 miles 30 10.60%
Not yet, I have 105-120,000 miles 20 7.07%
Not yet, I'm invincible and have 120,000+ miles 10 3.53%
Yes I've had to replace and it was... 69 24.38%
Voters: 283. You may not vote on this poll

Closed Thread
 
Thread Tools Search this Thread
      08-17-2012, 05:40 PM   #23
GoRomeo
Colonel
GoRomeo's Avatar
26
Rep
2,367
Posts

 
Drives: 330i
Join Date: Feb 2006
Location: San Diego CA

iTrader: (0)

Garage List
2006 330i  [2.83]
93k miles and going strong.. 330i baby!! yeah lets not jinx it ok?? LOL... yes I voted in the poll already.
Appreciate 0
      08-17-2012, 06:14 PM   #24
OlivaresAnthony
Colonel
OlivaresAnthony's Avatar
United_States
26
Rep
2,097
Posts

 
Drives: E90 325i
Join Date: Nov 2009
Location: San Diego, CA

iTrader: (6)

Garage List
2006 325i  [5.00]
2007 335i  [0.00]
I'm at 85,100 miles on the original water pump. I do sometimes worry that it could go at any time though...
__________________
E90 325i|Sparkling Graphite Metallic|Steptronic|Black Leatherette/Dark Burl Interior|OEM Alarm|35%Front/5%Rear Tint|RD LED License Plate Lights|Rear Fogs Activated|Debadged|Smoked Sidemarkers|Blacklines|Depo P90v2|Matte Black Grille|BMS PBX|AFE Drop In|Charcoal Filter Delete|Air Scoops| RM Silicone Intake Hose| Magnaflow 14815| 19" Avant Garde M310|Continental DWS|M3 Lip Spoiler
Appreciate 0
      08-18-2012, 03:14 AM   #25
shragon
Moderator
shragon's Avatar
No_Country
321
Rep
27,450
Posts

 
Drives: 2006 325i SG Sedan
Join Date: Oct 2005
Location: Bay Area, CA

iTrader: (7)

a. 65k
b. don't remember, plus I got other stuff done at the same time.
c. indy
d. No
e. occational spirited driving
f. auto

Car over heated, that's how I knew. My friend, who is my mechanic hooked it up to a power supply. The water pump blew the fuse in the power supply several times.

I had an e34 525i with a m50 motor, where we had to deal with exploding and disintegrating impellers in the water pump. Now with the electrical water pumps, it's just them failing all together. Just can't win...

Btw... My friend's dad owns an e60 530i. Water pump died at around 50k miles.
__________________
Appreciate 0
      08-20-2012, 09:57 PM   #26
Cisco661
Cisco661
Cisco661's Avatar
United_States
13
Rep
921
Posts

 
Drives: 2006 Monaco Blue 330I
Join Date: Jul 2011
Location: California

iTrader: (17)

Garage List
2006 BMW 330i  [0.00]
great thread with poll! i have an 06 330i with just under 70k now. still has same coolant from day one. i was actually looking here to find out more about preventative maintenance like a coolant flush. i will be doing it in the next few weeks. i have read before that early models like my 330i last a bit longer but then again the 330i is little different from the 328 and 335. i will be adding this thread to see when others have failed and what costs were. you might wanna add if there were any symptoms before failure and maybe location cause some places have different weather that could affect the cooling system differently.
__________________
2006 330i/ Monaco Blue/ ZSP/ ZPP/ I Drive/ Burl Walnut Trim/ Steptronic/ Xenon Adaptives/ Logic7/ CF Mirror Caps/ Matte Black Grills
Appreciate 0
      08-21-2012, 06:15 AM   #27
Handsome_Rob
Private First Class
United_States
2
Rep
127
Posts

 
Drives: 528
Join Date: Apr 2009
Location: NNY

iTrader: (0)

We've got 96k on our '08 528. I did the coolant flush about 6k miles ago. The fan is loud as hell but doesn't imediately come on when I start the car. I think it may be getting close to going out. Might be time to trade it in.
Appreciate 0
      08-25-2012, 01:58 AM   #28
Joker330i
MURK3D
Joker330i's Avatar
Iran
26
Rep
1,051
Posts

 
Drives: E90 330i
Join Date: Dec 2008
Location: L.A., CA

iTrader: (2)

Garage List
2006 330i  [0.00]
Send a message via AIM to Joker330i
went out at 64,000. 2006 330i, PBX, exhaust, k and n drop in.
__________________
DDM Tuning HID Fogs, RD Angel Eyes V2, RD License Plate Lights, White LED Blinkers, Gloss Black Grill/330i Badge/Window Trim/Lower Slats, M-Tech Spoiler, Black Roundels, Matte Black Shift Knob, Blacklines, Red Air Scoops, Muffler Delete w/ 3.5 inch tips, Goodyear Eagle F1 Asymmetric 225/40/18 255/35/18
Appreciate 0
      08-25-2012, 08:24 AM   #29
monkey_wrench
Caught the Bimmer-Bug
monkey_wrench's Avatar
No_Country
10
Rep
660
Posts

 
Drives: '06 330i
Join Date: Aug 2011
Location: Florida

iTrader: (10)

Garage List
2006 330i  [0.00]
Just broke 100K, still on my original pump.

Replacement pump, hardware and T-stat housing are on my bench, ready to go.
If it wasn't for this stupid hurricane I'd change it out today.
Appreciate 0
      08-25-2012, 08:26 AM   #30
Cisco661
Cisco661
Cisco661's Avatar
United_States
13
Rep
921
Posts

 
Drives: 2006 Monaco Blue 330I
Join Date: Jul 2011
Location: California

iTrader: (17)

Garage List
2006 BMW 330i  [0.00]
Quote:
Originally Posted by monkey_wrench
Just broke 100K, still on my original pump.

Replacement pump, hardware and T-stat housing are on my bench, ready to go.
If it wasn't for this stupid hurricane I'd change it out today.
Did you ever perform a coolant flush more than once or you still on original coolant?
__________________
2006 330i/ Monaco Blue/ ZSP/ ZPP/ I Drive/ Burl Walnut Trim/ Steptronic/ Xenon Adaptives/ Logic7/ CF Mirror Caps/ Matte Black Grills
Appreciate 0
      08-25-2012, 10:49 AM   #31
monkey_wrench
Caught the Bimmer-Bug
monkey_wrench's Avatar
No_Country
10
Rep
660
Posts

 
Drives: '06 330i
Join Date: Aug 2011
Location: Florida

iTrader: (10)

Garage List
2006 330i  [0.00]
Quote:
Originally Posted by Cisco661
Quote:
Originally Posted by monkey_wrench
Just broke 100K, still on my original pump.

Replacement pump, hardware and T-stat housing are on my bench, ready to go.
If it wasn't for this stupid hurricane I'd change it out today.
Did you ever perform a coolant flush more than once or you still on original coolant?
Still original as far as I know. I bought it with 60k miles and never did it.
Appreciate 0
      08-25-2012, 03:04 PM   #32
BennyD330i
New Member
United_States
0
Rep
8
Posts

 
Drives: 2006 330i 6MT
Join Date: Mar 2010
Location: New Jersey

iTrader: (0)

Water pump being replaced

06 330i 6speed with 127k had the original wp go. Threw a code that morning, (im guessing low flow rate, will put my reader on it today to confirm) later that afternoon , On the jersey parkway, low coolant level alarm, 10 seconds later overheat alarm and limp mode, quickly coasted off highway, fan in highspeed, and popped hood. Antifreeze spewing everywhere from the reservoir vent.

New water pump, thermostat, and aluminum screws purchased from thebmwpartstore.com for $427. I do all my own work ( like the eccentric shaft sensor!! On 5/2011) however local Indy shop is doing install of water pump and I'm looking at $350-$450 for labor.

The fluid was flushed at 52k however I knew I was on borrowed time regardless.

Bbd
Appreciate 0
      08-25-2012, 03:35 PM   #33
DimSum
Banned
Canada
60
Rep
2,743
Posts

 
Drives: SLOW
Join Date: May 2008
Location: LITTLEBIMMER.COM

iTrader: (10)

Always use OEM fluids for the car...

Oh and the waterpump and thermostat are replaced with new parts that are revised and better quality.
NEVER buy a USED pump/thermostat.

So if your car has not done the waterpump yet, get ready for it down the road.
Appreciate 0
      08-25-2012, 06:07 PM   #34
Chapo
Chapo
United_States
0
Rep
1
Posts

 
Drives: 325i
Join Date: Aug 2012
Location: OC

iTrader: (0)

Exclamation Thermostat or Water Pump

what would be more likely to have been damage if the the cooling reservoir was replace do to a crack from an idle pulley breaking off??? my 325i keeps overheating and from what I have read from this helpful forums I have concluded that it might be one of those 2. any toughs?? please...
Appreciate 0
      08-26-2012, 08:31 AM   #35
ZeroSix
Private First Class
ZeroSix's Avatar
United_States
1
Rep
135
Posts

 
Drives: 2013 BMW 335i
Join Date: Dec 2011
Location: SoCal

iTrader: (1)

Garage List
2013 BMW 335i  [5.00]
A. 72,000 ish
B. 3000 I'll edit when I check the paper
C. Dealer (as you can tell by how cheap it was)
D. No
E. No
F. Auto
Appreciate 0
      08-29-2012, 08:21 PM   #36
Kodak
The Law
Kodak's Avatar
United_States
15
Rep
327
Posts

 
Drives: 06 325xi, 4dr, Alpine
Join Date: Apr 2008
Location: Bronx, NYC

iTrader: (0)

I have a 2006, 325xi sedan, completely stock, automatic, and my water pump went out at 40826 miles, and also changed the thermostat,coolant for a total of $900.00 by an Indy in May 2012.

If you did replace your water pump, please also provide the following info:

a. at how many miles? 40826
b. how much did the repair cost (and indicate labor vs parts)? $250 labor,$680.00 parts, Total $930, negotiated to $900.00
c. was it replaced at indy or dealer? Indy
d. was there any other damage caused as a result? No
e. do you track your vehicle (canyon carving, street racing, backroads DOES NOT apply)? No
f. auto or manual? Auto
__________________
2006 Alpine ,325xi sedan,Terra, steptronic,Xenon,heated seats,Premium package

Last edited by Kodak; 08-29-2012 at 08:40 PM. Reason: update
Appreciate 0
      08-29-2012, 08:54 PM   #37
monkey_wrench
Caught the Bimmer-Bug
monkey_wrench's Avatar
No_Country
10
Rep
660
Posts

 
Drives: '06 330i
Join Date: Aug 2011
Location: Florida

iTrader: (10)

Garage List
2006 330i  [0.00]
a. 100057
b. Pump -$250, Thermostat Housing -$80 Hardware and coolant $45
c. Self
d. No.
e. No.
f. Auto

I replaced it as I was getting more frequent 2e84 errors. (Communication w/ pump) One time on my way to work, I got an orange coolant message, which went out immediately. I turned around and drove home, as I had the pump and thermostat housing on the shelf, ready to go.
Appreciate 0
      09-22-2012, 02:39 PM   #38
PTA85
Second Lieutenant
PTA85's Avatar
United_States
3
Rep
248
Posts

 
Drives: 06' 330i
Join Date: Apr 2010
Location: VA

iTrader: (0)

Garage List
2006 330i  [0.00]
88,000 miles just replaced my pump and thermostat before they died. Paid $478 from tischer for the whole kit. Now I really wonder how long the original could have gone for.
Appreciate 0
      09-22-2012, 05:35 PM   #39
dubenvy
Registered
United_States
0
Rep
1
Posts

 
Drives: 06 325xi 6MT
Join Date: Sep 2012
Location: MD

iTrader: (0)

ours went on the highway 2 weeks ago at 94k
Appreciate 0
      09-22-2012, 06:52 PM   #40
PTA85
Second Lieutenant
PTA85's Avatar
United_States
3
Rep
248
Posts

 
Drives: 06' 330i
Join Date: Apr 2010
Location: VA

iTrader: (0)

Garage List
2006 330i  [0.00]
Quote:
Originally Posted by dubenvy
ours went on the highway 2 weeks ago at 94k
That's what I was afraid of. Hope everything worked out.
Appreciate 0
      09-23-2012, 01:17 AM   #41
tldoxmf87
Captain
tldoxmf87's Avatar
South Korea
16
Rep
723
Posts

 
Drives: e92 TiAg
Join Date: Mar 2010
Location: Bellevue

iTrader: (14)

a. at how many miles?
- Right at 70,000 miles
b. how much did the repair cost (and indicate labor vs parts)?
- Parts: $300 for new waterpump (bought from member here), $140 for thermostat at the stealership, $350 for labor at a local shop
c. was it replaced at indy or dealer?
- Replaced by an indy
d. was there any other damage caused as a result?
- Nope
e. do you track your vehicle (canyon carving, street racing, backroads DOES NOT apply)?
- Never
f. auto or manual?
- Auto
__________________
E92 TiAg
Appreciate 0
      09-30-2012, 03:45 PM   #42
Nesquik15
Private First Class
Nesquik15's Avatar
No_Country
1
Rep
154
Posts

 
Drives: 335xi
Join Date: Sep 2012
Location: United states

iTrader: (1)

33k miles, replaced my thermostat and pump due to overheating, the pump will still not operate when attempting to go through with the bleeding procedure (
__________________
2008 335XI//JB4 G5 ISO//AFE STG2 INTAKE//M6 18"//BLACKED OUT TAILS//BLACKED OUT TRIM//
Appreciate 0
      10-03-2012, 08:37 PM   #43
Efthreeoh
Brigadier General
United_States
50
Rep
3,721
Posts

 
Drives: E90
Join Date: May 2012
Location: MARLAND

iTrader: (0)

Mine went at 149K. The pump fails due to heat, not frequency of coolant changes. Heat. Heat kills the electronic control unit.
Appreciate 0
      10-04-2012, 06:40 AM   #44
dcg71
Captain
Australia
12
Rep
865
Posts

 
Drives: F30 335i Sport BSM
Join Date: Jul 2009
Location: Brisbane, Australia

iTrader: (2)

Mine went about 90,000km. Replaced both the water pump and thermostat. I bought OEM parts from overseas and fitted them myself (parts are ridiculously expensive here). I rate it as one of the harder things I've done maintenance wise. There's limited space to work with and some interesting hose connectors.
No other damage, car was auto and never tracked.
__________________
------------------------------
2012 F30 335i Sapphire Black Sport Line | ///M Performance Exhaust | ///M Performance Suspension | ///M Sport Front Bumper | ///M Sport 403M Wheels
2006 E92 325i Titan Silver
2000 E46 318i Cosmos Black

Last edited by dcg71; 10-04-2012 at 06:46 AM.
Appreciate 0
Closed Thread

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:55 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST