E90Post
 


VIBE Motorsports
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > 14mm sway bar rubbing on undercarage



Reply
 
Thread Tools Search this Thread
      10-05-2012, 09:21 AM   #1
BaseM3
Private First Class
United_States
8

 
BaseM3's Avatar
 
Drives: 2011 Space Grey M3
Join Date: Jan 2012
Location: Jacksonville fl


Posts: 139
iTrader: (1)

14mm sway bar rubbing on undercarage

Swapped out the 13rmm for the 14mm bar along with the performance suspension and its rubbing in the body undercarrage and very little clearance to the wheels. I bought the bar through Tischer. Any one else had this problem. I kept the orginal springs on the car.
__________________
11 Space Grey, M-DCT Base M3
Appreciate 0
      10-05-2012, 11:36 AM   #2
BaseM3
Private First Class
United_States
8

 
BaseM3's Avatar
 
Drives: 2011 Space Grey M3
Join Date: Jan 2012
Location: Jacksonville fl


Posts: 139
iTrader: (1)

Quote:
Originally Posted by mels335i View Post
Swapped out the 13rmm for the 14mm bar along with the performance suspension and its rubbing in the body undercarrage and very little clearance to the wheels. I bought the bar through Tischer. Any one else had this problem. I kept the orginal springs on the car.
After further examination it almost looks like the bar is to wide. Is there anyway to install it backward?
__________________
11 Space Grey, M-DCT Base M3
Appreciate 0
      10-05-2012, 01:27 PM   #3
AlanAZ
Captain
18

 
AlanAZ's Avatar
 
Drives: E90 325i sport manual
Join Date: Aug 2009
Location: Scottsdale, AZ


Posts: 798
iTrader: (4)

I have the 14mm bar with original sport springs. I had read a couple of cases where a new bar was installed upside down, so I marked one end of the old bar before removing, and matched the new one to it before installing. No problems with it rubbing and has done wonders to lessen the oversteer.

Last edited by AlanAZ; 10-05-2012 at 01:32 PM.
Appreciate 0
      10-05-2012, 01:33 PM   #4
BaseM3
Private First Class
United_States
8

 
BaseM3's Avatar
 
Drives: 2011 Space Grey M3
Join Date: Jan 2012
Location: Jacksonville fl


Posts: 139
iTrader: (1)

Thanks, I'll research this more. Do you recall where you came across this?
So you can install it wrong. It was late in the night after installing the other components so I may have made a mistake. Everything seems to line up correctly, links and rubber supports etc.
__________________
11 Space Grey, M-DCT Base M3
Appreciate 0
      10-05-2012, 02:02 PM   #5
BaseM3
Private First Class
United_States
8

 
BaseM3's Avatar
 
Drives: 2011 Space Grey M3
Join Date: Jan 2012
Location: Jacksonville fl


Posts: 139
iTrader: (1)

Just located my old bar and i think the new one is indeed upside down. Could someone verify if the bar goes up or down at the end attachment points to the links would really help me out.
__________________
11 Space Grey, M-DCT Base M3
Appreciate 0
      10-05-2012, 02:56 PM   #6
BaseM3
Private First Class
United_States
8

 
BaseM3's Avatar
 
Drives: 2011 Space Grey M3
Join Date: Jan 2012
Location: Jacksonville fl


Posts: 139
iTrader: (1)

On the original bar there is a white paint mark. is this on the drivers side or passengers side?
__________________
11 Space Grey, M-DCT Base M3
Appreciate 0
      10-05-2012, 03:42 PM   #7
BaseM3
Private First Class
United_States
8

 
BaseM3's Avatar
 
Drives: 2011 Space Grey M3
Join Date: Jan 2012
Location: Jacksonville fl


Posts: 139
iTrader: (1)

Found my answer the bar is upside down:
for future reference:

http://www.e90post.com/forums/showth...=230973&page=4
__________________
11 Space Grey, M-DCT Base M3
Appreciate 0
      10-05-2012, 04:11 PM   #8
ericruiz911
Captain
United_States
28

 
ericruiz911's Avatar
 
Drives: 2014 Chevy Silverado
Join Date: May 2012
Location: MIAMI, FL


Posts: 665
iTrader: (1)

it happens to the best of us. Hopefully this thread will help someone out in the future
Appreciate 0
      10-05-2012, 07:11 PM   #9
cvc 22349a
Colonel
United_States
37

 
cvc 22349a's Avatar
 
Drives: 335i
Join Date: Sep 2007
Location: SF Bay


Posts: 2,255
iTrader: (8)

I have a 14mm rear sway bar and it doesn't rub anywhere. Yours is installed backwards
__________________
2007 E90 335i, TiAg, 6AT, ZPP, ZSP, ZCW, 6FL, HD
Quaife lsd, ETS fmic, GIAC s/w, Dinan intake/exhaust/oc, KW/M3 susp, Apex Arc 8, Mich PSS
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:25 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST