E90Post
 


VIBE Motorsports
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Outside temperature reading stuck on -40*F???



Reply
 
Thread Tools Search this Thread
      10-01-2012, 06:23 PM   #1
Zero
Private
1
Rep
52
Posts

 
Drives: 335i
Join Date: Dec 2011
Location: CA

iTrader: (0)

Exclamation Outside temperature reading stuck on -40*F???

Yesterday on the dash of my 335i the snowflake in the triangle light came up (signifying its cold as balls outside) came up and my outside temperature gauge is stuck saying it's -40*F outside. Also my check engine light came on too, any ideas what it is? Outside temperature sensor go out? I don't have iDrive btw.

Thanks for the help!
__________________
- Muffler Delete - BMS DC Intake - 5%/Side 50%/Shield - Depo Blacklines - Shadowline - M3 Bumper - Full LED/HID swap - Forgestar F14s - Hankook V12s
Appreciate 0
      10-01-2012, 06:26 PM   #2
BMW_Belgier
Lieutenant Colonel
BMW_Belgier's Avatar
Switzerland
19
Rep
1,522
Posts

 
Drives: E92 335xi n55
Join Date: May 2012
Location: Switzerland

iTrader: (0)

Battery?
__________________
BEFORE: 130i N52 (2006-2011)
NOW: 335xi N55 (2011- )
Appreciate 0
      10-01-2012, 06:27 PM   #3
islandbimmer
First Lieutenant
4
Rep
329
Posts

 
Drives: 2007 e92 SG
Join Date: Feb 2007
Location: Victoria BC Canada

iTrader: (1)

broken wire or sensor . On the e36's they often fell out of their sockets and dangled underneath the bumper till you curbed them. Check the sensor see if the wires look oK .
Appreciate 0
      10-01-2012, 06:45 PM   #4
BMW_Belgier
Lieutenant Colonel
BMW_Belgier's Avatar
Switzerland
19
Rep
1,522
Posts

 
Drives: E92 335xi n55
Join Date: May 2012
Location: Switzerland

iTrader: (0)

Quote:
Originally Posted by islandbimmer View Post
broken wire or sensor . On the e36's they often fell out of their sockets and dangled underneath the bumper till you curbed them. Check the sensor see if the wires look oK .
Would that explain the CEL aswell?
__________________
BEFORE: 130i N52 (2006-2011)
NOW: 335xi N55 (2011- )
Appreciate 0
      10-01-2012, 07:58 PM   #5
Tom K.
Major General
Tom K.'s Avatar
United_States
54
Rep
5,409
Posts

 
Drives: '07 328iT, '13 Boxster
Join Date: Mar 2008
Location: Maryland

iTrader: (0)

Quote:
Originally Posted by islandbimmer View Post
broken wire or sensor . On the e36's they often fell out of their sockets and dangled underneath the bumper till you curbed them. Check the sensor see if the wires look oK .
On my E46, it was chipmunk damage to the wiring near the sensor. While it didn't throw a SES light, the A/C compressor (thinking it was well below freezing) wouldn't come on.

Tom
Appreciate 0
      10-02-2012, 12:47 PM   #6
Zero
Private
1
Rep
52
Posts

 
Drives: 335i
Join Date: Dec 2011
Location: CA

iTrader: (0)

Quote:
Originally Posted by islandbimmer View Post
broken wire or sensor . On the e36's they often fell out of their sockets and dangled underneath the bumper till you curbed them. Check the sensor see if the wires look oK .
Alright, where's the sensor located at on the car? Pics? Thanks
__________________
- Muffler Delete - BMS DC Intake - 5%/Side 50%/Shield - Depo Blacklines - Shadowline - M3 Bumper - Full LED/HID swap - Forgestar F14s - Hankook V12s
Appreciate 0
      10-02-2012, 03:05 PM   #7
mxchris727
Private
United_States
0
Rep
57
Posts

 
Drives: E90 with 3 pedals
Join Date: Aug 2012
Location: Wilton, CT

iTrader: (0)

It should be right under the front bumper on the passenger side
__________________
I have a workstation set up with DIS, TIS, SSS, INPA, NCS Expert, WinKFP, Tool32 with an K+D CAN interface; PM me if you want to stop by and code your car. ISTA/D + /P with an iCOMM interface finally here!
Appreciate 0
      10-06-2012, 07:41 PM   #8
Zero
Private
1
Rep
52
Posts

 
Drives: 335i
Join Date: Dec 2011
Location: CA

iTrader: (0)

Does anyone have a diagram where they can point out where it is? I looked under the car the other night and have been looking for diagrams to see what I'm looking for and can't seem to find anything. Thanks guys, I really don't want to take it to the stealership just to replace a sensor.
__________________
- Muffler Delete - BMS DC Intake - 5%/Side 50%/Shield - Depo Blacklines - Shadowline - M3 Bumper - Full LED/HID swap - Forgestar F14s - Hankook V12s
Appreciate 0
      10-07-2012, 07:22 AM   #9
gzim335
Captain
gzim335's Avatar
Montenegro
11
Rep
658
Posts

 
Drives: 07 e90n54-08 zx10r-lci328ix
Join Date: Feb 2011
Location: staten island ny

iTrader: (4)

Garage List
2007/1 e90 335i  [1.00]
Quote:
Originally Posted by Zero View Post
Does anyone have a diagram where they can point out where it is? I looked under the car the other night and have been looking for diagrams to see what I'm looking for and can't seem to find anything. Thanks guys, I really don't want to take it to the stealership just to replace a sensor.
im having the exact same issue...
u have to take off the bumper to get to the sensor.
__________________
2007/1 e90 335i jet black

jb4 g5 iso/race flash--rb turbos/rb pcv--bms occ--dci/scoops--cpe dp's corsa race full system--cpe ic--er cp/hks bov--trunk mount meth cm7/cm10--inline lpfp--kw v2/stoptech bbk f&r--m3 bits f&r,m3 fsb,wavetrack lsd--f14s nitto invo--lci conversion
Appreciate 0
      10-08-2012, 11:22 AM   #10
r3dbimmer89
The Coolest
r3dbimmer89's Avatar
United_States
9
Rep
820
Posts

 
Drives: F80 M3
Join Date: Nov 2010
Location: SoCal

iTrader: (0)

That happened to me in my E46...my sister rolled over a high curb and popped the fender lining pulling the sensor off with it. Most likely your sensor is broken or gone but I think the SES light is something different going on.
__________________
Past:12 E92 335i/ 08 E90 335i/02 E46 325i
Present:15 F80 ///M3
Appreciate 0
      10-08-2012, 11:45 AM   #11
ttribe
First Lieutenant
ttribe's Avatar
United_States
4
Rep
361
Posts

 
Drives: '09 E93 335i
Join Date: Jul 2012
Location: Phoenix, AZ

iTrader: (0)

My ambient temperature sensor went out on the E60 M5 last year and triggered a limp mode on the engine. Get the sensor replaced and you'll be up and running again.
__________________
2012+ 09 E93 335i - Space Gray, N54, Sport, Premium, Comfort, Logic7, Nav Mods - Reflectors, LUX, Pedals, M3 Spoiler, Black Grilles, Macht Schnell, Aero, ESS, RE760
2011-12 07 E60 M5 - Indy Red
Appreciate 0
      10-08-2012, 05:33 PM   #12
Zero
Private
1
Rep
52
Posts

 
Drives: 335i
Join Date: Dec 2011
Location: CA

iTrader: (0)

Quote:
Originally Posted by gzim335 View Post
im having the exact same issue...
u have to take off the bumper to get to the sensor.
Have you done yours yet? If you haven't can you take a picture of the sensor and where it mounts?

Quote:
Originally Posted by ttribe View Post
My ambient temperature sensor went out on the E60 M5 last year and triggered a limp mode on the engine. Get the sensor replaced and you'll be up and running again.
Hopefully that's it, I literally just got the car back from an oil change at the stealership so I can't think of anything that could have made the SES light go off
__________________
- Muffler Delete - BMS DC Intake - 5%/Side 50%/Shield - Depo Blacklines - Shadowline - M3 Bumper - Full LED/HID swap - Forgestar F14s - Hankook V12s
Appreciate 0
      10-08-2012, 06:00 PM   #13
ttribe
First Lieutenant
ttribe's Avatar
United_States
4
Rep
361
Posts

 
Drives: '09 E93 335i
Join Date: Jul 2012
Location: Phoenix, AZ

iTrader: (0)

Quote:
Originally Posted by Zero View Post
Hopefully that's it, I literally just got the car back from an oil change at the stealership so I can't think of anything that could have made the SES light go off
I thought the ambient temp sensor was just a convenience thing but, according to my dealer service adviser, the car actually uses the sensor to adjust the fuel mix; hence the limp mode. My sensor was telling the car it was 125F outside when it was in the 90s, so it freaked out.
__________________
2012+ 09 E93 335i - Space Gray, N54, Sport, Premium, Comfort, Logic7, Nav Mods - Reflectors, LUX, Pedals, M3 Spoiler, Black Grilles, Macht Schnell, Aero, ESS, RE760
2011-12 07 E60 M5 - Indy Red
Appreciate 0
      10-08-2012, 06:06 PM   #14
gzim335
Captain
gzim335's Avatar
Montenegro
11
Rep
658
Posts

 
Drives: 07 e90n54-08 zx10r-lci328ix
Join Date: Feb 2011
Location: staten island ny

iTrader: (4)

Garage List
2007/1 e90 335i  [1.00]
Quote:
Originally Posted by Zero
Quote:
Originally Posted by gzim335 View Post
im having the exact same issue...
u have to take off the bumper to get to the sensor.
Have you done yours yet? If you haven't can you take a picture of the sensor and where it mounts?

Quote:
Originally Posted by ttribe View Post
My ambient temperature sensor went out on the E60 M5 last year and triggered a limp mode on the engine. Get the sensor replaced and you'll be up and running again.
Hopefully that's it, I literally just got the car back from an oil change at the stealership so I can't think of anything that could have made the SES light go off
just tackled it today with a friend,I took the bumper off n the sensor was on the driver side between bumper and radiator.
my issue was the wire was exposed,I reattached and wrapped it in elec tape and deleted the code after and my temp is reading again
I'll post a pic when I get on my PC
SES light is gone
Attached Images
 
__________________
2007/1 e90 335i jet black

jb4 g5 iso/race flash--rb turbos/rb pcv--bms occ--dci/scoops--cpe dp's corsa race full system--cpe ic--er cp/hks bov--trunk mount meth cm7/cm10--inline lpfp--kw v2/stoptech bbk f&r--m3 bits f&r,m3 fsb,wavetrack lsd--f14s nitto invo--lci conversion

Last edited by gzim335; 10-08-2012 at 07:38 PM.
Appreciate 0
      11-12-2013, 04:38 PM   #15
fazman
Lieutenant Colonel
United_States
20
Rep
1,795
Posts

 
Drives: 335 e90
Join Date: Feb 2011
Location: LI, NY

iTrader: (0)

What is an expected difference from the true outside temp? Mine seems to read a difference of +7*F to +11*F compared to what my iPhone reads as the local temp and maybe a difference of about +5*F compared to my friends stock e92.

I've just assumed that it was my ER FMIC which was warming up that temp sensor???
Appreciate 0
      11-12-2013, 05:04 PM   #16
captainaudio
World's Foremost Authority
United_States
36
Rep
3,216
Posts

 
Drives: 335i E93 750Li
Join Date: Jul 2007
Location: Upper East Side Manhattan - Boca Raton Florida

iTrader: (0)

__________________

Drivers Club at Lime Rock - International Motorsports Research Center
Madison Avenue Sports Car Driving and Chowder Society (Only a Vice President)
Polish Racing Drivers of America (PRDA)
The Glen Club - Sports Car Club of America
Appreciate 0
      11-12-2013, 05:04 PM   #17
fazman
Lieutenant Colonel
United_States
20
Rep
1,795
Posts

 
Drives: 335 e90
Join Date: Feb 2011
Location: LI, NY

iTrader: (0)



Quote:
Originally Posted by captainaudio View Post
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:07 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST