E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Help! 2007 e92 engine whistle at idle



Reply
 
Thread Tools Search this Thread
      09-23-2012, 06:41 PM   #1
Veester
New Member
0
Rep
21
Posts

 
Drives: '10 335d
Join Date: Sep 2012
Location: Dallas

iTrader: (1)

Hi, I've had this preowned '07 E92 for less than a month and this super high pitched sound just started happening today. It seems to go away at higher RPMs but it's pretty persistent at idle. The car just hit 50k miles and it's so loud in the engine bay I can't even lock down where it might be coming from.

I took this video right after the sound began to happen.


Last edited by Veester; 09-23-2012 at 08:05 PM.
Appreciate 0
      10-06-2012, 01:26 PM   #2
mlifxs
Diamond Geezer
mlifxs's Avatar
24
Rep
1,791
Posts

 
Drives: Jet Black 2007 328i Saloon
Join Date: Nov 2007
Location: Florida

iTrader: (3)

Garage List
I have something like this going on, about once or twice a month. Here's my thread on the topic:
http://www.e90post.com/forums/showthread.php?t=691932

It happened today, sent me back searching. When it occurs, it makes the sound when I let off the gas or idling. Goes away when I step on the gas. If I shut the car off and restart it, it usually goes away, first try.

So far only one code thrown, but I'm not positive it's related to it. On one occurrence got code P0012.
Appreciate 0
      10-07-2012, 07:28 PM   #3
Veester
New Member
0
Rep
21
Posts

 
Drives: '10 335d
Join Date: Sep 2012
Location: Dallas

iTrader: (1)

Thanks for the reply. I took it to BMW of Dallas last week and they had it for two days but couldn't figure it out. I'll update the post if I learn anything else.
Appreciate 0
      10-07-2012, 07:58 PM   #4
mlifxs
Diamond Geezer
mlifxs's Avatar
24
Rep
1,791
Posts

 
Drives: Jet Black 2007 328i Saloon
Join Date: Nov 2007
Location: Florida

iTrader: (3)

Garage List
Quote:
Originally Posted by Veester View Post
Thanks for the reply. I took it to BMW of Dallas last week and they had it for two days but couldn't figure it out. I'll update the post if I learn anything else.
thanks, I'll do the same.
Appreciate 0
      01-15-2013, 05:04 PM   #5
Veester
New Member
0
Rep
21
Posts

 
Drives: '10 335d
Join Date: Sep 2012
Location: Dallas

iTrader: (1)

Just heard back from my SA and he said that it was a faulty belt tensioner.
Appreciate 0
      01-16-2013, 11:02 AM   #6
mlifxs
Diamond Geezer
mlifxs's Avatar
24
Rep
1,791
Posts

 
Drives: Jet Black 2007 328i Saloon
Join Date: Nov 2007
Location: Florida

iTrader: (3)

Garage List
good to hear they figured it out. I've also had belt tensioner issues (cost 300+ to fix at dealer). Didn't make noise at idle.
__________________
AA Stage 2 - M3 control Arms FR - BMW PS2 - Dinan springs - APEX EC-7 - H&R front swaybar - GC street camber plates - Whiteline subframe inserts
Appreciate 0
      01-17-2013, 10:01 AM   #7
Veester
New Member
0
Rep
21
Posts

 
Drives: '10 335d
Join Date: Sep 2012
Location: Dallas

iTrader: (1)

Quote:
Originally Posted by Veester View Post
Just heard back from my SA and he said that it was a faulty belt tensioner.
Got my car back yesterday and the noise is still there...
Appreciate 0
      01-18-2013, 04:12 PM   #8
humbertob
Enlisted Member
humbertob's Avatar
0
Rep
49
Posts

 
Drives: '07 BMW E92 Coupe 328i
Join Date: Jan 2013
Location: Laredo, Tx.

iTrader: (0)

I have heard that same noise on some E46s back then, and resulted to be a faulty belt tensioner and a bad alternator bearing, after those 2 parts have replaced the noise went off. It's so simply to know or to find out if you got either of those two faulty parts, with the engine running (idling) put some water in the belt tensioner and/or alternator bearing, if the noise goes off, without a doubt you got either a bad tensioner or a bad alternator bearing, both of them are very easy to replace yourself and they are not so expensive. Hope you find the problem soon !
Appreciate 0
      06-20-2013, 03:36 AM   #9
evolnimi
Registered
0
Rep
4
Posts

 
Drives: 2008 E92
Join Date: Apr 2012
Location: Los Angeles

iTrader: (0)

This might be the problem:


Last edited by evolnimi; 06-20-2013 at 03:43 AM.
Appreciate 0
      07-21-2013, 05:52 PM   #10
Sparklinone
Registered
0
Rep
3
Posts

 
Drives: BMW 328i
Join Date: Jul 2013
Location: Dallas tx

iTrader: (0)

Any resolution to this problem? Mine is doing exact same thing. Does replacing the pcv valve fix this annoying problem?
Appreciate 0
Reply

Bookmarks

Tags
engine noise e92

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:23 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST