E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > 335i Check engine light ON/OFF @ 6000+ RPM?



Reply
 
Thread Tools Search this Thread
      10-07-2012, 02:10 PM   #1
jonho90
Private
 
jonho90's Avatar
 
Drives: 2007 e92 335i
Join Date: Feb 2012
Location: Vancouver, B.C.

Posts: 61
iTrader: (0)

335i Check engine light ON/OFF @ 6000+ RPM?

I recently installed the JB4 tune on my 335i.

My engine light came on when I was going at about 6000rpm+ and it automatically turned off within the next 5-8seconds? This happened twice and I'm not sure what's going on.

I also installed an oil catch can, and to prevent the tube getting squeezed to hard when I put the engine body shell back on top of the N54 engine, I did not tighten upper nuts (closer to the windshield). I did tighten the two nuts down below though. Could this be the problem?

I recently replaced my spark plugs about 2000km ago, so I doubt it could be a misfire? but when I was going at 6000rpm+ @ 130km/h, it did vibrate quite a bit.
jonho90 is offline   Canada
0
Reply With Quote
      10-07-2012, 03:33 PM   #2
straightcashhomie
Lieutenant
 
straightcashhomie's Avatar
 
Drives: 335i
Join Date: Aug 2012
Location: home

Posts: 545
iTrader: (1)

Sounds like it could be a dme failure ..
straightcashhomie is offline  
0
Reply With Quote
      10-07-2012, 05:01 PM   #3
jonho90
Private
 
jonho90's Avatar
 
Drives: 2007 e92 335i
Join Date: Feb 2012
Location: Vancouver, B.C.

Posts: 61
iTrader: (0)

Quote:
Originally Posted by straightcashhomie View Post
Sounds like it could be a dme failure ..
how would i verify that this is the case and how do i rectify the problem? replacing the DME is gonna be costly right
jonho90 is offline   Canada
0
Reply With Quote
      10-07-2012, 10:29 PM   #4
straightcashhomie
Lieutenant
 
straightcashhomie's Avatar
 
Drives: 335i
Join Date: Aug 2012
Location: home

Posts: 545
iTrader: (1)

plug in the usb and read codes, it could be anything spark plugs injectors ignition coils. it all depends, the codes will help distinguish the problem
straightcashhomie is offline  
0
Reply With Quote
      10-08-2012, 02:55 AM   #5
jonho90
Private
 
jonho90's Avatar
 
Drives: 2007 e92 335i
Join Date: Feb 2012
Location: Vancouver, B.C.

Posts: 61
iTrader: (0)

Quote:
Originally Posted by straightcashhomie View Post
plug in the usb and read codes, it could be anything spark plugs injectors ignition coils. it all depends, the codes will help distinguish the problem
my boost guage is not moving either, could it be the turbos...some kinda failure?
jonho90 is offline   Canada
0
Reply With Quote
      10-08-2012, 04:56 AM   #6
jonho90
Private
 
jonho90's Avatar
 
Drives: 2007 e92 335i
Join Date: Feb 2012
Location: Vancouver, B.C.

Posts: 61
iTrader: (0)

OK, I literally had to connect my laptop and speed so that the engine light came back on and I could quicky click read code.

It shows this:
30FF Boost under target - poossible boost leak

What should i do next? Take it to mechanic? I recently installed the JB4, Injen DCI, Stett CP + Tial BOV, BSH OCC
jonho90 is offline   Canada
0
Reply With Quote
      10-08-2012, 10:49 AM   #7
straightcashhomie
Lieutenant
 
straightcashhomie's Avatar
 
Drives: 335i
Join Date: Aug 2012
Location: home

Posts: 545
iTrader: (1)

Quote:
Originally Posted by jonho90 View Post
OK, I literally had to connect my laptop and speed so that the engine light came back on and I could quicky click read code.

It shows this:
30FF Boost under target - poossible boost leak

What should i do next? Take it to mechanic? I recently installed the JB4, Injen DCI, Stett CP + Tial BOV, BSH OCC
I would check all of my installs to make sure everything is in tightly, if you still cannot find the issue I would bring it to an Indy shop. Boost leak could just be a user install of something, good thing we didn't see DME or misfires lol.
straightcashhomie is offline  
0
Reply With Quote
      10-08-2012, 01:56 PM   #8
amill411
Second Lieutenant
 
amill411's Avatar
 
Drives: 2008 335i E92
Join Date: Jul 2011
Location: Tampa, Florida

Posts: 295
iTrader: (0)

Sounds like you may have installed JB4 wrong.

Did you double check everything?
__________________
JB4 and other stuff

amill411 is offline  
0
Reply With Quote
      10-08-2012, 02:11 PM   #9
jonho90
Private
 
jonho90's Avatar
 
Drives: 2007 e92 335i
Join Date: Feb 2012
Location: Vancouver, B.C.

Posts: 61
iTrader: (0)

Quote:
Originally Posted by amill411 View Post
Sounds like you may have installed JB4 wrong.

Did you double check everything?
i think it's probably either the charge pipe or DCI.

the JB4 controls works fine on my dash control so I doubt so? I don't get what you mean by installing it wrong. I wouldn't be able to read the codes if I did haha
__________________
07' 335i e92
JB4, Injen DCI, Stett CP & Tial BOV, BSH OCC, BLACK VMRs 19", Interior LED Kit, AC Schnitzer Race Pedals
Next Mods (PM ME if you have any): Oil Cooler (Retrofit), AR DPs, BMS Trunk-mount Meth Kit, whichever FMIC
jonho90 is offline   Canada
0
Reply With Quote
      11-25-2012, 11:32 PM   #10
alexman360z
New Member
 
Drives: bmw 335i
Join Date: Sep 2012
Location: new york

Posts: 20
iTrader: (3)

did you ever figure out what happened to your car?
alexman360z is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:02 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST