E90Post
 


jb4store
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Just installed downpipes, rough idle questions



Reply
 
Thread Tools Search this Thread
      10-08-2012, 06:02 PM   #1
RockChalkKU
Major League Airpower. STRIKE EAGLE
United_States
3

 
Drives: 2007 BMW M5
Join Date: Sep 2012
Location: NC


Posts: 79
iTrader: (1)

Just installed downpipes, rough idle questions

I just installed catless downpipes. Easy install, but now I am having some issues with an incredibly rough idle. The car sputters and pops. I have a jb3 tune on it and when given gas the car smooths out and sounds nice. Any suggestions as how to fix this? The car sounds like its choking, obviously not getting enough fuel but how do I adjust that at idle?

On another note, has anyone ever replaced a turbo waste gate?
Appreciate 0
      10-08-2012, 09:11 PM   #2
ksalih
First Lieutenant
United_States
5

 
ksalih's Avatar
 
Drives: '08 335i
Join Date: Mar 2012
Location: Gilbert, AZ


Posts: 338
iTrader: (1)

Did you reverse your o2 sensors? Sounds like you might have..
__________________
'08 E92 335i Pre-LCI | Sparkling Graphite Metallic | VRSF Downpipes | JB4 G5 ISO | Mr. 5 Intake | Alpina B3 TCU Flash | NGK 5992 Plugs | More to Come...?
Appreciate 0
      10-08-2012, 09:55 PM   #3
Tiago@VRSF
BimmerPost Supporting Vendor
United_States
100


 
Tiago@VRSF's Avatar
 
Drives: E92 335i, F30 328i, F82 M4
Join Date: Dec 2007
Location: Hudson, MA


Posts: 7,314
iTrader: (94)

Garage List
Send a message via AIM to Tiago@VRSF
Gray sensors go on the short pipe, black on the long pipe
Appreciate 0
      10-08-2012, 11:11 PM   #4
marv85
Colonel
United_States
25

 
marv85's Avatar
 
Drives: '07 335i MT
Join Date: Jun 2010
Location: Portland


Posts: 2,558
iTrader: (5)

yup, definitely you reversed the o2 sensors.

PM if you want a JB4 with the G5 board and NLS/2step. You can get the Isolated boost control firmware as well (I'm trying to help a friend sell his).
__________________
'10 E92 335i , COBB
Appreciate 0
      10-09-2012, 01:05 AM   #5
ar design
United_States
88

 
ar design's Avatar
 
Drives: 04 M3
Join Date: Jan 2008
Location: Denver, CO


Posts: 4,409
iTrader: (9)

Garage List
Send a message via AIM to ar design
Quote:
Originally Posted by Tiago@VRSF View Post
Gray sensors go on the short pipe, black on the long pipe
This.
__________________
-Critter
Appreciate 0
      10-09-2012, 03:20 AM   #6
RockChalkKU
Major League Airpower. STRIKE EAGLE
United_States
3

 
Drives: 2007 BMW M5
Join Date: Sep 2012
Location: NC


Posts: 79
iTrader: (1)

Thanks, ill get under the car tomorrow and ill verify the o2 sensors.thanks for all the input!
Appreciate 0
      10-09-2012, 09:16 AM   #7
Gugs
Cynical
United_States
4

 
Gugs's Avatar
 
Drives: E92 JetBlack
Join Date: Jul 2012
Location: Long island


Posts: 431
iTrader: (1)

Quote:
Originally Posted by RockChalkKU
Thanks, ill get under the car tomorrow and ill verify the o2 sensors.thanks for all the input!
Connectors go Up the passenger side of the engine. If ur slick u can just swap from up top.
Appreciate 0
      10-09-2012, 09:23 AM   #8
JamesM3M5
Some dude
United_States
23

 
Drives: E28 M5, E92 335i
Join Date: Sep 2011
Location: Northern VA


Posts: 1,757
iTrader: (0)

The wire lengths are different - bank 2 (grey) is much shorter than bank 1 (black). Best to just unscrew them from the incorrect DP and reinstall properly.
__________________
RRT Racing
E92 335i/6MT Dinan Stage 3: intercooler, oil cooler, intake, flash, exhaust, LW dual-mass flywheel.
Vishnu PWM methanol custom trunk mount, Diffsonline 3-clutch Salisbury custom diff, Ohlins Road and Track coilovers, Vorshlag camber plates, much more...
E28 M5 w/ buncha stuff, R171 SLK350
Appreciate 0
      10-09-2012, 09:38 AM   #9
Dylan335i
Lieutenant
United_States
5

 
Dylan335i's Avatar
 
Drives: 2007 BMW 335i
Join Date: Sep 2011
Location: Orlando


Posts: 459
iTrader: (4)

OP if your sensors are not swapped then you have the same issue as me.... no codes sensors in the correct spot just a rough idle no one knows how to fix
__________________
JB4 G5 / Walboro LPFP/ BMS Flash/ M3 Rep Front Bumper / OSS Headlights / BC Coilovers / 5" ETS FMIC / 3" VRSF Downpipes / AA Charge Pipe & BOV / BMS DCI / LCI Tails / CSL Trunk / CF Interior / CF Emblems / Cyba Air Scoops / 15% Tints / 5k Fogs / EBC RedStuff Pads / Drilled & Slotted Rotors / ECS SS Brake Lines
Appreciate 0
      10-09-2012, 09:49 AM   #10
gzim335
Captain
Montenegro
10

 
gzim335's Avatar
 
Drives: 07 e90n54-08 zx10r-lci328ix
Join Date: Feb 2011
Location: staten island ny


Posts: 633
iTrader: (4)

Garage List
2007/1 e90 335i  [1.00]
Quote:
Originally Posted by spoiledxjoker
OP if your sensors are not swapped then you have the same issue as me.... no codes sensors in the correct spot just a rough idle no one knows how to fix
if theyr in the right places than its possible the sensors r damaged.
__________________
2007/1 e90 335i jet black

jb4 g5 iso/race flash--rb turbos/rb pcv--bms occ--dci/scoops--cpe dp's corsa race full system--cpe ic--er cp/hks bov--trunk mount meth cm7/cm10--inline lpfp--kw v2/stoptech bbk f&r--m3 bits f&r,m3 fsb,wavetrack lsd--f14s nitto invo--lci conversion
Appreciate 0
      10-09-2012, 09:58 AM   #11
secretsquirrel
Colonel
24

 
secretsquirrel's Avatar
 
Drives: 335i nFifty4LiFe
Join Date: Dec 2010
Location: land of the squirrel


Posts: 2,087
iTrader: (2)

Double check that they are plugged in properly. They are pretty resilient to damage.
Appreciate 0
      10-09-2012, 10:42 AM   #12
Josh1a1h
Banned
United Kingdom
51

 
Drives: AzuriteBlack 335i E92
Join Date: Aug 2011
Location: Central North to West London


Posts: 3,836
iTrader: (2)

i hope you solve this issue asap
Appreciate 0
      10-09-2012, 10:46 AM   #13
hemi to e90
dat boost doe
Poland
17

 
hemi to e90's Avatar
 
Drives: 10 335i, 12 a8, 14 899, 10 zr1
Join Date: Aug 2005
Location: staten island


Posts: 1,548
iTrader: (1)

Quote:
Originally Posted by spoiledxjoker View Post
OP if your sensors are not swapped then you have the same issue as me.... no codes sensors in the correct spot just a rough idle no one knows how to fix
damaged o2 sensors, check with ecstuning they sell replacements.
__________________
Appreciate 0
      10-09-2012, 10:51 AM   #14
marv85
Colonel
United_States
25

 
marv85's Avatar
 
Drives: '07 335i MT
Join Date: Jun 2010
Location: Portland


Posts: 2,558
iTrader: (5)

ECStuning or tischer BMW. I usually check them both.
__________________
'10 E92 335i , COBB
Appreciate 0
      10-09-2012, 11:10 AM   #15
Tiago@VRSF
BimmerPost Supporting Vendor
United_States
100


 
Tiago@VRSF's Avatar
 
Drives: E92 335i, F30 328i, F82 M4
Join Date: Dec 2007
Location: Hudson, MA


Posts: 7,314
iTrader: (94)

Garage List
Send a message via AIM to Tiago@VRSF
Damaged o2 sensors generally throw a code.
Appreciate 0
      10-09-2012, 11:11 AM   #16
hemi to e90
dat boost doe
Poland
17

 
hemi to e90's Avatar
 
Drives: 10 335i, 12 a8, 14 899, 10 zr1
Join Date: Aug 2005
Location: staten island


Posts: 1,548
iTrader: (1)

Quote:
Originally Posted by Tiago@VRSF View Post
Damaged o2 sensors generally throw a code.
so if its not switched 02 sensors, and theres no code, what gives?
__________________
Appreciate 0
      10-09-2012, 11:26 AM   #17
JamesM3M5
Some dude
United_States
23

 
Drives: E28 M5, E92 335i
Join Date: Sep 2011
Location: Northern VA


Posts: 1,757
iTrader: (0)

Age, heat, "wear"? Could just be crappy and old.

You can use two bank one sensors - Bosch # 17098, available from many places online. The rear bank sensor, 17102 is much more expensive and harder to find.

http://www.e90post.com/forums/showthread.php?t=726481
__________________
RRT Racing
E92 335i/6MT Dinan Stage 3: intercooler, oil cooler, intake, flash, exhaust, LW dual-mass flywheel.
Vishnu PWM methanol custom trunk mount, Diffsonline 3-clutch Salisbury custom diff, Ohlins Road and Track coilovers, Vorshlag camber plates, much more...
E28 M5 w/ buncha stuff, R171 SLK350
Appreciate 0
      10-09-2012, 01:02 PM   #18
RockChalkKU
Major League Airpower. STRIKE EAGLE
United_States
3

 
Drives: 2007 BMW M5
Join Date: Sep 2012
Location: NC


Posts: 79
iTrader: (1)

Quote:
Originally Posted by spoiledxjoker View Post
OP if your sensors are not swapped then you have the same issue as me.... no codes sensors in the correct spot just a rough idle no one knows how to fix
how long have you been driving with this issue?
Appreciate 0
      10-10-2012, 08:37 AM   #19
Dylan335i
Lieutenant
United_States
5

 
Dylan335i's Avatar
 
Drives: 2007 BMW 335i
Join Date: Sep 2011
Location: Orlando


Posts: 459
iTrader: (4)

Quote:
Originally Posted by RockChalkKU View Post
how long have you been driving with this issue?
probably 6 months
__________________
JB4 G5 / Walboro LPFP/ BMS Flash/ M3 Rep Front Bumper / OSS Headlights / BC Coilovers / 5" ETS FMIC / 3" VRSF Downpipes / AA Charge Pipe & BOV / BMS DCI / LCI Tails / CSL Trunk / CF Interior / CF Emblems / Cyba Air Scoops / 15% Tints / 5k Fogs / EBC RedStuff Pads / Drilled & Slotted Rotors / ECS SS Brake Lines
Appreciate 0
      10-10-2012, 08:41 PM   #20
RockChalkKU
Major League Airpower. STRIKE EAGLE
United_States
3

 
Drives: 2007 BMW M5
Join Date: Sep 2012
Location: NC


Posts: 79
iTrader: (1)

I coded it out today, and it said bank one o2 sensor incorrect. Same for bank 2. So you guys were right. Thank you for all the help now the car is running like a champ!
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:24 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST