E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > Canada > Engine Overheating



Reply
 
Thread Tools Search this Thread
      10-08-2012, 05:55 PM   #1
ELITE_TRAYUNZE
Captain
 
ELITE_TRAYUNZE's Avatar
 
Drives: AW 07 E90 328i Sport
Join Date: Oct 2008
Location: Vancouver, BC

Posts: 616
iTrader: (1)

Engine Overheating

Hi guys,

I got the 'engine overheating' symbol (pictured below) in my car a few days ago, and now it seems like the fan is making a lot of noise, fluctuating in its volume from normal to loud back to normal several times per minute.

Any idea what this could be? I plan to take it to the shop to have my mechanic look at it, but wondering if I can get some ideas as to what it could be before I get it in the shop.

Thanks in advance.

ELITE_TRAYUNZE is offline   Canada
0
Reply With Quote
      10-08-2012, 06:27 PM   #2
Wai328
Major
 
Wai328's Avatar
 
Drives: F31/E90 328i/M3
Join Date: Mar 2007
Location: YVR/HKG

Posts: 1,006
iTrader: (1)

I had the same problem, turns out it was the water pump..you might need to get yours replace.
Wai328 is offline   Hong Kong
0
Reply With Quote
      10-08-2012, 08:18 PM   #3
Kriston
The Ultimate Driving Machine
 
Kriston's Avatar
 
Drives: Like Donkey Kong on Roids
Join Date: Mar 2009
Location: Toronto

Posts: 2,241
iTrader: (4)

any loss of power / limp mode? if so, I wouldnt drive it, it could be your water pump fo sho.
__________________
CHUCK NORRIS ON WHEELS

Kriston is offline   Canada
0
Reply With Quote
      10-08-2012, 11:42 PM   #4
abhishriv
Major
 
Drives: 2007 335i Coupe (Space grey)
Join Date: Oct 2011
Location: Toronto

Posts: 1,237
iTrader: (0)

this just happened to me last week on the highway! its the water pump... covered under warranty.
abhishriv is offline  
0
Reply With Quote
      10-09-2012, 12:41 AM   #5
ELITE_TRAYUNZE
Captain
 
ELITE_TRAYUNZE's Avatar
 
Drives: AW 07 E90 328i Sport
Join Date: Oct 2008
Location: Vancouver, BC

Posts: 616
iTrader: (1)

Quote:
Originally Posted by Kriston View Post
any loss of power / limp mode? if so, I wouldnt drive it, it could be your water pump fo sho.
No loss of power; just sounds like a piece of shit when I turn it on, and then the fan starts going really loud and then normal and loud and normal over and over again.

Quote:
Originally Posted by abhishriv View Post
this just happened to me last week on the highway! its the water pump... covered under warranty.
I don't know when my warranty ran out....It's a 2006, and I bought the car from the dealership as a "certified pre-owned" in September of 2008 I believe....It has 80,000km on it....Would I still be covered?
ELITE_TRAYUNZE is offline   Canada
0
Reply With Quote
      10-09-2012, 02:45 AM   #6
mreddiekim
New Member
 
mreddiekim's Avatar
 
Drives: 06 325i
Join Date: Jan 2011
Location: Fullerton, CA

Posts: 18
iTrader: (0)

Garage List
2006 BMW  [5.00]
Send a message via AIM to mreddiekim
water pump

hopefully your covered under warranty because my 06 325i had the same issue on my way home from vegas and boy did it cost me a pretty penny. Cost me around 1200 to fix the whole thing.
mreddiekim is offline   United_States
0
Reply With Quote
      10-09-2012, 03:19 AM   #7
ELITE_TRAYUNZE
Captain
 
ELITE_TRAYUNZE's Avatar
 
Drives: AW 07 E90 328i Sport
Join Date: Oct 2008
Location: Vancouver, BC

Posts: 616
iTrader: (1)

Quote:
Originally Posted by mreddiekim View Post
hopefully your covered under warranty because my 06 325i had the same issue on my way home from vegas and boy did it cost me a pretty penny. Cost me around 1200 to fix the whole thing.
Yeah, I'm pretty confident I'm not covered anymore...Car was originally purchased in April of 2006....Warranty would cover 6 years from that date...thus April of 2012 - about 6 months ago.

Guess I should get ready to pull out the ol' wallet, though I'm still praying it's something else.
ELITE_TRAYUNZE is offline   Canada
0
Reply With Quote
      10-10-2012, 08:36 PM   #8
KCX_335xi
Major
 
KCX_335xi's Avatar
 
Drives: 2013 335xi e92 | 2013 e70 X5
Join Date: Apr 2011
Location: Oakville, ON

Posts: 1,021
iTrader: (9)

I did research on this a few weeks back, and it is your water pump most likely... Need to replace it and also put in a new thermostat while you are at it... Parts alone are about ~600 USD @ ecstuning.com, for my car anyways... Realoem.com will give you the part numbers you need.... Good luck !!
KCX_335xi is offline  
0
Reply With Quote
      10-10-2012, 09:31 PM   #9
abhishriv
Major
 
Drives: 2007 335i Coupe (Space grey)
Join Date: Oct 2011
Location: Toronto

Posts: 1,237
iTrader: (0)

thermostat cost me $350 the rest was under warranty for me
abhishriv is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:52 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST