E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Turbos not active suddenly?? just did vishnu blow off and intake yesterday



Reply
 
Thread Tools Search this Thread
      10-13-2012, 02:39 PM   #1
Pooj
Private First Class
 
Drives: 335i convertible coupe
Join Date: Sep 2012
Location: montreal, canada

Posts: 176
iTrader: (0)

Turbos not active suddenly?? just did vishnu blow off and intake yesterday

Hey guys,

I did my vishnu v5, afe intake and autowerkz blow off yesterday and today i was drinving and suddenly the turbos shut down? no more blow off and no turbo noise and way slower... Didnt hear any weird noise or anything, they are just off... even if i turn the car off and on. Any ideas? I see the blow off has 2 mini plugs for a small wire, only 1 is connected ?? id be surprised if it feel off tho..

Other than that yesterday the passenger restraint system failed.. i hear that may we just a wire..


ANwyays ill take it back to the shop monday, I just need reassurance that nothing reallly major happened to my engine

Cheers,
Dan
Pooj is offline  
0
Reply With Quote
      10-13-2012, 03:27 PM   #2
WilliamS
GoofBall
 
Drives: 2008 E92 N54 Xdrive
Join Date: Jun 2012
Location: Tampa, FL

Posts: 709
iTrader: (1)

Sounds like the plugs for the stock diverter plugs went Awol.
WilliamS is offline   United_States
0
Reply With Quote
      10-13-2012, 03:34 PM   #3
bigdnno98
Major
 
bigdnno98's Avatar
 
Drives: 09 e92 335i MT
Join Date: Jul 2011
Location: Clarksville, TN

Posts: 1,143
iTrader: (7)

Read codes.
__________________
New Project....... 2.4L Long Rod motor for my EVO
03 Evo 8 HTA3582r Blown Motor
09 e92 335i MT Sold 440hp/480tq
bigdnno98 is offline  
0
Reply With Quote
      10-13-2012, 08:10 PM   #4
Pooj
Private First Class
 
Drives: 335i convertible coupe
Join Date: Sep 2012
Location: montreal, canada

Posts: 176
iTrader: (0)

Quote:
Originally Posted by Goofyguy View Post
Sounds like the plugs for the stock diverter plugs went Awol.
I dunno what that is lol
Pooj is offline  
0
Reply With Quote
      10-13-2012, 11:03 PM   #5
Chrisred
Captain
 
Chrisred's Avatar
 
Drives: BMW 335xi coupe
Join Date: Jan 2010
Location: Montreal, Canada

Posts: 738
iTrader: (0)

Happens to me on cold starts sometimes. I'll start driving and I hear this metallic sound (must be wastegates) then turbo spool has stopped and exhaust noise is deeper and louder. Then after a couple of minutes the turbos come back on and everything normal. Guess wastegates getting stuck.....
__________________
JB4 cp-e IC AMS exhaust BMS DCI AR DP's METH
19" VMR VB3 Stoptech BBK TC KLINE VORSHLAG
Chrisred is offline   Canada
0
Reply With Quote
      10-14-2012, 04:04 PM   #6
Pooj
Private First Class
 
Drives: 335i convertible coupe
Join Date: Sep 2012
Location: montreal, canada

Posts: 176
iTrader: (0)

Quote:
Originally Posted by Chrisred View Post
Happens to me on cold starts sometimes. I'll start driving and I hear this metallic sound (must be wastegates) then turbo spool has stopped and exhaust noise is deeper and louder. Then after a couple of minutes the turbos come back on and everything normal. Guess wastegates getting stuck.....
mine never came back on... going to shop tomorrow heh
Pooj is offline  
0
Reply With Quote
      10-15-2012, 08:42 AM   #7
JamesM3M5
Some dude
 
Drives: E28 M5, E92 335i
Join Date: Sep 2011
Location: Northern VA

Posts: 1,654
iTrader: (0)

You didn't go into Map 3, did you?
__________________
RRT Racing
E92 335i/6MT Dinan Stage 3: intercooler, oil cooler, intake, flash, exhaust, LW dual-mass flywheel.
Vishnu PWM methanol custom trunk mount, Diffsonline 3-clutch Salisbury custom diff, Ohlins Road and Track coilovers, Vorshlag camber plates, much more...
E28 M5 w/ buncha stuff, R171 SLK350
JamesM3M5 is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:37 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST