E90Post
 


Bimmertech
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > New coil



Reply
 
Thread Tools Search this Thread
      10-21-2012, 04:30 PM   #1
Foreman05
Private First Class
 
Drives: 06 330i
Join Date: Jul 2011
Location: NC

Posts: 161
iTrader: (2)

New coil

Hey guys, my yellow check engine light has been on for almost a year now, i brought my car to the dealer after i hit a coyote they said the code they read was for a misfire due to a bad coil. I got my car back after a month in the body shop. Now my car runs like a tractor, very rough idle and anytime i accelerate i feel it missing. Does anyone else find it strange that the coil went out completely while at the shop. I never had a rough idle before or any misfires like this. I bought a coil today from Bavarian auto on ebay $35 shipped not bad considering they wanted $350 to replace it i will try to post a video i took with my iPhone later.
Foreman05 is offline  
0
Reply With Quote
      10-30-2012, 01:11 AM   #2
dylim
Second Lieutenant
 
Drives: 328xi
Join Date: Mar 2012
Location: bay area

Posts: 239
iTrader: (3)

Did you get this resolved? I have rough idle too and I'm trying to hunt down the problem. Dealer replaced VANOS solenoids, but the problem still exists.
dylim is offline  
0
Reply With Quote
      10-30-2012, 09:15 AM   #3
Foreman05
Private First Class
 
Drives: 06 330i
Join Date: Jul 2011
Location: NC

Posts: 161
iTrader: (2)

Yep it was a bad coil. #5 cylinder misfire. Ordered from bav auto on eBay for 35 bucks. Took about 45 minutes from opening hood to closing it. Not at all a 350 dollar job. If it is a coil it should be real doggy when u give it gas. My rpm was real twitchy when driving at a constant speed. One way to find a bad coil is with the car running pop the locking cap on each coil. 1 at a time. If the car runs worse than that coil was good. Reconnect and try the next one. It's not as drastic change as I would have thought running on 4 cylinders instead of 5 but you can tell. Once I got to #5 and popped the cap there was no change to my idle...winner. Let me know if u need anything else
Foreman05 is offline  
0
Reply With Quote
      11-07-2012, 10:17 AM   #4
hunt55
Second Lieutenant
 
Drives: 325i
Join Date: Oct 2005
Location: Maryland

Posts: 210
iTrader: (0)

Got a 06 325i with 136,000. Just started rough idle and sluggish. Enigne light for service came on last night. Does it hurt to drive the car so I can get it to a shop. Not up to doing the work and we have some good reasonable shops in Wash. DC area.
hunt55 is offline  
0
Reply With Quote
      11-07-2012, 03:24 PM   #5
e90pilot
Freight Dawg
 
e90pilot's Avatar
 
Drives: E90 325i
Join Date: Jul 2005
Location: Oakland, CA

Posts: 2,095
iTrader: (3)

Don't drive the car with a misfire. You could damage the cats and those are expensive.
__________________
--Marcelo
'06 Arctic Metallic 325i | Sport Package | 6MT | Dinan Stage III suspension | Dinan exhaust | 330i manifold swap! Click here! | Active Autowerke tune | 135i Brake Calipers | Deiselboost caliper brackets | E46 M3 front rotors
e90pilot is offline   United_States
0
Reply With Quote
      11-07-2012, 05:01 PM   #6
E90-07
Private First Class
 
E90-07's Avatar
 
Drives: Montego blue 328i
Join Date: Jul 2009
Location: Wayne nj

Posts: 148
iTrader: (0)

Just had the same problem with mine, N51 motor but i believe everything internally should be the same to an N52 just exhaust pipe modifications, as i just read in the AA exhaust thread, but yea had a rough idle outta no where would misfire on WOT and bog down at cursing speeds took it into the dealer and ended up being #4 coil pack was shot, actually had oil inside the cylinder and the spark plug hold was also flooded with oil and i was leaking air out of my valve cover gasket, as they did a smoke test and realized that, but since then knock on word cars running fine no problems so far, hope this helps you guys oh and I'm around 80k mileage wise
__________________
E90-07 is offline  
0
Reply With Quote
      11-09-2012, 12:42 AM   #7
Foreman05
Private First Class
 
Drives: 06 330i
Join Date: Jul 2011
Location: NC

Posts: 161
iTrader: (2)

FYI my SES light is still on I guess it may be some other reason its on unless BMW has to turn it off? Im not to concerned.
Foreman05 is offline  
0
Reply With Quote
      11-09-2012, 01:48 AM   #8
e90pilot
Freight Dawg
 
e90pilot's Avatar
 
Drives: E90 325i
Join Date: Jul 2005
Location: Oakland, CA

Posts: 2,095
iTrader: (3)

It will clear after 3 starts without the error occurring. The SES light will remain on until then or until it is manually cleared. The shop you took it to should have cleared it.
__________________
--Marcelo
'06 Arctic Metallic 325i | Sport Package | 6MT | Dinan Stage III suspension | Dinan exhaust | 330i manifold swap! Click here! | Active Autowerke tune | 135i Brake Calipers | Deiselboost caliper brackets | E46 M3 front rotors
e90pilot is offline   United_States
0
Reply With Quote
      11-09-2012, 05:40 AM   #9
Patmos330
Private
 
Patmos330's Avatar
 
Drives: 06 330I
Join Date: Jun 2012
Location: WA

Posts: 70
iTrader: (0)

Quote:
Originally Posted by e90pilot View Post
Don't drive the car with a misfire. You could damage the cats and those are expensive.
Driving on one bad coil isnt going to hurt the car

Edit: and you dont need cats anyways
Patmos330 is offline  
0
Reply With Quote
      11-09-2012, 10:49 AM   #10
e90pilot
Freight Dawg
 
e90pilot's Avatar
 
Drives: E90 325i
Join Date: Jul 2005
Location: Oakland, CA

Posts: 2,095
iTrader: (3)

Quote:
Originally Posted by Patmos330 View Post
Driving on one bad coil isnt going to hurt the car

Edit: and you dont need cats anyways
Depends on the state. And why would you knowingly destroy part of you car? You can also end up clogging the cat which will require you to remove it or replace it. Driving with a misfire will also cause vibrations which can shorten the life if the internals.

Replacing a coil is so easy and cheap. There is absolutly no reason you should be driving with a dead one.
__________________
--Marcelo
'06 Arctic Metallic 325i | Sport Package | 6MT | Dinan Stage III suspension | Dinan exhaust | 330i manifold swap! Click here! | Active Autowerke tune | 135i Brake Calipers | Deiselboost caliper brackets | E46 M3 front rotors
e90pilot is offline   United_States
0
Reply With Quote
      11-20-2012, 02:24 PM   #11
dylim
Second Lieutenant
 
Drives: 328xi
Join Date: Mar 2012
Location: bay area

Posts: 239
iTrader: (3)

Still haven't resolved my rough idle problem - E90 328xi with 87K miles. It occurs mostly with the AC and fan off - the whole car shakes, the engine looks like it's going to jump out. Sometimes I see white smoke too.

This started occurring 2 days after I went to the dealer to do a coolant flush, oil change (to non BMW LL01 oil!), and transmission oil change. After a while CEL is on. Went back right to the dealer, they said the VANOS solenoids are bad, so they replaced those (on my $ of course), but problem still exists. Then they said the oil filter cap is broken and denied they broke it 2 days ago, ok, so I pay for a new cap.

After this mess, problem still existed, though the CEL never came back. I also often hear high pitched noises, as if a plane is landing, while in the driver's seat.

INPA shows some errors in the history, like ebox fan problems, but the status is "OK" right now, so not sure if any of the problems are relevant.

I also had rather weaker AC after retrofitting CCC idrive, 6FL and BT. Now I have to explicitly choose only the vent settings to the front blowers (the middle button), otherwise the fan is blowing somewhere else that makes no difference in the cabin.

Any ideas what could be the problem? I love to work on stuff myself, but I do not have a garage so I can't do any work involving fluids. But seems like even the dealerships cannot be trusted. Indie shops nearby are a joke - e.g. they only use non BMW LL01 oil and "if you bring your oil we cannot warrant our work, don't blame us if the oil leaks"
dylim is offline  
0
Reply With Quote
      11-20-2012, 11:38 PM   #12
Foreman05
Private First Class
 
Drives: 06 330i
Join Date: Jul 2011
Location: NC

Posts: 161
iTrader: (2)

I cant believe they charged your for the oil cap...that seems crazy to me. Same thing with the vanos, if they said that was the issue and it wasnt they should have put your old one back in and figure out what the real issue was. Do you have another shop around? from previous experience if you bring it to a new one and tell them how horrible the last shop was they should try to make you happy.
Foreman05 is offline  
0
Reply With Quote
      11-21-2012, 02:05 PM   #13
dylim
Second Lieutenant
 
Drives: 328xi
Join Date: Mar 2012
Location: bay area

Posts: 239
iTrader: (3)

Thanks for the reply Foreman05. I am a bit hesitant to go to another dealer, as the one I went to is already one that is highly rated (Peter Pan BMW). Somehow I feel like it's similar to finding a new dentist... ><

Happy holidays!
dylim is offline  
0
Reply With Quote
      11-29-2012, 11:29 AM   #14
Okbye2
Private
 
Okbye2's Avatar
 
Drives: 335i Atlantic Blue
Join Date: Jan 2009
Location: Miami, FL.

Posts: 86
iTrader: (0)

Quote:
Originally Posted by Foreman05 View Post
Yep it was a bad coil. #5 cylinder misfire. Ordered from bav auto on eBay for 35 bucks. Took about 45 minutes from opening hood to closing it. Not at all a 350 dollar job. If it is a coil it should be real doggy when u give it gas. My rpm was real twitchy when driving at a constant speed. One way to find a bad coil is with the car running pop the locking cap on each coil. 1 at a time. If the car runs worse than that coil was good. Reconnect and try the next one. It's not as drastic change as I would have thought running on 4 cylinders instead of 5 but you can tell. Once I got to #5 and popped the cap there was no change to my idle...winner. Let me know if u need anything else
Hi, What was the color of that Spark plug you had an issue with the coil? I have a miss, changed the spark plugs and one of them is foul. Im thinking I have a bad coil?
Okbye2 is offline  
0
Reply With Quote
      11-29-2012, 08:44 PM   #15
Foreman05
Private First Class
 
Drives: 06 330i
Join Date: Jul 2011
Location: NC

Posts: 161
iTrader: (2)

Sorry I didn't replace any plugs just the coil. A fouled plug should be black and most Likely wet with unburnt fuel.
Foreman05 is offline  
0
Reply With Quote
      11-30-2012, 07:00 AM   #16
Three_thirty_I
Captain
 
Three_thirty_I's Avatar
 
Drives: '05 E90 330i Manual
Join Date: Aug 2010
Location: Cape Town, South Africa

Posts: 804
iTrader: (0)

Garage List
Just out of interest, found this - a good way to diagnose a faulty coil pack...

__________________
BMW E90 330i (M) '05 (His) | (Hers) BMW E46 320i f/l (M) '03


Three_thirty_I is offline   South Africa
0
Reply With Quote
      12-01-2012, 02:04 PM   #17
Foreman05
Private First Class
 
Drives: 06 330i
Join Date: Jul 2011
Location: NC

Posts: 161
iTrader: (2)

Quote:
Originally Posted by Three_thirty_I View Post
Just out of interest, found this - a good way to diagnose a faulty coil pack...

Thats what i did, worked like a champ!
Foreman05 is offline  
0
Reply With Quote
      12-04-2012, 02:13 PM   #18
BoogeyMan'sBMW
Major
 
BoogeyMan'sBMW's Avatar
 
Drives: SLOW
Join Date: Jun 2009
Location: Queens NY

Posts: 1,290
iTrader: (3)

Quote:
Originally Posted by E90-07 View Post
Just had the same problem with mine, N51 motor but i believe everything internally should be the same to an N52 just exhaust pipe modifications, as i just read in the AA exhaust thread, but yea had a rough idle outta no where would misfire on WOT and bog down at cursing speeds took it into the dealer and ended up being #4 coil pack was shot, actually had oil inside the cylinder and the spark plug hold was also flooded with oil and i was leaking air out of my valve cover gasket, as they did a smoke test and realized that, but since then knock on word cars running fine no problems so far, hope this helps you guys oh and I'm around 80k mileage wise
did you have a SES light?

im having the same symptoms. When idling, the car sputters/shakes/hiccups most of the time and when i go WOT it misfires. no SES light tho and occasionally it behaves normally
BoogeyMan'sBMW is offline   Bangladesh
0
Reply With Quote
      12-10-2012, 12:01 PM   #19
E90-07
Private First Class
 
E90-07's Avatar
 
Drives: Montego blue 328i
Join Date: Jul 2009
Location: Wayne nj

Posts: 148
iTrader: (0)

Quote:
Originally Posted by BoogeyMan'sBMW View Post
did you have a SES light?

im having the same symptoms. When idling, the car sputters/shakes/hiccups most of the time and when i go WOT it misfires. no SES light tho and occasionally it behaves normally
SES light would only come on if i was driving and had a misfire under accel or WOT. but if i turned the car off then on again it cleared the light. And same occasionally it behaved normal. like the funny thing that day to me was i took it to my dealer and as soon as i pulled into the service bay, like no rough idle nothing and had to rev the nuts off the car to recreate the misfire. sounded good tho hearing the PE in a service bay lol but still made me cringe when i heard if misfire. but most likely my friend you have a leak in your valve cover gasket.
__________________
E90-07 is offline  
0
Reply With Quote
      12-16-2012, 06:41 PM   #20
BoogeyMan'sBMW
Major
 
BoogeyMan'sBMW's Avatar
 
Drives: SLOW
Join Date: Jun 2009
Location: Queens NY

Posts: 1,290
iTrader: (3)

Quote:
Originally Posted by E90-07 View Post
SES light would only come on if i was driving and had a misfire under accel or WOT. but if i turned the car off then on again it cleared the light. And same occasionally it behaved normal. like the funny thing that day to me was i took it to my dealer and as soon as i pulled into the service bay, like no rough idle nothing and had to rev the nuts off the car to recreate the misfire. sounded good tho hearing the PE in a service bay lol but still made me cringe when i heard if misfire. but most likely my friend you have a leak in your valve cover gasket.
yea, sounds like a good place to start with a smoke test. i cant even try to disconnect each coil and check cuz the car acts normally. maybe i shud misfire and then try that. Car has been behaving on WOT recently, except yday i misfired twice.
BoogeyMan'sBMW is offline   Bangladesh
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:55 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST